re-import sources as agreed with the maintainer

This commit is contained in:
Adam Samalik 2023-06-29 18:15:12 +02:00
parent 2a019bf319
commit 5ba3b0b337
4 changed files with 112 additions and 1 deletions

2
.gitignore vendored
View File

@ -1,2 +1,2 @@
SOURCES/openssl-ibmpkcs11-1.0.2.tar.gz
/openssl-ibmpkcs11-1.0.1.tar.gz
/openssl-ibmpkcs11-1.0.2.tar.gz

3
README.md Normal file
View File

@ -0,0 +1,3 @@
# openssl-ibmpkcs11
The openssl-ibmpkcs11 package

View File

@ -0,0 +1,29 @@
From b033a49486f70670d72e8e95b6e4bb54903d1d1b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Robert-Andr=C3=A9=20Mauchin?= <zebob.m@gmail.com>
Date: Tue, 23 Jan 2018 15:22:22 +0100
Subject: [PATCH] Remove obsolete m4s macro from configure
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 22e976f..ce6299f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,7 +42,7 @@ AC_CHECK_LIB(crypto, RAND_add, [], \
AC_DISABLE_STATIC
AC_PROG_CC
-AC_PROG_LIBTOOL
+LT_INIT
CFLAGS="$CFLAGS -Wall -DLINUX -DOPENCRYPTOKI"
AC_SUBST(CFLAGS)
--
2.13.6

View File

@ -0,0 +1,79 @@
From 71ab5ebe2fe97487e2cc3d0b1f72fbc115fe311b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 17 Jan 2018 14:56:19 +0100
Subject: [PATCH 1/2] switch to ibmpkcs11.so filename to allow a standalone use
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Dan Horák <dan@danny.cz>
---
openssl.cnf.sample.in | 2 +-
src/Makefile.am | 8 ++++----
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/openssl.cnf.sample.in b/openssl.cnf.sample.in
index 60d37df..fcf3dcd 100644
--- a/openssl.cnf.sample.in
+++ b/openssl.cnf.sample.in
@@ -18,7 +18,7 @@ ibmpkcs11 = ibmpkcs11_section
[ibmpkcs11_section]
SLOT_ID=0
-dynamic_path = @LIBDIR@/libibmpkcs11.so
+dynamic_path = @LIBDIR@/ibmpkcs11.so
engine_id = ibmpkcs11
#
# The following algorithms will be enabled by these parameters
diff --git a/src/Makefile.am b/src/Makefile.am
index fc41f1b..135413b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,9 +1,9 @@
-lib_LTLIBRARIES=libibmpkcs11.la
+lib_LTLIBRARIES=ibmpkcs11.la
-libibmpkcs11_la_CFLAGS=-I./include
+ibmpkcs11_la_CFLAGS=-I./include
-libibmpkcs11_la_LDFLAGS=@LIBS@ -lc -lpthread -ldl
-libibmpkcs11_la_SOURCES=e_pkcs11.c \
+ibmpkcs11_la_LDFLAGS=@LIBS@ -lc -lpthread -ldl
+ibmpkcs11_la_SOURCES=e_pkcs11.c \
e_pkcs11_err.c \
e_pkcs11.h \
pkcs11f.h \
--
2.13.6
From 578cd8567bd102b25ecf04db105e16f0a177d1f3 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 17 Jan 2018 15:00:00 +0100
Subject: [PATCH 2/2] link as a module, not as a shared library
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Dan Horák <dan@danny.cz>
---
src/Makefile.am | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/Makefile.am b/src/Makefile.am
index 135413b..869ec0e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,7 +2,8 @@ lib_LTLIBRARIES=ibmpkcs11.la
ibmpkcs11_la_CFLAGS=-I./include
-ibmpkcs11_la_LDFLAGS=@LIBS@ -lc -lpthread -ldl
+ibmpkcs11_la_LIBADD=@LIBS@ -lc -lpthread -ldl
+ibmpkcs11_la_LDFLAGS=-module -version-info 0:1:0 -shared -no-undefined -avoid-version
ibmpkcs11_la_SOURCES=e_pkcs11.c \
e_pkcs11_err.c \
e_pkcs11.h \
--
2.13.6