update to 1.2.0
This commit is contained in:
parent
1ec3222006
commit
b01b48287e
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
openssl-ibmca-1.1.tar.gz
|
||||
/openssl-ibmca-1.2.0.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up openssl-ibmca-1.1/e_ibmca.c.soname openssl-ibmca-1.1/e_ibmca.c
|
||||
--- openssl-ibmca-1.1/e_ibmca.c.soname 2010-04-22 13:18:48.000000000 +0200
|
||||
+++ openssl-ibmca-1.1/e_ibmca.c 2010-04-22 13:19:11.000000000 +0200
|
||||
@@ -113,7 +113,7 @@ typedef struct ibmca_sha256_ctx {
|
||||
} IBMCA_SHA256_CTX;
|
||||
#endif
|
||||
|
||||
-static const char *IBMCA_LIBNAME = "ica";
|
||||
+static const char *IBMCA_LIBNAME = "ica-2.0";
|
||||
|
||||
static int cipher_nids[] = {
|
||||
NID_des_ecb,
|
@ -1,24 +0,0 @@
|
||||
diff -up openssl-ibmca-1.1/configure.in.make openssl-ibmca-1.1/configure.in
|
||||
--- openssl-ibmca-1.1/configure.in.make 2010-04-22 14:26:23.000000000 +0200
|
||||
+++ openssl-ibmca-1.1/configure.in 2010-04-22 14:28:26.000000000 +0200
|
||||
@@ -25,8 +25,11 @@ fi
|
||||
AC_MSG_CHECKING([libica-2.x])
|
||||
AC_CHECK_HEADER([ica_api.h], [], \
|
||||
AC_MSG_ERROR([*** libica header not found]))
|
||||
+# libica is dlopened, so do not add it to LIBS
|
||||
+save_LIBS=$LIBS
|
||||
AC_CHECK_LIB(ica, ica_open_adapter, [], \
|
||||
AC_MSG_ERROR([*** libica-2.x library not found]), [-lssl])
|
||||
+LIBS=$save_LIBS
|
||||
|
||||
# OpenSSL location
|
||||
AC_MSG_CHECKING([OpenSSL])
|
||||
diff -up openssl-ibmca-1.1/Makefile.am.make openssl-ibmca-1.1/Makefile.am
|
||||
--- openssl-ibmca-1.1/Makefile.am.make 2010-01-26 12:51:47.000000000 +0100
|
||||
+++ openssl-ibmca-1.1/Makefile.am 2010-04-22 14:25:13.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
lib_LTLIBRARIES=libibmca.la
|
||||
|
||||
-libibmca_la_LDFLAGS=@LIBS@ -lc
|
||||
libibmca_la_SOURCES=e_ibmca.c e_ibmca.h e_ibmca_err.c
|
||||
+libibmca_la_LDFLAGS=-module -version-info 0:1:0 -shared -no-undefined -avoid-version
|
12
openssl-ibmca-1.2.0-libica-soname.patch
Normal file
12
openssl-ibmca-1.2.0-libica-soname.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up openssl-ibmca-1.2.0/e_ibmca.c.libica-soname openssl-ibmca-1.2.0/e_ibmca.c
|
||||
--- openssl-ibmca-1.2.0/e_ibmca.c.libica-soname 2011-05-02 19:50:50.000000000 +0200
|
||||
+++ openssl-ibmca-1.2.0/e_ibmca.c 2011-05-04 20:57:50.000000000 +0200
|
||||
@@ -114,7 +114,7 @@ typedef struct ibmca_sha256_ctx {
|
||||
} IBMCA_SHA256_CTX;
|
||||
#endif
|
||||
|
||||
-static const char *IBMCA_LIBNAME = "ica";
|
||||
+static const char *IBMCA_LIBNAME = "ica-2.0";
|
||||
|
||||
#if defined(NID_aes_128_cfb128) && ! defined (NID_aes_128_cfb)
|
||||
#define NID_aes_128_cfb NID_aes_128_cfb128
|
@ -1,15 +1,13 @@
|
||||
Summary: A dynamic OpenSSL engine for IBMCA
|
||||
Name: openssl-ibmca
|
||||
Version: 1.1
|
||||
Release: 3%{?dist}
|
||||
Version: 1.2.0
|
||||
Release: 1%{?dist}
|
||||
License: OpenSSL
|
||||
Group: System Environment/Libraries
|
||||
URL: http://sourceforge.net/projects/opencryptoki
|
||||
Source0: http://downloads.sourceforge.net/opencryptoki/%{name}-%{version}.tar.gz
|
||||
# fix linking
|
||||
Patch0: openssl-ibmca-1.1-linking.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=584765
|
||||
Patch1: openssl-ibmca-1.1-libica-soname.patch
|
||||
Patch0: openssl-ibmca-1.2.0-libica-soname.patch
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: libica
|
||||
BuildRequires: libica-devel automake libtool
|
||||
@ -21,8 +19,7 @@ A dynamic OpenSSL engine for IBMCA crypto hardware on IBM zSeries machines.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .linking
|
||||
%patch1 -p1 -b .libica-soname
|
||||
%patch0 -p1 -b .libica-soname
|
||||
|
||||
sh ./bootstrap.sh
|
||||
|
||||
@ -52,6 +49,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jul 07 2011 Dan Horák <dan[at]danny.cz - 1.2.0-1
|
||||
- update to 1.2.0
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user