- updated to 2.0.0
This commit is contained in:
parent
5fc820d1f5
commit
a88669965b
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ openssl-ibmca-1.1.tar.gz
|
|||||||
/openssl-ibmca-1.3.1.tar.gz
|
/openssl-ibmca-1.3.1.tar.gz
|
||||||
/openssl-ibmca-1.4.0.tar.gz
|
/openssl-ibmca-1.4.0.tar.gz
|
||||||
/openssl-ibmca-1.4.1.tar.gz
|
/openssl-ibmca-1.4.1.tar.gz
|
||||||
|
/openssl-ibmca-2.0.0.tar.gz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up openssl-ibmca-1.4.0/src/e_ibmca.c.libica-soname openssl-ibmca-1.4.0/src/e_ibmca.c
|
|
||||||
--- openssl-ibmca-1.4.0/src/e_ibmca.c.libica-soname 2017-09-11 13:56:54.144885532 +0200
|
|
||||||
+++ openssl-ibmca-1.4.0/src/e_ibmca.c 2017-09-11 13:57:09.724885532 +0200
|
|
||||||
@@ -46,7 +46,7 @@
|
|
||||||
#include "e_ibmca_err.h"
|
|
||||||
|
|
||||||
#define IBMCA_LIB_NAME "ibmca engine"
|
|
||||||
-#define LIBICA_SHARED_LIB "libica.so"
|
|
||||||
+#define LIBICA_SHARED_LIB "libica.so.3"
|
|
||||||
|
|
||||||
#define AP_PATH "/sys/devices/ap"
|
|
||||||
|
|
12
openssl-ibmca-2.0.0-libica-soname.patch
Normal file
12
openssl-ibmca-2.0.0-libica-soname.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up openssl-ibmca-2.0.0/src/e_ibmca.c.orig openssl-ibmca-2.0.0/src/e_ibmca.c
|
||||||
|
--- openssl-ibmca-2.0.0/src/e_ibmca.c.orig 2018-06-12 12:37:00.803473301 +0200
|
||||||
|
+++ openssl-ibmca-2.0.0/src/e_ibmca.c 2018-06-12 12:37:09.263473301 +0200
|
||||||
|
@@ -43,7 +43,7 @@
|
||||||
|
#ifndef OPENSSL_NO_HW_IBMCA
|
||||||
|
|
||||||
|
#define IBMCA_LIB_NAME "ibmca engine"
|
||||||
|
-#define LIBICA_SHARED_LIB "libica.so"
|
||||||
|
+#define LIBICA_SHARED_LIB "libica.so.3"
|
||||||
|
|
||||||
|
#define AP_PATH "/sys/devices/ap"
|
||||||
|
|
27
openssl-ibmca-2.0.0-linking.patch
Normal file
27
openssl-ibmca-2.0.0-linking.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From a6a837166e45e6537f35f6d35c38db54c6f4a640 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||||
|
Date: Tue, 12 Jun 2018 12:51:12 +0200
|
||||||
|
Subject: [PATCH] omit version from filename
|
||||||
|
|
||||||
|
The ibmca.so file is a dlopen()-ed module, so having the version info
|
||||||
|
in the filename is superfluous.
|
||||||
|
---
|
||||||
|
src/Makefile.am | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||||
|
index fa37e4d..2254379 100644
|
||||||
|
--- a/src/Makefile.am
|
||||||
|
+++ b/src/Makefile.am
|
||||||
|
@@ -13,7 +13,7 @@ ibmca_la_SOURCES=e_ibmca.c \
|
||||||
|
|
||||||
|
ibmca_la_LIBADD=-ldl
|
||||||
|
ibmca_la_LDFLAGS=-module -version-info ${VERSION} -shared -no-undefined \
|
||||||
|
- -Wl,--version-script=${srcdir}/../ibmca.map
|
||||||
|
+ -avoid-version -Wl,--version-script=${srcdir}/../ibmca.map
|
||||||
|
|
||||||
|
dist_ibmca_la_SOURCES=ibmca.h e_ibmca_err.h
|
||||||
|
EXTRA_DIST = openssl.cnf.sample
|
||||||
|
--
|
||||||
|
2.14.3
|
||||||
|
|
@ -2,17 +2,19 @@
|
|||||||
|
|
||||||
Summary: A dynamic OpenSSL engine for IBMCA
|
Summary: A dynamic OpenSSL engine for IBMCA
|
||||||
Name: openssl-ibmca
|
Name: openssl-ibmca
|
||||||
Version: 1.4.1
|
Version: 2.0.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: https://github.com/opencryptoki
|
URL: https://github.com/opencryptoki
|
||||||
Source0: https://github.com/opencryptoki/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
Source0: https://github.com/opencryptoki/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=584765
|
# https://bugzilla.redhat.com/show_bug.cgi?id=584765
|
||||||
Patch0: %{name}-1.4.0-libica-soname.patch
|
Patch0: %{name}-2.0.0-libica-soname.patch
|
||||||
Requires: libica >= 3.1.0
|
# https://github.com/opencryptoki/openssl-ibmca/pull/44
|
||||||
|
Patch1: %{name}-2.0.0-linking.patch
|
||||||
|
Requires: libica >= 3.3.0
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: libica-devel >= 3.1.0
|
BuildRequires: libica-devel >= 3.3.0
|
||||||
BuildRequires: automake libtool
|
BuildRequires: automake libtool
|
||||||
ExclusiveArch: s390 s390x
|
ExclusiveArch: s390 s390x
|
||||||
|
|
||||||
@ -49,6 +51,9 @@ popd
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 18 2018 Dan Horák <dan@danny.cz> - 2.0.0-1
|
||||||
|
- updated to 2.0.0
|
||||||
|
|
||||||
* Fri Feb 23 2018 Dan Horák <dan@danny.cz> - 1.4.1-1
|
* Fri Feb 23 2018 Dan Horák <dan@danny.cz> - 1.4.1-1
|
||||||
- updated to 1.4.1
|
- updated to 1.4.1
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (openssl-ibmca-1.4.1.tar.gz) = cba1a6a02b303dda9e2b20790b7507a1dd97e237f4bf98793e73dba83c3091986b14fad7e2fd53f52460ac0aca7c35b58345545c86101f5cd5b040eb226a0229
|
SHA512 (openssl-ibmca-2.0.0.tar.gz) = 1a2d881b828369c7686d1514d6539451eb41f53f582f683513c7d64d4e081fd0f86c624ee2792fc4debcbf510611a9889e614f2a9999bf1d230658954e4d4f3f
|
||||||
|
Loading…
Reference in New Issue
Block a user