update to 1.1
This commit is contained in:
parent
8611e3373b
commit
545c9ce317
@ -1 +1 @@
|
||||
openssl-ibmca-1.0.0.tar.bz2
|
||||
openssl-ibmca-1.1.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- openssl-ibmca-1.0.0/Makefile.am.make 2007-01-23 14:33:32.000000000 -0500
|
||||
+++ openssl-ibmca-1.0.0/Makefile.am 2009-07-09 15:44:06.000000000 -0400
|
||||
@@ -1,7 +1,6 @@
|
||||
lib_LTLIBRARIES=libibmca.la
|
||||
|
||||
-libibmca_la_LIBADD=@OPENSSL_LIB_DIR@/libcrypto.a
|
||||
-libibmca_la_LDFLAGS=-lc
|
||||
libibmca_la_CFLAGS=-I@OPENSSL_INCLUDE_DIR@
|
||||
-AM_CFLAGS=-I@OPENSSL_INCLUDE_DIR@
|
||||
libibmca_la_SOURCES=e_ibmca.c e_ibmca.h e_ibmca_err.c
|
||||
+libibmca_la_LDFLAGS=-module -version-info 0:1:0 -shared -no-undefined -avoid-version
|
||||
+libibmca_la_LIBADD=-L@OPENSSL_LIB_DIR@ -lcrypto
|
12
openssl-ibmca-1.1-libica-soname.patch
Normal file
12
openssl-ibmca-1.1-libica-soname.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up openssl-ibmca-1.1/e_ibmca.c.soname openssl-ibmca-1.1/e_ibmca.c
|
||||
--- openssl-ibmca-1.1/e_ibmca.c.soname 2010-04-22 13:18:48.000000000 +0200
|
||||
+++ openssl-ibmca-1.1/e_ibmca.c 2010-04-22 13:19:11.000000000 +0200
|
||||
@@ -113,7 +113,7 @@ typedef struct ibmca_sha256_ctx {
|
||||
} IBMCA_SHA256_CTX;
|
||||
#endif
|
||||
|
||||
-static const char *IBMCA_LIBNAME = "ica";
|
||||
+static const char *IBMCA_LIBNAME = "ica-2.0";
|
||||
|
||||
static int cipher_nids[] = {
|
||||
NID_des_ecb,
|
24
openssl-ibmca-1.1-linking.patch
Normal file
24
openssl-ibmca-1.1-linking.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -up openssl-ibmca-1.1/configure.in.make openssl-ibmca-1.1/configure.in
|
||||
--- openssl-ibmca-1.1/configure.in.make 2010-04-22 14:26:23.000000000 +0200
|
||||
+++ openssl-ibmca-1.1/configure.in 2010-04-22 14:28:26.000000000 +0200
|
||||
@@ -25,8 +25,11 @@ fi
|
||||
AC_MSG_CHECKING([libica-2.x])
|
||||
AC_CHECK_HEADER([ica_api.h], [], \
|
||||
AC_MSG_ERROR([*** libica header not found]))
|
||||
+# libica is dlopened, so do not add it to LIBS
|
||||
+save_LIBS=$LIBS
|
||||
AC_CHECK_LIB(ica, ica_open_adapter, [], \
|
||||
AC_MSG_ERROR([*** libica-2.x library not found]), [-lssl])
|
||||
+LIBS=$save_LIBS
|
||||
|
||||
# OpenSSL location
|
||||
AC_MSG_CHECKING([OpenSSL])
|
||||
diff -up openssl-ibmca-1.1/Makefile.am.make openssl-ibmca-1.1/Makefile.am
|
||||
--- openssl-ibmca-1.1/Makefile.am.make 2010-01-26 12:51:47.000000000 +0100
|
||||
+++ openssl-ibmca-1.1/Makefile.am 2010-04-22 14:25:13.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
lib_LTLIBRARIES=libibmca.la
|
||||
|
||||
-libibmca_la_LDFLAGS=@LIBS@ -lc
|
||||
libibmca_la_SOURCES=e_ibmca.c e_ibmca.h e_ibmca_err.c
|
||||
+libibmca_la_LDFLAGS=-module -version-info 0:1:0 -shared -no-undefined -avoid-version
|
@ -1,14 +1,17 @@
|
||||
Summary: A dynamic OpenSSL engine for IBMCA
|
||||
Name: openssl-ibmca
|
||||
Version: 1.0.0
|
||||
Version: 1.1
|
||||
Release: 2%{?dist}
|
||||
License: OpenSSL
|
||||
Group: System Environment/Libraries
|
||||
URL: http://sourceforge.net/projects/opencryptoki
|
||||
Source0: http://downloads.sourceforge.net/opencryptoki/%{name}-%{version}.tar.bz2
|
||||
Patch0: openssl-ibmca-1.0.0-make.patch
|
||||
Source0: http://downloads.sourceforge.net/opencryptoki/%{name}-%{version}.tar.gz
|
||||
# fix linking
|
||||
Patch0: openssl-ibmca-1.1-linking.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=584765
|
||||
Patch1: openssl-ibmca-1.1-libica-soname.patch
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: openssl >= 0.9.8
|
||||
Requires: libica
|
||||
BuildRequires: libica-devel automake libtool
|
||||
ExclusiveArch: s390 s390x
|
||||
|
||||
@ -18,12 +21,14 @@ A dynamic OpenSSL engine for IBMCA crypto hardware on IBM zSeries machines.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .make
|
||||
autoreconf -i -f
|
||||
%patch0 -p1 -b .linking
|
||||
%patch1 -p1 -b .libica-soname
|
||||
|
||||
sh ./bootstrap.sh
|
||||
|
||||
|
||||
%build
|
||||
%configure --with-openssl=%{_prefix} --with-engines-dir=%{_libdir}/openssl/engines
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
@ -31,7 +36,9 @@ make %{?_smp_mflags}
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
rm -f $RPM_BUILD_ROOT/%{_libdir}/openssl/engines/libibmca.la
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libibmca.la
|
||||
mkdir -p $RPM_BUILD_ROOT%{_libdir}/openssl/engines
|
||||
mv $RPM_BUILD_ROOT%{_libdir}/*.so $RPM_BUILD_ROOT%{_libdir}/openssl/engines
|
||||
|
||||
|
||||
%clean
|
||||
@ -45,6 +52,26 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Apr 22 2010 Dan Horák <dhorak@redhat.com> - 1.1-2
|
||||
- fixed opening of the libica library (#584765)
|
||||
- Resolves: #584765
|
||||
|
||||
* Thu Mar 4 2010 Dan Horák <dhorak@redhat.com> - 1.1-1
|
||||
- rebased to 1.1 instead of patching
|
||||
- Resolves: #568847
|
||||
|
||||
* Thu Feb 18 2010 Dan Horák <dhorak@redhat.com> - 1.0.0-5
|
||||
- added patch with port to libica 2.x API
|
||||
- Related: #543948
|
||||
|
||||
* Wed Feb 10 2010 Dan Horák <dhorak@redhat.com> - 1.0.0-4
|
||||
- added explicit dependency on libica, because it's dlopened
|
||||
- Related: #543948
|
||||
|
||||
* Tue Jan 12 2010 Dan Horák <dhorak@redhat.com> - 1.0.0-3
|
||||
- rebuild
|
||||
- Related: #543948
|
||||
|
||||
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user