opensp/opensp-multilib.patch

75 lines
2.3 KiB
Diff

--- OpenSP-1.5.2/configure.in.multilib 2006-05-26 18:12:45.000000000 +0100
+++ OpenSP-1.5.2/configure.in 2006-05-26 18:13:04.000000000 +0100
@@ -90,7 +90,7 @@
#define SP_SIZEOF_BOOL_1
#endif
-#if (SIZEOF_WCHAR_T == SIZEOF_UNSIGNED_SHORT)
+#if (WCHAR_MAX == SHRT_MAX)
#define SP_WCHAR_T_USHORT
#endif
--- OpenSP-1.5.2/lib/parser_inst.cxx.multilib 2006-05-26 16:30:16.000000000 +0100
+++ OpenSP-1.5.2/lib/parser_inst.cxx 2006-05-26 16:41:10.000000000 +0100
@@ -9,6 +9,7 @@
// Copyright (c) 1994 James Clark
// See the file COPYING for copying permission.
+#include <limits.h>
#include "splib.h"
#ifdef SP_MANUAL_INST
@@ -1338,7 +1339,7 @@
#endif
#endif
// we really just want to test if size_t == unsigned int
-#if !defined(SIZEOF_SIZE_T) || !defined(SIZEOF_UNSIGNED_INT) || (SIZEOF_SIZE_T != SIZEOF_UNSIGNED_INT)
+#if INT_MAX != SSIZE_MAX
#ifdef __DECCXX
#pragma define_template Vector<unsigned int>
#else
--- OpenSP-1.5.2/lib/parser_inst.m4.multilib 2006-05-26 16:30:32.000000000 +0100
+++ OpenSP-1.5.2/lib/parser_inst.m4 2006-05-26 16:39:32.000000000 +0100
@@ -1,6 +1,7 @@
// Copyright (c) 1994 James Clark
// See the file COPYING for copying permission.
+#include <limits.h>
#include "splib.h"
#ifdef SP_MANUAL_INST
@@ -166,7 +167,7 @@
__instantiate(Vector<LeafContentToken*>)
__instantiate(Vector<size_t>)
// we really just want to test if size_t == unsigned int
-#if !defined(SIZEOF_SIZE_T) || !defined(SIZEOF_UNSIGNED_INT) || (SIZEOF_SIZE_T != SIZEOF_UNSIGNED_INT)
+#if INT_MAX != SSIZE_MAX
__instantiate(Vector<unsigned int>)
#endif
--- OpenSP-1.5.2/config.h.in.multilib 2006-05-26 16:41:21.000000000 +0100
+++ OpenSP-1.5.2/config.h.in 2006-05-26 18:13:39.000000000 +0100
@@ -333,22 +333,6 @@
/* The size of a `bool', as computed by sizeof. */
#undef SIZEOF_BOOL
-/* The size of a `size_t', as computed by sizeof. */
-#undef SIZEOF_SIZE_T
-
-/* The size of a `unsigned int', as computed by sizeof. */
-#undef SIZEOF_UNSIGNED_INT
-
-/* The size of a `unsigned short', as computed by sizeof. */
-#undef SIZEOF_UNSIGNED_SHORT
-
-/* The size of a `wchar_t', as computed by sizeof. */
-#undef SIZEOF_WCHAR_T
-
-/* Define as the maximum value of type 'size_t', if the system doesn't define
- it. */
-#undef SIZE_MAX
-
/* define this if h_errno should be declared extern int */
#undef SP_DECLARE_H_ERRNO