Port configure script to C99
Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
This commit is contained in:
parent
886fd9af34
commit
ad3afd1f07
198
opensp-configure-c99.patch
Normal file
198
opensp-configure-c99.patch
Normal file
@ -0,0 +1,198 @@
|
||||
Avoid implicit function declarations because they have been removed
|
||||
from C in 1999. Future compilers are likely to reject them by
|
||||
default.
|
||||
|
||||
No need to upstream this because the aclocal.m4 file is not checked
|
||||
into the repository since:
|
||||
|
||||
------------------------------------------------------------------------
|
||||
r412 | clasen | 1999-11-06 14:10:34 +0100 (Sat, 06 Nov 1999) | 3 lines
|
||||
Changed paths:
|
||||
M /trunk/sp/Makefile.in
|
||||
D /trunk/sp/config/aclocal.m4
|
||||
D /trunk/sp/config/configure.in
|
||||
M /trunk/sp/configure
|
||||
A /trunk/sp/configure.in
|
||||
|
||||
Install headers in $(includedir)/OpenSP, move configure.in to toplevel,
|
||||
remove generated file aclocal.m4.
|
||||
|
||||
diff --git a/aclocal.m4 b/aclocal.m4
|
||||
index d7cc45cf7b80ca54..2fde71fb866f12bc 100644
|
||||
--- a/aclocal.m4
|
||||
+++ b/aclocal.m4
|
||||
@@ -833,10 +833,6 @@ else
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" void exit (int);
|
||||
-#endif
|
||||
-
|
||||
void fnord() { int i=42;}
|
||||
int main ()
|
||||
{
|
||||
@@ -850,7 +846,7 @@ int main ()
|
||||
/* dlclose (self); */
|
||||
}
|
||||
|
||||
- exit (status);
|
||||
+ return status;
|
||||
}]
|
||||
EOF
|
||||
if AC_TRY_EVAL(ac_link) && test -s conftest${ac_exeext} 2>/dev/null; then
|
||||
diff --git a/configure b/configure
|
||||
index caa2d31585b112bd..90dce8e854b35393 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -2917,7 +2917,7 @@ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
for ac_declaration in \
|
||||
- '' \
|
||||
+ '#include <stdlib.h>' \
|
||||
'extern "C" void std::exit (int) throw (); using std::exit;' \
|
||||
'extern "C" void std::exit (int); using std::exit;' \
|
||||
'extern "C" void exit (int) throw ();' \
|
||||
@@ -5186,8 +5186,8 @@ main ()
|
||||
for (i = 0; i < 256; i++)
|
||||
if (XOR (islower (i), ISLOWER (i))
|
||||
|| toupper (i) != TOUPPER (i))
|
||||
- exit(2);
|
||||
- exit (0);
|
||||
+ return 2;
|
||||
+ return 0;
|
||||
}
|
||||
_ACEOF
|
||||
rm -f conftest$ac_exeext
|
||||
@@ -9508,10 +9508,6 @@ else
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" void exit (int);
|
||||
-#endif
|
||||
-
|
||||
void fnord() { int i=42;}
|
||||
int main ()
|
||||
{
|
||||
@@ -9525,7 +9521,7 @@ int main ()
|
||||
/* dlclose (self); */
|
||||
}
|
||||
|
||||
- exit (status);
|
||||
+ return status;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
@@ -9606,10 +9602,6 @@ else
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" void exit (int);
|
||||
-#endif
|
||||
-
|
||||
void fnord() { int i=42;}
|
||||
int main ()
|
||||
{
|
||||
@@ -9623,7 +9615,7 @@ int main ()
|
||||
/* dlclose (self); */
|
||||
}
|
||||
|
||||
- exit (status);
|
||||
+ return status;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
@@ -13321,10 +13313,6 @@ else
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" void exit (int);
|
||||
-#endif
|
||||
-
|
||||
void fnord() { int i=42;}
|
||||
int main ()
|
||||
{
|
||||
@@ -13338,7 +13326,7 @@ int main ()
|
||||
/* dlclose (self); */
|
||||
}
|
||||
|
||||
- exit (status);
|
||||
+ return status;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
@@ -13419,10 +13407,6 @@ else
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" void exit (int);
|
||||
-#endif
|
||||
-
|
||||
void fnord() { int i=42;}
|
||||
int main ()
|
||||
{
|
||||
@@ -13436,7 +13420,7 @@ int main ()
|
||||
/* dlclose (self); */
|
||||
}
|
||||
|
||||
- exit (status);
|
||||
+ return status;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
@@ -19110,10 +19094,6 @@ else
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" void exit (int);
|
||||
-#endif
|
||||
-
|
||||
void fnord() { int i=42;}
|
||||
int main ()
|
||||
{
|
||||
@@ -19127,7 +19107,7 @@ int main ()
|
||||
/* dlclose (self); */
|
||||
}
|
||||
|
||||
- exit (status);
|
||||
+ return status;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
@@ -19208,10 +19188,6 @@ else
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef __cplusplus
|
||||
-extern "C" void exit (int);
|
||||
-#endif
|
||||
-
|
||||
void fnord() { int i=42;}
|
||||
int main ()
|
||||
{
|
||||
@@ -19225,7 +19201,7 @@ int main ()
|
||||
/* dlclose (self); */
|
||||
}
|
||||
|
||||
- exit (status);
|
||||
+ return status;
|
||||
}
|
||||
EOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
@@ -27450,8 +27426,8 @@ main ()
|
||||
for (i = 0; i < 256; i++)
|
||||
if (XOR (islower (i), ISLOWER (i))
|
||||
|| toupper (i) != TOUPPER (i))
|
||||
- exit(2);
|
||||
- exit (0);
|
||||
+ return 2;
|
||||
+ return 0;
|
||||
}
|
||||
_ACEOF
|
||||
rm -f conftest$ac_exeext
|
@ -1,7 +1,7 @@
|
||||
Summary: SGML and XML parser
|
||||
Name: opensp
|
||||
Version: 1.5.2
|
||||
Release: 40%{?dist}
|
||||
Release: 41%{?dist}
|
||||
Requires: sgml-common >= 0.5
|
||||
Provides: bundled(gettext) = 0.14.5
|
||||
URL: http://openjade.sourceforge.net/
|
||||
@ -10,6 +10,7 @@ Patch0: opensp-multilib.patch
|
||||
Patch1: opensp-nodeids.patch
|
||||
Patch2: opensp-sigsegv.patch
|
||||
Patch3: opensp-manpage.patch
|
||||
Patch4: opensp-configure-c99.patch
|
||||
License: MIT
|
||||
|
||||
BuildRequires: make
|
||||
@ -39,6 +40,7 @@ Header files and libtool library for developing applications that use OpenSP.
|
||||
%patch1 -p1 -b .nodeids
|
||||
%patch2 -p1 -b .sigsegv
|
||||
%patch3 -p1 -b .manpage
|
||||
%patch4 -p1 -b .configure-c99
|
||||
# convert files to UTF-8
|
||||
iconv -f latin1 -t utf8 ChangeLog -o ChangeLog.tmp
|
||||
mv -f ChangeLog.tmp ChangeLog
|
||||
@ -117,6 +119,9 @@ make check || : # TODO: failures as of 1.5.2 :(
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Dec 6 2022 Florian Weimer <fweimer@redhat.com> - 1.5.2-41
|
||||
- Port configure script to C99
|
||||
|
||||
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.2-40
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user