- Fixed multilib fix (bug #194702).
This commit is contained in:
parent
a80ea167ed
commit
1cc6ee6b84
@ -1,5 +1,5 @@
|
|||||||
--- OpenSP-1.5.2/configure.in.multilib 2006-05-26 18:12:45.000000000 +0100
|
--- OpenSP-1.5.2/configure.in.multilib 2005-12-23 14:15:21.000000000 +0000
|
||||||
+++ OpenSP-1.5.2/configure.in 2006-05-26 18:13:04.000000000 +0100
|
+++ OpenSP-1.5.2/configure.in 2006-06-13 13:36:49.000000000 +0100
|
||||||
@@ -90,7 +90,7 @@
|
@@ -90,7 +90,7 @@
|
||||||
#define SP_SIZEOF_BOOL_1
|
#define SP_SIZEOF_BOOL_1
|
||||||
#endif
|
#endif
|
||||||
@ -9,8 +9,8 @@
|
|||||||
#define SP_WCHAR_T_USHORT
|
#define SP_WCHAR_T_USHORT
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
--- OpenSP-1.5.2/lib/parser_inst.cxx.multilib 2006-05-26 16:30:16.000000000 +0100
|
--- OpenSP-1.5.2/lib/parser_inst.cxx.multilib 2005-07-21 16:33:41.000000000 +0100
|
||||||
+++ OpenSP-1.5.2/lib/parser_inst.cxx 2006-05-26 16:41:10.000000000 +0100
|
+++ OpenSP-1.5.2/lib/parser_inst.cxx 2006-06-13 13:36:49.000000000 +0100
|
||||||
@@ -9,6 +9,7 @@
|
@@ -9,6 +9,7 @@
|
||||||
// Copyright (c) 1994 James Clark
|
// Copyright (c) 1994 James Clark
|
||||||
// See the file COPYING for copying permission.
|
// See the file COPYING for copying permission.
|
||||||
@ -28,8 +28,8 @@
|
|||||||
#ifdef __DECCXX
|
#ifdef __DECCXX
|
||||||
#pragma define_template Vector<unsigned int>
|
#pragma define_template Vector<unsigned int>
|
||||||
#else
|
#else
|
||||||
--- OpenSP-1.5.2/lib/parser_inst.m4.multilib 2006-05-26 16:30:32.000000000 +0100
|
--- OpenSP-1.5.2/lib/parser_inst.m4.multilib 2005-05-14 10:17:35.000000000 +0100
|
||||||
+++ OpenSP-1.5.2/lib/parser_inst.m4 2006-05-26 16:39:32.000000000 +0100
|
+++ OpenSP-1.5.2/lib/parser_inst.m4 2006-06-13 13:36:49.000000000 +0100
|
||||||
@@ -1,6 +1,7 @@
|
@@ -1,6 +1,7 @@
|
||||||
// Copyright (c) 1994 James Clark
|
// Copyright (c) 1994 James Clark
|
||||||
// See the file COPYING for copying permission.
|
// See the file COPYING for copying permission.
|
||||||
@ -47,9 +47,17 @@
|
|||||||
__instantiate(Vector<unsigned int>)
|
__instantiate(Vector<unsigned int>)
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
--- OpenSP-1.5.2/config.h.in.multilib 2006-05-26 16:41:21.000000000 +0100
|
--- OpenSP-1.5.2/config.h.in.multilib 2005-11-05 09:43:42.000000000 +0000
|
||||||
+++ OpenSP-1.5.2/config.h.in 2006-05-26 18:13:39.000000000 +0100
|
+++ OpenSP-1.5.2/config.h.in 2006-06-13 13:41:45.000000000 +0100
|
||||||
@@ -333,22 +333,6 @@
|
@@ -1,5 +1,7 @@
|
||||||
|
/* config.h.in. Generated from configure.in by autoheader. */
|
||||||
|
|
||||||
|
+#include <limits.h>
|
||||||
|
+
|
||||||
|
/* Define to one of `_getb67', `GETB67', `getb67' for Cray-2 and Cray-YMP
|
||||||
|
systems. This function is required for `alloca.c' support on those systems.
|
||||||
|
*/
|
||||||
|
@@ -333,22 +335,6 @@
|
||||||
/* The size of a `bool', as computed by sizeof. */
|
/* The size of a `bool', as computed by sizeof. */
|
||||||
#undef SIZEOF_BOOL
|
#undef SIZEOF_BOOL
|
||||||
|
|
||||||
@ -72,3 +80,12 @@
|
|||||||
/* define this if h_errno should be declared extern int */
|
/* define this if h_errno should be declared extern int */
|
||||||
#undef SP_DECLARE_H_ERRNO
|
#undef SP_DECLARE_H_ERRNO
|
||||||
|
|
||||||
|
@@ -503,7 +489,7 @@
|
||||||
|
#define SP_SIZEOF_BOOL_1
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#if (SIZEOF_WCHAR_T == SIZEOF_UNSIGNED_SHORT)
|
||||||
|
+#if (WCHAR_MAX == SHRT_MAX)
|
||||||
|
#define SP_WCHAR_T_USHORT
|
||||||
|
#endif
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: SGML and XML parser
|
Summary: SGML and XML parser
|
||||||
Name: opensp
|
Name: opensp
|
||||||
Version: 1.5.2
|
Version: 1.5.2
|
||||||
Release: 2
|
Release: 3
|
||||||
Requires: sgml-common >= 0.5
|
Requires: sgml-common >= 0.5
|
||||||
URL: http://openjade.sourceforge.net/
|
URL: http://openjade.sourceforge.net/
|
||||||
Source: http://download.sourceforge.net/openjade/OpenSP-%{version}.tar.gz
|
Source: http://download.sourceforge.net/openjade/OpenSP-%{version}.tar.gz
|
||||||
@ -97,6 +97,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 13 2006 Tim Waugh <twaugh@redhat.com> 1.5.2-3
|
||||||
|
- Fixed multilib fix (bug #194702).
|
||||||
|
|
||||||
* Fri May 26 2006 Tim Waugh <twaugh@redhat.com> 1.5.2-2
|
* Fri May 26 2006 Tim Waugh <twaugh@redhat.com> 1.5.2-2
|
||||||
- Fixed multilib devel conflicts (bug #192741).
|
- Fixed multilib devel conflicts (bug #192741).
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user