Rebase opensm to latest upstream release 3.3.21
Resolves: bz1637260 Signed-off-by: Honggang Li <honli@redhat.com>
This commit is contained in:
parent
e80cd84a40
commit
82e02b9b50
@ -1,56 +0,0 @@
|
|||||||
--- opensm-3.3.17/man/opensm.8.in.orig 2014-03-17 22:57:54.510928914 +0000
|
|
||||||
+++ opensm-3.3.17/man/opensm.8.in 2014-03-17 22:59:18.885215712 +0000
|
|
||||||
@@ -11,6 +11,7 @@
|
|
||||||
[\-g(uid) <GUID in hex>]
|
|
||||||
[\-l(mc) <LMC>]
|
|
||||||
[\-p(riority) <PRIORITY>]
|
|
||||||
+[\-\-subnet_prefix <PREFIX in hex>]
|
|
||||||
[\-\-smkey <SM_Key>]
|
|
||||||
[\-\-sm_sl <SL number>]
|
|
||||||
[\-r(eassign_lids)]
|
|
||||||
@@ -135,6 +136,13 @@
|
|
||||||
is chosen by priority and GUID. Range goes from 0
|
|
||||||
(default and lowest priority) to 15 (highest).
|
|
||||||
.TP
|
|
||||||
+\fB\-\-subnet_prefix\fR <PREFIX in hex>
|
|
||||||
+This option specifies the subnet prefix to use in
|
|
||||||
+on the fabric. The default prefix is
|
|
||||||
+0xfe80000000000000. OpenMPI in particular requires
|
|
||||||
+separate fabrics plugged into different ports to
|
|
||||||
+have different prefixes or else it won't run.
|
|
||||||
+.TP
|
|
||||||
\fB\-\-smkey\fR <SM_Key value>
|
|
||||||
This option specifies the SM\'s SM_Key (64 bits).
|
|
||||||
This will effect SM authentication.
|
|
||||||
--- opensm-3.3.17/opensm/main.c.orig 2014-01-29 20:50:51.000000000 +0000
|
|
||||||
+++ opensm-3.3.17/opensm/main.c 2014-03-17 22:57:54.513928955 +0000
|
|
||||||
@@ -160,6 +160,9 @@
|
|
||||||
" This will effect the handover cases, where master\n"
|
|
||||||
" is chosen by priority and GUID. Range goes\n"
|
|
||||||
" from 0 (lowest priority) to 15 (highest).\n\n");
|
|
||||||
+ printf("--subnet_prefix <prefix>\n"
|
|
||||||
+ " Set the subnet prefix to something other than the\n"
|
|
||||||
+ " default value of 0xfe80000000000000\n\n");
|
|
||||||
printf("--smkey, -k <SM_Key>\n"
|
|
||||||
" This option specifies the SM's SM_Key (64 bits).\n"
|
|
||||||
" This will effect SM authentication.\n"
|
|
||||||
@@ -654,6 +657,7 @@
|
|
||||||
{"once", 0, NULL, 'o'},
|
|
||||||
{"reassign_lids", 0, NULL, 'r'},
|
|
||||||
{"priority", 1, NULL, 'p'},
|
|
||||||
+ {"subnet_prefix", 1, NULL, 15},
|
|
||||||
{"smkey", 1, NULL, 'k'},
|
|
||||||
{"routing_engine", 1, NULL, 'R'},
|
|
||||||
{"ucast_cache", 0, NULL, 'A'},
|
|
||||||
@@ -996,6 +1000,11 @@
|
|
||||||
printf(" Priority = %d\n", temp);
|
|
||||||
break;
|
|
||||||
|
|
||||||
+ case 15:
|
|
||||||
+ opt.subnet_prefix = cl_hton64(strtoull(optarg, NULL, 16));
|
|
||||||
+ printf(" Subnet_Prefix = <0x%" PRIx64 ">\n", cl_hton64(opt.subnet_prefix));
|
|
||||||
+ break;
|
|
||||||
+
|
|
||||||
case 'k':
|
|
||||||
sm_key = cl_hton64(strtoull(optarg, NULL, 16));
|
|
||||||
printf(" SM Key <0x%" PRIx64 ">\n", cl_hton64(sm_key));
|
|
@ -1,78 +0,0 @@
|
|||||||
diff -up opensm-3.3.18/man/opensm.8.in.options opensm-3.3.18/man/opensm.8.in
|
|
||||||
--- opensm-3.3.18/man/opensm.8.in.options 2014-10-17 13:14:58.462550601 -0400
|
|
||||||
+++ opensm-3.3.18/man/opensm.8.in 2014-10-17 13:22:19.587173079 -0400
|
|
||||||
@@ -7,14 +7,14 @@ opensm \- InfiniBand subnet manager and
|
|
||||||
.B opensm
|
|
||||||
[\-\-version]]
|
|
||||||
[\-F | \-\-config <file_name>]
|
|
||||||
-[\-c(reate-config) <file_name>]
|
|
||||||
-[\-g(uid) <GUID in hex>]
|
|
||||||
-[\-l(mc) <LMC>]
|
|
||||||
-[\-p(riority) <PRIORITY>]
|
|
||||||
+[\-c | \-\-create-config <file_name>]
|
|
||||||
+[\-g | \-\-guid <GUID in hex>]
|
|
||||||
+[\-l | \-\-lmc <LMC>]
|
|
||||||
+[\-p | \-\-priority <PRIORITY>]
|
|
||||||
[\-\-subnet_prefix <PREFIX in hex>]
|
|
||||||
[\-\-smkey <SM_Key>]
|
|
||||||
[\-\-sm_sl <SL number>]
|
|
||||||
-[\-r(eassign_lids)]
|
|
||||||
+[\-r | \-\-reassign_lids]
|
|
||||||
[\-R <engine name(s)> | \-\-routing_engine <engine name(s)>]
|
|
||||||
[\-\-do_mesh_analysis]
|
|
||||||
[\-\-lash_start_vl <vl number>]
|
|
||||||
@@ -31,20 +31,21 @@ opensm \- InfiniBand subnet manager and
|
|
||||||
[\-H | \-\-max_reverse_hops <max reverse hops allowed>]
|
|
||||||
[\-X | \-\-guid_routing_order_file <path to file>]
|
|
||||||
[\-m | \-\-ids_guid_file <path to file>]
|
|
||||||
-[\-o(nce)]
|
|
||||||
-[\-s(weep) <interval>]
|
|
||||||
-[\-t(imeout) <milliseconds>]
|
|
||||||
+[\-o | \-\-once]
|
|
||||||
+[\-s | \-\-sweep <interval>]
|
|
||||||
+[\-t | \-\-timeout <milliseconds>]
|
|
||||||
[\-\-retries <number>]
|
|
||||||
[\-\-maxsmps <number>]
|
|
||||||
[\-\-console [off | local | socket | loopback]]
|
|
||||||
[\-\-console-port <port>]
|
|
||||||
-[\-i(gnore-guids) <equalize-ignore-guids-file>]
|
|
||||||
+[\-i | \-\-ignore-guids <equalize-ignore-guids-file>]
|
|
||||||
[\-w | \-\-hop_weights_file <path to file>]
|
|
||||||
[\-O | \-\-port_search_ordering_file <path to file>]
|
|
||||||
[\-O | \-\-dimn_ports_file <path to file>] (DEPRECATED)
|
|
||||||
-[\-f <log file path> | \-\-log_file <log file path> ]
|
|
||||||
-[\-L | \-\-log_limit <size in MB>] [\-e(rase_log_file)]
|
|
||||||
-[\-P(config) <partition config file> ]
|
|
||||||
+[\-f | \-\-log_file <log file path> ]
|
|
||||||
+[\-L | \-\-log_limit <size in MB>]
|
|
||||||
+[\-e | \-\-erase_log_file]
|
|
||||||
+[\-P | \-\-Pconfig <partition config file> ]
|
|
||||||
[\-N | \-\-no_part_enforce] (DEPRECATED)
|
|
||||||
[\-Z | \-\-part_enforce [both | in | out | off]]
|
|
||||||
[\-W | \-\-allow_both_pkeys]
|
|
||||||
@@ -61,8 +62,11 @@ opensm \- InfiniBand subnet manager and
|
|
||||||
[\-\-consolidate_ipv6_snm_req]
|
|
||||||
[\-\-log_prefix <prefix text>]
|
|
||||||
[\-\-torus_config <path to file>]
|
|
||||||
-[\-v(erbose)] [\-V] [\-D <flags>] [\-d(ebug) <number>]
|
|
||||||
-[\-h(elp)] [\-?]
|
|
||||||
+[\-v | \-\-verbose]
|
|
||||||
+[\-V]
|
|
||||||
+[\-D <flags>]
|
|
||||||
+[\-d | \-\-debug <number>]
|
|
||||||
+[\-h | \-? | \-\-help]
|
|
||||||
|
|
||||||
.SH DESCRIPTION
|
|
||||||
.PP
|
|
||||||
@@ -511,10 +515,7 @@ option to enable as follows:
|
|
||||||
-d2 - Force log flushing after each log message
|
|
||||||
-d3 - Disable multicast support
|
|
||||||
.TP
|
|
||||||
-\fB\-h\fR, \fB\-\-help\fR
|
|
||||||
-Display this usage info then exit.
|
|
||||||
-.TP
|
|
||||||
-\fB\-?\fR
|
|
||||||
+\fB\-h\fR, \fB\-\-help\fR, \fB\-?\fR
|
|
||||||
Display this usage info then exit.
|
|
||||||
|
|
||||||
.SH ENVIRONMENT VARIABLES
|
|
@ -12,7 +12,7 @@
|
|||||||
# 5 = 4096
|
# 5 = 4096
|
||||||
#
|
#
|
||||||
# rate =
|
# rate =
|
||||||
# 2 = 2.5 GBit/s (SDR 1x)
|
# 2 = 2.5 GBit/s (SDR 1x)
|
||||||
# 3 = 10 GBit/s (SDR 4x/QDR 1x)
|
# 3 = 10 GBit/s (SDR 4x/QDR 1x)
|
||||||
# 4 = 30 GBit/s (SDR 12x)
|
# 4 = 30 GBit/s (SDR 12x)
|
||||||
# 5 = 5 GBit/s (DDR 1x)
|
# 5 = 5 GBit/s (DDR 1x)
|
||||||
@ -31,9 +31,9 @@
|
|||||||
# 17 = 200 GBit/s (EDR 8x)
|
# 17 = 200 GBit/s (EDR 8x)
|
||||||
# 18 = 300 GBit/s (EDR 12x)
|
# 18 = 300 GBit/s (EDR 12x)
|
||||||
|
|
||||||
Default=0x7fff, rate=3 mtu=4 scope=2, defmember=full:
|
Default=0x7fff, rate=3, mtu=4, scope=2, defmember=full:
|
||||||
ALL, ALL_SWITCHES=full;
|
ALL, ALL_SWITCHES=full;
|
||||||
Default=0x7fff, ipoib, rate=3 mtu=4 scope=2:
|
Default=0x7fff, ipoib, rate=3, mtu=4, scope=2:
|
||||||
mgid=ff12:401b::ffff:ffff # IPv4 Broadcast address
|
mgid=ff12:401b::ffff:ffff # IPv4 Broadcast address
|
||||||
mgid=ff12:401b::1 # IPv4 All Hosts group
|
mgid=ff12:401b::1 # IPv4 All Hosts group
|
||||||
mgid=ff12:401b::2 # IPv4 All Routers group
|
mgid=ff12:401b::2 # IPv4 All Routers group
|
||||||
@ -52,9 +52,9 @@ Default=0x7fff, ipoib, rate=3 mtu=4 scope=2:
|
|||||||
ALL=full, ALL_SWITCHES=full;
|
ALL=full, ALL_SWITCHES=full;
|
||||||
|
|
||||||
# 40GBit, 4K MTU IPoIB example
|
# 40GBit, 4K MTU IPoIB example
|
||||||
#ib0_2=0x0002, rate=7 mtu=5 scope=2, defmember=full:
|
#ib0_2=0x0002, rate=7, mtu=5, scope=2, defmember=full:
|
||||||
# ALL, ALL_SWITCHES=full;
|
# ALL, ALL_SWITCHES=full;
|
||||||
#ib0_2=0x0002, ipoib, rate=7 mtu=5 scope=2:
|
#ib0_2=0x0002, ipoib, rate=7, mtu=5, scope=2:
|
||||||
# mgid=ff12:401b::ffff:ffff # IPv4 Broadcast address
|
# mgid=ff12:401b::ffff:ffff # IPv4 Broadcast address
|
||||||
# mgid=ff12:401b::1 # IPv4 All Hosts group
|
# mgid=ff12:401b::1 # IPv4 All Hosts group
|
||||||
# mgid=ff12:401b::2 # IPv4 All Routers group
|
# mgid=ff12:401b::2 # IPv4 All Routers group
|
||||||
|
24
opensm.spec
24
opensm.spec
@ -1,27 +1,25 @@
|
|||||||
%global __remake_config 0
|
%global __remake_config 1
|
||||||
|
|
||||||
Name: opensm
|
Name: opensm
|
||||||
Version: 3.3.20
|
Version: 3.3.21
|
||||||
Release: 9%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: OpenIB InfiniBand Subnet Manager and management utilities
|
Summary: OpenIB InfiniBand Subnet Manager and management utilities
|
||||||
Group: System Environment/Daemons
|
|
||||||
License: GPLv2 or BSD
|
License: GPLv2 or BSD
|
||||||
Url: https://www.openfabrics.org/
|
Url: https://github.com/linux-rdma/opensm
|
||||||
|
|
||||||
Source0: https://www.openfabrics.org/downloads/management/%{name}-%{version}.tar.gz
|
Source0: https://github.com/linux-rdma/opensm/releases/download/%{version}/%{name}-%{version}.tar.gz
|
||||||
Source2: opensm.logrotate
|
Source2: opensm.logrotate
|
||||||
Source4: opensm.sysconfig
|
Source4: opensm.sysconfig
|
||||||
Source5: opensm.service
|
Source5: opensm.service
|
||||||
Source6: opensm.launch
|
Source6: opensm.launch
|
||||||
Source7: opensm.rwtab
|
Source7: opensm.rwtab
|
||||||
Source8: opensm.partitions
|
Source8: opensm.partitions
|
||||||
Patch0: opensm-3.3.17-prefix.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: libibumad-devel, systemd, systemd-units
|
BuildRequires: libibumad-devel, systemd, systemd-units
|
||||||
BuildRequires: bison, flex, byacc
|
BuildRequires: bison, flex, byacc
|
||||||
%if %{__remake_config}
|
%if %{__remake_config}
|
||||||
BuildRequires: libtool, autoconf, autoheader
|
BuildRequires: libtool, autoconf, automake
|
||||||
%endif
|
%endif
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}, logrotate, rdma
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}, logrotate, rdma
|
||||||
Requires(post): systemd
|
Requires(post): systemd
|
||||||
@ -62,13 +60,12 @@ Static version of opensm libraries
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .prefix
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if %{__remake_config}
|
%if %{__remake_config}
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
%endif
|
%endif
|
||||||
%configure --with-opensm-conf-sub-dir=rdma CFLAGS="$CFLAGS -fno-strict-aliasing"
|
%configure --with-opensm-conf-sub-dir=rdma
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
cd opensm
|
cd opensm
|
||||||
./opensm -c ../opensm-%{version}.conf
|
./opensm -c ../opensm-%{version}.conf
|
||||||
@ -114,7 +111,8 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/rdma/partitions.conf
|
%config(noreplace) %{_sysconfdir}/rdma/partitions.conf
|
||||||
%config(noreplace) %{_sysconfdir}/sysconfig/opensm
|
%config(noreplace) %{_sysconfdir}/sysconfig/opensm
|
||||||
%{_sysconfdir}/rwtab.d/opensm
|
%{_sysconfdir}/rwtab.d/opensm
|
||||||
%doc AUTHORS COPYING ChangeLog INSTALL README NEWS
|
%doc AUTHORS ChangeLog INSTALL README NEWS
|
||||||
|
%license COPYING
|
||||||
|
|
||||||
%files libs
|
%files libs
|
||||||
%{_libdir}/lib*.so.*
|
%{_libdir}/lib*.so.*
|
||||||
@ -127,6 +125,10 @@ fi
|
|||||||
%{_libdir}/lib*.a
|
%{_libdir}/lib*.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 8 2018 Honggang Li <honli@redhat.com> - 3.3.21-1
|
||||||
|
- Rebase opensm to latest upstream release 3.3.21
|
||||||
|
- Resolves: bz1637260
|
||||||
|
|
||||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.20-9
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.20-9
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user