Rebase opensm to latest upstream release 3.3.22
Resolves: bz1700766 Signed-off-by: Honggang Li <honli@redhat.com>
This commit is contained in:
parent
d7bb1737a8
commit
527faec9eb
@ -1,60 +0,0 @@
|
||||
diff --git a/man/opensm.8.in b/man/opensm.8.in
|
||||
index df55768..79e1bfb 100644
|
||||
--- a/man/opensm.8.in
|
||||
+++ b/man/opensm.8.in
|
||||
@@ -11,6 +11,7 @@ opensm \- InfiniBand subnet manager and administration (SM/SA)
|
||||
[\-g(uid) <GUID in hex>]
|
||||
[\-l(mc) <LMC>]
|
||||
[\-p(riority) <PRIORITY>]
|
||||
+[\-\-subnet_prefix <PREFIX in hex>]
|
||||
[\-\-smkey <SM_Key>]
|
||||
[\-\-sm_sl <SL number>]
|
||||
[\-r(eassign_lids)]
|
||||
@@ -136,6 +137,13 @@ This will effect the handover cases, where master
|
||||
is chosen by priority and GUID. Range goes from 0
|
||||
(default and lowest priority) to 15 (highest).
|
||||
.TP
|
||||
+\fB\-\-subnet_prefix\fR <PREFIX in hex>
|
||||
+This option specifies the subnet prefix to use in
|
||||
+on the fabric. The default prefix is
|
||||
+0xfe80000000000000. OpenMPI in particular requires
|
||||
+separate fabrics plugged into different ports to
|
||||
+have different prefixes or else it won't run.
|
||||
+.TP
|
||||
\fB\-\-smkey\fR <SM_Key value>
|
||||
This option specifies the SM\'s SM_Key (64 bits).
|
||||
This will effect SM authentication.
|
||||
diff --git a/opensm/main.c b/opensm/main.c
|
||||
index 2d23fe2..b4bb348 100644
|
||||
--- a/opensm/main.c
|
||||
+++ b/opensm/main.c
|
||||
@@ -161,6 +161,9 @@ static void show_usage(void)
|
||||
" This will effect the handover cases, where master\n"
|
||||
" is chosen by priority and GUID. Range goes\n"
|
||||
" from 0 (lowest priority) to 15 (highest).\n\n");
|
||||
+ printf("--subnet_prefix <prefix>\n"
|
||||
+ " Set the subnet prefix to something other than the\n"
|
||||
+ " default value of 0xfe80000000000000\n\n");
|
||||
printf("--smkey, -k <SM_Key>\n"
|
||||
" This option specifies the SM's SM_Key (64 bits).\n"
|
||||
" This will effect SM authentication.\n"
|
||||
@@ -665,6 +668,7 @@ int main(int argc, char *argv[])
|
||||
{"once", 0, NULL, 'o'},
|
||||
{"reassign_lids", 0, NULL, 'r'},
|
||||
{"priority", 1, NULL, 'p'},
|
||||
+ {"subnet_prefix", 1, NULL, 15},
|
||||
{"smkey", 1, NULL, 'k'},
|
||||
{"routing_engine", 1, NULL, 'R'},
|
||||
{"ucast_cache", 0, NULL, 'A'},
|
||||
@@ -1008,6 +1012,11 @@ int main(int argc, char *argv[])
|
||||
printf(" Priority = %d\n", temp);
|
||||
break;
|
||||
|
||||
+ case 16:
|
||||
+ opt.subnet_prefix = cl_hton64(strtoull(optarg, NULL, 16));
|
||||
+ printf(" Subnet_Prefix = <0x%" PRIx64 ">\n", cl_hton64(opt.subnet_prefix));
|
||||
+ break;
|
||||
+
|
||||
case 'k':
|
||||
sm_key = cl_hton64(strtoull(optarg, NULL, 16));
|
||||
printf(" SM Key <0x%" PRIx64 ">\n", cl_hton64(sm_key));
|
11
opensm.spec
11
opensm.spec
@ -1,8 +1,8 @@
|
||||
%global __remake_config 1
|
||||
|
||||
Name: opensm
|
||||
Version: 3.3.21
|
||||
Release: 3%{?dist}
|
||||
Version: 3.3.22
|
||||
Release: 1%{?dist}
|
||||
Summary: OpenIB InfiniBand Subnet Manager and management utilities
|
||||
License: GPLv2 or BSD
|
||||
Url: https://github.com/linux-rdma/opensm
|
||||
@ -15,8 +15,6 @@ Source6: opensm.launch
|
||||
Source7: opensm.rwtab
|
||||
Source8: opensm.partitions
|
||||
|
||||
Patch100: opensm-3.3.17-prefix.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libibumad-devel, systemd, systemd-units
|
||||
BuildRequires: bison, flex, byacc
|
||||
@ -59,7 +57,6 @@ Static version of opensm libraries
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch100 -p1
|
||||
|
||||
%build
|
||||
%if %{__remake_config}
|
||||
@ -123,6 +120,10 @@ fi
|
||||
%{_libdir}/lib*.a
|
||||
|
||||
%changelog
|
||||
* Wed Apr 17 2019 Honggang Li <honli@redhat.com> - 3.3.22-1
|
||||
- Rebase opensm to latest upstream release 3.3.22
|
||||
- Resolves: bz1700766
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.21-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (opensm-3.3.21.tar.gz) = c3c541ad8cfc71ee5e34f80c05d374df016e9713d0dc34d52d6be52486fae6fc07dd5302db8379c50219fbf3f08d91801561b577ad8bcfb15b1c17f61c0070d4
|
||||
SHA512 (opensm-3.3.22.tar.gz) = 4334a44dbf26e0bc9349cbf22044730d1fe584ad3fda0c6623145e4aab611823e161bba669e3979d75326d90ccf558d85634bfe7f4a1db14adb63f153b77cb2f
|
||||
|
Loading…
Reference in New Issue
Block a user