- 1.2.1
- move most docs to -server - --enable-slpv2-security - --disable-dependency-tracking
This commit is contained in:
parent
fc991491c2
commit
fe8788230a
@ -1 +1 @@
|
|||||||
openslp-1.2.0.tar.gz
|
openslp-1.2.1.tar.gz
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- openslp-1.2.0/configure.in.optflags 2004-07-15 09:03:43.000000000 -0500
|
|
||||||
+++ openslp-1.2.0/configure.in 2004-02-04 14:07:33.000000000 -0600
|
|
||||||
@@ -126,7 +126,7 @@
|
|
||||||
CFLAGS="$CFLAGS -Werror"
|
|
||||||
fi
|
|
||||||
if test X"$debug" = X"no"; then
|
|
||||||
- OPTFLAGS="-O3"
|
|
||||||
+ OPTFLAGS="-O3 $RPM_OPT_FLAGS "
|
|
||||||
fi
|
|
||||||
|
|
||||||
elif $CC -V 2>&1 | grep "WorkShop Compilers"; then
|
|
22
openslp-1.2.1-optflags.patch
Normal file
22
openslp-1.2.1-optflags.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- openslp-1.2.1/configure.in.optflags 2005-02-15 14:06:02.000000000 -0600
|
||||||
|
+++ openslp-1.2.1/configure.in 2005-03-04 06:53:02.000000000 -0600
|
||||||
|
@@ -130,7 +130,7 @@
|
||||||
|
CFLAGS="$CFLAGS -Werror"
|
||||||
|
fi
|
||||||
|
if test X"$debug" = X"no"; then
|
||||||
|
- OPTFLAGS="-O3"
|
||||||
|
+ OPTFLAGS="-O3 $RPM_OPT_FLAGS"
|
||||||
|
fi
|
||||||
|
|
||||||
|
elif $CC -V 2>&1 | grep "WorkShop Compilers"; then
|
||||||
|
--- openslp-1.2.1/configure.optflags 2005-03-02 12:00:28.000000000 -0600
|
||||||
|
+++ openslp-1.2.1/configure 2005-03-04 06:53:04.000000000 -0600
|
||||||
|
@@ -20596,7 +20596,7 @@
|
||||||
|
CFLAGS="$CFLAGS -Werror"
|
||||||
|
fi
|
||||||
|
if test X"$debug" = X"no"; then
|
||||||
|
- OPTFLAGS="-O3"
|
||||||
|
+ OPTFLAGS="-O3 $RPM_OPT_FLAGS"
|
||||||
|
fi
|
||||||
|
|
||||||
|
elif $CC -V 2>&1 | grep "WorkShop Compilers"; then
|
55
openslp.spec
55
openslp.spec
@ -1,25 +1,23 @@
|
|||||||
# $Id: openslp.spec,v 1.7 2005/05/23 00:20:08 katzj Exp $
|
# $Id: openslp.spec,v 1.8 2005/10/21 18:56:57 rdieter Exp $
|
||||||
|
|
||||||
%define pie 1
|
|
||||||
|
|
||||||
Summary: Open implementation of Service Location Protocol V2
|
Summary: Open implementation of Service Location Protocol V2
|
||||||
Name: openslp
|
Name: openslp
|
||||||
Version: 1.2.0
|
Version: 1.2.1
|
||||||
Release: 6%{?dist_tag}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: BSD
|
License: BSD
|
||||||
#URL: http://www.openslp.org/
|
|
||||||
URL: http://sourceforge.net/projects/openslp/
|
URL: http://sourceforge.net/projects/openslp/
|
||||||
Source: http://dl.sourceforge.net/sourceforge/openslp/openslp-1.2.0.tar.gz
|
Source: http://dl.sourceforge.net/sourceforge/openslp/openslp-1.2.1.tar.gz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Source1: slpd.init
|
Source1: slpd.init
|
||||||
Patch1: openslp-1.2.0-optflags.patch
|
Patch1: openslp-1.2.1-optflags.patch
|
||||||
|
|
||||||
BuildRequires: autoconf automake libtool
|
BuildRequires: automake
|
||||||
BuildRequires: bison flex
|
BuildRequires: libtool
|
||||||
#BuildRequires: byacc
|
BuildRequires: bison
|
||||||
|
BuildRequires: flex
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -42,7 +40,7 @@ OpenSLP header files and libraries.
|
|||||||
Summary: OpenSLP server daemon
|
Summary: OpenSLP server daemon
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires(preun): chkconfig /sbin/service
|
Requires(preun): chkconfig, /sbin/service
|
||||||
Requires(post): chkconfig
|
Requires(post): chkconfig
|
||||||
Requires(postun): /sbin/service
|
Requires(postun): /sbin/service
|
||||||
%description server
|
%description server
|
||||||
@ -54,6 +52,7 @@ OpenSLP server daemon to dynamically register services.
|
|||||||
|
|
||||||
%patch1 -p1 -b .optflags
|
%patch1 -p1 -b .optflags
|
||||||
|
|
||||||
|
# tarball goof (?), it wants to re-automake anyway, so let's do it right.
|
||||||
libtoolize --force
|
libtoolize --force
|
||||||
aclocal
|
aclocal
|
||||||
autoconf
|
autoconf
|
||||||
@ -62,18 +61,15 @@ automake --add-missing
|
|||||||
# remove CVS leftovers...
|
# remove CVS leftovers...
|
||||||
find . -name "CVS" | xargs rm -rf
|
find . -name "CVS" | xargs rm -rf
|
||||||
|
|
||||||
# remove hard-coded compiler flags: -O3 -Wall
|
|
||||||
perl -pi -e "s@-O3@@g" configure
|
|
||||||
#perl -pi -e "s@-Wall@@g" configure
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
%{?pie:export CFLAGS="-fPIC $RPM_OPT_FLAGS"; export LDFLAGS="-pie"}
|
export LDFLAGS="-pie"
|
||||||
|
|
||||||
%configure \
|
%configure \
|
||||||
--disable-static
|
--disable-dependency-tracking \
|
||||||
# --enable-slpv2-security
|
--disable-static \
|
||||||
|
--enable-slpv2-security
|
||||||
# --enable-async-api
|
# --enable-async-api
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
@ -88,7 +84,7 @@ install -p -D -m755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/slpd
|
|||||||
|
|
||||||
# nuke unpackaged/unwanted files
|
# nuke unpackaged/unwanted files
|
||||||
rm -rf $RPM_BUILD_ROOT/usr/doc
|
rm -rf $RPM_BUILD_ROOT/usr/doc
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -96,19 +92,22 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
%post server
|
%post server
|
||||||
/sbin/chkconfig --add slpd
|
/sbin/chkconfig --add slpd
|
||||||
|
|
||||||
%preun server
|
%preun server
|
||||||
|
# on remove
|
||||||
if [ $1 -eq 0 ]; then
|
if [ $1 -eq 0 ]; then
|
||||||
/sbin/service slpd stop >/dev/null 2>&1 ||:
|
/sbin/service slpd stop >/dev/null 2>&1 ||:
|
||||||
/sbin/chkconfig --del slpd
|
/sbin/chkconfig --del slpd
|
||||||
fi
|
fi
|
||||||
|
|
||||||
%postun server
|
%postun server
|
||||||
if [ $1 -ge 1 ]; then
|
# on upgrade
|
||||||
|
if [ $1 -gt 0 ]; then
|
||||||
/sbin/service slpd condrestart >/dev/null 2>&1
|
/sbin/service slpd condrestart >/dev/null 2>&1
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -116,15 +115,15 @@ fi
|
|||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc AUTHORS COPYING FAQ NEWS README THANKS
|
%doc AUTHORS COPYING FAQ NEWS README THANKS
|
||||||
%doc doc/html/IntroductionToSLP
|
|
||||||
%doc doc/html/UsersGuide
|
|
||||||
%doc doc/html/faq*
|
|
||||||
%config(noreplace) %{_sysconfdir}/slp.conf
|
%config(noreplace) %{_sysconfdir}/slp.conf
|
||||||
%{_bindir}/*
|
%{_bindir}/*
|
||||||
%{_libdir}/lib*.so.*
|
%{_libdir}/lib*.so.*
|
||||||
|
|
||||||
%files server
|
%files server
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
|
%doc doc/html/IntroductionToSLP
|
||||||
|
%doc doc/html/UsersGuide
|
||||||
|
%doc doc/html/faq*
|
||||||
%{_sbindir}/*
|
%{_sbindir}/*
|
||||||
%config(noreplace) %{_sysconfdir}/slp.reg
|
%config(noreplace) %{_sysconfdir}/slp.reg
|
||||||
%config(noreplace) %{_sysconfdir}/slp.spi
|
%config(noreplace) %{_sysconfdir}/slp.spi
|
||||||
@ -139,6 +138,12 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 21 2005 Rex Dieter <rexdieter[AT]users.sf.net> 1.2.1-1
|
||||||
|
- 1.2.1
|
||||||
|
- move most docs to -server
|
||||||
|
- --enable-slpv2-security
|
||||||
|
- --disable-dependency-tracking
|
||||||
|
|
||||||
* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.2.0
|
* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.2.0
|
||||||
- rebuild on all arches
|
- rebuild on all arches
|
||||||
|
|
||||||
|
@ -249,7 +249,7 @@ case "$1" in
|
|||||||
fi
|
fi
|
||||||
;;
|
;;
|
||||||
*)
|
*)
|
||||||
echo "Usage: slpd {start|stop|restart|reload|status}"
|
echo "Usage: slpd {start|stop|restart|condrestart|reload|status}"
|
||||||
exit 1
|
exit 1
|
||||||
esac
|
esac
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user