b00e70fa17
Resolves: rhbz#1967200
43 lines
1.4 KiB
Diff
43 lines
1.4 KiB
Diff
From 5f8879927fa34827f1b367eac311845e6ebec9a7 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Jan=20=C4=8Cern=C3=BD?= <jcerny@redhat.com>
|
|
Date: Thu, 10 Jun 2021 13:41:25 +0200
|
|
Subject: [PATCH] Do not set Rpath
|
|
|
|
See: https://docs.fedoraproject.org/en-US/packaging-guidelines/#_beware_of_rpath
|
|
|
|
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1967200
|
|
---
|
|
CMakeLists.txt | 18 ------------------
|
|
1 file changed, 18 deletions(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index c70ba29bf..cc7b5e005 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -482,25 +482,7 @@ else()
|
|
endif()
|
|
set(OSCAP_TEMP_DIR "/tmp" CACHE STRING "use different temporary directory to execute sce scripts (default=/tmp)")
|
|
|
|
-# ---------- RPATHS for linking
|
|
|
|
-# see https://cmake.org/Wiki/CMake_RPATH_handling
|
|
-
|
|
-# use, i.e. don't skip the full RPATH for the build tree
|
|
-set(CMAKE_SKIP_BUILD_RPATH FALSE)
|
|
-
|
|
-# when building, don't use the install RPATH already
|
|
-# (but later on when installing)
|
|
-set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
|
|
-
|
|
-set(CMAKE_INSTALL_RPATH ${CMAKE_INSTALL_FULL_LIBDIR})
|
|
-
|
|
-# add the automatically determined parts of the RPATH
|
|
-# which point to directories outside the build tree to the install RPATH
|
|
-set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
|
|
-
|
|
-# Turn on RPATH for OSX for policy warning
|
|
-set(CMAKE_MACOSX_RPATH ON)
|
|
# ---------- CONFIGURATION
|
|
|
|
configure_file("config.h.in" "config.h")
|