bump to 1.3.9

This commit is contained in:
Michal Ambroz 2023-11-24 04:20:38 +01:00
parent 0555927c6c
commit 58c40227ac
3 changed files with 80 additions and 14 deletions

View File

@ -0,0 +1,12 @@
diff -ru openscap-1.3.9/swig/perl/CMakeLists.txt openscap-1.3.9.new/swig/perl/CMakeLists.txt
--- openscap-1.3.9/swig/perl/CMakeLists.txt 2023-09-06 16:04:46.000000000 +0200
+++ openscap-1.3.9.new/swig/perl/CMakeLists.txt 2023-11-23 23:55:45.662845801 +0100
@@ -20,7 +20,7 @@
DESTINATION ${CMAKE_INSTALL_DATADIR}/perl5/vendor_perl)
else()
install(TARGETS ${SWIG_MODULE_openscap_pm_REAL_NAME}
- DESTINATION ${PERL_VENDORLIB})
+ DESTINATION ${PERL_VENDORARCH})
install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/openscap_pm.pm
DESTINATION ${PERL_VENDORARCH})
endif()

View File

@ -1,20 +1,31 @@
Name: openscap
Version: 1.3.8
Release: 6%{?dist}
Version: 1.3.9
Release: 1%{?dist}
Epoch: 1
Summary: Set of open source libraries enabling integration of the SCAP line of standards
License: LGPL-2.1-or-later
URL: http://www.open-scap.org/
VCS: https://github.com/OpenSCAP/openscap
Source0: https://github.com/OpenSCAP/%{name}/releases/download/%{version}/%{name}-%{version}.tar.gz
%bcond_without check
# merged to 1.3.9
# port to PCRE2 (PR#2015), minus CI-specific changes
Patch0: 2015.patch
# Patch0: 2015.patch
# Fedora arched lib directories
# https://github.com/OpenSCAP/openscap/pull/2056
Patch1: openscap-1.3.9-perlpath.patch
BuildRequires: make
BuildRequires: cmake >= 2.6
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: swig libxml2-devel libxslt-devel perl-generators perl-XML-Parser
BuildRequires: swig
BuildRequires: libxml2-devel
BuildRequires: libxslt-devel
BuildRequires: rpm-devel
BuildRequires: libgcrypt-devel
BuildRequires: pcre2-devel
@ -28,12 +39,20 @@ BuildRequires: openldap-devel
BuildRequires: glib2-devel
BuildRequires: dbus-devel
BuildRequires: libyaml-devel
BuildRequires: xmlsec1-devel xmlsec1-openssl-devel
%if %{?_with_check:1}%{!?_with_check:0}
BuildRequires: xmlsec1-devel
BuildRequires: xmlsec1-openssl-devel
BuildRequires: apt-devel
BuildRequires: opendbx-devel
# GConf2 not used on purpose as obsolete and blocking anaconda addon
# BuildRequires: GConf2-devel
BuildRequires: procps-ng-devel
%if %{with check}
BuildRequires: perl-interpreter
BuildRequires: perl-XML-XPath
BuildRequires: bzip2
%endif
BuildRequires: systemd-rpm-macros
Requires: bash
Requires: bzip2-libs
Requires: dbus
@ -65,15 +84,34 @@ BuildRequires: doxygen
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%package python3
Summary: Python 3 bindings for %{name}
Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
BuildRequires: python3-devel
%{?python_provide:%python_provide python%{python3_pkgversion}-openscap }
BuildRequires: python%{python3_pkgversion}-devel
%description python3
The %{name}-python3 package contains the bindings so that %{name}
libraries can be used by python3.
%package perl
Summary: Perl bindings for %{name}
Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
BuildRequires: coreutils
BuildRequires: findutils
BuildRequires: make
BuildRequires: perl-generators
BuildRequires: perl-interpreter
BuildRequires: perl-devel
BuildRequires: perl-XML-Parser
%description perl
The perl package contains the bindings so that %{name}
libraries can be used by perl.
%package scanner
Summary: OpenSCAP Scanner Tool (oscap)
Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
@ -132,7 +170,7 @@ Tool for scanning Atomic containers.
# as gconf is no longer part of the installation medium
%cmake \
-DWITH_PCRE2=ON \
-DENABLE_PERL=OFF \
-DENABLE_PERL=ON \
-DENABLE_DOCS=ON \
-DOPENSCAP_PROBE_UNIX_GCONF=OFF \
-DGCONF_LIBRARY=
@ -140,8 +178,10 @@ Tool for scanning Atomic containers.
make docs
%check
%if %{?_with_check:1}%{!?_with_check:0}
ctest -V %{?_smp_mflags}
%if %{with check}
# Skip failing test in sce/test_sce_in_ds.sh
# %{?_smp_mflags} not used as it is failing many other tests
ctest -V -E sce/test_sce_in_ds.sh
%endif
%install
@ -167,9 +207,16 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%{_datadir}/openscap/xsl/*
%{_datadir}/openscap/cpe/*
%files python3
%{python3_sitearch}/*
%files perl
%{perl_vendorarch}/openscap_pm.pm
%{perl_vendorarch}/openscap_pm.so
%files devel
%doc %{_pkgdocdir}/html/
%{_libdir}/libopenscap.so
@ -177,16 +224,22 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%{_includedir}/openscap
%exclude %{_includedir}/openscap/sce_engine_api.h
%files engine-sce
%{_libdir}/libopenscap_sce.so.*
%files engine-sce-devel
%{_libdir}/libopenscap_sce.so
%{_includedir}/openscap/sce_engine_api.h
%files scanner
%{_mandir}/man8/oscap.8*
%{_bindir}/oscap
%{_bindir}/oscap-chroot
%{_sysconfdir}/bash_completion.d
%files utils
%doc docs/oscap-scan.cron
%{_mandir}/man8/*
@ -197,8 +250,6 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%exclude %{_bindir}/oscap-docker
%exclude %{_bindir}/oscap-chroot
%files engine-sce
%{_libdir}/libopenscap_sce.so.*
%files containers
%{_bindir}/oscap-docker
@ -208,6 +259,10 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%{_mandir}/man8/oscap-podman.8*
%changelog
* Thu Nov 23 2023 Michal Ambroz <rebus _AT seznam.cz> - 1:1.3.9-1
- bump to 1.3.9
- provide perl binding
* Tue Sep 05 2023 Yaakov Selkowitz <yselkowi@redhat.com> - 1:1.3.8-6
- Use pcre2 (#2128342)

View File

@ -1,2 +1 @@
SHA512 (openscap-1.3.7.tar.gz) = 64dcceadbbb5b6045d2ebaca89287c80c26e05d7247fc0dd31cd9bff98398c7a26d6ed0e9191dcd2fd01f0711181f15d34fe9784bd043ccd0854baa17397cd88
SHA512 (openscap-1.3.8.tar.gz) = 4a05f6467ea88f92cc74d7470ed97de10be4ae3de9b16ab065adcedc403adfae667b1b787b65ba6d9c85d38bf7ef47dbd10c90b2dd2b2a48056655a451103ae9
SHA512 (openscap-1.3.9.tar.gz) = 4c7fd10618c36188ed63d722d6cc7b04b45f4e72ff25b8c8ac066baa650b2f1bbd34c561f487a7f58ae8a506228b7d1d2208d54b976df84e2d2ea532629dc6eb