opensc-0.20.0-1
This commit is contained in:
parent
c88838d6d5
commit
7cf6069f07
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
||||
/opensc-0.17.0.tar.gz
|
||||
/opensc-0.18.0.tar.gz
|
||||
/opensc-0.19.0.tar.gz
|
||||
/opensc-0.20.0.tar.gz
|
||||
|
@ -1,31 +0,0 @@
|
||||
commit 35cb70b5d664c4be417dee2cbe6b652185e6da2d
|
||||
Author: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Mon Dec 17 18:44:23 2018 -0800
|
||||
|
||||
Remove redundant logging
|
||||
|
||||
Same information is printed a few line below in same function, the only
|
||||
difference is that there it takes care of case when label is NULL pointer
|
||||
unlike this line
|
||||
|
||||
secondly, every function call to cosm_write_tokeninfo() in this file
|
||||
passes label=NULL, and then it tries to print a null pointer
|
||||
|
||||
Fixes errors like
|
||||
src/libopensc/log.h:48:47: error: '%s' directive argument is null
|
||||
[-Werror=format-overflow=]
|
||||
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
|
||||
diff --git a/src/pkcs15init/pkcs15-oberthur.c b/src/pkcs15init/pkcs15-oberthur.c
|
||||
index 322a74a4..98a61d5a 100644
|
||||
--- a/src/pkcs15init/pkcs15-oberthur.c
|
||||
+++ b/src/pkcs15init/pkcs15-oberthur.c
|
||||
@@ -70,7 +70,6 @@ cosm_write_tokeninfo (struct sc_pkcs15_card *p15card, struct sc_profile *profile
|
||||
ctx = p15card->card->ctx;
|
||||
|
||||
SC_FUNC_CALLED(ctx, SC_LOG_DEBUG_VERBOSE);
|
||||
- sc_debug(ctx, SC_LOG_DEBUG_NORMAL, "cosm_write_tokeninfo() label '%s'; flags 0x%X", label, flags);
|
||||
if (sc_profile_get_file(profile, COSM_TITLE"-token-info", &file)) {
|
||||
rv = SC_ERROR_INCONSISTENT_PROFILE;
|
||||
SC_TEST_GOTO_ERR(ctx, SC_LOG_DEBUG_NORMAL, rv, "Cannot find "COSM_TITLE"-token-info");
|
File diff suppressed because it is too large
Load Diff
25
opensc.spec
25
opensc.spec
@ -2,8 +2,8 @@
|
||||
%define nssdb %{_sysconfdir}/pki/nssdb
|
||||
|
||||
Name: opensc
|
||||
Version: 0.19.0
|
||||
Release: 8%{?dist}
|
||||
Version: 0.20.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Smart card library and applications
|
||||
|
||||
License: LGPLv2+
|
||||
@ -13,12 +13,6 @@ Source1: opensc.module
|
||||
# Missing from release tarball
|
||||
# https://github.com/OpenSC/OpenSC/blob/master/tests/common.sh
|
||||
Source2: common.sh
|
||||
# https://github.com/OpenSC/OpenSC/pull/1435
|
||||
# https://github.com/OpenSC/OpenSC/pull/1521
|
||||
Patch2: opensc-0.19.0-rsa-pss.patch
|
||||
Patch3: opensc-0.19.0-pinpad.patch
|
||||
# https://github.com/OpenSC/OpenSC/pull/1557
|
||||
Patch4: opensc-0.19.0-gcc9.patch
|
||||
Patch1: opensc-0.19.0-pinpad.patch
|
||||
|
||||
BuildRequires: pcsc-lite-devel
|
||||
@ -55,9 +49,7 @@ every software/card that does so, too.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch2 -p1 -b .pss
|
||||
%patch3 -p1 -b .pinpad
|
||||
%patch4 -p1 -b .gcc9
|
||||
%patch1 -p1 -b .pinpad
|
||||
|
||||
cp %{SOURCE2} tests/
|
||||
# The test-pkcs11-tool-allowed-mechanisms already works in Fedora
|
||||
@ -79,6 +71,7 @@ sed -i -e 's/opensc.conf/opensc-%{_arch}.conf/g' src/libopensc/Makefile.in
|
||||
%endif
|
||||
sed -i -e 's|"/lib /usr/lib\b|"/%{_lib} %{_libdir}|' configure # lib64 rpaths
|
||||
%configure --disable-static \
|
||||
--disable-autostart-items \
|
||||
--disable-assert \
|
||||
--enable-pcsc \
|
||||
--enable-tests \
|
||||
@ -167,8 +160,8 @@ fi
|
||||
|
||||
%config(noreplace) %{_sysconfdir}/opensc-%{_arch}.conf
|
||||
# Co-owned with p11-kit so it is not hard dependency
|
||||
%{_datadir}/p11-kit
|
||||
%{_datadir}/p11-kit/modules
|
||||
%dir %{_datadir}/p11-kit
|
||||
%dir %{_datadir}/p11-kit/modules
|
||||
%{_datadir}/p11-kit/modules/opensc.module
|
||||
%{_bindir}/cardos-tool
|
||||
%{_bindir}/cryptoflex-tool
|
||||
@ -190,6 +183,8 @@ fi
|
||||
%{_bindir}/dnie-tool
|
||||
%{_bindir}/westcos-tool
|
||||
%{_bindir}/egk-tool
|
||||
%{_bindir}/goid-tool
|
||||
%{_bindir}/pkcs11-register
|
||||
%{_datadir}/applications/org.opensc.notify.desktop
|
||||
%{_libdir}/lib*.so.*
|
||||
%{_libdir}/opensc-pkcs11.so
|
||||
@ -224,6 +219,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jan 02 2020 Jakub Jelen <jjelen@redhat.com> - 0.20.0-1
|
||||
- New upstream release (#1749357)
|
||||
- Fixes for various security issues identified by fuzzing (#1765223, #1765231, #1782520, #1782951, #1782956)
|
||||
|
||||
* Mon Sep 30 2019 Jakub Jelen <jjelen@redhat.com> - 0.19.0-8
|
||||
- Correctly mention bundled simclist library
|
||||
- Add missing zlib build requires (#1756326)
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (opensc-0.19.0.tar.gz) = 90659133fb593cbf82ed6502e3858f34119bff051e3090489b7622659dcb1c26d389a4715892aa60a5606bc0ce115bd6c504521abfb965de9ad46441e4ed2b8e
|
||||
SHA512 (opensc-0.20.0.tar.gz) = 71f71fa6062410e63c6c60f5b2d10d1d855cc6cc815ef0e42e42a1ddd25bbd52fc396c1e495ef54610f3243996dec84dacc8007b186deb670ed645b04ee6eda5
|
||||
|
Loading…
Reference in New Issue
Block a user