Update to 4.0.2rc2
Re-enable C++ bindings on power64
This commit is contained in:
parent
73fc922a86
commit
cc73771497
1
.gitignore
vendored
1
.gitignore
vendored
@ -45,3 +45,4 @@ openmpi-1.4.1-RH.tar.bz2
|
||||
/openmpi-4.0.0.tar.bz2
|
||||
/openmpi-4.0.1.tar.bz2
|
||||
/openmpi-4.0.2rc1.tar.bz2
|
||||
/openmpi-4.0.2rc2.tar.bz2
|
||||
|
46
6946.patch
46
6946.patch
@ -1,46 +0,0 @@
|
||||
From fbbacc1303f02b4c955975911b82e8755ea0721c Mon Sep 17 00:00:00 2001
|
||||
From: Harumi Kuno <harumi.kuno@hpe.com>
|
||||
Date: Tue, 30 Jul 2019 06:32:27 -0700
|
||||
Subject: [PATCH] Fix mmap infinite recurse in memory patcher
|
||||
|
||||
This commit fixes issue #6853 by removing
|
||||
MacOS/Darwin-specific logic from intercept_mmap.
|
||||
|
||||
Signed-off-by: Harumi Kuno <harumi.kuno@hpe.com>
|
||||
---
|
||||
opal/mca/memory/patcher/configure.m4 | 4 ----
|
||||
opal/mca/memory/patcher/memory_patcher_component.c | 5 -----
|
||||
2 files changed, 9 deletions(-)
|
||||
|
||||
diff --git a/opal/mca/memory/patcher/configure.m4 b/opal/mca/memory/patcher/configure.m4
|
||||
index 6881ec69366..0c5d8553259 100644
|
||||
--- a/opal/mca/memory/patcher/configure.m4
|
||||
+++ b/opal/mca/memory/patcher/configure.m4
|
||||
@@ -40,10 +40,6 @@ AC_DEFUN([MCA_opal_memory_patcher_CONFIG],[
|
||||
|
||||
AC_CHECK_HEADERS([linux/mman.h sys/syscall.h])
|
||||
|
||||
- AC_CHECK_DECLS([__mmap], [], [], [#include <sys/mman.h>])
|
||||
-
|
||||
- AC_CHECK_FUNCS([__mmap])
|
||||
-
|
||||
AC_CHECK_DECLS([__syscall], [], [], [#include <sys/syscall.h>])
|
||||
|
||||
AC_CHECK_FUNCS([__syscall])
|
||||
diff --git a/opal/mca/memory/patcher/memory_patcher_component.c b/opal/mca/memory/patcher/memory_patcher_component.c
|
||||
index 5db3a6016f8..687d430fa36 100644
|
||||
--- a/opal/mca/memory/patcher/memory_patcher_component.c
|
||||
+++ b/opal/mca/memory/patcher/memory_patcher_component.c
|
||||
@@ -125,12 +125,7 @@ static void *_intercept_mmap(void *start, size_t length, int prot, int flags, in
|
||||
}
|
||||
|
||||
if (!original_mmap) {
|
||||
-#ifdef HAVE___MMAP
|
||||
- /* the darwin syscall returns an int not a long so call the underlying __mmap function */
|
||||
- result = __mmap (start, length, prot, flags, fd, offset);
|
||||
-#else
|
||||
result = (void*)(intptr_t) memory_patcher_syscall(SYS_mmap, start, length, prot, flags, fd, offset);
|
||||
-#endif
|
||||
} else {
|
||||
result = original_mmap (start, length, prot, flags, fd, offset);
|
||||
}
|
14
openmpi.spec
14
openmpi.spec
@ -27,19 +27,17 @@
|
||||
|
||||
Name: openmpi%{?_cc_name_suffix}
|
||||
Version: 4.0.2
|
||||
Release: 0.3.rc1%{?dist}
|
||||
Release: 0.4.rc2%{?dist}
|
||||
Summary: Open Message Passing Interface
|
||||
License: BSD and MIT and Romio
|
||||
URL: http://www.open-mpi.org/
|
||||
|
||||
# We can't use %%{name} here because of _cc_name_suffix
|
||||
Source0: https://www.open-mpi.org/software/ompi/v4.0/downloads/openmpi-%{version}rc1.tar.bz2
|
||||
Source0: https://www.open-mpi.org/software/ompi/v4.0/downloads/openmpi-%{version}rc2.tar.bz2
|
||||
Source1: openmpi.module.in
|
||||
Source2: openmpi.pth.py2
|
||||
Source3: openmpi.pth.py3
|
||||
Source4: macros.openmpi
|
||||
# Upstream PR 6946 to avoid linking to __mmap
|
||||
Patch0: https://patch-diff.githubusercontent.com/raw/open-mpi/ompi/pull/6946.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
@ -167,7 +165,7 @@ OpenMPI support for Python 3.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n openmpi-%{version}rc1
|
||||
%autosetup -p1 -n openmpi-%{version}rc2
|
||||
|
||||
%build
|
||||
./autogen.pl --force
|
||||
@ -177,9 +175,7 @@ OpenMPI support for Python 3.
|
||||
--sysconfdir=%{_sysconfdir}/%{namearch} \
|
||||
--disable-silent-rules \
|
||||
--enable-builtin-atomics \
|
||||
%ifnarch %{power64}
|
||||
--enable-mpi-cxx \
|
||||
%endif
|
||||
--enable-mpi-java \
|
||||
--enable-mpi1-compatibility \
|
||||
--with-sge \
|
||||
@ -349,6 +345,10 @@ make check
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Sep 14 2019 Orion Poplawski <orion@nwra.com> - 4.0.2-0.4.rc2
|
||||
- Update to 4.0.2rc2
|
||||
- Re-enable C++ bindings on power64
|
||||
|
||||
* Fri Sep 6 2019 Philip Kovacs <pkdevel@yahoo.com> - 4.0.2-0.3.rc1
|
||||
- Rebuild for annobin update to correct aarch64 build (bug #1748529)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (openmpi-4.0.2rc1.tar.bz2) = 7009b9b9a2ef398195e95735d907171091a13f6287d3290862465720249eac1815d9152f1804adc8ec8129ad858536f759521d392fac8c1e495928e6634372b6
|
||||
SHA512 (openmpi-4.0.2rc2.tar.bz2) = a87dfff53f31bb4dae27e6953d111b7d6c22a1165f17061546ed286e3f5b1a9ea5a95876e3480dc87d0e20bb7753f99a0825bf204724d895a340fb3b66062255
|
||||
|
Loading…
Reference in New Issue
Block a user