Update to 1.7.4
- Drop format patch fixed upstream - Build against system libevent - Build Java mpi bindings, ship in -java sub-package
This commit is contained in:
parent
311a78a5de
commit
af9818cd2c
1
.gitignore
vendored
1
.gitignore
vendored
@ -13,3 +13,4 @@ openmpi-1.4.1-RH.tar.bz2
|
|||||||
/openmpi-1.7.1-clean.tar.xz
|
/openmpi-1.7.1-clean.tar.xz
|
||||||
/openmpi-1.7.2-clean.tar.xz
|
/openmpi-1.7.2-clean.tar.xz
|
||||||
/openmpi-1.7.3.tar.bz2
|
/openmpi-1.7.3.tar.bz2
|
||||||
|
/openmpi-1.7.4.tar.bz2
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up openmpi-1.7.3/ompi/mca/btl/usnic/btl_usnic_module.c.format openmpi-1.7.3/ompi/mca/btl/usnic/btl_usnic_module.c
|
|
||||||
--- openmpi-1.7.3/ompi/mca/btl/usnic/btl_usnic_module.c.format 2013-10-01 16:13:44.000000000 -0600
|
|
||||||
+++ openmpi-1.7.3/ompi/mca/btl/usnic/btl_usnic_module.c 2013-12-03 16:35:41.206022575 -0700
|
|
||||||
@@ -826,7 +826,7 @@ static void usnic_stats_callback(int fd,
|
|
||||||
}
|
|
||||||
|
|
||||||
strncat(str, tmp, sizeof(str) - strlen(str) - 1);
|
|
||||||
- opal_output(0, str);
|
|
||||||
+ opal_output(0, "%s", str);
|
|
||||||
|
|
||||||
if (mca_btl_usnic_component.stats_relative) {
|
|
||||||
usnic_stats_reset(module);
|
|
47
openmpi.spec
47
openmpi.spec
@ -19,8 +19,8 @@
|
|||||||
#global _cc_name_suffix -gcc
|
#global _cc_name_suffix -gcc
|
||||||
|
|
||||||
Name: openmpi%{?_cc_name_suffix}
|
Name: openmpi%{?_cc_name_suffix}
|
||||||
Version: 1.7.3
|
Version: 1.7.4
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Open Message Passing Interface
|
Summary: Open Message Passing Interface
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: BSD, MIT and Romio
|
License: BSD, MIT and Romio
|
||||||
@ -32,9 +32,6 @@ Source1: openmpi.module.in
|
|||||||
Source2: macros.openmpi
|
Source2: macros.openmpi
|
||||||
# Patch to use system ltdl for tests
|
# Patch to use system ltdl for tests
|
||||||
Patch1: openmpi-ltdl.patch
|
Patch1: openmpi-ltdl.patch
|
||||||
# Patch to fix compilation with -Werror=format-security
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1037231
|
|
||||||
Patch2: openmpi-format.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc-gfortran
|
BuildRequires: gcc-gfortran
|
||||||
#sparc64 and aarch64 don't have valgrind
|
#sparc64 and aarch64 don't have valgrind
|
||||||
@ -46,6 +43,8 @@ BuildRequires: librdmacm-devel libibcm-devel
|
|||||||
BuildRequires: hwloc-devel
|
BuildRequires: hwloc-devel
|
||||||
# So configure can find lstopo
|
# So configure can find lstopo
|
||||||
BuildRequires: hwloc
|
BuildRequires: hwloc
|
||||||
|
BuildRequires: java-devel
|
||||||
|
BuildRequires: libevent-devel
|
||||||
BuildRequires: papi-devel
|
BuildRequires: papi-devel
|
||||||
BuildRequires: python libtool-ltdl-devel
|
BuildRequires: python libtool-ltdl-devel
|
||||||
BuildRequires: torque-devel
|
BuildRequires: torque-devel
|
||||||
@ -77,7 +76,25 @@ Requires: %{name} = %{version}-%{release}, gcc-gfortran
|
|||||||
Provides: mpi-devel
|
Provides: mpi-devel
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
Contains development headers and libraries for openmpi
|
Contains development headers and libraries for openmpi.
|
||||||
|
|
||||||
|
%package java
|
||||||
|
Summary: Java library
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: java
|
||||||
|
|
||||||
|
%description java
|
||||||
|
Java library.
|
||||||
|
|
||||||
|
%package java-devel
|
||||||
|
Summary: Java development files for openmpi
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name}-java = %{version}-%{release}
|
||||||
|
Requires: java-devel
|
||||||
|
|
||||||
|
%description java-devel
|
||||||
|
Contains development wrapper for compiling Java with openmpi.
|
||||||
|
|
||||||
# We set this to for convenience, since this is the unique dir we use for this
|
# We set this to for convenience, since this is the unique dir we use for this
|
||||||
# particular package, version, compiler
|
# particular package, version, compiler
|
||||||
@ -86,7 +103,6 @@ Contains development headers and libraries for openmpi
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n openmpi-%{version}
|
%setup -q -n openmpi-%{version}
|
||||||
%patch1 -p1 -b .ltdl
|
%patch1 -p1 -b .ltdl
|
||||||
%patch2 -p1 -b .format
|
|
||||||
# Make sure we don't use the local libltdl library
|
# Make sure we don't use the local libltdl library
|
||||||
rm -r opal/libltdl
|
rm -r opal/libltdl
|
||||||
|
|
||||||
@ -96,7 +112,9 @@ rm -r opal/libltdl
|
|||||||
--includedir=%{_includedir}/%{namearch} \
|
--includedir=%{_includedir}/%{namearch} \
|
||||||
--sysconfdir=%{_sysconfdir}/%{namearch} \
|
--sysconfdir=%{_sysconfdir}/%{namearch} \
|
||||||
--disable-silent-rules \
|
--disable-silent-rules \
|
||||||
|
--enable-mpi-java \
|
||||||
--enable-opal-multi-threads \
|
--enable-opal-multi-threads \
|
||||||
|
--with-libevent=/usr \
|
||||||
--with-verbs=/usr \
|
--with-verbs=/usr \
|
||||||
--with-sge \
|
--with-sge \
|
||||||
%ifnarch %{sparc} aarch64
|
%ifnarch %{sparc} aarch64
|
||||||
@ -137,7 +155,6 @@ mkdir -p %{buildroot}/%{_fmoddir}/%{namearch}
|
|||||||
mkdir -p %{buildroot}/%{python_sitearch}/openmpi%{?_cc_name_suffix}
|
mkdir -p %{buildroot}/%{python_sitearch}/openmpi%{?_cc_name_suffix}
|
||||||
# Remove extraneous wrapper link libraries (bug 814798)
|
# Remove extraneous wrapper link libraries (bug 814798)
|
||||||
sed -i -e s/-ldl// -e s/-lhwloc// \
|
sed -i -e s/-ldl// -e s/-lhwloc// \
|
||||||
%{buildroot}%{_libdir}/%{name}/bin/orte_wrapper_script \
|
|
||||||
%{buildroot}%{_libdir}/%{name}/share/openmpi/*-wrapper-data.txt
|
%{buildroot}%{_libdir}/%{name}/share/openmpi/*-wrapper-data.txt
|
||||||
|
|
||||||
%check
|
%check
|
||||||
@ -198,7 +215,21 @@ make check
|
|||||||
%{_libdir}/%{name}/share/vampirtrace/*
|
%{_libdir}/%{name}/share/vampirtrace/*
|
||||||
%{_sysconfdir}/rpm/macros.%{namearch}
|
%{_sysconfdir}/rpm/macros.%{namearch}
|
||||||
|
|
||||||
|
%files java
|
||||||
|
%{_libdir}/%{name}/lib/mpi.jar
|
||||||
|
|
||||||
|
%files java-devel
|
||||||
|
%{_libdir}/%{name}/bin/mpijavac
|
||||||
|
%{_libdir}/%{name}/bin/mpijavac.pl
|
||||||
|
%{_mandir}/%{namearch}/man1/mpijavac.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 5 2014 Orion Poplawski <orion@cora.nwra.com> 1.7.4-4
|
||||||
|
- Update to 1.7.4
|
||||||
|
- Drop format patch fixed upstream
|
||||||
|
- Build against system libevent
|
||||||
|
- Build Java mpi bindings, ship in -java sub-package
|
||||||
|
|
||||||
* Tue Jan 28 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.3-5
|
* Tue Jan 28 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.3-5
|
||||||
- Drop mode/modeflag. mode no longer used, modeflag obsolete as set in CFLAGS
|
- Drop mode/modeflag. mode no longer used, modeflag obsolete as set in CFLAGS
|
||||||
- Use distro LDFLAGS for hardened build
|
- Use distro LDFLAGS for hardened build
|
||||||
|
Loading…
Reference in New Issue
Block a user