Update to 1.5.4

Drop dt-textrel patch fixed upstream
Fixup handling removed files (bug #722534)
Uses hwloc instead of plpa
Exclude private libraries from provides/requires (bug #741104)
Drop --enable-mpi-threads & --enable-openib-ibcm, no longer recognized
This commit is contained in:
Orion Poplawski 2011-11-17 15:51:10 -07:00
parent 5f4379b0b6
commit ac4b2b29eb
5 changed files with 61 additions and 27 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
openmpi-1.4.1-RH.tar.bz2
/openmpi-1.5-RH.tar.bz2
/openmpi-1.5.4-clean.tar.bz2

View File

@ -1,11 +0,0 @@
--- openmpi-1.5/opal/config/opal_config_asm.m4.jj 2010-09-28 23:33:51.000000000 +0200
+++ openmpi-1.5/opal/config/opal_config_asm.m4 2011-02-23 01:39:21.191433509 +0100
@@ -885,7 +885,7 @@ AC_DEFUN([OMPI_CONFIG_ASM],[
ompi_cv_asm_arch="AMD64"
fi
OPAL_ASM_SUPPORT_64BIT=1
- OMPI_GCC_INLINE_ASSIGN='"xaddl %1,%0" : "=m"(ret), "+r"(negone)'
+ OMPI_GCC_INLINE_ASSIGN='"xaddl %1,%0" : "=m"(ret), "+r"(negone) : "m"(ret)'
;;
ia64-*)

33
openmpi-removed.patch Normal file
View File

@ -0,0 +1,33 @@
diff -up openmpi-1.5.4/configure.removed openmpi-1.5.4/configure
--- openmpi-1.5.4/configure.removed 2011-08-18 07:49:03.000000000 -0600
+++ openmpi-1.5.4/configure 2011-11-17 15:13:57.461774628 -0700
@@ -146215,10 +146215,6 @@ ac_config_files="$ac_config_files opal/m
-ac_config_files="$ac_config_files opal/mca/backtrace/darwin/Makefile"
-
-
-
ac_config_files="$ac_config_files opal/mca/backtrace/execinfo/Makefile"
@@ -169069,7 +169065,6 @@ do
"opal/mca/paffinity/hwloc/hwloc/include/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/paffinity/hwloc/hwloc/include/Makefile" ;;
"opal/mca/paffinity/hwloc/hwloc/src/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/paffinity/hwloc/hwloc/src/Makefile" ;;
"opal/mca/backtrace/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/Makefile" ;;
- "opal/mca/backtrace/darwin/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/darwin/Makefile" ;;
"opal/mca/backtrace/execinfo/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/execinfo/Makefile" ;;
"opal/mca/backtrace/none/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/none/Makefile" ;;
"opal/mca/backtrace/printstack/Makefile") CONFIG_FILES="$CONFIG_FILES opal/mca/backtrace/printstack/Makefile" ;;
diff -up openmpi-1.5.4/Makefile.in.removed openmpi-1.5.4/Makefile.in
--- openmpi-1.5.4/Makefile.in.removed 2011-08-18 07:46:01.000000000 -0600
+++ openmpi-1.5.4/Makefile.in 2011-11-17 15:21:13.302181490 -0700
@@ -197,7 +197,6 @@ am__aclocal_m4_deps = $(top_srcdir)/ompi
$(top_srcdir)/config/ext_no_configure_components.m4 \
$(top_srcdir)/config/mca_m4_config_include.m4 \
$(top_srcdir)/opal/mca/backtrace/configure.m4 \
- $(top_srcdir)/opal/mca/backtrace/darwin/configure.m4 \
$(top_srcdir)/opal/mca/backtrace/execinfo/configure.m4 \
$(top_srcdir)/opal/mca/backtrace/none/configure.m4 \
$(top_srcdir)/opal/mca/backtrace/printstack/configure.m4 \

View File

@ -18,24 +18,22 @@
#define _cc_name_suffix -gcc
Name: openmpi%{?_cc_name_suffix}
Version: 1.5
Release: 4%{?dist}
Version: 1.5.4
Release: 1%{?dist}
Summary: Open Message Passing Interface
Group: Development/Libraries
License: BSD, MIT and Romio
URL: http://www.open-mpi.org/
# We can't use %{name} here because of _cc_name_suffix
#Source0: http://www.open-mpi.org/software/ompi/v1.5/downloads/openmpi-%{version}.tar.bz2
# openmpi-1.5-RH.tar.bz2 was generated by taking the upstream 1.5 tarball
# and removing license-incompatible files
# (MoreDebugging/* is AML but unused in our configuration),
# and packaging-guidelines-incompatable (MUST use system versions of libltdl
# and libplpa, not the (formerly included ones), and also remove the generated
# Makefile.in and configure related files.
Source0: openmpi-%{version}-RH.tar.bz2
# openmpi-%{version}-clean.tar.bz2 was generated by taking the upstream tarball
# and removing license-incompatible files:
# rm -r opal/mca/backtrace/darwin/MoreBacktrace
Source0: openmpi-%{version}-clean.tar.bz2
Source1: openmpi.module.in
Source2: macros.openmpi
Patch0: openmpi-1.5-dt-textrel.patch
# Patch to handle removed items
Patch0: openmpi-removed.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: gcc-gfortran, libtool, numactl-devel
#sparc 64 doesnt have valgrind
@ -44,7 +42,8 @@ BuildRequires: valgrind-devel
%endif
BuildRequires: libibverbs-devel >= 1.1.3, opensm-devel > 3.3.0
BuildRequires: librdmacm librdmacm-devel libibcm libibcm-devel
BuildRequires: python libtool-ltdl-devel plpa-devel
BuildRequires: hwloc-devel
BuildRequires: python libtool-ltdl-devel
BuildRequires: libesmtp-devel
#%ifnarch ppc
#BuildRequires: compat-dapl-devel
@ -59,6 +58,9 @@ Obsoletes: openmpi-libs
# ARM has issues with a lack of "atomic primitives" so we'll exclude it as well for the moment
ExcludeArch: s390 s390x %{arm}
# Private openmpi libraries
%define __provides_exclude_from %{_libdir}/openmpi/lib/(lib(mca|o|v)|openmpi/).*.so
%define __requires_exclude lib(mca|o|v).*
%description
Open MPI is an open source, freely available implementation of both the
@ -119,8 +121,9 @@ Contains development headers and libraries for openmpi
%prep
%setup -q -n openmpi-%{version}
%patch0 -p1 -b .dt-textrel
./autogen.sh
%patch0 -p1 -b .removed
# Make sure we don't use the local libltdl library
rm -r opal/libltdl
%build
%ifarch x86_64
@ -131,14 +134,14 @@ XFLAGS="-fPIC"
--mandir=%{_mandir}/%{namearch} \
--includedir=%{_includedir}/%{namearch} \
--sysconfdir=%{_sysconfdir}/%{namearch} \
--enable-mpi-threads \
--enable-openib-ibcm \
--with-sge \
%ifnarch %{sparc}
--with-valgrind \
--enable-memchecker \
%endif
--with-esmtp \
--with-hwloc=external \
--with-libltdl=external \
--with-wrapper-cflags="%{?opt_cflags} %{?modeflag}" \
--with-wrapper-cxxflags="%{?opt_cxxflags} %{?modeflag}" \
--with-wrapper-fflags="%{?opt_fflags} %{?modeflag}" \
@ -233,6 +236,14 @@ rm -rf %{buildroot}
%{_sysconfdir}/rpm/macros.%{namearch}
%changelog
* Thu Nov 17 2011 Orion Poplawski <orion@cora.nwra.com> 1.5.4-1
- Update to 1.5.4
- Drop dt-textrel patch fixed upstream
- Fixup handling removed files (bug #722534)
- Uses hwloc instead of plpa
- Exclude private libraries from provides/requires (bug #741104)
- Drop --enable-mpi-threads & --enable-openib-ibcm, no longer recognized
* Sat Jun 18 2011 Peter Robinson <pbrobinson@gmail.com> 1.5-4
- Exclude ARM platforms due to current lack of "atomic primitives" on the platform

View File

@ -1 +1 @@
40b9683299fb20630f2adb818db055b4 openmpi-1.5-RH.tar.bz2
9a6c16e0b4235f00eefad17cb6b489b1 openmpi-1.5.4-clean.tar.bz2