parent
1d457c8c91
commit
9d271f4752
1
.gitignore
vendored
1
.gitignore
vendored
@ -44,3 +44,4 @@ openmpi-1.4.1-RH.tar.bz2
|
||||
/openmpi-3.1.4.tar.bz2
|
||||
/openmpi-4.0.0.tar.bz2
|
||||
/openmpi-4.0.1.tar.bz2
|
||||
/openmpi-4.0.2rc1.tar.bz2
|
||||
|
32
6594.patch
32
6594.patch
@ -1,32 +0,0 @@
|
||||
From 68c88e86f2c8ff515a4c54927077143de13516b9 Mon Sep 17 00:00:00 2001
|
||||
From: Valentin Petrov <valentinp@mellanox.com>
|
||||
Date: Tue, 16 Apr 2019 14:04:11 +0300
|
||||
Subject: [PATCH] OSC/UCX: use correct rkey for atomic_fadd in rget/rput
|
||||
|
||||
Signed-off-by: Valentin Petrov <valentinp@mellanox.com>
|
||||
---
|
||||
ompi/mca/osc/ucx/osc_ucx_comm.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/ompi/mca/osc/ucx/osc_ucx_comm.c b/ompi/mca/osc/ucx/osc_ucx_comm.c
|
||||
index ec760d4fda3..bc3b7f5e7ed 100644
|
||||
--- a/ompi/mca/osc/ucx/osc_ucx_comm.c
|
||||
+++ b/ompi/mca/osc/ucx/osc_ucx_comm.c
|
||||
@@ -881,7 +881,7 @@ int ompi_osc_ucx_rput(const void *origin_addr, int origin_count,
|
||||
|
||||
CHECK_VALID_RKEY(module, target, target_count);
|
||||
|
||||
- rkey = (module->win_info_array[target]).rkey;
|
||||
+ rkey = (module->state_info_array[target]).rkey;
|
||||
|
||||
OMPI_OSC_UCX_REQUEST_ALLOC(win, ucx_req);
|
||||
assert(NULL != ucx_req);
|
||||
@@ -942,7 +942,7 @@ int ompi_osc_ucx_rget(void *origin_addr, int origin_count,
|
||||
|
||||
CHECK_VALID_RKEY(module, target, target_count);
|
||||
|
||||
- rkey = (module->win_info_array[target]).rkey;
|
||||
+ rkey = (module->state_info_array[target]).rkey;
|
||||
|
||||
OMPI_OSC_UCX_REQUEST_ALLOC(win, ucx_req);
|
||||
assert(NULL != ucx_req);
|
34
6668.patch
34
6668.patch
@ -1,34 +0,0 @@
|
||||
From c6ba949f3a0618e26ce2ef53b052b3d38cbbd0d8 Mon Sep 17 00:00:00 2001
|
||||
From: Nathan Hjelm <hjelmn@me.com>
|
||||
Date: Wed, 15 May 2019 12:24:22 -0600
|
||||
Subject: [PATCH] btl/uct: check for support before disabling UCX memory hooks
|
||||
|
||||
Signed-off-by: Nathan Hjelm <hjelmn@me.com>
|
||||
---
|
||||
opal/mca/btl/uct/btl_uct_component.c | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/opal/mca/btl/uct/btl_uct_component.c b/opal/mca/btl/uct/btl_uct_component.c
|
||||
index 971b31a1d85..830c262325d 100644
|
||||
--- a/opal/mca/btl/uct/btl_uct_component.c
|
||||
+++ b/opal/mca/btl/uct/btl_uct_component.c
|
||||
@@ -17,6 +17,7 @@
|
||||
* Copyright (c) 2018 Amazon.com, Inc. or its affiliates. All Rights reserved.
|
||||
* Copyright (c) 2018 Triad National Security, LLC. All rights
|
||||
* reserved.
|
||||
+ * Copyright (c) 2019 Google, LLC. All rights reserved.
|
||||
* $COPYRIGHT$
|
||||
*
|
||||
* Additional copyrights may follow
|
||||
@@ -129,7 +130,10 @@ static int mca_btl_uct_component_open(void)
|
||||
mca_btl_uct_component.num_contexts_per_module = MCA_BTL_UCT_MAX_WORKERS;
|
||||
}
|
||||
|
||||
- if (mca_btl_uct_component.disable_ucx_memory_hooks) {
|
||||
+ if (mca_btl_uct_component.disable_ucx_memory_hooks &&
|
||||
+ ((OPAL_MEMORY_FREE_SUPPORT | OPAL_MEMORY_MUNMAP_SUPPORT) ==
|
||||
+ ((OPAL_MEMORY_FREE_SUPPORT | OPAL_MEMORY_MUNMAP_SUPPORT) &
|
||||
+ opal_mem_hooks_support_level()))) {
|
||||
ucm_set_external_event(UCM_EVENT_VM_UNMAPPED);
|
||||
opal_mem_hooks_register_release(mca_btl_uct_mem_release_cb, NULL);
|
||||
}
|
16
openmpi.spec
16
openmpi.spec
@ -26,22 +26,18 @@
|
||||
%endif
|
||||
|
||||
Name: openmpi%{?_cc_name_suffix}
|
||||
Version: 4.0.1
|
||||
Release: 11%{?dist}
|
||||
Version: 4.0.2
|
||||
Release: 0.1.rc1%{?dist}
|
||||
Summary: Open Message Passing Interface
|
||||
License: BSD and MIT and Romio
|
||||
URL: http://www.open-mpi.org/
|
||||
|
||||
# We can't use %%{name} here because of _cc_name_suffix
|
||||
Source0: https://www.open-mpi.org/software/ompi/v4.0/downloads/openmpi-%{version}.tar.bz2
|
||||
Source0: https://www.open-mpi.org/software/ompi/v4.0/downloads/openmpi-%{version}rc1.tar.bz2
|
||||
Source1: openmpi.module.in
|
||||
Source2: openmpi.pth.py2
|
||||
Source3: openmpi.pth.py3
|
||||
Source4: macros.openmpi
|
||||
# Fix for UCX usage with BTL/UCT
|
||||
Patch0: https://patch-diff.githubusercontent.com/raw/open-mpi/ompi/pull/6668.patch
|
||||
# OSC/UCX: use correct rkey for atomic_fadd in rget/rput
|
||||
Patch1: https://patch-diff.githubusercontent.com/raw/open-mpi/ompi/pull/6594.patch
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gcc-gfortran
|
||||
@ -165,7 +161,7 @@ OpenMPI support for Python 3.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n openmpi-%{version}
|
||||
%autosetup -p1 -n openmpi-%{version}rc1
|
||||
|
||||
%build
|
||||
./configure --prefix=%{_libdir}/%{name} \
|
||||
@ -346,6 +342,10 @@ make check
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Aug 29 2019 Philip Kovacs <pkdevel@yahoo.com> - 4.0.2-0.1.rc1
|
||||
- Update to 4.0.2rc1
|
||||
- Closes bug #1746564
|
||||
|
||||
* Thu Aug 29 2019 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 4.0.1-11
|
||||
- Fix MANPATH so normal modules can still be loaded (#1564899)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (openmpi-4.0.1.tar.bz2) = 09f35dc2e44b4f84aab9c5af9d81f90bbdb030e4d90800a5d3ffae88cb32b7faecc9bea0abb113da53c21f73e9d19db68f961f997bc47bdd28d83a87beee0731
|
||||
SHA512 (openmpi-4.0.2rc1.tar.bz2) = 7009b9b9a2ef398195e95735d907171091a13f6287d3290862465720249eac1815d9152f1804adc8ec8129ad858536f759521d392fac8c1e495928e6634372b6
|
||||
|
Loading…
Reference in New Issue
Block a user