Add patch to fix libmpi_f90.so version

Add patch to link tests with system libltdl
Run make check
This commit is contained in:
Orion Poplawski 2012-11-05 14:11:53 -07:00
parent eed30b5af8
commit 8a9a5e2928
3 changed files with 116 additions and 1 deletions

12
openmpi-f90sover.patch Normal file
View File

@ -0,0 +1,12 @@
diff -up openmpi-1.6.3/VERSION.f90sover openmpi-1.6.3/VERSION
--- openmpi-1.6.3/VERSION.f90sover 2012-10-24 09:37:48.000000000 -0600
+++ openmpi-1.6.3/VERSION 2012-11-05 10:36:14.904136788 -0700
@@ -82,7 +82,7 @@ date="Oct 24, 2012"
libmpi_so_version=1:6:0
libmpi_cxx_so_version=1:1:0
libmpi_f77_so_version=1:6:0
-libmpi_f90_so_version=4:0:1
+libmpi_f90_so_version=4:0:3
libopen_rte_so_version=4:3:0
libopen_pal_so_version=4:3:0

89
openmpi-ltdl.patch Normal file
View File

@ -0,0 +1,89 @@
diff -up openmpi-1.6.3/ompi/debuggers/dlopen_test.c.ltdl openmpi-1.6.3/ompi/debuggers/dlopen_test.c
--- openmpi-1.6.3/ompi/debuggers/dlopen_test.c.ltdl 2012-04-03 08:30:25.000000000 -0600
+++ openmpi-1.6.3/ompi/debuggers/dlopen_test.c 2012-11-05 10:28:06.365041243 -0700
@@ -13,7 +13,17 @@
#include <string.h>
#include <stdlib.h>
-#include "opal/libltdl/ltdl.h"
+#if OPAL_WANT_LIBLTDL
+ #ifndef __WINDOWS__
+ #if OPAL_LIBLTDL_INTERNAL
+ #include "opal/libltdl/ltdl.h"
+ #else
+ #include "ltdl.h"
+ #endif
+ #else
+ #include "ltdl.h"
+ #endif
+#endif
static int do_test(void);
diff -up openmpi-1.6.3/ompi/debuggers/Makefile.in.ltdl openmpi-1.6.3/ompi/debuggers/Makefile.in
--- openmpi-1.6.3/ompi/debuggers/Makefile.in.ltdl 2012-10-24 09:40:15.000000000 -0600
+++ openmpi-1.6.3/ompi/debuggers/Makefile.in 2012-11-05 10:59:10.288662790 -0700
@@ -346,7 +346,7 @@ libompi_debugger_canary_la_OBJECTS = \
@OPAL_HAVE_DLOPEN_TRUE@am__EXEEXT_1 = dlopen_test$(EXEEXT)
am_dlopen_test_OBJECTS = dlopen_test-dlopen_test.$(OBJEXT)
dlopen_test_OBJECTS = $(am_dlopen_test_OBJECTS)
-dlopen_test_DEPENDENCIES = $(top_builddir)/opal/libltdl/libltdlc.la
+dlopen_test_DEPENDENCIES =
am_predefined_gap_test_OBJECTS = predefined_gap_test.$(OBJEXT)
predefined_gap_test_OBJECTS = $(am_predefined_gap_test_OBJECTS)
predefined_gap_test_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \
@@ -1216,8 +1216,8 @@ headers = \
# Simple checks to ensure that the DSOs are functional
dlopen_test_SOURCES = dlopen_test.c
-dlopen_test_CPPFLAGS = -I$(top_srcdir)/opal/libltdl
-dlopen_test_LDADD = $(top_builddir)/opal/libltdl/libltdlc.la
+dlopen_test_CPPFLAGS = $(LTDLINCL)
+dlopen_test_LDADD = $(LIBLTDL)
predefined_gap_test_SOURCES = predefined_gap_test.c
predefined_gap_test_LDFLAGS = $(WRAPPER_EXTRA_LDFLAGS)
predefined_gap_test_LDADD = $(top_builddir)/ompi/libmpi.la
diff -up openmpi-1.6.3/test/support/components.c.ltdl openmpi-1.6.3/test/support/components.c
--- openmpi-1.6.3/test/support/components.c.ltdl 2012-04-03 08:29:44.000000000 -0600
+++ openmpi-1.6.3/test/support/components.c 2012-11-05 10:28:06.366041244 -0700
@@ -24,7 +24,17 @@
#include "opal/constants.h"
#include "opal/mca/mca.h"
-#include "opal/libltdl/ltdl.h"
+#if OPAL_WANT_LIBLTDL
+ #ifndef __WINDOWS__
+ #if OPAL_LIBLTDL_INTERNAL
+ #include "opal/libltdl/ltdl.h"
+ #else
+ #include "ltdl.h"
+ #endif
+ #else
+ #include "ltdl.h"
+ #endif
+#endif
#include "components.h"
diff -up openmpi-1.6.3/test/support/components.h.ltdl openmpi-1.6.3/test/support/components.h
--- openmpi-1.6.3/test/support/components.h.ltdl 2012-04-03 08:29:44.000000000 -0600
+++ openmpi-1.6.3/test/support/components.h 2012-11-05 10:28:06.366041244 -0700
@@ -20,7 +20,17 @@
#ifndef OMPI_SUPPORT_COMPONENTS_H
#define OMPI_SUPPORT_COMPONENTS_H
-#include "opal/libltdl/ltdl.h"
+#if OPAL_WANT_LIBLTDL
+ #ifndef __WINDOWS__
+ #if OPAL_LIBLTDL_INTERNAL
+ #include "opal/libltdl/ltdl.h"
+ #else
+ #include "ltdl.h"
+ #endif
+ #else
+ #include "ltdl.h"
+ #endif
+#endif
#include "opal/mca/mca.h"
BEGIN_C_DECLS

View File

@ -19,7 +19,7 @@
Name: openmpi%{?_cc_name_suffix}
Version: 1.6.3
Release: 3%{?dist}
Release: 4%{?dist}
Summary: Open Message Passing Interface
Group: Development/Libraries
License: BSD, MIT and Romio
@ -35,6 +35,10 @@ Source1: openmpi.module.in
Source2: macros.openmpi
# Patch to handle removed items
Patch0: openmpi-removed.patch
# Patch to use system ltdl for tests
Patch1: openmpi-ltdl.patch
# Patch to fix libmpi_f90.so so version
Patch2: openmpi-f90sover.patch
BuildRequires: gcc-gfortran
#sparc 64 doesn't have valgrind
@ -112,6 +116,8 @@ Contains development headers and libraries for openmpi
%prep
%setup -q -n openmpi-%{version}
%patch0 -p1 -b .removed
%patch1 -p1 -b .ltdl
%patch2 -p1 -b .f90sover
# Make sure we don't use the local libltdl library
rm -r opal/libltdl
@ -168,6 +174,9 @@ sed -i -e s/-ldl// -e s/-lhwloc// \
%{buildroot}%{_libdir}/%{name}/bin/orte_wrapper_script \
%{buildroot}%{_libdir}/%{name}/share/%{name}/*-wrapper-data.txt
%check
make check
%files
%defattr(-,root,root,-)
@ -226,6 +235,11 @@ sed -i -e s/-ldl// -e s/-lhwloc// \
%{_sysconfdir}/rpm/macros.%{namearch}
%changelog
* Mon Nov 5 2012 Orion Poplawski <orion@cora.nwra.com> 1.6.3-4
- Add patch to fix libmpi_f90.so version
- Add patch to link tests with system libltdl
- Run make check
* Fri Nov 2 2012 Orion Poplawski <orion@cora.nwra.com> 1.6.3-3
- Set enable-opal-multi-threads for IB support