Update to 1.8.5rc3

This commit is contained in:
Orion Poplawski 2015-05-01 20:58:40 -06:00
parent 2b575376ec
commit 76eed0c526
5 changed files with 8 additions and 114 deletions

1
.gitignore vendored
View File

@ -23,3 +23,4 @@ openmpi-1.4.1-RH.tar.bz2
/openmpi-v1.8.4-99-gd83fb30.tar.gz /openmpi-v1.8.4-99-gd83fb30.tar.gz
/openmpi-v1.8.4-134-g9ad2aa8.tar.bz2 /openmpi-v1.8.4-134-g9ad2aa8.tar.bz2
/openmpi-1.8.5rc1.tar.bz2 /openmpi-1.8.5rc1.tar.bz2
/openmpi-1.8.5rc3.tar.bz2

View File

@ -1,89 +0,0 @@
diff -up openmpi-1.6.3/ompi/debuggers/dlopen_test.c.ltdl openmpi-1.6.3/ompi/debuggers/dlopen_test.c
--- openmpi-1.6.3/ompi/debuggers/dlopen_test.c.ltdl 2012-04-03 08:30:25.000000000 -0600
+++ openmpi-1.6.3/ompi/debuggers/dlopen_test.c 2012-11-05 10:28:06.365041243 -0700
@@ -13,7 +13,17 @@
#include <string.h>
#include <stdlib.h>
-#include "opal/libltdl/ltdl.h"
+#if OPAL_WANT_LIBLTDL
+ #ifndef __WINDOWS__
+ #if OPAL_LIBLTDL_INTERNAL
+ #include "opal/libltdl/ltdl.h"
+ #else
+ #include "ltdl.h"
+ #endif
+ #else
+ #include "ltdl.h"
+ #endif
+#endif
static int do_test(void);
diff -up openmpi-1.6.3/ompi/debuggers/Makefile.in.ltdl openmpi-1.6.3/ompi/debuggers/Makefile.in
--- openmpi-1.6.3/ompi/debuggers/Makefile.in.ltdl 2012-10-24 09:40:15.000000000 -0600
+++ openmpi-1.6.3/ompi/debuggers/Makefile.in 2012-11-05 10:59:10.288662790 -0700
@@ -346,7 +346,7 @@ libompi_debugger_canary_la_OBJECTS = \
@OPAL_HAVE_DLOPEN_TRUE@am__EXEEXT_1 = dlopen_test$(EXEEXT)
am_dlopen_test_OBJECTS = dlopen_test-dlopen_test.$(OBJEXT)
dlopen_test_OBJECTS = $(am_dlopen_test_OBJECTS)
-dlopen_test_DEPENDENCIES = $(top_builddir)/opal/libltdl/libltdlc.la
+dlopen_test_DEPENDENCIES =
am_predefined_gap_test_OBJECTS = predefined_gap_test.$(OBJEXT)
predefined_gap_test_OBJECTS = $(am_predefined_gap_test_OBJECTS)
predefined_gap_test_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \
@@ -1216,8 +1216,8 @@ headers = \
# Simple checks to ensure that the DSOs are functional
dlopen_test_SOURCES = dlopen_test.c
-dlopen_test_CPPFLAGS = -I$(top_srcdir)/opal/libltdl
-dlopen_test_LDADD = $(top_builddir)/opal/libltdl/libltdlc.la
+dlopen_test_CPPFLAGS = $(LTDLINCL)
+dlopen_test_LDADD = $(LIBLTDL)
predefined_gap_test_SOURCES = predefined_gap_test.c
predefined_gap_test_LDFLAGS = $(WRAPPER_EXTRA_LDFLAGS)
predefined_gap_test_LDADD = $(top_builddir)/ompi/libmpi.la
diff -up openmpi-1.6.3/test/support/components.c.ltdl openmpi-1.6.3/test/support/components.c
--- openmpi-1.6.3/test/support/components.c.ltdl 2012-04-03 08:29:44.000000000 -0600
+++ openmpi-1.6.3/test/support/components.c 2012-11-05 10:28:06.366041244 -0700
@@ -24,7 +24,17 @@
#include "opal/constants.h"
#include "opal/mca/mca.h"
-#include "opal/libltdl/ltdl.h"
+#if OPAL_WANT_LIBLTDL
+ #ifndef __WINDOWS__
+ #if OPAL_LIBLTDL_INTERNAL
+ #include "opal/libltdl/ltdl.h"
+ #else
+ #include "ltdl.h"
+ #endif
+ #else
+ #include "ltdl.h"
+ #endif
+#endif
#include "components.h"
diff -up openmpi-1.6.3/test/support/components.h.ltdl openmpi-1.6.3/test/support/components.h
--- openmpi-1.6.3/test/support/components.h.ltdl 2012-04-03 08:29:44.000000000 -0600
+++ openmpi-1.6.3/test/support/components.h 2012-11-05 10:28:06.366041244 -0700
@@ -20,7 +20,17 @@
#ifndef OMPI_SUPPORT_COMPONENTS_H
#define OMPI_SUPPORT_COMPONENTS_H
-#include "opal/libltdl/ltdl.h"
+#if OPAL_WANT_LIBLTDL
+ #ifndef __WINDOWS__
+ #if OPAL_LIBLTDL_INTERNAL
+ #include "opal/libltdl/ltdl.h"
+ #else
+ #include "ltdl.h"
+ #endif
+ #else
+ #include "ltdl.h"
+ #endif
+#endif
#include "opal/mca/mca.h"
BEGIN_C_DECLS

View File

@ -1,12 +0,0 @@
diff -up openmpi-1.8.3/oshmem/tools/wrappers/shmemcc-wrapper-data.txt.in.oshmem openmpi-1.8.3/oshmem/tools/wrappers/shmemcc-wrapper-data.txt.in
--- openmpi-1.8.3/oshmem/tools/wrappers/shmemcc-wrapper-data.txt.in.oshmem 2014-07-23 15:43:33.000000000 -0600
+++ openmpi-1.8.3/oshmem/tools/wrappers/shmemcc-wrapper-data.txt.in 2014-10-03 15:26:43.728048287 -0600
@@ -31,7 +31,7 @@ linker_flags=@OMPI_WRAPPER_EXTRA_LDFLAGS
# applications to only use the SHMEM and MPI APIs.
libs=-loshmem -lmpi
libs_static=-loshmem -lmpi -lopen-rte -lopen-pal @OMPI_WRAPPER_EXTRA_LIBS@
-dyn_lib_file=libsohmem.@OPAL_DYN_LIB_SUFFIX@
+dyn_lib_file=liboshmem.@OPAL_DYN_LIB_SUFFIX@
static_lib_file=liboshmem.a
required_file=
includedir=${includedir}

View File

@ -22,23 +22,18 @@
Name: openmpi%{?_cc_name_suffix} Name: openmpi%{?_cc_name_suffix}
Version: 1.8.5 Version: 1.8.5
Release: 0.1.rc1%{?dist} Release: 0.2.rc3%{?dist}
Summary: Open Message Passing Interface Summary: Open Message Passing Interface
Group: Development/Libraries Group: Development/Libraries
License: BSD, MIT and Romio License: BSD, MIT and Romio
URL: http://www.open-mpi.org/ URL: http://www.open-mpi.org/
# We can't use %{name} here because of _cc_name_suffix # We can't use %{name} here because of _cc_name_suffix
Source0: http://www.open-mpi.org/software/ompi/v1.8/downloads/openmpi-%{version}rc1.tar.bz2 Source0: http://www.open-mpi.org/software/ompi/v1.8/downloads/openmpi-%{version}rc3.tar.bz2
Source1: openmpi.module.in Source1: openmpi.module.in
Source2: macros.openmpi Source2: macros.openmpi
# Upstream patch to fix atomics on 32bit # Upstream patch to fix atomics on 32bit
Patch0: openmpi-atomic.patch Patch0: openmpi-atomic.patch
# Patch to use system ltdl for tests
Patch1: openmpi-ltdl.patch
# Fix typo in liboshmem name
# https://github.com/open-mpi/ompi/pull/221
Patch2: openmpi-oshmem.patch
BuildRequires: gcc-gfortran BuildRequires: gcc-gfortran
#sparc64 don't have valgrind #sparc64 don't have valgrind
@ -115,12 +110,8 @@ Contains development wrapper for compiling Java with openmpi.
%global namearch openmpi-%{_arch}%{?_cc_name_suffix} %global namearch openmpi-%{_arch}%{?_cc_name_suffix}
%prep %prep
%setup -q -n openmpi-%{version}rc1 %setup -q -n openmpi-%{version}rc3
%patch0 -p1 -b .atomic %patch0 -p1 -b .atomic
%patch1 -p1 -b .ltdl
%patch2 -p1 -b .oshmem
# Make sure we don't use the local libltdl library
rm -r opal/libltdl
%build %build
./configure --prefix=%{_libdir}/%{name} \ ./configure --prefix=%{_libdir}/%{name} \
@ -243,6 +234,9 @@ make check
%changelog %changelog
* Fri May 1 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.5-0.2.rc3
- Update to 1.8.5rc3
* Sun Apr 5 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.5-0.1.rc1 * Sun Apr 5 2015 Orion Poplawski <orion@cora.nwra.com> 1.8.5-0.1.rc1
- Update to 1.8.5rc1 - Update to 1.8.5rc1

View File

@ -1 +1 @@
49dfc95644b0740a23a1fcdea2ddd413 openmpi-1.8.5rc1.tar.bz2 c0e4ffb57d8fd231fb88fe6cf34b8896 openmpi-1.8.5rc3.tar.bz2