import openmpi-4.0.1-3.el8
This commit is contained in:
parent
9f12c9fc9e
commit
3f5c497815
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/openmpi-3.1.2.tar.bz2
|
SOURCES/openmpi-4.0.1.tar.bz2
|
||||||
|
@ -1 +1 @@
|
|||||||
b93c3b6ece16064e95578ec104f0c695c47a9fc8 SOURCES/openmpi-3.1.2.tar.bz2
|
35bf7c9162b08ecdc4876af573786cd290015631 SOURCES/openmpi-4.0.1.tar.bz2
|
||||||
|
@ -1,187 +0,0 @@
|
|||||||
Index: openmpi-3.1.2/orte/test/system/Makefile
|
|
||||||
===================================================================
|
|
||||||
--- openmpi-3.1.2.orig/orte/test/system/Makefile
|
|
||||||
+++ openmpi-3.1.2/orte/test/system/Makefile
|
|
||||||
@@ -21,4 +21,4 @@ pmixtool:
|
|
||||||
ortecc -o pmixtool pmixtool.c -lpmix
|
|
||||||
|
|
||||||
threads:
|
|
||||||
- ortecc -O0 -g -lpthread -lhwloc threads.c -o threads
|
|
||||||
+ ortecc -O2 -g -lpthread -lhwloc threads.c -o threads
|
|
||||||
Index: openmpi-3.1.2/orte/tools/orte-dvm/Makefile.in
|
|
||||||
===================================================================
|
|
||||||
--- openmpi-3.1.2.orig/orte/tools/orte-dvm/Makefile.in
|
|
||||||
+++ openmpi-3.1.2/orte/tools/orte-dvm/Makefile.in
|
|
||||||
@@ -558,7 +558,7 @@ CCAS = @CCAS@
|
|
||||||
CCASDEPMODE = @CCASDEPMODE@
|
|
||||||
CCASFLAGS = @CCASFLAGS@
|
|
||||||
CCDEPMODE = @CCDEPMODE@
|
|
||||||
-CFLAGS = $(CFLAGS_WITHOUT_OPTFLAGS) $(DEBUGGER_CFLAGS)
|
|
||||||
+CFLAGS = @CFLAGS@
|
|
||||||
CFLAGS_WITHOUT_OPTFLAGS = @CFLAGS_WITHOUT_OPTFLAGS@
|
|
||||||
CLEANFILES = @CLEANFILES@
|
|
||||||
CONFIGURE_DEPENDENCIES = @CONFIGURE_DEPENDENCIES@
|
|
||||||
Index: openmpi-3.1.2/orte/tools/prun/Makefile.in
|
|
||||||
===================================================================
|
|
||||||
--- openmpi-3.1.2.orig/orte/tools/prun/Makefile.in
|
|
||||||
+++ openmpi-3.1.2/orte/tools/prun/Makefile.in
|
|
||||||
@@ -558,7 +558,7 @@ CCAS = @CCAS@
|
|
||||||
CCASDEPMODE = @CCASDEPMODE@
|
|
||||||
CCASFLAGS = @CCASFLAGS@
|
|
||||||
CCDEPMODE = @CCDEPMODE@
|
|
||||||
-CFLAGS = $(CFLAGS_WITHOUT_OPTFLAGS) $(DEBUGGER_CFLAGS)
|
|
||||||
+CFLAGS = @CFLAGS@
|
|
||||||
CFLAGS_WITHOUT_OPTFLAGS = @CFLAGS_WITHOUT_OPTFLAGS@
|
|
||||||
CLEANFILES = @CLEANFILES@
|
|
||||||
CONFIGURE_DEPENDENCIES = @CONFIGURE_DEPENDENCIES@
|
|
||||||
Index: openmpi-3.1.2/orte/Makefile.in
|
|
||||||
===================================================================
|
|
||||||
--- openmpi-3.1.2.orig/orte/Makefile.in
|
|
||||||
+++ openmpi-3.1.2/orte/Makefile.in
|
|
||||||
@@ -2162,7 +2162,7 @@ AM_LFLAGS = -Porte_util_hostfile_
|
|
||||||
liborted_mpir_la_SOURCES = \
|
|
||||||
orted/orted_submit.c
|
|
||||||
|
|
||||||
-liborted_mpir_la_CFLAGS = $(CFLAGS_WITHOUT_OPTFLAGS) $(DEBUGGER_CFLAGS)
|
|
||||||
+liborted_mpir_la_CFLAGS = $(CFLAGS)
|
|
||||||
all: all-recursive
|
|
||||||
|
|
||||||
.SUFFIXES:
|
|
||||||
Index: openmpi-3.1.2/ompi/debuggers/Makefile.in
|
|
||||||
===================================================================
|
|
||||||
--- openmpi-3.1.2.orig/ompi/debuggers/Makefile.in
|
|
||||||
+++ openmpi-3.1.2/ompi/debuggers/Makefile.in
|
|
||||||
@@ -756,7 +756,7 @@ CCDEPMODE = @CCDEPMODE@
|
|
||||||
# may already have debugging and/or optimization flags). We use
|
|
||||||
# post-processed forms of the CFLAGS in the library targets down
|
|
||||||
# below.
|
|
||||||
-CFLAGS = $(CFLAGS_WITHOUT_OPTFLAGS) $(DEBUGGER_CFLAGS)
|
|
||||||
+CFLAGS = @CFLAGS@
|
|
||||||
CFLAGS_WITHOUT_OPTFLAGS = @CFLAGS_WITHOUT_OPTFLAGS@
|
|
||||||
CLEANFILES = @CLEANFILES@
|
|
||||||
CONFIGURE_DEPENDENCIES = @CONFIGURE_DEPENDENCIES@
|
|
||||||
@@ -1984,7 +1984,7 @@ common = ompi_common_dll_defs.h ompi_com
|
|
||||||
|
|
||||||
# MPI message queue DLL
|
|
||||||
libompi_dbg_msgq_la_SOURCES = ompi_msgq_dll.c ompi_msgq_dll_defs.h $(common)
|
|
||||||
-libompi_dbg_msgq_la_CFLAGS = -g
|
|
||||||
+libompi_dbg_msgq_la_CFLAGS = -O2 -g
|
|
||||||
libompi_dbg_msgq_la_LDFLAGS = -module -avoid-version
|
|
||||||
|
|
||||||
# These are checks for the padding on predefined MPI object types.
|
|
||||||
Index: openmpi-3.1.2/ompi/mpi/fortran/use-mpi-tkr/Makefile.in
|
|
||||||
===================================================================
|
|
||||||
--- openmpi-3.1.2.orig/ompi/mpi/fortran/use-mpi-tkr/Makefile.in
|
|
||||||
+++ openmpi-3.1.2/ompi/mpi/fortran/use-mpi-tkr/Makefile.in
|
|
||||||
@@ -1809,7 +1809,7 @@ ompi__v_GEN_0 = @echo " GENERATE" $@;
|
|
||||||
# current directory) because it is generated.
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPI_TKR_BINDINGS_TRUE@AM_FCFLAGS = -I$(top_builddir)/ompi/include -I$(top_srcdir)/ompi/include \
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPI_TKR_BINDINGS_TRUE@ $(OMPI_FC_MODULE_FLAG). -I$(srcdir) -I. \
|
|
||||||
-@OMPI_BUILD_FORTRAN_USEMPI_TKR_BINDINGS_TRUE@ -I$(top_builddir)/ompi/mpi/fortran/use-mpi-tkr $(FCFLAGS_f90)
|
|
||||||
+@OMPI_BUILD_FORTRAN_USEMPI_TKR_BINDINGS_TRUE@ -I$(top_builddir)/ompi/mpi/fortran/use-mpi-tkr $(FCFLAGS) $(FCFLAGS_f90)
|
|
||||||
|
|
||||||
|
|
||||||
# Do different things if the top-level configure decided that we're
|
|
||||||
@@ -1969,13 +1969,13 @@ distclean-compile:
|
|
||||||
$(AM_V_PPFC)$(LTPPFCCOMPILE) -c -o $@ $<
|
|
||||||
|
|
||||||
.f90.o:
|
|
||||||
- $(AM_V_FC)$(FCCOMPILE) -c -o $@ $(FCFLAGS_f90) $<
|
|
||||||
+ $(AM_V_FC)$(FCCOMPILE) -c -o $@ $(FCFLAGS) $(FCFLAGS_f90) $<
|
|
||||||
|
|
||||||
.f90.obj:
|
|
||||||
- $(AM_V_FC)$(FCCOMPILE) -c -o $@ $(FCFLAGS_f90) `$(CYGPATH_W) '$<'`
|
|
||||||
+ $(AM_V_FC)$(FCCOMPILE) -c -o $@ $(FCFLAGS) $(FCFLAGS_f90) `$(CYGPATH_W) '$<'`
|
|
||||||
|
|
||||||
.f90.lo:
|
|
||||||
- $(AM_V_FC)$(LTFCCOMPILE) -c -o $@ $(FCFLAGS_f90) $<
|
|
||||||
+ $(AM_V_FC)$(LTFCCOMPILE) -c -o $@ $(FCFLAGS) $(FCFLAGS_f90) $<
|
|
||||||
|
|
||||||
mostlyclean-libtool:
|
|
||||||
-rm -f *.lo
|
|
||||||
Index: openmpi-3.1.2/ompi/mpi/fortran/use-mpi-ignore-tkr/Makefile.in
|
|
||||||
===================================================================
|
|
||||||
--- openmpi-3.1.2.orig/ompi/mpi/fortran/use-mpi-ignore-tkr/Makefile.in
|
|
||||||
+++ openmpi-3.1.2/ompi/mpi/fortran/use-mpi-ignore-tkr/Makefile.in
|
|
||||||
@@ -1783,7 +1783,7 @@ ompi__v_GEN_0 = @echo " GENERATE" $@;
|
|
||||||
# mpi" MPI bindings.
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPI_IGNORE_TKR_BINDINGS_TRUE@AM_CPPFLAGS = -DOMPI_PROFILE_LAYER=0 -DOMPI_COMPILING_FORTRAN_WRAPPERS=1
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPI_IGNORE_TKR_BINDINGS_TRUE@AM_FCFLAGS = -I$(top_builddir)/ompi/include -I$(top_srcdir)/ompi/include \
|
|
||||||
-@OMPI_BUILD_FORTRAN_USEMPI_IGNORE_TKR_BINDINGS_TRUE@ -I$(top_builddir) -I$(top_srcdir) $(FCFLAGS_f90)
|
|
||||||
+@OMPI_BUILD_FORTRAN_USEMPI_IGNORE_TKR_BINDINGS_TRUE@ -I$(top_builddir) -I$(top_srcdir) $(FCFLAGS) $(FCFLAGS_f90)
|
|
||||||
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPI_IGNORE_TKR_BINDINGS_TRUE@lib_LTLIBRARIES = lib@OMPI_LIBMPI_NAME@_usempi_ignore_tkr.la
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPI_IGNORE_TKR_BINDINGS_TRUE@lib@OMPI_LIBMPI_NAME@_usempi_ignore_tkr_la_SOURCES = \
|
|
||||||
@@ -1904,13 +1904,13 @@ distclean-compile:
|
|
||||||
$(AM_V_PPFC)$(LTPPFCCOMPILE) -c -o $@ $<
|
|
||||||
|
|
||||||
.f90.o:
|
|
||||||
- $(AM_V_FC)$(FCCOMPILE) -c -o $@ $(FCFLAGS_f90) $<
|
|
||||||
+ $(AM_V_FC)$(FCCOMPILE) -c -o $@ $(FCFLAGS) $(FCFLAGS_f90) $<
|
|
||||||
|
|
||||||
.f90.obj:
|
|
||||||
- $(AM_V_FC)$(FCCOMPILE) -c -o $@ $(FCFLAGS_f90) `$(CYGPATH_W) '$<'`
|
|
||||||
+ $(AM_V_FC)$(FCCOMPILE) -c -o $@ $(FCFLAGS) $(FCFLAGS_f90) `$(CYGPATH_W) '$<'`
|
|
||||||
|
|
||||||
.f90.lo:
|
|
||||||
- $(AM_V_FC)$(LTFCCOMPILE) -c -o $@ $(FCFLAGS_f90) $<
|
|
||||||
+ $(AM_V_FC)$(LTFCCOMPILE) -c -o $@ $(FCFLAGS) $(FCFLAGS_f90) $<
|
|
||||||
|
|
||||||
mostlyclean-libtool:
|
|
||||||
-rm -f *.lo
|
|
||||||
Index: openmpi-3.1.2/ompi/mpi/fortran/mpiext/Makefile.in
|
|
||||||
===================================================================
|
|
||||||
--- openmpi-3.1.2.orig/ompi/mpi/fortran/mpiext/Makefile.in
|
|
||||||
+++ openmpi-3.1.2/ompi/mpi/fortran/mpiext/Makefile.in
|
|
||||||
@@ -1723,7 +1723,7 @@ ucx_STATIC_LIBS = @ucx_STATIC_LIBS@
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPI_OR_USEMPIF08_EXT_TRUE@AM_FCFLAGS = -I$(top_builddir)/ompi/include -I$(top_srcdir)/ompi/include \
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPI_OR_USEMPIF08_EXT_TRUE@ $(OMPI_FC_MODULE_FLAG)$(top_builddir)/ompi/mpi/fortran/base \
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPI_OR_USEMPIF08_EXT_TRUE@ $(OMPI_FC_MODULE_FLAG)$(top_builddir)/ompi/mpi/fortran/use-mpi-f08/mod \
|
|
||||||
-@OMPI_BUILD_FORTRAN_USEMPI_OR_USEMPIF08_EXT_TRUE@ -I$(top_srcdir) $(FCFLAGS_f90)
|
|
||||||
+@OMPI_BUILD_FORTRAN_USEMPI_OR_USEMPIF08_EXT_TRUE@ -I$(top_srcdir) $(FCFLAGS) $(FCFLAGS_f90)
|
|
||||||
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPI_OR_USEMPIF08_EXT_TRUE@flibs = $(am__append_1) \
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPI_OR_USEMPIF08_EXT_TRUE@ $(am__append_2)
|
|
||||||
Index: openmpi-3.1.2/ompi/mpi/fortran/use-mpi-f08/Makefile.in
|
|
||||||
===================================================================
|
|
||||||
--- openmpi-3.1.2.orig/ompi/mpi/fortran/use-mpi-f08/Makefile.in
|
|
||||||
+++ openmpi-3.1.2/ompi/mpi/fortran/use-mpi-f08/Makefile.in
|
|
||||||
@@ -2870,7 +2870,7 @@ ompi__v_GEN_0 = @echo " GENERATE" $@;
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPIF08_BINDINGS_TRUE@ -I$(top_srcdir)/ompi/include \
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPIF08_BINDINGS_TRUE@ $(OMPI_FC_MODULE_FLAG)$(top_builddir)/ompi/$(OMPI_FORTRAN_USEMPI_DIR) \
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPIF08_BINDINGS_TRUE@ $(OMPI_FC_MODULE_FLAG)mod \
|
|
||||||
-@OMPI_BUILD_FORTRAN_USEMPIF08_BINDINGS_TRUE@ -I$(top_srcdir) $(FCFLAGS_f90)
|
|
||||||
+@OMPI_BUILD_FORTRAN_USEMPIF08_BINDINGS_TRUE@ -I$(top_srcdir) $(FCFLAGS) $(FCFLAGS_f90)
|
|
||||||
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPIF08_BINDINGS_TRUE@MOSTLYCLEANFILES = *.mod
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPIF08_BINDINGS_TRUE@lib_LTLIBRARIES = lib@OMPI_LIBMPI_NAME@_usempif08.la
|
|
||||||
@@ -4444,13 +4444,13 @@ distclean-compile:
|
|
||||||
@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(LTCOMPILE) -c -o $@ $<
|
|
||||||
|
|
||||||
.f90.o:
|
|
||||||
- $(AM_V_FC)$(FCCOMPILE) -c -o $@ $(FCFLAGS_f90) $<
|
|
||||||
+ $(AM_V_FC)$(FCCOMPILE) -c -o $@ $(FCFLAGS) $(FCFLAGS_f90) $<
|
|
||||||
|
|
||||||
.f90.obj:
|
|
||||||
- $(AM_V_FC)$(FCCOMPILE) -c -o $@ $(FCFLAGS_f90) `$(CYGPATH_W) '$<'`
|
|
||||||
+ $(AM_V_FC)$(FCCOMPILE) -c -o $@ $(FCFLAGS) $(FCFLAGS_f90) `$(CYGPATH_W) '$<'`
|
|
||||||
|
|
||||||
.f90.lo:
|
|
||||||
- $(AM_V_FC)$(LTFCCOMPILE) -c -o $@ $(FCFLAGS_f90) $<
|
|
||||||
+ $(AM_V_FC)$(LTFCCOMPILE) -c -o $@ $(FCFLAGS) $(FCFLAGS_f90) $<
|
|
||||||
|
|
||||||
mostlyclean-libtool:
|
|
||||||
-rm -f *.lo
|
|
||||||
Index: openmpi-3.1.2/ompi/mpi/fortran/use-mpi-f08/mod/Makefile.in
|
|
||||||
===================================================================
|
|
||||||
--- openmpi-3.1.2.orig/ompi/mpi/fortran/use-mpi-f08/mod/Makefile.in
|
|
||||||
+++ openmpi-3.1.2/ompi/mpi/fortran/use-mpi-f08/mod/Makefile.in
|
|
||||||
@@ -1737,7 +1737,7 @@ ompi__v_GEN_0 = @echo " GENERATE" $@;
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPIF08_BINDINGS_TRUE@ -I$(top_srcdir)/ompi/include \
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPIF08_BINDINGS_TRUE@ $(OMPI_FC_MODULE_FLAG)$(top_builddir)/ompi/$(OMPI_FORTRAN_USEMPI_DIR) \
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPIF08_BINDINGS_TRUE@ $(OMPI_FC_MODULE_FLAG). \
|
|
||||||
-@OMPI_BUILD_FORTRAN_USEMPIF08_BINDINGS_TRUE@ -I$(top_srcdir) $(FCFLAGS_f90)
|
|
||||||
+@OMPI_BUILD_FORTRAN_USEMPIF08_BINDINGS_TRUE@ -I$(top_srcdir) $(FCFLAGS) $(FCFLAGS_f90)
|
|
||||||
|
|
||||||
@OMPI_BUILD_FORTRAN_USEMPIF08_BINDINGS_TRUE@MOSTLYCLEANFILES = *.mod
|
|
||||||
|
|
@ -1,103 +0,0 @@
|
|||||||
--- openmpi-2.1.1/test/class/Makefile.am 2017-05-10 08:41:36.000000000 -0700
|
|
||||||
+++ openmpi-2.1.1/test/class/Makefile.am.new 2017-08-24 09:07:12.539374461 -0700
|
|
||||||
@@ -95,11 +95,14 @@
|
|
||||||
$(top_builddir)/test/support/libsupport.a
|
|
||||||
opal_lifo_DEPENDENCIES = $(opal_lifo_LDADD)
|
|
||||||
|
|
||||||
-opal_fifo_SOURCES = opal_fifo.c
|
|
||||||
-opal_fifo_LDADD = \
|
|
||||||
- $(top_builddir)/opal/lib@OPAL_LIB_PREFIX@open-pal.la \
|
|
||||||
- $(top_builddir)/test/support/libsupport.a
|
|
||||||
-opal_fifo_DEPENDENCIES = $(opal_fifo_LDADD)
|
|
||||||
+# Disabled due to:
|
|
||||||
+# https://github.com/open-mpi/ompi/issues/2526
|
|
||||||
+# https://github.com/open-mpi/ompi/issues/2966
|
|
||||||
+#opal_fifo_SOURCES = opal_fifo.c
|
|
||||||
+#opal_fifo_LDADD = \
|
|
||||||
+# $(top_builddir)/opal/lib@OPAL_LIB_PREFIX@open-pal.la \
|
|
||||||
+# $(top_builddir)/test/support/libsupport.a
|
|
||||||
+#opal_fifo_DEPENDENCIES = $(opal_fifo_LDADD)
|
|
||||||
|
|
||||||
clean-local:
|
|
||||||
rm -f opal_bitmap_test_out.txt opal_hash_table_test_out.txt opal_proc_table_test_out.txt
|
|
||||||
--- openmpi-2.1.1/test/class/Makefile.in 2017-05-10 09:01:13.000000000 -0700
|
|
||||||
+++ openmpi-2.1.1/test/class/Makefile.in.new 2017-08-24 09:07:12.539374461 -0700
|
|
||||||
@@ -115,7 +115,7 @@
|
|
||||||
opal_hash_table$(EXEEXT) opal_proc_table$(EXEEXT) \
|
|
||||||
opal_tree$(EXEEXT) opal_list$(EXEEXT) \
|
|
||||||
opal_value_array$(EXEEXT) opal_pointer_array$(EXEEXT) \
|
|
||||||
- opal_lifo$(EXEEXT) opal_fifo$(EXEEXT)
|
|
||||||
+ opal_lifo$(EXEEXT)
|
|
||||||
subdir = test/class
|
|
||||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
|
||||||
am__aclocal_m4_deps = $(top_srcdir)/config/c_get_alignment.m4 \
|
|
||||||
@@ -411,8 +411,6 @@
|
|
||||||
am__v_lt_1 =
|
|
||||||
am_opal_bitmap_OBJECTS = opal_bitmap.$(OBJEXT)
|
|
||||||
opal_bitmap_OBJECTS = $(am_opal_bitmap_OBJECTS)
|
|
||||||
-am_opal_fifo_OBJECTS = opal_fifo.$(OBJEXT)
|
|
||||||
-opal_fifo_OBJECTS = $(am_opal_fifo_OBJECTS)
|
|
||||||
am_opal_hash_table_OBJECTS = opal_hash_table.$(OBJEXT)
|
|
||||||
opal_hash_table_OBJECTS = $(am_opal_hash_table_OBJECTS)
|
|
||||||
am_opal_lifo_OBJECTS = opal_lifo.$(OBJEXT)
|
|
||||||
@@ -462,12 +460,12 @@
|
|
||||||
am__v_CCLD_0 = @echo " CCLD " $@;
|
|
||||||
am__v_CCLD_1 =
|
|
||||||
SOURCES = $(ompi_rb_tree_SOURCES) $(opal_bitmap_SOURCES) \
|
|
||||||
- $(opal_fifo_SOURCES) $(opal_hash_table_SOURCES) \
|
|
||||||
+ $(opal_hash_table_SOURCES) \
|
|
||||||
$(opal_lifo_SOURCES) $(opal_list_SOURCES) \
|
|
||||||
$(opal_pointer_array_SOURCES) $(opal_proc_table_SOURCES) \
|
|
||||||
$(opal_tree_SOURCES) $(opal_value_array_SOURCES)
|
|
||||||
DIST_SOURCES = $(ompi_rb_tree_SOURCES) $(opal_bitmap_SOURCES) \
|
|
||||||
- $(opal_fifo_SOURCES) $(opal_hash_table_SOURCES) \
|
|
||||||
+ $(opal_hash_table_SOURCES) \
|
|
||||||
$(opal_lifo_SOURCES) $(opal_list_SOURCES) \
|
|
||||||
$(opal_pointer_array_SOURCES) $(opal_proc_table_SOURCES) \
|
|
||||||
$(opal_tree_SOURCES) $(opal_value_array_SOURCES)
|
|
||||||
@@ -1900,12 +1898,6 @@
|
|
||||||
$(top_builddir)/test/support/libsupport.a
|
|
||||||
|
|
||||||
opal_lifo_DEPENDENCIES = $(opal_lifo_LDADD)
|
|
||||||
-opal_fifo_SOURCES = opal_fifo.c
|
|
||||||
-opal_fifo_LDADD = \
|
|
||||||
- $(top_builddir)/opal/lib@OPAL_LIB_PREFIX@open-pal.la \
|
|
||||||
- $(top_builddir)/test/support/libsupport.a
|
|
||||||
-
|
|
||||||
-opal_fifo_DEPENDENCIES = $(opal_fifo_LDADD)
|
|
||||||
all: all-am
|
|
||||||
|
|
||||||
.SUFFIXES:
|
|
||||||
@@ -1957,10 +1949,6 @@
|
|
||||||
@rm -f opal_bitmap$(EXEEXT)
|
|
||||||
$(AM_V_CCLD)$(LINK) $(opal_bitmap_OBJECTS) $(opal_bitmap_LDADD) $(LIBS)
|
|
||||||
|
|
||||||
-opal_fifo$(EXEEXT): $(opal_fifo_OBJECTS) $(opal_fifo_DEPENDENCIES) $(EXTRA_opal_fifo_DEPENDENCIES)
|
|
||||||
- @rm -f opal_fifo$(EXEEXT)
|
|
||||||
- $(AM_V_CCLD)$(LINK) $(opal_fifo_OBJECTS) $(opal_fifo_LDADD) $(LIBS)
|
|
||||||
-
|
|
||||||
opal_hash_table$(EXEEXT): $(opal_hash_table_OBJECTS) $(opal_hash_table_DEPENDENCIES) $(EXTRA_opal_hash_table_DEPENDENCIES)
|
|
||||||
@rm -f opal_hash_table$(EXEEXT)
|
|
||||||
$(AM_V_CCLD)$(LINK) $(opal_hash_table_OBJECTS) $(opal_hash_table_LDADD) $(LIBS)
|
|
||||||
@@ -1997,7 +1985,6 @@
|
|
||||||
|
|
||||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ompi_rb_tree.Po@am__quote@
|
|
||||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/opal_bitmap.Po@am__quote@
|
|
||||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/opal_fifo.Po@am__quote@
|
|
||||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/opal_hash_table.Po@am__quote@
|
|
||||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/opal_lifo.Po@am__quote@
|
|
||||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/opal_list.Po@am__quote@
|
|
||||||
@@ -2291,13 +2278,6 @@
|
|
||||||
$(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
|
|
||||||
--log-file $$b.log --trs-file $$b.trs \
|
|
||||||
$(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
|
|
||||||
- "$$tst" $(AM_TESTS_FD_REDIRECT)
|
|
||||||
-opal_fifo.log: opal_fifo$(EXEEXT)
|
|
||||||
- @p='opal_fifo$(EXEEXT)'; \
|
|
||||||
- b='opal_fifo'; \
|
|
||||||
- $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
|
|
||||||
- --log-file $$b.log --trs-file $$b.trs \
|
|
||||||
- $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
|
|
||||||
"$$tst" $(AM_TESTS_FD_REDIRECT)
|
|
||||||
.test.log:
|
|
||||||
@p='$<'; \
|
|
@ -21,31 +21,28 @@
|
|||||||
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
||||||
|
|
||||||
Name: openmpi%{?_cc_name_suffix}
|
Name: openmpi%{?_cc_name_suffix}
|
||||||
Version: 3.1.2
|
Version: 4.0.1
|
||||||
Release: 5%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Open Message Passing Interface
|
Summary: Open Message Passing Interface
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: BSD and MIT and Romio
|
License: BSD and MIT and Romio
|
||||||
URL: http://www.open-mpi.org/
|
URL: http://www.open-mpi.org/
|
||||||
|
|
||||||
# We can't use %%{name} here because of _cc_name_suffix
|
# We can't use %%{name} here because of _cc_name_suffix
|
||||||
Source0: https://www.open-mpi.org/software/ompi/v3.1/downloads/openmpi-%{version}.tar.bz2
|
Source0: https://www.open-mpi.org/software/ompi/v4.0/downloads/openmpi-%{version}.tar.bz2
|
||||||
Source1: openmpi.module.in
|
Source1: openmpi.module.in
|
||||||
Source2: openmpi.pth.py3
|
Source2: openmpi.pth.py3
|
||||||
Source3: macros.openmpi
|
Source3: macros.openmpi
|
||||||
|
|
||||||
# Only for ppc64le
|
BuildRequires: gcc-gfortran, gcc-c++
|
||||||
# https://github.com/open-mpi/ompi/issues/2526
|
|
||||||
# https://github.com/open-mpi/ompi/issues/2966
|
|
||||||
Patch0: openmpi-2.1.1-disable-fifo-test.patch
|
|
||||||
Patch1: fix-optimization-flags.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc-gfortran
|
|
||||||
%ifnarch s390 s390x
|
%ifnarch s390 s390x
|
||||||
BuildRequires: valgrind-devel
|
BuildRequires: valgrind-devel
|
||||||
%endif
|
%endif
|
||||||
|
%ifnarch s390 s390x i686
|
||||||
|
BuildRequires: ucx-devel
|
||||||
|
%endif
|
||||||
%ifnarch s390 s390x %{arm}
|
%ifnarch s390 s390x %{arm}
|
||||||
BuildRequires: libibverbs-devel >= 1.1.3, opensm-devel >= 3.3.21
|
BuildRequires: libibverbs-devel >= 1.1.3, opensm-devel >= 3.3.22
|
||||||
BuildRequires: librdmacm-devel rdma-core-devel
|
BuildRequires: librdmacm-devel rdma-core-devel
|
||||||
%endif
|
%endif
|
||||||
# Doesn't compile:
|
# Doesn't compile:
|
||||||
@ -136,10 +133,6 @@ OpenMPI support for Python 3.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n openmpi-%{version}
|
%setup -q -n openmpi-%{version}
|
||||||
%ifarch ppc64le
|
|
||||||
%patch0 -p1
|
|
||||||
%endif
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%set_build_flags
|
%set_build_flags
|
||||||
@ -160,6 +153,10 @@ OpenMPI support for Python 3.
|
|||||||
%ifnarch s390 s390x
|
%ifnarch s390 s390x
|
||||||
--with-valgrind \
|
--with-valgrind \
|
||||||
--enable-memchecker \
|
--enable-memchecker \
|
||||||
|
%endif
|
||||||
|
%ifnarch s390 s390x i686
|
||||||
|
--with-ucx \
|
||||||
|
--with-ucx-libdir=%{_libdir} \
|
||||||
%endif
|
%endif
|
||||||
--with-hwloc=external \
|
--with-hwloc=external \
|
||||||
--with-pmix=external \
|
--with-pmix=external \
|
||||||
@ -238,9 +235,10 @@ make check
|
|||||||
%{_libdir}/%{name}/bin/mpi[er]*
|
%{_libdir}/%{name}/bin/mpi[er]*
|
||||||
%{_libdir}/%{name}/bin/ompi*
|
%{_libdir}/%{name}/bin/ompi*
|
||||||
%{_libdir}/%{name}/bin/orte[-dr_]*
|
%{_libdir}/%{name}/bin/orte[-dr_]*
|
||||||
|
%ifnarch s390 s390x i686
|
||||||
%{_libdir}/%{name}/bin/osh*
|
%{_libdir}/%{name}/bin/osh*
|
||||||
%{_libdir}/%{name}/bin/shmem*
|
%{_libdir}/%{name}/bin/shmem*
|
||||||
%{_libdir}/%{name}/bin/prun
|
%endif
|
||||||
%{_libdir}/%{name}/lib/*.so.*
|
%{_libdir}/%{name}/lib/*.so.*
|
||||||
%{_mandir}/%{namearch}/man1/*
|
%{_mandir}/%{namearch}/man1/*
|
||||||
%{_mandir}/%{namearch}/man7/*
|
%{_mandir}/%{namearch}/man7/*
|
||||||
@ -254,13 +252,12 @@ make check
|
|||||||
%{_libdir}/%{name}/share/openmpi/mca-btl-openib-device-params.ini
|
%{_libdir}/%{name}/share/openmpi/mca-btl-openib-device-params.ini
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%dir %{_includedir}/%{namearch}
|
%dir %{_includedir}/%{namearch}
|
||||||
%{_libdir}/%{name}/bin/mpi[cCf]*
|
%{_libdir}/%{name}/bin/mpi[cCf]*
|
||||||
%{_libdir}/%{name}/bin/opal_*
|
%{_libdir}/%{name}/bin/opal_*
|
||||||
%{_libdir}/%{name}/bin/orte[cCf]*
|
%{_libdir}/%{name}/bin/orte[cCf]*
|
||||||
%{_libdir}/%{name}/bin/osh[cf]*
|
|
||||||
%{_libdir}/%{name}/bin/shmem[cf]*
|
|
||||||
%{_includedir}/%{namearch}/*
|
%{_includedir}/%{namearch}/*
|
||||||
%{_fmoddir}/%{name}/
|
%{_fmoddir}/%{name}/
|
||||||
%{_libdir}/%{name}/lib/*.so
|
%{_libdir}/%{name}/lib/*.so
|
||||||
@ -268,8 +265,6 @@ make check
|
|||||||
%{_libdir}/%{name}/lib/pkgconfig/
|
%{_libdir}/%{name}/lib/pkgconfig/
|
||||||
%{_libdir}/pkgconfig/*.pc
|
%{_libdir}/pkgconfig/*.pc
|
||||||
%{_mandir}/%{namearch}/man1/mpi[cCf]*
|
%{_mandir}/%{namearch}/man1/mpi[cCf]*
|
||||||
%{_mandir}/%{namearch}/man1/osh[cCf]*
|
|
||||||
%{_mandir}/%{namearch}/man1/shmem[cCf]*
|
|
||||||
%{_mandir}/%{namearch}/man1/opal_*
|
%{_mandir}/%{namearch}/man1/opal_*
|
||||||
%{_mandir}/%{namearch}/man3/*
|
%{_mandir}/%{namearch}/man3/*
|
||||||
%{_libdir}/%{name}/share/openmpi/openmpi-valgrind.supp
|
%{_libdir}/%{name}/share/openmpi/openmpi-valgrind.supp
|
||||||
@ -292,6 +287,18 @@ make check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 01 2019 Jarod Wilson <jarod@redhat.com> - 4.0.1-3
|
||||||
|
- Actually enable UCX support
|
||||||
|
- Resolves: rhbz#1642942
|
||||||
|
|
||||||
|
* Wed Jun 19 2019 Jarod Wilson <jarod@redhat.com> - 4.0.1-2
|
||||||
|
- Bump and rebuild for newer opensm
|
||||||
|
- Resolves: rhbz#1717289
|
||||||
|
|
||||||
|
* Mon Apr 29 2019 Jarod Wilson <jarod@redhat.com> - 4.0.1-1
|
||||||
|
- Update to upstream v4.0.1 release
|
||||||
|
- Resolves: rhbz#1660623
|
||||||
|
|
||||||
* Tue Sep 25 2018 Jarod Wilson <jarod@redhat.com> - 3.1.2-5
|
* Tue Sep 25 2018 Jarod Wilson <jarod@redhat.com> - 3.1.2-5
|
||||||
- Update BR: opensm-devel min version and rebuild against opensm 3.3.21
|
- Update BR: opensm-devel min version and rebuild against opensm 3.3.21
|
||||||
- Resolves: rhbz#1630653
|
- Resolves: rhbz#1630653
|
||||||
|
Loading…
Reference in New Issue
Block a user