- New upstream version, which includes the changeset_r22324 patch.
- Correct a typo in the Source0 line in this spec file.
This commit is contained in:
parent
257caf3e1d
commit
12da6620fc
@ -1,3 +1 @@
|
||||
openmpi-1.3.1.tar.bz2
|
||||
openmpi-1.3.3.tar.bz2
|
||||
openmpi-1.4.tar.bz2
|
||||
openmpi-1.4.1.tar.bz2
|
||||
|
@ -1,50 +0,0 @@
|
||||
Index: /trunk/opal/include/opal/sys/amd64/atomic.h
|
||||
===================================================================
|
||||
--- /trunk/opal/include/opal/sys/amd64/atomic.h (revision 21180)
|
||||
+++ /trunk/opal/include/opal/sys/amd64/atomic.h (revision 22324)
|
||||
@@ -85,9 +85,9 @@
|
||||
unsigned char ret;
|
||||
__asm__ __volatile__ (
|
||||
- SMPLOCK "cmpxchgl %1,%2 \n\t"
|
||||
+ SMPLOCK "cmpxchgl %3,%4 \n\t"
|
||||
"sete %0 \n\t"
|
||||
- : "=qm" (ret)
|
||||
- : "q"(newval), "m"(*addr), "a"(oldval)
|
||||
- : "memory");
|
||||
+ : "=qm" (ret), "=a" (oldval), "=m" (*addr)
|
||||
+ : "q"(newval), "m"(*addr), "1"(oldval)
|
||||
+ );
|
||||
|
||||
return (int)ret;
|
||||
@@ -106,9 +106,9 @@
|
||||
unsigned char ret;
|
||||
__asm__ __volatile__ (
|
||||
- SMPLOCK "cmpxchgq %1,%2 \n\t"
|
||||
+ SMPLOCK "cmpxchgq %3,%4 \n\t"
|
||||
"sete %0 \n\t"
|
||||
- : "=qm" (ret)
|
||||
- : "q"(newval), "m"(*((volatile long*)addr)), "a"(oldval)
|
||||
- : "memory");
|
||||
+ : "=qm" (ret), "=a" (oldval), "=m" (*((volatile long*)addr))
|
||||
+ : "q"(newval), "m"(*((volatile long*)addr)), "1"(oldval)
|
||||
+ );
|
||||
|
||||
return (int)ret;
|
||||
Index: /trunk/opal/include/opal/sys/ia32/atomic.h
|
||||
===================================================================
|
||||
--- /trunk/opal/include/opal/sys/ia32/atomic.h (revision 21180)
|
||||
+++ /trunk/opal/include/opal/sys/ia32/atomic.h (revision 22324)
|
||||
@@ -92,9 +92,9 @@
|
||||
unsigned char ret;
|
||||
__asm__ __volatile__ (
|
||||
- SMPLOCK "cmpxchgl %1,%2 \n\t"
|
||||
+ SMPLOCK "cmpxchgl %3,%4 \n\t"
|
||||
"sete %0 \n\t"
|
||||
- : "=qm" (ret)
|
||||
- : "q"(newval), "m"(*((volatile long*)addr)), "a"(oldval)
|
||||
- : "memory");
|
||||
+ : "=qm" (ret), "=a" (oldval), "=m" (*addr)
|
||||
+ : "q"(newval), "m"(*((volatile long*)addr)), "1"(oldval)
|
||||
+ );
|
||||
|
||||
return (int)ret;
|
13
openmpi.spec
13
openmpi.spec
@ -18,18 +18,17 @@
|
||||
#define _cc_name_suffix -gcc
|
||||
|
||||
Name: openmpi%{?_cc_name_suffix}
|
||||
Version: 1.4
|
||||
Release: 4%{?dist}
|
||||
Version: 1.4.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Open Message Passing Interface
|
||||
Group: Development/Libraries
|
||||
License: BSD
|
||||
URL: http://www.open-mpi.org/
|
||||
# We can't use %{name} here because of _cc_name_suffix
|
||||
Source0: http://www.open-mpi.org/software/ompi/v1.3/downloads/openmpi-%{version}.tar.bz2
|
||||
Source0: http://www.open-mpi.org/software/ompi/v1.4/downloads/openmpi-%{version}.tar.bz2
|
||||
Source1: openmpi.pc.in
|
||||
Source2: openmpi.module.in
|
||||
Source3: macros.openmpi
|
||||
Patch0: openmpi-changeset_r22324.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: gcc-gfortran, libtool, numactl-devel, valgrind-devel
|
||||
BuildRequires: libibverbs-devel >= 1.1.3, opensm-devel > 3.3.0
|
||||
@ -106,7 +105,6 @@ Contains development headers and libraries for openmpi
|
||||
|
||||
%prep
|
||||
%setup -q -n openmpi-%{version}
|
||||
%patch0 -p2 -b .bz538199
|
||||
%ifarch x86_64
|
||||
XFLAGS="-fPIC"
|
||||
%endif
|
||||
@ -211,11 +209,16 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/%{namearch}/man1/opal_*
|
||||
%{_mandir}/%{namearch}/man3/*
|
||||
%{_mandir}/%{namearch}/man7/opal*
|
||||
%{_libdir}/%{name}/share/openmpi/openmpi-valgrind.supp
|
||||
%{_libdir}/%{name}/share/openmpi/mpi*
|
||||
%{_libdir}/%{name}/share/vampirtrace/*
|
||||
%{_sysconfdir}/rpm/macros.%{namearch}
|
||||
|
||||
%changelog
|
||||
* Tue Jan 26 2010 Jay Fenlason <fenlason@redhat.com> - 1.4.1-1
|
||||
- New upstream version, which includes the changeset_r22324 patch.
|
||||
- Correct a typo in the Source0 line in this spec file.
|
||||
|
||||
* Fri Jan 15 2010 Doug Ledford <dledford@redhat.com> - 1.4-4
|
||||
- Fix an issue with usage of _cc_name_suffix that cause a broken define in
|
||||
our module file
|
||||
|
Loading…
Reference in New Issue
Block a user