Update to 4.1.1rc1
This commit is contained in:
parent
8fc779b59b
commit
059848ce5b
1
.gitignore
vendored
1
.gitignore
vendored
@ -54,3 +54,4 @@ openmpi-1.4.1-RH.tar.bz2
|
||||
/openmpi-4.0.4.tar.bz2
|
||||
/openmpi-4.0.5.tar.bz2
|
||||
/openmpi-4.1.0.tar.bz2
|
||||
/openmpi-4.1.1rc1.tar.bz2
|
||||
|
1682
8322.patch
1682
8322.patch
File diff suppressed because it is too large
Load Diff
25
8348.patch
25
8348.patch
@ -1,25 +0,0 @@
|
||||
From 838568da9fce85b4555b0e0cbd899c8e8ef75696 Mon Sep 17 00:00:00 2001
|
||||
From: George Bosilca <bosilca@icl.utk.edu>
|
||||
Date: Wed, 6 Jan 2021 13:30:40 -0500
|
||||
Subject: [PATCH] A started generalized request should be marked as pending.
|
||||
|
||||
Fixes #8340
|
||||
|
||||
Signed-off-by: George Bosilca <bosilca@icl.utk.edu>
|
||||
(cherry picked from commit 434a2515f8aab11f505b2fca0b3d8cc41e24cef2)
|
||||
---
|
||||
ompi/request/grequest.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/ompi/request/grequest.c b/ompi/request/grequest.c
|
||||
index c895b4232b6..02affd642aa 100644
|
||||
--- a/ompi/request/grequest.c
|
||||
+++ b/ompi/request/grequest.c
|
||||
@@ -163,6 +163,7 @@ int ompi_grequest_start(
|
||||
greq->greq_free.c_free = gfree_fn;
|
||||
greq->greq_cancel.c_cancel = gcancel_fn;
|
||||
greq->greq_base.req_status = ompi_status_empty;
|
||||
+ greq->greq_base.req_complete = REQUEST_PENDING;
|
||||
|
||||
*request = &greq->greq_base;
|
||||
return OMPI_SUCCESS;
|
19
openmpi.spec
19
openmpi.spec
@ -26,28 +26,22 @@
|
||||
%endif
|
||||
|
||||
# Run autogen - needed for some patches
|
||||
# For Patch0
|
||||
%bcond_without autogen
|
||||
%bcond_with autogen
|
||||
|
||||
Name: openmpi%{?_cc_name_suffix}
|
||||
Version: 4.1.0
|
||||
Release: 5%{?dist}
|
||||
Version: 4.1.1
|
||||
Release: 0.1.rc1%{?dist}
|
||||
Summary: Open Message Passing Interface
|
||||
License: BSD and MIT and Romio
|
||||
URL: http://www.open-mpi.org/
|
||||
|
||||
# We can't use %%{name} here because of _cc_name_suffix
|
||||
Source0: https://www.open-mpi.org/software/ompi/v4.1/downloads/openmpi-%{version}.tar.bz2
|
||||
Source0: https://www.open-mpi.org/software/ompi/v4.1/downloads/openmpi-%{version}rc1.tar.bz2
|
||||
Source1: openmpi.module.in
|
||||
Source2: openmpi.pth.py2
|
||||
Source3: openmpi.pth.py3
|
||||
Source4: macros.openmpi
|
||||
|
||||
# Fix AVX library linkage
|
||||
Patch0: https://patch-diff.githubusercontent.com/raw/open-mpi/ompi/pull/8322.patch
|
||||
# Fix generalized requests (mpi4py test failure)
|
||||
Patch1: https://patch-diff.githubusercontent.com/raw/open-mpi/ompi/pull/8348.patch
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gcc-gfortran
|
||||
BuildRequires: make
|
||||
@ -174,7 +168,7 @@ OpenMPI support for Python 3.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
%autosetup -p1 -n %{name}-%{version}rc1
|
||||
%if %{with autogen}
|
||||
./autogen.pl --force
|
||||
%endif
|
||||
@ -363,6 +357,9 @@ make check
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 11 2021 Orion Poplawski <orion@nwra.com> - 4.1.1-0.1.rc1
|
||||
- Update to 4.1.1rc1
|
||||
|
||||
* Thu Jan 28 2021 Orion Poplawski <orion@nwra.com> - 4.1.0-5
|
||||
- Add upstream patch for generalized requests
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (openmpi-4.1.0.tar.bz2) = eaf086ab4929ce5a9a3e867c8315bf802ff4dc75d3f05d740e22dfd97803a4559212dacbe06920d42ac6644f46057eb6980cccf5a8b0a7df9c5bdf5bffc0b3a6
|
||||
SHA512 (openmpi-4.1.1rc1.tar.bz2) = 642ac706cd2d4fc34fdd5002b84fd1680e57a01edc78bcc1f0ab65b8da36af19952ae6b09c759562d5f97bafd0d931064b2d1e0926248793c8cddf2a5c38c3a3
|
||||
|
Loading…
Reference in New Issue
Block a user