16 lines
609 B
Diff
16 lines
609 B
Diff
Build both slapd as position-independent executables. This really
|
|
should be threaded into the various autotools, but I guess this is what we have
|
|
until that happens, if it happens.
|
|
|
|
--- openldap-2.2.13/servers/slapd/Makefile.in 2004-04-12 14:07:40.000000000 -0400
|
|
+++ openldap-2.2.13/servers/slapd/Makefile.in 2004-06-15 13:45:45.000000000 -0400
|
|
@@ -255,7 +255,7 @@
|
|
cp slapi/.libs/libslapi.a .
|
|
|
|
slapd: $(SLAPD_DEPENDS) @LIBSLAPI@
|
|
- $(LTLINK) -o $@ $(SLAPD_OBJECTS) $(LIBS) \
|
|
+ $(LTLINK) -pie -Wl,-z,defs -o $@ $(SLAPD_OBJECTS) $(LIBS) \
|
|
$(WRAP_LIBS)
|
|
rm -f $(SLAPTOOLS)
|
|
for i in $(SLAPTOOLS); do \
|