004e302f0d
- rediff all patches and remove patches now upstream - use upstream source location for check password module and rediff patch due to this - add patch to fix build issue in 2.5.4 (from upstream) - clean and sort buildreqs - remove various refs to bdb - remove now default -DLDAP_USE_NON_BLOCKING_TLS - add new modules and enable load balancer as module - disable wiredtired backend due to missing build deps - don't remove files that don't exist - let check-config work on *.mdb over legacy files - remove refs to old-style config - new soname names - remove libldap_r link as the library was merged with libldap - refactor openldap-compat package to support the transition from 2.4 - add UPGRADE_INSTRUCTIONS for openldap-server upgrade The original patch was submitted by Fedora user - terjeros https://src.fedoraproject.org/rpms/openldap/pull-request/6 Resolves: #1955293
60 lines
2.1 KiB
Diff
60 lines
2.1 KiB
Diff
Compile smbk5pwd together with other overlays.
|
|
|
|
Author: Jan Šafránek <jsafrane@redhat.com>
|
|
Resolves: #550895
|
|
|
|
Update to link against OpenSSL
|
|
|
|
Author: Jan Vcelak <jvcelak@redhat.com>
|
|
Resolves: #841560
|
|
|
|
diff --git a/contrib/slapd-modules/smbk5pwd/README b/contrib/slapd-modules/smbk5pwd/README
|
|
index 4a710a7..0cd4e9e 100644
|
|
--- a/contrib/slapd-modules/smbk5pwd/README
|
|
+++ b/contrib/slapd-modules/smbk5pwd/README
|
|
@@ -1,3 +1,8 @@
|
|
+******************************************************************************
|
|
+Red Hat note: We do not provide Heimdal Kerberos but MIT. Therefore the module
|
|
+is compiled only with Samba features in Fedora and Red Hat Enterprise Linux.
|
|
+******************************************************************************
|
|
+
|
|
This directory contains a slapd overlay, smbk5pwd, that extends the
|
|
PasswordModify Extended Operation to update Kerberos keys and Samba
|
|
password hashes for an LDAP user.
|
|
diff --git a/servers/slapd/overlays/Makefile.in b/servers/slapd/overlays/Makefile.in
|
|
index b84bc54..b5c3fc8 100644
|
|
--- a/servers/slapd/overlays/Makefile.in
|
|
+++ b/servers/slapd/overlays/Makefile.in
|
|
@@ -37,7 +37,8 @@ SRCS = overlays.c \
|
|
syncprov.c \
|
|
translucent.c \
|
|
unique.c \
|
|
- valsort.c
|
|
+ valsort.c \
|
|
+ smbk5pwd.c
|
|
OBJS = statover.o \
|
|
@SLAPD_STATIC_OVERLAYS@ \
|
|
overlays.o
|
|
@@ -57,7 +58,7 @@ NT_LINK_LIBS = -L.. -lslapd $(@BUILD_LIBS_DYNAMIC@_LDAP_LIBS)
|
|
UNIX_LINK_LIBS = $(@BUILD_LIBS_DYNAMIC@_LDAP_LIBS)
|
|
|
|
LIBRARY = ../liboverlays.a
|
|
-PROGRAMS = @SLAPD_DYNAMIC_OVERLAYS@
|
|
+PROGRAMS = @SLAPD_DYNAMIC_OVERLAYS@ smbk5pwd.la
|
|
|
|
XINCPATH = -I.. -I$(srcdir)/..
|
|
XDEFS = $(MODULES_CPPFLAGS)
|
|
@@ -141,6 +142,12 @@ unique.la : unique.lo
|
|
valsort.la : valsort.lo
|
|
$(LTLINK_MOD) -module -o $@ valsort.lo version.lo $(LINK_LIBS)
|
|
|
|
+smbk5pwd.lo : smbk5pwd.c
|
|
+ $(LTCOMPILE_MOD) -DDO_SAMBA -UHAVE_MOZNSS -DHAVE_OPENSSL $(shell pkg-config openssl --cflags) $<
|
|
+
|
|
+smbk5pwd.la : smbk5pwd.lo
|
|
+ $(LTLINK_MOD) -module -o $@ smbk5pwd.lo version.lo $(LINK_LIBS) $(shell pkg-config openssl --libs)
|
|
+
|
|
install-local: $(PROGRAMS)
|
|
@if test -n "$?" ; then \
|
|
$(MKDIR) $(DESTDIR)$(moduledir); \
|