reapplied all patches
added series file to support quilt
This commit is contained in:
parent
202278bcf4
commit
f81fb151c9
@ -1,10 +1,9 @@
|
||||
Get rid of this patch as soon as possible.
|
||||
More details are provided in README.evolution
|
||||
|
||||
diff -uNPrp openldap-2.4.23.old/include/ldap.h openldap-2.4.23.new/include/ldap.h
|
||||
--- openldap-2.4.23.old/include/ldap.h 2010-06-10 20:48:36.000000000 +0200
|
||||
+++ openldap-2.4.23.new/include/ldap.h 2010-08-24 18:17:46.306679878 +0200
|
||||
@@ -2487,5 +2487,26 @@ ldap_parse_deref_control LDAP_P((
|
||||
--- openldap-2.4.24.orig/include/ldap.h
|
||||
+++ openldap-2.4.24/include/ldap.h
|
||||
@@ -2518,5 +2518,26 @@ ldap_parse_deref_control LDAP_P((
|
||||
LDAPControl **ctrls,
|
||||
LDAPDerefRes **drp ));
|
||||
|
||||
@ -31,9 +30,8 @@ diff -uNPrp openldap-2.4.23.old/include/ldap.h openldap-2.4.23.new/include/ldap.
|
||||
+
|
||||
LDAP_END_DECL
|
||||
#endif /* _LDAP_H */
|
||||
diff -uNPrp openldap-2.4.23.old/libraries/libldap/Makefile.in openldap-2.4.23.new/libraries/libldap/Makefile.in
|
||||
--- openldap-2.4.23.old/libraries/libldap/Makefile.in 2010-04-13 22:22:55.000000000 +0200
|
||||
+++ openldap-2.4.23.new/libraries/libldap/Makefile.in 2010-08-24 18:17:46.306679878 +0200
|
||||
--- openldap-2.4.24.orig/libraries/libldap/Makefile.in
|
||||
+++ openldap-2.4.24/libraries/libldap/Makefile.in
|
||||
@@ -20,7 +20,7 @@ PROGRAMS = apitest dntest ftest ltest ur
|
||||
SRCS = bind.c open.c result.c error.c compare.c search.c \
|
||||
controls.c messages.c references.c extended.c cyrus.c \
|
||||
@ -52,9 +50,8 @@ diff -uNPrp openldap-2.4.23.old/libraries/libldap/Makefile.in openldap-2.4.23.ne
|
||||
filter.lo free.lo sort.lo passwd.lo whoami.lo \
|
||||
getdn.lo getentry.lo getattr.lo getvalues.lo addentry.lo \
|
||||
request.lo os-ip.lo url.lo pagectrl.lo sortctrl.lo vlvctrl.lo \
|
||||
diff -uNPrp openldap-2.4.23.old/libraries/libldap/ntlm.c openldap-2.4.23.new/libraries/libldap/ntlm.c
|
||||
--- openldap-2.4.23.old/libraries/libldap/ntlm.c 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ openldap-2.4.23.new/libraries/libldap/ntlm.c 2010-08-24 18:17:46.330680333 +0200
|
||||
--- /dev/null
|
||||
+++ openldap-2.4.24/libraries/libldap/ntlm.c
|
||||
@@ -0,0 +1,137 @@
|
||||
+/* $OpenLDAP: pkg/ldap/libraries/libldap/ntlm.c,v 1.1.4.10 2002/01/04 20:38:21 kurt Exp $ */
|
||||
+/*
|
||||
|
@ -4,9 +4,8 @@ mozldap with openldap in FreeIPA project.
|
||||
Upstream: ITS #6194
|
||||
Author: Rich Megginson <rmeggins@redhat.com>
|
||||
|
||||
diff -uNPrp openldap-2.4.23.old/include/Makefile.in openldap-2.4.23.new/include/Makefile.in
|
||||
--- openldap-2.4.23.old/include/Makefile.in 2010-04-13 22:22:47.000000000 +0200
|
||||
+++ openldap-2.4.23.new/include/Makefile.in 2010-08-19 17:40:29.073805139 +0200
|
||||
--- openldap-2.4.24.orig/include/Makefile.in
|
||||
+++ openldap-2.4.24/include/Makefile.in
|
||||
@@ -20,7 +20,8 @@ install-local: FORCE
|
||||
for header in $(srcdir)/lber.h lber_types.h \
|
||||
$(srcdir)/ldap.h $(srcdir)/ldap_cdefs.h \
|
||||
@ -17,9 +16,8 @@ diff -uNPrp openldap-2.4.23.old/include/Makefile.in openldap-2.4.23.new/include/
|
||||
do \
|
||||
$(INSTALL) $(INSTALLFLAGS) -m 644 $$header $(DESTDIR)$(includedir); \
|
||||
done
|
||||
diff -uNPrp openldap-2.4.23.old/libraries/liblutil/Makefile.in openldap-2.4.23.new/libraries/liblutil/Makefile.in
|
||||
--- openldap-2.4.23.old/libraries/liblutil/Makefile.in 2010-04-19 18:53:01.000000000 +0200
|
||||
+++ openldap-2.4.23.new/libraries/liblutil/Makefile.in 2010-08-19 17:40:20.424679962 +0200
|
||||
--- openldap-2.4.24.orig/libraries/liblutil/Makefile.in
|
||||
+++ openldap-2.4.24/libraries/liblutil/Makefile.in
|
||||
@@ -14,6 +14,9 @@
|
||||
## <http://www.OpenLDAP.org/license.html>.
|
||||
|
||||
|
@ -4,9 +4,8 @@ Resolves: #38402
|
||||
Upstream: ITS #1131
|
||||
Author: Henning Schmiedehausen <hps@intermeta.de>
|
||||
|
||||
diff -u -uNPrp openldap-2.4.23.old/libraries/libldap/init.c openldap-2.4.23.new/libraries/libldap/init.c
|
||||
--- openldap-2.4.23.old/libraries/libldap/init.c 2010-04-13 22:22:57.000000000 +0200
|
||||
+++ openldap-2.4.23.new/libraries/libldap/init.c 2010-08-24 15:34:27.780680598 +0200
|
||||
--- openldap-2.4.24.orig/libraries/libldap/init.c
|
||||
+++ openldap-2.4.24/libraries/libldap/init.c
|
||||
@@ -346,9 +346,6 @@ static void openldap_ldap_init_w_usercon
|
||||
if(path != NULL) {
|
||||
LDAP_FREE(path);
|
||||
|
@ -2,9 +2,8 @@ Various manual pages changes:
|
||||
* removes LIBEXECDIR from slapd.8
|
||||
* removes references to non-existing manpages (bz 624616)
|
||||
|
||||
diff -uNPrp openldap-2.4.23.old/doc/man/man1/ldapmodify.1 openldap-2.4.23.new/doc/man/man1/ldapmodify.1
|
||||
--- openldap-2.4.23.old/doc/man/man1/ldapmodify.1 2010-04-13 22:22:36.000000000 +0200
|
||||
+++ openldap-2.4.23.new/doc/man/man1/ldapmodify.1 2010-08-19 17:42:10.256805450 +0200
|
||||
--- openldap-2.4.24.orig/doc/man/man1/ldapmodify.1
|
||||
+++ openldap-2.4.24/doc/man/man1/ldapmodify.1
|
||||
@@ -364,9 +364,7 @@ exit status and a diagnostic message bei
|
||||
.BR ldap_add_ext (3),
|
||||
.BR ldap_delete_ext (3),
|
||||
@ -16,20 +15,18 @@ diff -uNPrp openldap-2.4.23.old/doc/man/man1/ldapmodify.1 openldap-2.4.23.new/do
|
||||
.SH AUTHOR
|
||||
The OpenLDAP Project <http://www.openldap.org/>
|
||||
.SH ACKNOWLEDGEMENTS
|
||||
diff -uNPrp openldap-2.4.23.old/doc/man/man5/ldap.conf.5 openldap-2.4.23.new/doc/man/man5/ldap.conf.5
|
||||
--- openldap-2.4.23.old/doc/man/man5/ldap.conf.5 2010-04-13 22:22:41.000000000 +0200
|
||||
+++ openldap-2.4.23.new/doc/man/man5/ldap.conf.5 2010-08-19 17:43:25.312805428 +0200
|
||||
--- openldap-2.4.24.orig/doc/man/man5/ldap.conf.5
|
||||
+++ openldap-2.4.24/doc/man/man5/ldap.conf.5
|
||||
@@ -317,6 +317,7 @@ certificates in separate individual file
|
||||
.B TLS_CACERT
|
||||
is always used before
|
||||
.B TLS_CACERTDIR.
|
||||
+The specified directory must be managed with the OpenSSL c_rehash utility.
|
||||
This parameter is ignored with GNUtls.
|
||||
.TP
|
||||
.B TLS_CERT <filename>
|
||||
diff -uNPrp openldap-2.4.23.old/doc/man/man5/ldif.5 openldap-2.4.23.new/doc/man/man5/ldif.5
|
||||
--- openldap-2.4.23.old/doc/man/man5/ldif.5 2010-04-13 22:22:41.000000000 +0200
|
||||
+++ openldap-2.4.23.new/doc/man/man5/ldif.5 2010-08-19 17:42:10.256805450 +0200
|
||||
This parameter is ignored with GnuTLS.
|
||||
|
||||
When using Mozilla NSS, <path> may contain a Mozilla NSS cert/key
|
||||
--- openldap-2.4.24.orig/doc/man/man5/ldif.5
|
||||
+++ openldap-2.4.24/doc/man/man5/ldif.5
|
||||
@@ -270,8 +270,7 @@ commands.
|
||||
.BR ldapmodify (1),
|
||||
.BR slapadd (8),
|
||||
@ -40,10 +37,9 @@ diff -uNPrp openldap-2.4.23.old/doc/man/man5/ldif.5 openldap-2.4.23.new/doc/man/
|
||||
.LP
|
||||
"LDAP Data Interchange Format," Good, G., RFC 2849.
|
||||
.SH ACKNOWLEDGEMENTS
|
||||
diff -uNPrp openldap-2.4.23.old/doc/man/man5/slapd-config.5 openldap-2.4.23.new/doc/man/man5/slapd-config.5
|
||||
--- openldap-2.4.23.old/doc/man/man5/slapd-config.5 2010-06-10 19:17:53.000000000 +0200
|
||||
+++ openldap-2.4.23.new/doc/man/man5/slapd-config.5 2010-08-19 17:42:10.258805346 +0200
|
||||
@@ -1995,7 +1995,6 @@ default slapd configuration directory
|
||||
--- openldap-2.4.24.orig/doc/man/man5/slapd-config.5
|
||||
+++ openldap-2.4.24/doc/man/man5/slapd-config.5
|
||||
@@ -2068,7 +2068,6 @@ default slapd configuration directory
|
||||
.BR slapd.conf (5),
|
||||
.BR slapd.overlays (5),
|
||||
.BR slapd.plugin (5),
|
||||
@ -51,10 +47,9 @@ diff -uNPrp openldap-2.4.23.old/doc/man/man5/slapd-config.5 openldap-2.4.23.new/
|
||||
.BR slapd (8),
|
||||
.BR slapacl (8),
|
||||
.BR slapadd (8),
|
||||
diff -uNPrp openldap-2.4.23.old/doc/man/man5/slapd.conf.5 openldap-2.4.23.new/doc/man/man5/slapd.conf.5
|
||||
--- openldap-2.4.23.old/doc/man/man5/slapd.conf.5 2010-04-16 20:05:07.000000000 +0200
|
||||
+++ openldap-2.4.23.new/doc/man/man5/slapd.conf.5 2010-08-19 17:42:10.261805644 +0200
|
||||
@@ -1927,7 +1927,6 @@ default slapd configuration file
|
||||
--- openldap-2.4.24.orig/doc/man/man5/slapd.conf.5
|
||||
+++ openldap-2.4.24/doc/man/man5/slapd.conf.5
|
||||
@@ -1998,7 +1998,6 @@ default slapd configuration file
|
||||
.BR slapd.backends (5),
|
||||
.BR slapd.overlays (5),
|
||||
.BR slapd.plugin (5),
|
||||
@ -62,9 +57,8 @@ diff -uNPrp openldap-2.4.23.old/doc/man/man5/slapd.conf.5 openldap-2.4.23.new/do
|
||||
.BR slapd (8),
|
||||
.BR slapacl (8),
|
||||
.BR slapadd (8),
|
||||
diff -uNPrp openldap-2.4.23.old/doc/man/man8/slapd.8 openldap-2.4.23.new/doc/man/man8/slapd.8
|
||||
--- openldap-2.4.23.old/doc/man/man8/slapd.8 2010-04-13 22:22:46.000000000 +0200
|
||||
+++ openldap-2.4.23.new/doc/man/man8/slapd.8 2010-08-19 17:44:19.996680613 +0200
|
||||
--- openldap-2.4.24.orig/doc/man/man8/slapd.8
|
||||
+++ openldap-2.4.24/doc/man/man8/slapd.8
|
||||
@@ -5,7 +5,7 @@
|
||||
.SH NAME
|
||||
slapd \- Stand-alone LDAP Daemon
|
||||
|
@ -7,9 +7,8 @@ the functions, even if we're not being compiled for use in libldap_r
|
||||
Resolves: #179730
|
||||
Author: Jeffery Layton <jlayton@redhat.com>
|
||||
|
||||
diff -uNPrp openldap-2.4.23.old/libraries/libldap/util-int.c openldap-2.4.23.new/libraries/libldap/util-int.c
|
||||
--- openldap-2.4.23.old/libraries/libldap/util-int.c 2010-04-19 18:53:01.000000000 +0200
|
||||
+++ openldap-2.4.23.new/libraries/libldap/util-int.c 2010-08-19 17:47:52.456805354 +0200
|
||||
--- openldap-2.4.24.orig/libraries/libldap/util-int.c
|
||||
+++ openldap-2.4.24/libraries/libldap/util-int.c
|
||||
@@ -52,8 +52,8 @@ extern int h_errno;
|
||||
#ifndef LDAP_R_COMPILE
|
||||
# undef HAVE_REENTRANT_FUNCTIONS
|
||||
@ -21,7 +20,7 @@ diff -uNPrp openldap-2.4.23.old/libraries/libldap/util-int.c openldap-2.4.23.new
|
||||
|
||||
#else
|
||||
# include <ldap_pvt_thread.h>
|
||||
@@ -330,7 +330,7 @@ ldap_pvt_csnstr(char *buf, size_t len, u
|
||||
@@ -312,7 +312,7 @@ ldap_pvt_csnstr(char *buf, size_t len, u
|
||||
#define BUFSTART (1024-32)
|
||||
#define BUFMAX (32*1024-32)
|
||||
|
||||
|
@ -3,9 +3,8 @@ address space layout randomization (ASLD).
|
||||
|
||||
Author: Thomas Woerner <twoerner@redhat.com>
|
||||
|
||||
diff -uNPrp openldap-2.4.23.old/servers/slapd/Makefile.in openldap-2.4.23.new/servers/slapd/Makefile.in
|
||||
--- openldap-2.4.23.old/servers/slapd/Makefile.in 2010-04-13 22:23:09.000000000 +0200
|
||||
+++ openldap-2.4.23.new/servers/slapd/Makefile.in 2010-08-24 15:09:08.999680712 +0200
|
||||
--- openldap-2.4.24.orig/servers/slapd/Makefile.in
|
||||
+++ openldap-2.4.24/servers/slapd/Makefile.in
|
||||
@@ -266,7 +266,7 @@ libslapi.a: slapi/.libs/libslapi.a
|
||||
cp slapi/.libs/libslapi.a .
|
||||
|
||||
|
@ -1,8 +1,7 @@
|
||||
Updates initial slapd configuration.
|
||||
|
||||
diff -uNPrp openldap-2.4.23.old/servers/slapd/slapd.conf openldap-2.4.23.new/servers/slapd/slapd.conf
|
||||
--- openldap-2.4.23.old/servers/slapd/slapd.conf 2007-02-13 21:22:22.000000000 +0100
|
||||
+++ openldap-2.4.23.new/servers/slapd/slapd.conf 2010-11-22 17:39:02.334511902 +0100
|
||||
--- openldap-2.4.24.orig/servers/slapd/slapd.conf
|
||||
+++ openldap-2.4.24/servers/slapd/slapd.conf
|
||||
@@ -2,22 +2,71 @@
|
||||
# See slapd.conf(5) for details on configuration options.
|
||||
# This file should NOT be world readable.
|
||||
|
@ -3,9 +3,8 @@ Compile smbk5pwd together with other overlays.
|
||||
Resolves: 550895
|
||||
Author: Jan Šafránek <jsafrane@redhat.com>
|
||||
|
||||
diff -urNPp openldap-2.4.23.old/contrib/slapd-modules/smbk5pwd/README openldap-2.4.23.new/contrib/slapd-modules/smbk5pwd/README
|
||||
--- openldap-2.4.23.old/contrib/slapd-modules/smbk5pwd/README 2010-04-13 22:22:30.000000000 +0200
|
||||
+++ openldap-2.4.23.new/contrib/slapd-modules/smbk5pwd/README 2010-08-23 13:20:33.338687818 +0200
|
||||
--- openldap-2.4.24.orig/contrib/slapd-modules/smbk5pwd/README
|
||||
+++ openldap-2.4.24/contrib/slapd-modules/smbk5pwd/README
|
||||
@@ -1,3 +1,8 @@
|
||||
+*******************************************************
|
||||
+Red Hat note: Kerberos support is NOT compiled into
|
||||
@ -15,9 +14,8 @@ diff -urNPp openldap-2.4.23.old/contrib/slapd-modules/smbk5pwd/README openldap-2
|
||||
This directory contains a slapd overlay, smbk5pwd, that extends the
|
||||
PasswordModify Extended Operation to update Kerberos keys and Samba
|
||||
password hashes for an LDAP user.
|
||||
diff -urNPp openldap-2.4.23.old/servers/slapd/overlays/Makefile.in openldap-2.4.23.new/servers/slapd/overlays/Makefile.in
|
||||
--- openldap-2.4.23.old/servers/slapd/overlays/Makefile.in 2010-04-13 22:23:44.000000000 +0200
|
||||
+++ openldap-2.4.23.new/servers/slapd/overlays/Makefile.in 2010-08-23 13:20:33.338687818 +0200
|
||||
--- openldap-2.4.24.orig/servers/slapd/overlays/Makefile.in
|
||||
+++ openldap-2.4.24/servers/slapd/overlays/Makefile.in
|
||||
@@ -33,7 +33,8 @@ SRCS = overlays.c \
|
||||
syncprov.c \
|
||||
translucent.c \
|
||||
|
@ -1,9 +1,8 @@
|
||||
Removes unnecessary linking of SQL libraries into slapd. This makes openldap-servers package
|
||||
independent on libodbc. (SQL backend is packaged separately in openldap-servers-sql.)
|
||||
|
||||
diff -uNPrp openldap-2.4.23.old/build/top.mk openldap-2.4.23.new/build/top.mk
|
||||
--- openldap-2.4.23.old/build/top.mk 2010-04-13 22:22:22.000000000 +0200
|
||||
+++ openldap-2.4.23.new/build/top.mk 2010-08-25 15:58:18.477648731 +0200
|
||||
--- openldap-2.4.24.orig/build/top.mk
|
||||
+++ openldap-2.4.24/build/top.mk
|
||||
@@ -201,7 +201,7 @@ SLAPD_SQL_LDFLAGS = @SLAPD_SQL_LDFLAGS@
|
||||
SLAPD_SQL_INCLUDES = @SLAPD_SQL_INCLUDES@
|
||||
SLAPD_SQL_LIBS = @SLAPD_SQL_LIBS@
|
||||
|
@ -3,10 +3,9 @@ This patch adds the same behavior for GID.
|
||||
|
||||
Author: Nalin Dahyabhai <nalin@redhat.com>
|
||||
|
||||
diff -uNPrp openldap-2.4.23.old/libraries/libldap/init.c openldap-2.4.23.new/libraries/libldap/init.c
|
||||
--- openldap-2.4.23.old/libraries/libldap/init.c 2010-04-13 22:22:57.000000000 +0200
|
||||
+++ openldap-2.4.23.new/libraries/libldap/init.c 2010-08-24 17:25:07.207682002 +0200
|
||||
@@ -663,7 +663,7 @@ void ldap_int_initialize( struct ldapopt
|
||||
--- openldap-2.4.24.orig/libraries/libldap/init.c
|
||||
+++ openldap-2.4.24/libraries/libldap/init.c
|
||||
@@ -670,7 +670,7 @@ void ldap_int_initialize( struct ldapopt
|
||||
openldap_ldap_init_w_sysconf(LDAP_CONF_FILE);
|
||||
|
||||
#ifdef HAVE_GETEUID
|
||||
|
10
series
Normal file
10
series
Normal file
@ -0,0 +1,10 @@
|
||||
openldap-slapd-conf.patch
|
||||
openldap-manpages.patch
|
||||
openldap-security-pie.patch
|
||||
openldap-sql-linking.patch
|
||||
openldap-reentrant-gethostby.patch
|
||||
openldap-export-ldif.patch
|
||||
openldap-smbk5pwd-overlay.patch
|
||||
openldap-ldaprc-currentdir.patch
|
||||
openldap-userconfig-setgid.patch
|
||||
openldap-evolution-ntlm.patch
|
Loading…
Reference in New Issue
Block a user