Removed unused patches
This commit is contained in:
parent
52aa157adb
commit
b54cec1399
@ -1,18 +0,0 @@
|
||||
--- db-4.3.29/dist/configure.ac.BAD 2006-07-13 17:59:04.000000000 -0400
|
||||
+++ db-4.3.29/dist/configure.ac 2006-07-13 17:59:32.000000000 -0400
|
||||
@@ -291,11 +291,11 @@
|
||||
INSTALLER="\$(LIBTOOL) --mode=install cp -p"
|
||||
|
||||
MAKEFILE_CC="\$(LIBTOOL) --mode=compile ${MAKEFILE_CC}"
|
||||
-MAKEFILE_SOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CCLINK} -avoid-version"
|
||||
-MAKEFILE_CCLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CCLINK}"
|
||||
+MAKEFILE_SOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CCLINK} ${CFLAGS} -avoid-version"
|
||||
+MAKEFILE_CCLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CCLINK} ${CFLAGS}"
|
||||
MAKEFILE_CXX="\$(LIBTOOL) --mode=compile ${MAKEFILE_CXX}"
|
||||
-MAKEFILE_XSOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK} -avoid-version"
|
||||
-MAKEFILE_CXXLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK}"
|
||||
+MAKEFILE_XSOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK} ${CFLAGS} -avoid-version"
|
||||
+MAKEFILE_CXXLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK} ${CFLAGS}"
|
||||
|
||||
LIBTOOL="\$(SHELL) ./libtool"
|
||||
|
@ -1,26 +0,0 @@
|
||||
Build both slapd and slurpd as position-independent executables. This really
|
||||
should be threaded into the various autotools, but I guess this is what we have
|
||||
until that happens, if it happens.
|
||||
|
||||
--- openldap-2.2.13/servers/slapd/Makefile.in 2004-04-12 14:07:40.000000000 -0400
|
||||
+++ openldap-2.2.13/servers/slapd/Makefile.in 2004-06-15 13:45:45.000000000 -0400
|
||||
@@ -255,7 +255,7 @@
|
||||
cp slapi/.libs/libslapi.a .
|
||||
|
||||
slapd: $(SLAPD_DEPENDS) @LIBSLAPI@
|
||||
- $(LTLINK) -o $@ $(SLAPD_OBJECTS) $(LIBS) \
|
||||
+ $(LTLINK) -pie -Wl,-z,defs -o $@ $(SLAPD_OBJECTS) $(LIBS) \
|
||||
$(WRAP_LIBS)
|
||||
rm -f $(SLAPTOOLS)
|
||||
for i in $(SLAPTOOLS); do \
|
||||
--- openldap-2.2.13/servers/slurpd/Makefile.in 2004-01-01 13:16:42.000000000 -0500
|
||||
+++ openldap-2.2.13/servers/slurpd/Makefile.in 2004-06-15 13:44:45.000000000 -0400
|
||||
@@ -44,7 +44,7 @@
|
||||
XXXLIBS = $(LTHREAD_LIBS)
|
||||
|
||||
slurpd: version.o
|
||||
- $(LTLINK) -o $@ $(OBJS) version.o $(LIBS)
|
||||
+ $(LTLINK) -pie -Wl,-z,defs -o $@ $(OBJS) version.o $(LIBS)
|
||||
|
||||
sslurpd: version.o
|
||||
$(LTLINK) -static -o $@ $(OBJS) version.o $(LIBS)
|
@ -1,12 +0,0 @@
|
||||
--- openldap-2.2.13/libraries/libldap/#tls.c~ 2005-07-06 13:14:00.000000000 -0400
|
||||
+++ openldap-2.2.13/libraries/libldap/tls.c 2005-07-06 13:14:00.000000000 -0400
|
||||
@@ -1736,7 +1736,8 @@
|
||||
|
||||
/* XXYYZ: this initiates operation only on default connection! */
|
||||
|
||||
- if ( ld->ld_sb != NULL && ldap_pvt_tls_inplace( ld->ld_sb ) != 0 ) {
|
||||
+ if ( ( ld->ld_defconn != NULL ) ? ( ld->ld_defconn->lconn_sb != NULL && ldap_pvt_tls_inplace( ld->ld_defconn->lconn_sb ) != 0 )
|
||||
+ : ( ld->ld_sb != NULL && ldap_pvt_tls_inplace( ld->ld_sb ) != 0 ) ) {
|
||||
return LDAP_LOCAL_ERROR;
|
||||
}
|
||||
|
@ -1,37 +0,0 @@
|
||||
Check for __res_query in libresolv before we check for it in libbind.
|
||||
--- openldap-2.2.23/configure.in 2005-03-01 19:57:10.053436724 -0500
|
||||
+++ openldap-2.2.23/configure.in 2005-03-01 19:57:27.663137034 -0500
|
||||
@@ -873,16 +873,6 @@
|
||||
fi
|
||||
|
||||
if test $ac_cv_func_res_query = no ; then
|
||||
- AC_CHECK_LIB(bind, res_query)
|
||||
- ac_cv_func_res_query=$ac_cv_lib_bind_res_query
|
||||
-fi
|
||||
-
|
||||
-if test $ac_cv_func_res_query = no ; then
|
||||
- AC_CHECK_LIB(bind, __res_query)
|
||||
- ac_cv_func_res_query=$ac_cv_lib_bind___res_query
|
||||
-fi
|
||||
-
|
||||
-if test $ac_cv_func_res_query = no ; then
|
||||
AC_CHECK_LIB(resolv, res_query)
|
||||
ac_cv_func_res_query=$ac_cv_lib_resolv_res_query
|
||||
fi
|
||||
@@ -897,6 +887,16 @@
|
||||
ac_cv_func_res_query=$ac_cv_lib_resolv_res_9_query
|
||||
fi
|
||||
|
||||
+if test $ac_cv_func_res_query = no ; then
|
||||
+ AC_CHECK_LIB(bind, res_query)
|
||||
+ ac_cv_func_res_query=$ac_cv_lib_bind_res_query
|
||||
+fi
|
||||
+
|
||||
+if test $ac_cv_func_res_query = no ; then
|
||||
+ AC_CHECK_LIB(bind, __res_query)
|
||||
+ ac_cv_func_res_query=$ac_cv_lib_bind___res_query
|
||||
+fi
|
||||
+
|
||||
if test "$ac_cv_func_res_query" = yes ; then
|
||||
AC_DEFINE(HAVE_RES_QUERY,1,
|
||||
[define if you have res_query()])
|
@ -1,17 +0,0 @@
|
||||
diff -uNr openldap-2.2.29/libraries/libldap/cyrus.c openldap-2.2.29/libraries/libldap/cyrus.c
|
||||
--- openldap-2.2.29/libraries/libldap/cyrus.c 2005-10-04 15:34:31.000000000 -0400
|
||||
+++ openldap-2.2.29/libraries/libldap/cyrus.c 2005-11-09 19:00:15.000000000 -0500
|
||||
@@ -755,10 +755,11 @@
|
||||
"ldap_int_sasl_bind: rc=%d sasl=%d len=%ld\n",
|
||||
rc, saslrc, scred->bv_len );
|
||||
#endif
|
||||
+ rc = ld->ld_errno = LDAP_LOCAL_ERROR;
|
||||
+ ber_bvfree( scred );
|
||||
+ goto done;
|
||||
}
|
||||
ber_bvfree( scred );
|
||||
- rc = ld->ld_errno = LDAP_LOCAL_ERROR;
|
||||
- goto done;
|
||||
}
|
||||
break;
|
||||
}
|
@ -1,14 +0,0 @@
|
||||
Don't link directly with perl or sql libraries -- they're pulled in by
|
||||
demand-loaded backends.
|
||||
|
||||
--- openldap-2.3.11/build/top.mk.nosql 2005-08-29 14:46:17.000000000 -0400
|
||||
+++ openldap-2.3.11/build/top.mk 2005-10-28 21:15:15.000000000 -0400
|
||||
@@ -197,7 +197,7 @@
|
||||
SLAPD_SQL_INCLUDES = @SLAPD_SQL_INCLUDES@
|
||||
SLAPD_SQL_LIBS = @SLAPD_SQL_LIBS@
|
||||
|
||||
-SLAPD_LIBS = @SLAPD_LIBS@ @SLAPD_PERL_LDFLAGS@ @SLAPD_SQL_LDFLAGS@ @SLAPD_SQL_LIBS@ @SLAPD_SLP_LIBS@ @SLAPD_GMP_LIBS@
|
||||
+SLAPD_LIBS = @SLAPD_LIBS@ @SLAPD_SLP_LIBS@
|
||||
SLURPD_LIBS = @SLURPD_LIBS@
|
||||
|
||||
# Our Defaults
|
@ -1,99 +0,0 @@
|
||||
--- openldap-2.3.34/servers/slapd/slapd.conf.orig 2007-06-29 09:01:50.000000000 +0200
|
||||
+++ openldap-2.3.34/servers/slapd/slapd.conf 2007-06-29 09:03:50.000000000 +0200
|
||||
@@ -3,23 +3,48 @@
|
||||
# This file should NOT be world readable.
|
||||
#
|
||||
include %SYSCONFDIR%/schema/core.schema
|
||||
+include %SYSCONFDIR%/schema/cosine.schema
|
||||
+include %SYSCONFDIR%/schema/inetorgperson.schema
|
||||
+include %SYSCONFDIR%/schema/nis.schema
|
||||
+include %SYSCONFDIR%/schema/misc.schema
|
||||
|
||||
-# Define global ACLs to disable default read access.
|
||||
+# Allow LDAPv2 client connections. This is NOT the default.
|
||||
+allow bind_v2
|
||||
|
||||
# Do not enable referrals until AFTER you have a working directory
|
||||
# service AND an understanding of referrals.
|
||||
#referral ldap://root.openldap.org
|
||||
|
||||
-pidfile %LOCALSTATEDIR%/run/slapd.pid
|
||||
-argsfile %LOCALSTATEDIR%/run/slapd.args
|
||||
+pidfile %LOCALSTATEDIR%/run/openldap/slapd.pid
|
||||
+argsfile %LOCALSTATEDIR%/run/openldap/slapd.args
|
||||
|
||||
# Load dynamic backend modules:
|
||||
-# modulepath %MODULEDIR%
|
||||
+# modulepath /usr/lib/openldap # or /usr/lib64/openldap
|
||||
-# moduleload back_bdb.la
|
||||
-# moduleload back_ldap.la
|
||||
-# moduleload back_ldbm.la
|
||||
-# moduleload back_passwd.la
|
||||
-# moduleload back_shell.la
|
||||
+# moduleload accesslog.la
|
||||
+# moduleload auditlog.la
|
||||
+# moduleload back_sql.la
|
||||
+# moduleload denyop.la
|
||||
+# moduleload dyngroup.la
|
||||
+# moduleload dynlist.la
|
||||
+# moduleload lastmod.la
|
||||
+# moduleload pcache.la
|
||||
+# moduleload ppolicy.la
|
||||
+# moduleload refint.la
|
||||
+# moduleload retcode.la
|
||||
+# moduleload rwm.la
|
||||
+# moduleload syncprov.la
|
||||
+# moduleload translucent.la
|
||||
+# moduleload unique.la
|
||||
+# moduleload valsort.la
|
||||
+
|
||||
+# The next three lines allow use of TLS for encrypting connections using a
|
||||
+# dummy test certificate which you can generate by changing to
|
||||
+# /etc/pki/tls/certs, running "make slapd.pem", and fixing permissions on
|
||||
+# slapd.pem so that the ldap user or group can read it. Your client software
|
||||
+# may balk at self-signed certificates, however.
|
||||
+# TLSCACertificateFile /etc/pki/tls/certs/ca-bundle.crt
|
||||
+# TLSCertificateFile /etc/pki/tls/certs/slapd.pem
|
||||
+# TLSCertificateKeyFile /etc/pki/tls/certs/slapd.pem
|
||||
|
||||
# Sample security restrictions
|
||||
# Require integrity protection (prevent hijacking)
|
||||
@@ -49,19 +74,32 @@
|
||||
# rootdn can always read and write EVERYTHING!
|
||||
|
||||
#######################################################################
|
||||
-# BDB database definitions
|
||||
+# ldbm and/or bdb database definitions
|
||||
#######################################################################
|
||||
|
||||
database bdb
|
||||
suffix "dc=my-domain,dc=com"
|
||||
rootdn "cn=Manager,dc=my-domain,dc=com"
|
||||
# Cleartext passwords, especially for the rootdn, should
|
||||
-# be avoid. See slappasswd(8) and slapd.conf(5) for details.
|
||||
+# be avoided. See slappasswd(8) and slapd.conf(5) for details.
|
||||
# Use of strong authentication encouraged.
|
||||
-rootpw secret
|
||||
+# rootpw secret
|
||||
+# rootpw {crypt}ijFYNcSNctBYg
|
||||
+
|
||||
# The database directory MUST exist prior to running slapd AND
|
||||
# should only be accessible by the slapd and slap tools.
|
||||
# Mode 700 recommended.
|
||||
-directory %LOCALSTATEDIR%/openldap-data
|
||||
-# Indices to maintain
|
||||
-index objectClass eq
|
||||
+directory /var/lib/ldap
|
||||
+
|
||||
+# Indices to maintain for this database
|
||||
+index objectClass eq,pres
|
||||
+index ou,cn,mail,surname,givenname eq,pres,sub
|
||||
+index uidNumber,gidNumber,loginShell eq,pres
|
||||
+index uid,memberUid eq,pres,sub
|
||||
+index nisMapName,nisMapEntry eq,pres,sub
|
||||
+
|
||||
+# Replicas of this database
|
||||
+#replogfile /var/lib/ldap/openldap-master-replog
|
||||
+#replica host=ldap-1.example.com:389 starttls=critical
|
||||
+# bindmethod=sasl saslmech=GSSAPI
|
||||
+# authcId=host/ldap-master.example.com@EXAMPLE.COM
|
Loading…
Reference in New Issue
Block a user