-changelog update

link libldap_r with pthread (bz#198226)
This commit is contained in:
Jan Šafránek 2007-04-24 09:12:34 +00:00
parent 6a03b2fdec
commit 3dbb0a0bce
3 changed files with 35 additions and 2 deletions

View File

@ -121,7 +121,17 @@ function configtest() {
fi
done
# Check the configuration file.
if ! action $"Checking configuration files for $prog: " /sbin/runuser -m -s "$slaptest" -- "$user" $slaptestflags; then
slaptestout=`/sbin/runuser -m -s "$slaptest" -- "$user" $slaptestflags 2>&1`
slaptestexit=$?
# print warning if slaptest passed but reports some problems
if test $slaptestexit == 0 -a -n "$slaptestout" ; then
echo -n $"Checking configuration files for $prog: " ; warning ; echo
echo "$slaptestout"
fi
# report error if configuration file is wrong
if test $slaptestexit != 0 ; then
echo -n $"Checking configuration files for $prog: " ; failure ; echo
echo "$slaptestout"
if /sbin/runuser -m -s "$slaptest" -- "$user" "-u" > /dev/null 2> /dev/null ; then
dirs=`LANG=C egrep '^directory[[:space:]]+[[:print:]]+$' /etc/openldap/slapd.conf | awk '{print $2}'`
for directory in $dirs ; do

View File

@ -0,0 +1,13 @@
Make libldap_r.so link with pthread.
--- openldap-2.3.34/libraries/libldap_r/Makefile.in.orig 2007-01-02 22:43:50.000000000 +0100
+++ openldap-2.3.34/libraries/libldap_r/Makefile.in 2007-04-24 10:27:53.000000000 +0200
@@ -56,7 +56,7 @@
XXLIBS = $(SECURITY_LIBS) $(LUTIL_LIBS)
XXXLIBS = $(LTHREAD_LIBS)
NT_LINK_LIBS = $(LDAP_LIBLBER_LA) $(AC_LIBS) $(SECURITY_LIBS)
-UNIX_LINK_LIBS = $(LDAP_LIBLBER_LA) $(AC_LIBS) $(SECURITY_LIBS)
+UNIX_LINK_LIBS = $(LDAP_LIBLBER_LA) $(AC_LIBS) $(SECURITY_LIBS) $(LTHREAD_LIBS)
.links : Makefile
@for i in $(XXSRCS); do \

View File

@ -13,7 +13,7 @@
Summary: The configuration files, libraries, and documentation for OpenLDAP
Name: openldap
Version: %{version_23}
Release: 0%{?dist}.1
Release: 1%{?dist}
License: OpenLDAP
Group: System Environment/Daemons
Source0: ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/openldap-%{version_23}.tgz
@ -41,6 +41,7 @@ Patch6: openldap-2.3.11-nosql.patch
#Patch7: openldap-2.3.19-nostrip.patch
Patch8: openldap-2.3.19-gethostbyXXXX_r.patch
Patch9: openldap-2.3.34-quiet-slaptest.patch
Patch10: openldap-2.3.34-pthread.patch
# Patches for 2.2.29 for the compat-openldap package.
Patch100: openldap-2.2.13-tls-fix-connection-test.patch
@ -176,6 +177,7 @@ pushd openldap-%{version_23}
#%patch7 -p1 -b .nostrip
%patch8 -p1 -b .gethostbyname_r
%patch9 -p1 -b .quiet-slaptest
%patch10 -p1 -b .pthread
cp %{_datadir}/libtool/config.{sub,guess} build/
popd
@ -714,6 +716,14 @@ fi
%attr(0644,root,root) %{evolution_connector_libdir}/*.a
%changelog
* Mon Apr 23 2007 Jan Safranek <jsafranek@redhat.com> 2.3.34-1%{?dist}
- slapadd during package update is now quiet (bz#224581)
- use _localstatedir instead of var/ during build (bz#220970)
- bind-libbind-devel removed from BuildRequires (bz#216851)
- slaptest is now quiet during service ldap start, if
there is no error/warning (bz#143697)
- libldap_r.so now links with pthread (bz#198226)
* Mon Feb 19 2007 Jay Fenlason <fenlason<redhat.com> 2.3.34-1%{?dist}
- New upstream release
- Upgrade the scripts for migrating the database so that they might