rediff all patches
This commit is contained in:
parent
b37b0e9be9
commit
2ba84591e1
@ -1,6 +1,7 @@
|
|||||||
--- openldap-2.0.11/libraries/libldap/init.c Tue Jul 3 16:17:14 2001
|
diff -up openldap-2.4.11/libraries/libldap/init.c.patch2 openldap-2.4.11/libraries/libldap/init.c
|
||||||
+++ openldap-2.0.11/libraries/libldap/init.c Tue Jul 3 16:17:22 2001
|
--- openldap-2.4.11/libraries/libldap/init.c.patch2 2008-02-12 00:26:41.000000000 +0100
|
||||||
@@ -278,9 +278,6 @@
|
+++ openldap-2.4.11/libraries/libldap/init.c 2008-09-01 09:57:09.000000000 +0200
|
||||||
|
@@ -327,9 +327,6 @@ static void openldap_ldap_init_w_usercon
|
||||||
if(path != NULL) {
|
if(path != NULL) {
|
||||||
LDAP_FREE(path);
|
LDAP_FREE(path);
|
||||||
}
|
}
|
||||||
|
@ -1,10 +1,11 @@
|
|||||||
Don't read the user's configuration file if we're running in a setuid
|
Don't read the user's configuration file if we're running in a setuid
|
||||||
or setgid application.
|
or setgid application.
|
||||||
--- openldap-2.2.13/libraries/libldap/init.c 2004-06-15 11:51:32.000000000 -0400
|
diff -up openldap-2.4.11/libraries/libldap/init.c.patch3 openldap-2.4.11/libraries/libldap/init.c
|
||||||
+++ openldap-2.2.13/libraries/libldap/init.c 2004-06-15 13:42:35.000000000 -0400
|
--- openldap-2.4.11/libraries/libldap/init.c.patch3 2008-09-01 09:57:09.000000000 +0200
|
||||||
@@ -551,10 +551,11 @@
|
+++ openldap-2.4.11/libraries/libldap/init.c 2008-09-01 09:57:09.000000000 +0200
|
||||||
|
@@ -609,10 +609,11 @@ void ldap_int_initialize( struct ldapopt
|
||||||
if( user != NULL ) {
|
if( user != NULL ) {
|
||||||
gopts->ldo_def_sasl_authcid = user;
|
gopts->ldo_def_sasl_authcid = LDAP_STRDUP( user );
|
||||||
}
|
}
|
||||||
- }
|
- }
|
||||||
+ }
|
+ }
|
||||||
@ -15,7 +16,7 @@ or setgid application.
|
|||||||
openldap_ldap_init_w_userconf(LDAP_USERRC_FILE);
|
openldap_ldap_init_w_userconf(LDAP_USERRC_FILE);
|
||||||
|
|
||||||
{
|
{
|
||||||
@@ -608,4 +609,5 @@
|
@@ -642,4 +643,5 @@ void ldap_int_initialize( struct ldapopt
|
||||||
}
|
}
|
||||||
|
|
||||||
openldap_ldap_init_w_env(gopts, NULL);
|
openldap_ldap_init_w_env(gopts, NULL);
|
||||||
|
@ -1,9 +1,10 @@
|
|||||||
If libexecdir and sbindir are the same, avoid making an absolute symlink.
|
If libexecdir and sbindir are the same, avoid making an absolute symlink.
|
||||||
|
|
||||||
|
|
||||||
--- openldap-2.3.11/servers/slapd/Makefile.in.toollinks 2005-10-28 21:09:04.000000000 -0400
|
diff -up openldap-2.4.11/servers/slapd/Makefile.in.patch5 openldap-2.4.11/servers/slapd/Makefile.in
|
||||||
+++ openldap-2.3.11/servers/slapd/Makefile.in 2005-10-28 21:11:18.000000000 -0400
|
--- openldap-2.4.11/servers/slapd/Makefile.in.patch5 2008-09-01 09:57:09.000000000 +0200
|
||||||
@@ -270,7 +270,12 @@
|
+++ openldap-2.4.11/servers/slapd/Makefile.in 2008-09-01 09:57:09.000000000 +0200
|
||||||
|
@@ -270,7 +270,12 @@ slapd: $(SLAPD_DEPENDS) @LIBSLAPI@
|
||||||
$(WRAP_LIBS)
|
$(WRAP_LIBS)
|
||||||
$(RM) $(SLAPTOOLS)
|
$(RM) $(SLAPTOOLS)
|
||||||
for i in $(SLAPTOOLS); do \
|
for i in $(SLAPTOOLS); do \
|
||||||
|
@ -4,9 +4,10 @@ actually happens if nss_ldap is used for hostname resolution and earlier
|
|||||||
modules can't resolve the local host name), so use the reentrant versions of
|
modules can't resolve the local host name), so use the reentrant versions of
|
||||||
the functions, even if we're not being compiled for use in libldap_r (patch
|
the functions, even if we're not being compiled for use in libldap_r (patch
|
||||||
from Jeffery Layton, #179730).
|
from Jeffery Layton, #179730).
|
||||||
--- openldap-2.3.19/libraries/libldap/util-int.c 2006-02-23 15:42:14.000000000 -0500
|
diff -up openldap-2.4.11/libraries/libldap/util-int.c.patch7 openldap-2.4.11/libraries/libldap/util-int.c
|
||||||
+++ openldap-2.3.19/libraries/libldap/util-int.c 2006-02-23 15:42:02.000000000 -0500
|
--- openldap-2.4.11/libraries/libldap/util-int.c.patch7 2008-02-12 00:26:41.000000000 +0100
|
||||||
@@ -52,8 +52,8 @@
|
+++ openldap-2.4.11/libraries/libldap/util-int.c 2008-09-01 09:57:09.000000000 +0200
|
||||||
|
@@ -52,8 +52,8 @@ extern int h_errno;
|
||||||
#ifndef LDAP_R_COMPILE
|
#ifndef LDAP_R_COMPILE
|
||||||
# undef HAVE_REENTRANT_FUNCTIONS
|
# undef HAVE_REENTRANT_FUNCTIONS
|
||||||
# undef HAVE_CTIME_R
|
# undef HAVE_CTIME_R
|
||||||
@ -17,7 +18,7 @@ from Jeffery Layton, #179730).
|
|||||||
|
|
||||||
#else
|
#else
|
||||||
# include <ldap_pvt_thread.h>
|
# include <ldap_pvt_thread.h>
|
||||||
@@ -110,7 +110,7 @@
|
@@ -110,7 +110,7 @@ char *ldap_pvt_ctime( const time_t *tp,
|
||||||
#define BUFSTART (1024-32)
|
#define BUFSTART (1024-32)
|
||||||
#define BUFMAX (32*1024-32)
|
#define BUFMAX (32*1024-32)
|
||||||
|
|
||||||
|
@ -1,7 +1,8 @@
|
|||||||
Compile smbk5pwd together with other overlays.
|
Compile smbk5pwd together with other overlays.
|
||||||
|
|
||||||
--- openldap-2.3.34/contrib/slapd-modules/smbk5pwd/README.smbk5pwd 2005-11-14 19:06:04.000000000 +0100
|
diff -up openldap-2.4.11/contrib/slapd-modules/smbk5pwd/README.patch8 openldap-2.4.11/contrib/slapd-modules/smbk5pwd/README
|
||||||
+++ openldap-2.3.34/contrib/slapd-modules/smbk5pwd/README 2007-07-09 09:44:43.000000000 +0200
|
--- openldap-2.4.11/contrib/slapd-modules/smbk5pwd/README.patch8 2005-11-12 16:18:09.000000000 +0100
|
||||||
|
+++ openldap-2.4.11/contrib/slapd-modules/smbk5pwd/README 2008-09-01 09:57:09.000000000 +0200
|
||||||
@@ -1,3 +1,8 @@
|
@@ -1,3 +1,8 @@
|
||||||
+***************************************************************
|
+***************************************************************
|
||||||
+Red Hat note: Kerberos support is NOT compiled into
|
+Red Hat note: Kerberos support is NOT compiled into
|
||||||
@ -11,9 +12,10 @@ Compile smbk5pwd together with other overlays.
|
|||||||
Copyright 2004-2005 Howard Chu, Symas Corp. All rights reserved.
|
Copyright 2004-2005 Howard Chu, Symas Corp. All rights reserved.
|
||||||
|
|
||||||
Redistribution and use in source and binary forms, with or without
|
Redistribution and use in source and binary forms, with or without
|
||||||
--- openldap-2.3.37/servers/slapd/overlays/Makefile.in.orig 2007-05-29 23:57:47.000000000 +0200
|
diff -up openldap-2.4.11/servers/slapd/overlays/Makefile.in.patch8 openldap-2.4.11/servers/slapd/overlays/Makefile.in
|
||||||
+++ openldap-2.3.37/servers/slapd/overlays/Makefile.in 2007-07-31 16:27:08.000000000 +0200
|
--- openldap-2.4.11/servers/slapd/overlays/Makefile.in.patch8 2008-02-12 00:26:48.000000000 +0100
|
||||||
@@ -28,7 +28,8 @@ SRCS = overlays.c \
|
+++ openldap-2.4.11/servers/slapd/overlays/Makefile.in 2008-09-01 09:57:09.000000000 +0200
|
||||||
|
@@ -30,7 +30,8 @@ SRCS = overlays.c \
|
||||||
syncprov.c \
|
syncprov.c \
|
||||||
translucent.c \
|
translucent.c \
|
||||||
unique.c \
|
unique.c \
|
||||||
@ -23,7 +25,7 @@ Compile smbk5pwd together with other overlays.
|
|||||||
OBJS = statover.o \
|
OBJS = statover.o \
|
||||||
@SLAPD_STATIC_OVERLAYS@ \
|
@SLAPD_STATIC_OVERLAYS@ \
|
||||||
overlays.o
|
overlays.o
|
||||||
@@ -41,14 +42,14 @@ LTONLY_MOD = $(LTONLY_mod)
|
@@ -43,14 +44,14 @@ LTONLY_MOD = $(LTONLY_mod)
|
||||||
LDAP_INCDIR= ../../../include
|
LDAP_INCDIR= ../../../include
|
||||||
LDAP_LIBDIR= ../../../libraries
|
LDAP_LIBDIR= ../../../libraries
|
||||||
|
|
||||||
@ -40,7 +42,7 @@ Compile smbk5pwd together with other overlays.
|
|||||||
|
|
||||||
XINCPATH = -I.. -I$(srcdir)/..
|
XINCPATH = -I.. -I$(srcdir)/..
|
||||||
XDEFS = $(MODULES_CPPFLAGS)
|
XDEFS = $(MODULES_CPPFLAGS)
|
||||||
@@ -105,6 +106,9 @@ unique.la : unique.lo
|
@@ -113,6 +114,9 @@ unique.la : unique.lo
|
||||||
valsort.la : valsort.lo
|
valsort.la : valsort.lo
|
||||||
$(LTLINK_MOD) -module -o $@ valsort.lo version.lo $(LINK_LIBS)
|
$(LTLINK_MOD) -module -o $@ valsort.lo version.lo $(LINK_LIBS)
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up openldap-2.4.6/servers/slapd/slapd.conf.old openldap-2.4.6/servers/slapd/slapd.conf
|
diff -up openldap-2.4.11/servers/slapd/slapd.conf.patch1 openldap-2.4.11/servers/slapd/slapd.conf
|
||||||
--- openldap-2.4.6/servers/slapd/slapd.conf.old 2007-11-20 16:02:19.000000000 +0100
|
--- openldap-2.4.11/servers/slapd/slapd.conf.patch1 2007-02-13 21:22:22.000000000 +0100
|
||||||
+++ openldap-2.4.6/servers/slapd/slapd.conf 2007-11-20 16:02:26.000000000 +0100
|
+++ openldap-2.4.11/servers/slapd/slapd.conf 2008-09-01 09:57:09.000000000 +0200
|
||||||
@@ -2,22 +2,57 @@
|
@@ -2,22 +2,57 @@
|
||||||
# See slapd.conf(5) for details on configuration options.
|
# See slapd.conf(5) for details on configuration options.
|
||||||
# This file should NOT be world readable.
|
# This file should NOT be world readable.
|
||||||
@ -67,7 +67,7 @@ diff -up openldap-2.4.6/servers/slapd/slapd.conf.old openldap-2.4.6/servers/slap
|
|||||||
|
|
||||||
# Sample security restrictions
|
# Sample security restrictions
|
||||||
# Require integrity protection (prevent hijacking)
|
# Require integrity protection (prevent hijacking)
|
||||||
@@ -47,19 +83,41 @@ argsfile %LOCALSTATEDIR%/run/slapd.args
|
@@ -47,19 +82,41 @@ argsfile %LOCALSTATEDIR%/run/slapd.args
|
||||||
# rootdn can always read and write EVERYTHING!
|
# rootdn can always read and write EVERYTHING!
|
||||||
|
|
||||||
#######################################################################
|
#######################################################################
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up openldap-2.3.38/doc/man/man8/slapd.8.orig openldap-2.3.38/doc/man/man8/slapd.8
|
diff -up openldap-2.4.11/doc/man/man8/slapd.8.patch9 openldap-2.4.11/doc/man/man8/slapd.8
|
||||||
--- openldap-2.3.38/doc/man/man8/slapd.8.orig 2007-01-02 22:43:46.000000000 +0100
|
--- openldap-2.4.11/doc/man/man8/slapd.8.patch9 2008-02-12 00:26:40.000000000 +0100
|
||||||
+++ openldap-2.3.38/doc/man/man8/slapd.8 2007-10-23 15:03:13.000000000 +0200
|
+++ openldap-2.4.11/doc/man/man8/slapd.8 2008-09-01 09:57:09.000000000 +0200
|
||||||
@@ -5,7 +5,7 @@
|
@@ -5,7 +5,7 @@
|
||||||
.SH NAME
|
.SH NAME
|
||||||
slapd \- Stand-alone LDAP Daemon
|
slapd \- Stand-alone LDAP Daemon
|
||||||
@ -10,7 +10,7 @@ diff -up openldap-2.3.38/doc/man/man8/slapd.8.orig openldap-2.3.38/doc/man/man8/
|
|||||||
.B [\-[4|6]]
|
.B [\-[4|6]]
|
||||||
.B [\-T {acl|add|auth|cat|dn|index|passwd|test}]
|
.B [\-T {acl|add|auth|cat|dn|index|passwd|test}]
|
||||||
.B [\-d debug\-level]
|
.B [\-d debug\-level]
|
||||||
@@ -234,7 +234,7 @@ the LDAP databases defined in the defaul
|
@@ -263,7 +263,7 @@ the LDAP databases defined in the defaul
|
||||||
.LP
|
.LP
|
||||||
.nf
|
.nf
|
||||||
.ft tt
|
.ft tt
|
||||||
@ -19,7 +19,7 @@ diff -up openldap-2.3.38/doc/man/man8/slapd.8.orig openldap-2.3.38/doc/man/man8/
|
|||||||
.ft
|
.ft
|
||||||
.fi
|
.fi
|
||||||
.LP
|
.LP
|
||||||
@@ -245,7 +245,7 @@ on voluminous debugging which will be pr
|
@@ -274,7 +274,7 @@ on voluminous debugging which will be pr
|
||||||
.LP
|
.LP
|
||||||
.nf
|
.nf
|
||||||
.ft tt
|
.ft tt
|
||||||
@ -28,7 +28,7 @@ diff -up openldap-2.3.38/doc/man/man8/slapd.8.orig openldap-2.3.38/doc/man/man8/
|
|||||||
.ft
|
.ft
|
||||||
.fi
|
.fi
|
||||||
.LP
|
.LP
|
||||||
@@ -253,7 +253,7 @@ To test whether the configuration file i
|
@@ -282,7 +282,7 @@ To test whether the configuration file i
|
||||||
.LP
|
.LP
|
||||||
.nf
|
.nf
|
||||||
.ft tt
|
.ft tt
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up openldap-2.4.6/build/top.mk.nosql openldap-2.4.6/build/top.mk
|
diff -up openldap-2.4.11/build/top.mk.patch6 openldap-2.4.11/build/top.mk
|
||||||
--- openldap-2.4.6/build/top.mk.nosql 2007-09-01 01:13:50.000000000 +0200
|
--- openldap-2.4.11/build/top.mk.patch6 2008-02-12 00:26:38.000000000 +0100
|
||||||
+++ openldap-2.4.6/build/top.mk 2007-11-02 14:55:23.000000000 +0100
|
+++ openldap-2.4.11/build/top.mk 2008-09-01 09:57:09.000000000 +0200
|
||||||
@@ -199,7 +199,7 @@ SLAPD_SQL_LDFLAGS = @SLAPD_SQL_LDFLAGS@
|
@@ -199,7 +199,7 @@ SLAPD_SQL_LDFLAGS = @SLAPD_SQL_LDFLAGS@
|
||||||
SLAPD_SQL_INCLUDES = @SLAPD_SQL_INCLUDES@
|
SLAPD_SQL_INCLUDES = @SLAPD_SQL_INCLUDES@
|
||||||
SLAPD_SQL_LIBS = @SLAPD_SQL_LIBS@
|
SLAPD_SQL_LIBS = @SLAPD_SQL_LIBS@
|
||||||
|
@ -2,9 +2,9 @@ Build both slapd as position-independent executables. This really
|
|||||||
should be threaded into the various autotools, but I guess this is what we have
|
should be threaded into the various autotools, but I guess this is what we have
|
||||||
until that happens, if it happens.
|
until that happens, if it happens.
|
||||||
|
|
||||||
diff -up openldap-2.4.11/servers/slapd/Makefile.in.backup_patch_3 openldap-2.4.11/servers/slapd/Makefile.in
|
diff -up openldap-2.4.11/servers/slapd/Makefile.in.patch4 openldap-2.4.11/servers/slapd/Makefile.in
|
||||||
--- openldap-2.4.11/servers/slapd/Makefile.in.backup_patch_3 2008-02-12 00:26:43.000000000 +0100
|
--- openldap-2.4.11/servers/slapd/Makefile.in.patch4 2008-02-12 00:26:43.000000000 +0100
|
||||||
+++ openldap-2.4.11/servers/slapd/Makefile.in 2008-07-25 13:13:37.000000000 +0200
|
+++ openldap-2.4.11/servers/slapd/Makefile.in 2008-09-01 09:57:09.000000000 +0200
|
||||||
@@ -266,7 +266,7 @@ libslapi.a: slapi/.libs/libslapi.a
|
@@ -266,7 +266,7 @@ libslapi.a: slapi/.libs/libslapi.a
|
||||||
cp slapi/.libs/libslapi.a .
|
cp slapi/.libs/libslapi.a .
|
||||||
|
|
||||||
|
@ -605,6 +605,7 @@ fi
|
|||||||
%changelog
|
%changelog
|
||||||
* Mon Sep 1 2008 Jan Safranek <jsafranek@redhat.com> 2.4.11-2
|
* Mon Sep 1 2008 Jan Safranek <jsafranek@redhat.com> 2.4.11-2
|
||||||
- provide ldif2ldbm functionality for migrationtools
|
- provide ldif2ldbm functionality for migrationtools
|
||||||
|
- rediff all patches to get rid of patch fuzz
|
||||||
|
|
||||||
* Mon Jul 21 2008 Jan Safranek <jsafranek@redhat.com> 2.4.11-1
|
* Mon Jul 21 2008 Jan Safranek <jsafranek@redhat.com> 2.4.11-1
|
||||||
- new upstream release
|
- new upstream release
|
||||||
|
Loading…
Reference in New Issue
Block a user