- search for __res_query in libresolv before checking libbind
This commit is contained in:
parent
1a0d6b505a
commit
01084b3059
37
openldap-2.2.23-resolv.patch
Normal file
37
openldap-2.2.23-resolv.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
Check for __res_query in libresolv before we check for it in libbind.
|
||||||
|
--- openldap-2.2.23/configure.in 2005-03-01 19:57:10.053436724 -0500
|
||||||
|
+++ openldap-2.2.23/configure.in 2005-03-01 19:57:27.663137034 -0500
|
||||||
|
@@ -873,16 +873,6 @@
|
||||||
|
fi
|
||||||
|
|
||||||
|
if test $ac_cv_func_res_query = no ; then
|
||||||
|
- AC_CHECK_LIB(bind, res_query)
|
||||||
|
- ac_cv_func_res_query=$ac_cv_lib_bind_res_query
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
-if test $ac_cv_func_res_query = no ; then
|
||||||
|
- AC_CHECK_LIB(bind, __res_query)
|
||||||
|
- ac_cv_func_res_query=$ac_cv_lib_bind___res_query
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
-if test $ac_cv_func_res_query = no ; then
|
||||||
|
AC_CHECK_LIB(resolv, res_query)
|
||||||
|
ac_cv_func_res_query=$ac_cv_lib_resolv_res_query
|
||||||
|
fi
|
||||||
|
@@ -897,6 +887,16 @@
|
||||||
|
ac_cv_func_res_query=$ac_cv_lib_resolv_res_9_query
|
||||||
|
fi
|
||||||
|
|
||||||
|
+if test $ac_cv_func_res_query = no ; then
|
||||||
|
+ AC_CHECK_LIB(bind, res_query)
|
||||||
|
+ ac_cv_func_res_query=$ac_cv_lib_bind_res_query
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+if test $ac_cv_func_res_query = no ; then
|
||||||
|
+ AC_CHECK_LIB(bind, __res_query)
|
||||||
|
+ ac_cv_func_res_query=$ac_cv_lib_bind___res_query
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
if test "$ac_cv_func_res_query" = yes ; then
|
||||||
|
AC_DEFINE(HAVE_RES_QUERY,1,
|
||||||
|
[define if you have res_query()])
|
@ -55,6 +55,9 @@ Patch25: MigrationTools-44-schema.patch
|
|||||||
Patch26: MigrationTools-45-noaliases.patch
|
Patch26: MigrationTools-45-noaliases.patch
|
||||||
Patch40: openldap-ntlm.diff
|
Patch40: openldap-ntlm.diff
|
||||||
Patch41: openldap-2.2.23-start_tls-async.patch
|
Patch41: openldap-2.2.23-start_tls-async.patch
|
||||||
|
Patch50: openldap-2.0.27-resolv.patch
|
||||||
|
Patch51: openldap-2.1.30-resolv.patch
|
||||||
|
Patch52: openldap-2.2.23-resolv.patch
|
||||||
URL: http://www.openldap.org/
|
URL: http://www.openldap.org/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version_22}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version_22}-root
|
||||||
BuildPreReq: cyrus-sasl-devel >= 2.1, gdbm-devel, libtool >= 1.5.6-2, krb5-devel
|
BuildPreReq: cyrus-sasl-devel >= 2.1, gdbm-devel, libtool >= 1.5.6-2, krb5-devel
|
||||||
@ -156,6 +159,7 @@ pushd openldap-%{version_22}
|
|||||||
%patch6 -p1 -b .pie
|
%patch6 -p1 -b .pie
|
||||||
%patch7 -p1 -b .toollinks
|
%patch7 -p1 -b .toollinks
|
||||||
%patch8 -p1 -b .nosql
|
%patch8 -p1 -b .nosql
|
||||||
|
%patch52 -p1 -b .resolv
|
||||||
cp %{_datadir}/libtool/config.{sub,guess} build/
|
cp %{_datadir}/libtool/config.{sub,guess} build/
|
||||||
popd
|
popd
|
||||||
|
|
||||||
@ -192,30 +196,6 @@ pushd MigrationTools-%{migtools_version}
|
|||||||
%patch26 -p1 -b .noaliases
|
%patch26 -p1 -b .noaliases
|
||||||
popd
|
popd
|
||||||
|
|
||||||
pushd openldap-%{version_20}
|
|
||||||
%patch9 -p1 -b .ldapi
|
|
||||||
for subdir in build-gdbm build-db build-clients build-compat ; do
|
|
||||||
mkdir $subdir
|
|
||||||
ln -s ../configure $subdir
|
|
||||||
done
|
|
||||||
popd
|
|
||||||
|
|
||||||
pushd openldap-%{version_21}
|
|
||||||
%patch9 -p1 -b .ldapi
|
|
||||||
%patch10 -p1 -b .libdir
|
|
||||||
for subdir in build-servers build-compat ; do
|
|
||||||
mkdir $subdir
|
|
||||||
ln -s ../configure $subdir
|
|
||||||
done
|
|
||||||
popd
|
|
||||||
|
|
||||||
pushd openldap-%{version_22}
|
|
||||||
for subdir in build-servers build-clients ; do
|
|
||||||
mkdir $subdir
|
|
||||||
ln -s ../configure $subdir
|
|
||||||
done
|
|
||||||
popd
|
|
||||||
|
|
||||||
autodir=`pwd`/auto-instroot
|
autodir=`pwd`/auto-instroot
|
||||||
pushd autoconf-2.13.1
|
pushd autoconf-2.13.1
|
||||||
./configure --prefix=$autodir
|
./configure --prefix=$autodir
|
||||||
@ -226,6 +206,35 @@ pushd automake-1.4a
|
|||||||
make all install
|
make all install
|
||||||
popd
|
popd
|
||||||
|
|
||||||
|
pushd openldap-%{version_20}
|
||||||
|
%patch9 -p1 -b .ldapi
|
||||||
|
%patch50 -p1 -b .resolv
|
||||||
|
for subdir in build-gdbm build-db build-clients build-compat ; do
|
||||||
|
mkdir $subdir
|
||||||
|
ln -s ../configure $subdir
|
||||||
|
done
|
||||||
|
$autodir/bin/autoconf
|
||||||
|
popd
|
||||||
|
|
||||||
|
pushd openldap-%{version_21}
|
||||||
|
%patch9 -p1 -b .ldapi
|
||||||
|
%patch10 -p1 -b .libdir
|
||||||
|
%patch51 -p1 -b .resolv
|
||||||
|
for subdir in build-servers build-compat ; do
|
||||||
|
mkdir $subdir
|
||||||
|
ln -s ../configure $subdir
|
||||||
|
done
|
||||||
|
$autodir/bin/autoconf
|
||||||
|
popd
|
||||||
|
|
||||||
|
pushd openldap-%{version_22}
|
||||||
|
for subdir in build-servers build-clients ; do
|
||||||
|
mkdir $subdir
|
||||||
|
ln -s ../configure $subdir
|
||||||
|
done
|
||||||
|
$autodir/bin/autoconf
|
||||||
|
popd
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autodir=`pwd`/auto-instroot
|
autodir=`pwd`/auto-instroot
|
||||||
dbdir=`pwd`/db-instroot
|
dbdir=`pwd`/db-instroot
|
||||||
@ -308,6 +317,7 @@ fi
|
|||||||
CPPFLAGS="-I${dbdir}/include $OPENSSL_CPPFLAGS" ; export CPPFLAGS
|
CPPFLAGS="-I${dbdir}/include $OPENSSL_CPPFLAGS" ; export CPPFLAGS
|
||||||
CFLAGS="$CPPFLAGS $RPM_OPT_FLAGS -D_REENTRANT -fPIC"; export CFLAGS
|
CFLAGS="$CPPFLAGS $RPM_OPT_FLAGS -D_REENTRANT -fPIC"; export CFLAGS
|
||||||
LDFLAGS="-L${dbdir}/%{_lib} $OPENSSL_LDFLAGS" ; export LDFLAGS
|
LDFLAGS="-L${dbdir}/%{_lib} $OPENSSL_LDFLAGS" ; export LDFLAGS
|
||||||
|
LD_LIBRARY_PATH=${dbdir}/%{_lib}${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}; export LD_LIBRARY_PATH
|
||||||
|
|
||||||
# Build the client libraries for the compat package.
|
# Build the client libraries for the compat package.
|
||||||
pushd openldap-%{compat_version}/build-compat
|
pushd openldap-%{compat_version}/build-compat
|
||||||
|
Loading…
Reference in New Issue
Block a user