import openjpeg2-2.3.0-8.el8
This commit is contained in:
commit
76054ee415
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/openjpeg-2.3.0.tar.gz
|
1
.openjpeg2.metadata
Normal file
1
.openjpeg2.metadata
Normal file
@ -0,0 +1 @@
|
||||
430b9949b65a11fdf53323009ffedf0c6bb075ea SOURCES/openjpeg-2.3.0.tar.gz
|
44
SOURCES/openjpeg2_CVE-2018-18088.patch
Normal file
44
SOURCES/openjpeg2_CVE-2018-18088.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From 3290295708fddcef482eb453432dc34bf4b54b19 Mon Sep 17 00:00:00 2001
|
||||
From: szukw000 <szukw000@arcor.de>
|
||||
Date: Fri, 12 Oct 2018 13:41:36 +0200
|
||||
Subject: [PATCH] Change in pnmtoimage if image->comps[].data is NULL
|
||||
|
||||
---
|
||||
src/bin/jp2/convert.c | 14 +++++++++++++-
|
||||
1 file changed, 13 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/bin/jp2/convert.c b/src/bin/jp2/convert.c
|
||||
index 7040969..0b17602 100644
|
||||
--- a/src/bin/jp2/convert.c
|
||||
+++ b/src/bin/jp2/convert.c
|
||||
@@ -1998,7 +1998,7 @@ int imagetopnm(opj_image_t * image, const char *outfile, int force_split)
|
||||
int *red, *green, *blue, *alpha;
|
||||
int wr, hr, max;
|
||||
int i;
|
||||
- unsigned int compno, ncomp;
|
||||
+ unsigned int compno, ncomp, ui;
|
||||
int adjustR, adjustG, adjustB, adjustA;
|
||||
int fails, two, want_gray, has_alpha, triple;
|
||||
int prec, v;
|
||||
@@ -2006,6 +2006,18 @@ int imagetopnm(opj_image_t * image, const char *outfile, int force_split)
|
||||
const char *tmp = outfile;
|
||||
char *destname;
|
||||
|
||||
+ fails = 0;
|
||||
+ ncomp = image->numcomps;
|
||||
+ for(ui = 0; ui < ncomp; ++ui) {
|
||||
+ if(image->comps[ui].data == NULL) {
|
||||
+ fprintf(stderr, "imagetopnm data[%u] == NULL\n", ui);
|
||||
+ fails = 1;
|
||||
+ }
|
||||
+ }
|
||||
+ if(fails) {
|
||||
+ return 1;
|
||||
+ }
|
||||
+
|
||||
alpha = NULL;
|
||||
|
||||
if ((prec = (int)image->comps[0].prec) > 16) {
|
||||
--
|
||||
2.17.2
|
||||
|
278
SOURCES/openjpeg2_coverity.patch
Normal file
278
SOURCES/openjpeg2_coverity.patch
Normal file
@ -0,0 +1,278 @@
|
||||
diff --git a/src/bin/jp2/convert.c b/src/bin/jp2/convert.c
|
||||
index 0b17602..34603eb 100644
|
||||
--- a/src/bin/jp2/convert.c
|
||||
+++ b/src/bin/jp2/convert.c
|
||||
@@ -1416,6 +1416,9 @@ int imagetopgx(opj_image_t * image, const char *outfile)
|
||||
unsigned char* line_buffer = malloc((size_t)w);
|
||||
if (line_buffer == NULL) {
|
||||
fprintf(stderr, "Out of memory");
|
||||
+ if (total > 256) {
|
||||
+ free(name);
|
||||
+ }
|
||||
goto fin;
|
||||
}
|
||||
for (j = 0; j < h; j++) {
|
||||
diff --git a/src/bin/jp2/opj_compress.c b/src/bin/jp2/opj_compress.c
|
||||
index 26454d9..e21431b 100644
|
||||
--- a/src/bin/jp2/opj_compress.c
|
||||
+++ b/src/bin/jp2/opj_compress.c
|
||||
@@ -1739,6 +1739,8 @@ int main(int argc, char **argv)
|
||||
img_fol_t img_fol;
|
||||
dircnt_t *dirptr = NULL;
|
||||
|
||||
+ int ret;
|
||||
+
|
||||
OPJ_BOOL bSuccess;
|
||||
OPJ_BOOL bUseTiles = OPJ_FALSE; /* OPJ_TRUE */
|
||||
OPJ_UINT32 l_nb_tiles = 4;
|
||||
@@ -1764,7 +1766,8 @@ int main(int argc, char **argv)
|
||||
255; /* This will be set later according to the input image or the provided option */
|
||||
if (parse_cmdline_encoder(argc, argv, ¶meters, &img_fol, &raw_cp,
|
||||
indexfilename, sizeof(indexfilename)) == 1) {
|
||||
- goto fails;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
|
||||
/* Read directory if necessary */
|
||||
@@ -1776,18 +1779,21 @@ int main(int argc, char **argv)
|
||||
char)); /* Stores at max 10 image file names*/
|
||||
dirptr->filename = (char**) malloc(num_images * sizeof(char*));
|
||||
if (!dirptr->filename_buf) {
|
||||
- return 0;
|
||||
+ ret = 0;
|
||||
+ goto end;
|
||||
}
|
||||
for (i = 0; i < num_images; i++) {
|
||||
dirptr->filename[i] = dirptr->filename_buf + i * OPJ_PATH_LEN;
|
||||
}
|
||||
}
|
||||
if (load_images(dirptr, img_fol.imgdirpath) == 1) {
|
||||
- return 0;
|
||||
+ ret = 0;
|
||||
+ goto end;
|
||||
}
|
||||
if (num_images == 0) {
|
||||
fprintf(stdout, "Folder is empty\n");
|
||||
- return 0;
|
||||
+ ret = 0;
|
||||
+ goto end;
|
||||
}
|
||||
} else {
|
||||
num_images = 1;
|
||||
@@ -1833,7 +1839,8 @@ int main(int argc, char **argv)
|
||||
image = pgxtoimage(parameters.infile, ¶meters);
|
||||
if (!image) {
|
||||
fprintf(stderr, "Unable to load pgx file\n");
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
break;
|
||||
|
||||
@@ -1841,7 +1848,8 @@ int main(int argc, char **argv)
|
||||
image = pnmtoimage(parameters.infile, ¶meters);
|
||||
if (!image) {
|
||||
fprintf(stderr, "Unable to load pnm file\n");
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
break;
|
||||
|
||||
@@ -1849,7 +1857,8 @@ int main(int argc, char **argv)
|
||||
image = bmptoimage(parameters.infile, ¶meters);
|
||||
if (!image) {
|
||||
fprintf(stderr, "Unable to load bmp file\n");
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
break;
|
||||
|
||||
@@ -1858,7 +1867,8 @@ int main(int argc, char **argv)
|
||||
image = tiftoimage(parameters.infile, ¶meters);
|
||||
if (!image) {
|
||||
fprintf(stderr, "Unable to load tiff file\n");
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
break;
|
||||
#endif /* OPJ_HAVE_LIBTIFF */
|
||||
@@ -1867,7 +1877,8 @@ int main(int argc, char **argv)
|
||||
image = rawtoimage(parameters.infile, ¶meters, &raw_cp);
|
||||
if (!image) {
|
||||
fprintf(stderr, "Unable to load raw file\n");
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
break;
|
||||
|
||||
@@ -1875,7 +1886,8 @@ int main(int argc, char **argv)
|
||||
image = rawltoimage(parameters.infile, ¶meters, &raw_cp);
|
||||
if (!image) {
|
||||
fprintf(stderr, "Unable to load raw file\n");
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
break;
|
||||
|
||||
@@ -1883,7 +1895,8 @@ int main(int argc, char **argv)
|
||||
image = tgatoimage(parameters.infile, ¶meters);
|
||||
if (!image) {
|
||||
fprintf(stderr, "Unable to load tga file\n");
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
break;
|
||||
|
||||
@@ -1892,7 +1905,8 @@ int main(int argc, char **argv)
|
||||
image = pngtoimage(parameters.infile, ¶meters);
|
||||
if (!image) {
|
||||
fprintf(stderr, "Unable to load png file\n");
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
break;
|
||||
#endif /* OPJ_HAVE_LIBPNG */
|
||||
@@ -1903,7 +1917,8 @@ int main(int argc, char **argv)
|
||||
*/
|
||||
if (!image) {
|
||||
fprintf(stderr, "Unable to load file: got no image\n");
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
|
||||
/* Decide if MCT should be used */
|
||||
@@ -1914,12 +1929,14 @@ int main(int argc, char **argv)
|
||||
if ((parameters.tcp_mct == 1) && (image->numcomps < 3)) {
|
||||
fprintf(stderr, "RGB->YCC conversion cannot be used:\n");
|
||||
fprintf(stderr, "Input image has less than 3 components\n");
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
if ((parameters.tcp_mct == 2) && (!parameters.mct_data)) {
|
||||
fprintf(stderr, "Custom MCT has been set but no array-based MCT\n");
|
||||
fprintf(stderr, "has been provided. Aborting.\n");
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
}
|
||||
|
||||
@@ -1959,13 +1976,15 @@ int main(int argc, char **argv)
|
||||
fprintf(stderr, "failed to encode image: opj_setup_encoder\n");
|
||||
opj_destroy_codec(l_codec);
|
||||
opj_image_destroy(image);
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
|
||||
/* open a byte stream for writing and allocate memory for all tiles */
|
||||
l_stream = opj_stream_create_default_file_stream(parameters.outfile, OPJ_FALSE);
|
||||
if (! l_stream) {
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
|
||||
/* encode the image */
|
||||
@@ -1978,7 +1997,8 @@ int main(int argc, char **argv)
|
||||
OPJ_UINT32 l_data_size = 512 * 512 * 3;
|
||||
l_data = (OPJ_BYTE*) calloc(1, l_data_size);
|
||||
if (l_data == NULL) {
|
||||
- goto fails;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
for (i = 0; i < l_nb_tiles; ++i) {
|
||||
if (! opj_write_tile(l_codec, i, l_data, l_data_size, l_stream)) {
|
||||
@@ -1987,7 +2007,8 @@ int main(int argc, char **argv)
|
||||
opj_stream_destroy(l_stream);
|
||||
opj_destroy_codec(l_codec);
|
||||
opj_image_destroy(image);
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
}
|
||||
free(l_data);
|
||||
@@ -2008,7 +2029,8 @@ int main(int argc, char **argv)
|
||||
opj_image_destroy(image);
|
||||
fprintf(stderr, "failed to encode image\n");
|
||||
remove(parameters.outfile);
|
||||
- return 1;
|
||||
+ ret = 1;
|
||||
+ goto end;
|
||||
}
|
||||
|
||||
num_compressed_files++;
|
||||
@@ -2024,26 +2046,15 @@ int main(int argc, char **argv)
|
||||
|
||||
}
|
||||
|
||||
- /* free user parameters structure */
|
||||
- if (parameters.cp_comment) {
|
||||
- free(parameters.cp_comment);
|
||||
- }
|
||||
- if (parameters.cp_matrice) {
|
||||
- free(parameters.cp_matrice);
|
||||
- }
|
||||
- if (raw_cp.rawComps) {
|
||||
- free(raw_cp.rawComps);
|
||||
- }
|
||||
-
|
||||
t = opj_clock() - t;
|
||||
if (num_compressed_files) {
|
||||
fprintf(stdout, "encode time: %d ms \n",
|
||||
(int)((t * 1000.0) / (OPJ_FLOAT64)num_compressed_files));
|
||||
}
|
||||
|
||||
- return 0;
|
||||
+ ret = 0;
|
||||
|
||||
-fails:
|
||||
+end:
|
||||
if (parameters.cp_comment) {
|
||||
free(parameters.cp_comment);
|
||||
}
|
||||
@@ -2065,5 +2076,5 @@ fails:
|
||||
}
|
||||
free(dirptr);
|
||||
}
|
||||
- return 1;
|
||||
+ return ret;
|
||||
}
|
||||
diff --git a/src/lib/openjp2/dwt.c b/src/lib/openjp2/dwt.c
|
||||
index 5b98d2b..17021de 100644
|
||||
--- a/src/lib/openjp2/dwt.c
|
||||
+++ b/src/lib/openjp2/dwt.c
|
||||
@@ -2696,17 +2696,20 @@ OPJ_BOOL opj_dwt_decode_partial_97(opj_tcd_tilecomp_t* OPJ_RESTRICT tilec,
|
||||
/* overflow check */
|
||||
if (l_data_size > (SIZE_MAX - 5U)) {
|
||||
/* FIXME event manager error callback */
|
||||
+ opj_sparse_array_int32_free(sa);
|
||||
return OPJ_FALSE;
|
||||
}
|
||||
l_data_size += 5U;
|
||||
/* overflow check */
|
||||
if (l_data_size > (SIZE_MAX / sizeof(opj_v4_t))) {
|
||||
/* FIXME event manager error callback */
|
||||
+ opj_sparse_array_int32_free(sa);
|
||||
return OPJ_FALSE;
|
||||
}
|
||||
h.wavelet = (opj_v4_t*) opj_aligned_malloc(l_data_size * sizeof(opj_v4_t));
|
||||
if (!h.wavelet) {
|
||||
/* FIXME event manager error callback */
|
||||
+ opj_sparse_array_int32_free(sa);
|
||||
return OPJ_FALSE;
|
||||
}
|
||||
v.wavelet = h.wavelet;
|
11
SOURCES/openjpeg2_install.patch
Normal file
11
SOURCES/openjpeg2_install.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -rupN openjpeg-2.3.0/src/lib/openjp2/CMakeLists.txt openjpeg-2.3.0-new/src/lib/openjp2/CMakeLists.txt
|
||||
--- openjpeg-2.3.0/src/lib/openjp2/CMakeLists.txt 2017-10-05 00:23:14.000000000 +0200
|
||||
+++ openjpeg-2.3.0-new/src/lib/openjp2/CMakeLists.txt 2017-12-25 13:53:07.000000000 +0100
|
||||
@@ -99,6 +99,7 @@ else()
|
||||
set(INSTALL_LIBS ${OPENJPEG_LIBRARY_NAME} openjp2_static)
|
||||
else()
|
||||
add_library(${OPENJPEG_LIBRARY_NAME} ${OPENJPEG_SRCS})
|
||||
+ set(INSTALL_LIBS ${OPENJPEG_LIBRARY_NAME})
|
||||
endif()
|
||||
endif()
|
||||
|
12
SOURCES/openjpeg2_opj2.patch
Normal file
12
SOURCES/openjpeg2_opj2.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -rupN openjpeg-2.3.0/src/bin/jp2/CMakeLists.txt openjpeg-2.3.0-new/src/bin/jp2/CMakeLists.txt
|
||||
--- openjpeg-2.3.0/src/bin/jp2/CMakeLists.txt 2017-10-05 00:23:14.000000000 +0200
|
||||
+++ openjpeg-2.3.0-new/src/bin/jp2/CMakeLists.txt 2017-12-25 14:55:37.562470567 +0100
|
||||
@@ -44,6 +44,8 @@ endif()
|
||||
# Loop over all executables:
|
||||
foreach(exe opj_decompress opj_compress opj_dump)
|
||||
add_executable(${exe} ${exe}.c ${common_SRCS})
|
||||
+ STRING(REPLACE "opj_" "opj2_" exe2 ${exe})
|
||||
+ set_target_properties(${exe} PROPERTIES OUTPUT_NAME ${exe2})
|
||||
if(${CMAKE_VERSION} VERSION_GREATER "2.8.11")
|
||||
target_compile_options(${exe} PRIVATE ${OPENJP2_COMPILE_OPTIONS})
|
||||
endif()
|
11
SOURCES/openjpeg2_remove-thirdparty.patch
Normal file
11
SOURCES/openjpeg2_remove-thirdparty.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -rupN openjpeg-2.1.1/CMakeLists.txt openjpeg-2.1.1-new/CMakeLists.txt
|
||||
--- openjpeg-2.1.1/CMakeLists.txt 2016-07-05 16:54:17.000000000 +0200
|
||||
+++ openjpeg-2.1.1-new/CMakeLists.txt 2016-07-06 09:38:26.083029127 +0200
|
||||
@@ -270,7 +270,6 @@ if(BUILD_CODEC OR BUILD_MJ2)
|
||||
# OFF: It will only build 3rd party libs if they are not found on the system
|
||||
# ON: 3rd party libs will ALWAYS be build, and used
|
||||
option(BUILD_THIRDPARTY "Build the thirdparty executables if it is needed" OFF)
|
||||
- add_subdirectory(thirdparty)
|
||||
add_subdirectory(src/bin)
|
||||
endif ()
|
||||
add_subdirectory(wrapping)
|
446
SPECS/openjpeg2.spec
Normal file
446
SPECS/openjpeg2.spec
Normal file
@ -0,0 +1,446 @@
|
||||
# Conformance tests disabled by default since it requires 1 GB of test data
|
||||
#global runcheck 1
|
||||
|
||||
#global optional_components 1
|
||||
|
||||
Name: openjpeg2
|
||||
Version: 2.3.0
|
||||
Release: 8%{?dist}
|
||||
Summary: C-Library for JPEG 2000
|
||||
|
||||
# windirent.h is MIT, the rest is BSD
|
||||
License: BSD and MIT
|
||||
URL: https://github.com/uclouvain/openjpeg
|
||||
Source0: https://github.com/uclouvain/openjpeg/archive/v%{version}/openjpeg-%{version}.tar.gz
|
||||
%if 0%{?runcheck}
|
||||
# git clone git@github.com:uclouvain/openjpeg-data.git
|
||||
Source1: data.tar.xz
|
||||
%endif
|
||||
|
||||
# Remove bundled libraries
|
||||
Patch0: openjpeg2_remove-thirdparty.patch
|
||||
# Fix shared libraries not getting installed if static libraries are disabled
|
||||
Patch1: openjpeg2_install.patch
|
||||
# Rename tool names to avoid conflicts with openjpeg-1.x
|
||||
Patch2: openjpeg2_opj2.patch
|
||||
# CVE-2018-18088
|
||||
Patch3: openjpeg2_CVE-2018-18088.patch
|
||||
# Fix Coverity defects
|
||||
Patch4: openjpeg2_coverity.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc
|
||||
BuildRequires: make
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: lcms2-devel
|
||||
BuildRequires: doxygen
|
||||
|
||||
%if 0%{?optional_components}
|
||||
BuildRequires: java-devel
|
||||
BuildRequires: xerces-j2
|
||||
%endif
|
||||
|
||||
%description
|
||||
The OpenJPEG library is an open-source JPEG 2000 library developed in order to
|
||||
promote the use of JPEG 2000.
|
||||
|
||||
This package contains
|
||||
* JPEG 2000 codec compliant with the Part 1 of the standard (Class-1 Profile-1
|
||||
compliance).
|
||||
* JP2 (JPEG 2000 standard Part 2 - Handling of JP2 boxes and extended multiple
|
||||
component transforms for multispectral and hyperspectral imagery)
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Development files for OpenJPEG 2
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
# OpenJPEGTargets.cmake refers to the tools
|
||||
Requires: %{name}-tools%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains libraries and header files for developing
|
||||
applications that use OpenJPEG 2.
|
||||
|
||||
|
||||
%package devel-docs
|
||||
Summary: Developer documentation for OpenJPEG 2
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel-docs
|
||||
The %{name}-devel-docs package contains documentation files for developing
|
||||
applications that use OpenJPEG 2.
|
||||
|
||||
|
||||
%package tools
|
||||
Summary: OpenJPEG 2 command line tools
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description tools
|
||||
Command line tools for JPEG 2000 file manipulation, using OpenJPEG2:
|
||||
* opj2_compress
|
||||
* opj2_decompress
|
||||
* opj2_dump
|
||||
|
||||
%if 0%{?optional_components}
|
||||
##### MJ2 #####
|
||||
|
||||
%package mj2
|
||||
Summary: OpenJPEG2 MJ2 module
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description mj2
|
||||
The OpenJPEG library is an open-source JPEG 2000 library developed in order to
|
||||
promote the use of JPEG 2000.
|
||||
|
||||
This package contains the MJ2 module (JPEG 2000 standard Part 3)
|
||||
|
||||
|
||||
%package mj2-devel
|
||||
Summary: Development files for OpenJPEG2 MJ2 module
|
||||
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-mj2%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description mj2-devel
|
||||
Development files for OpenJPEG2 MJ2 module
|
||||
|
||||
|
||||
%package mj2-tools
|
||||
Summary: OpenJPEG2 MJ2 module command line tools
|
||||
Requires: %{name}-mj2%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description mj2-tools
|
||||
OpenJPEG2 MJ2 module command line tools
|
||||
|
||||
##### JPWL #####
|
||||
|
||||
%package jpwl
|
||||
Summary: OpenJPEG2 JPWL module
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description jpwl
|
||||
The OpenJPEG library is an open-source JPEG 2000 library developed in order to
|
||||
promote the use of JPEG 2000.
|
||||
|
||||
This package contains the JPWL (JPEG 2000 standard Part 11 - Jpeg 2000 Wireless)
|
||||
|
||||
|
||||
%package jpwl-devel
|
||||
Summary: Development files for OpenJPEG2 JPWL module
|
||||
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-jpwl%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description jpwl-devel
|
||||
Development files for OpenJPEG2 JPWL module
|
||||
|
||||
|
||||
%package jpwl-tools
|
||||
Summary: OpenJPEG2 JPWL module command line tools
|
||||
Requires: %{name}-jpwl%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description jpwl-tools
|
||||
OpenJPEG2 JPWL module command line tools
|
||||
|
||||
##### JPIP #####
|
||||
|
||||
%package jpip
|
||||
Summary: OpenJPEG2 JPIP module
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description jpip
|
||||
The OpenJPEG library is an open-source JPEG 2000 library developed in order to
|
||||
promote the use of JPEG 2000.
|
||||
|
||||
This package contains the JPWL (JPEG 2000 standard Part 9 - Jpeg 2000 Interactive Protocol)
|
||||
|
||||
|
||||
%package jpip-devel
|
||||
Summary: Development files for OpenJPEG2 JPIP module
|
||||
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-jpwl%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description jpip-devel
|
||||
Development files for OpenJPEG2 JPIP module
|
||||
|
||||
|
||||
%package jpip-tools
|
||||
Summary: OpenJPEG2 JPIP module command line tools
|
||||
Requires: %{name}-jpip%{?_isa} = %{version}-%{release}
|
||||
Requires: jpackage-utils
|
||||
Requires: java
|
||||
|
||||
%description jpip-tools
|
||||
OpenJPEG2 JPIP module command line tools
|
||||
|
||||
##### JP3D #####
|
||||
|
||||
%package jp3d
|
||||
Summary: OpenJPEG2 JP3D module
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description jp3d
|
||||
The OpenJPEG library is an open-source JPEG 2000 library developed in order to
|
||||
promote the use of JPEG 2000.
|
||||
|
||||
This package contains the JP3D (JPEG 2000 standard Part 10 - Jpeg 2000 3D)
|
||||
|
||||
|
||||
%package jp3d-devel
|
||||
Summary: Development files for OpenJPEG2 JP3D module
|
||||
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-jp3d%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description jp3d-devel
|
||||
Development files for OpenJPEG2 JP3D module
|
||||
|
||||
|
||||
%package jp3d-tools
|
||||
Summary: OpenJPEG2 JP3D module command line tools
|
||||
Requires: %{name}-jp3d%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description jp3d-tools
|
||||
OpenJPEG2 JP3D module command line tools
|
||||
%endif
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n openjpeg-%{version} %{?runcheck:-a 1}
|
||||
|
||||
# Remove all third party libraries just to be sure
|
||||
rm -rf thirdparty
|
||||
|
||||
|
||||
%build
|
||||
mkdir %{_target_platform}
|
||||
pushd %{_target_platform}
|
||||
# TODO: Consider
|
||||
# -DBUILD_JPIP_SERVER=ON -DBUILD_JAVA=ON
|
||||
%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo -DOPENJPEG_INSTALL_LIB_DIR=%{_lib} \
|
||||
%{?optional_components:-DBUILD_MJ2=ON -DBUILD_JPWL=ON -DBUILD_JPIP=ON -DBUILD_JP3D=ON} \
|
||||
-DBUILD_DOC=ON \
|
||||
-DBUILD_STATIC_LIBS=OFF \
|
||||
-DBUILD_SHARED_LIBS=ON \
|
||||
%{?runcheck:-DBUILD_TESTING:BOOL=ON -DOPJ_DATA_ROOT=$PWD/../data} \
|
||||
..
|
||||
popd
|
||||
|
||||
%make_build VERBOSE=1 -C %{_target_platform}
|
||||
|
||||
|
||||
%install
|
||||
%make_install -C %{_target_platform}
|
||||
|
||||
mv %{buildroot}%{_mandir}/man1/opj_compress.1 %{buildroot}%{_mandir}/man1/opj2_compress.1
|
||||
mv %{buildroot}%{_mandir}/man1/opj_decompress.1 %{buildroot}%{_mandir}/man1/opj2_decompress.1
|
||||
mv %{buildroot}%{_mandir}/man1/opj_dump.1 %{buildroot}%{_mandir}/man1/opj2_dump.1
|
||||
|
||||
# Docs are installed through %%doc
|
||||
rm -rf %{buildroot}%{_datadir}/doc/
|
||||
|
||||
%if 0%{?optional_components}
|
||||
# Move the jar to the correct place
|
||||
mkdir -p %{buildroot}%{_javadir}
|
||||
mv %{buildroot}%{_datadir}/opj_jpip_viewer.jar %{buildroot}%{_javadir}/opj2_jpip_viewer.jar
|
||||
cat > %{buildroot}%{_bindir}/opj2_jpip_viewer <<EOF
|
||||
java -jar %{_javadir}/opj2_jpip_viewer.jar "$@"
|
||||
EOF
|
||||
chmod +x %{buildroot}%{_bindir}/opj2_jpip_viewer
|
||||
%endif
|
||||
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
|
||||
%check
|
||||
%if 0%{?runcheck}
|
||||
make test -C %{_target_platform}
|
||||
%endif
|
||||
|
||||
|
||||
%files
|
||||
%{!?_licensedir:%global license %doc}
|
||||
%license LICENSE
|
||||
%doc AUTHORS.md NEWS.md README.md THANKS.md
|
||||
%{_libdir}/libopenjp2.so.*
|
||||
%{_mandir}/man3/libopenjp2.3*
|
||||
|
||||
%files devel
|
||||
%dir %{_includedir}/openjpeg-2.3/
|
||||
%{_includedir}/openjpeg-2.3/openjpeg.h
|
||||
%{_includedir}/openjpeg-2.3/opj_config.h
|
||||
%{_includedir}/openjpeg-2.3/opj_stdint.h
|
||||
%{_libdir}/libopenjp2.so
|
||||
%{_libdir}/openjpeg-2.3/
|
||||
%{_libdir}/pkgconfig/libopenjp2.pc
|
||||
|
||||
%files devel-docs
|
||||
%doc %{_target_platform}/doc/html
|
||||
|
||||
%files tools
|
||||
%{_bindir}/opj2_compress
|
||||
%{_bindir}/opj2_decompress
|
||||
%{_bindir}/opj2_dump
|
||||
%{_mandir}/man1/opj2_compress.1*
|
||||
%{_mandir}/man1/opj2_decompress.1*
|
||||
%{_mandir}/man1/opj2_dump.1*
|
||||
|
||||
%if 0%{?optional_components}
|
||||
%files mj2
|
||||
%{_libdir}/libopenmj2.so.*
|
||||
|
||||
%files mj2-devel
|
||||
%{_libdir}/libopenmj2.so
|
||||
|
||||
%files mj2-tools
|
||||
%{_bindir}/opj2_mj2*
|
||||
|
||||
%files jpwl
|
||||
%{_libdir}/libopenjpwl.so.*
|
||||
|
||||
%files jpwl-devel
|
||||
%{_libdir}/libopenjpwl.so
|
||||
%{_libdir}/pkgconfig/libopenjpwl.pc
|
||||
|
||||
%files jpwl-tools
|
||||
%{_bindir}/opj2_jpwl*
|
||||
|
||||
%files jpip
|
||||
%{_libdir}/libopenjpip.so.*
|
||||
|
||||
%files jpip-devel
|
||||
%{_libdir}/libopenjpip.so
|
||||
%{_libdir}/pkgconfig/libopenjpip.pc
|
||||
|
||||
%files jpip-tools
|
||||
%{_bindir}/opj2_jpip*
|
||||
%{_bindir}/opj2_dec_server
|
||||
%{_javadir}/opj2_jpip_viewer.jar
|
||||
|
||||
%files jp3d
|
||||
%{_libdir}/libopenjp3d.so.*
|
||||
|
||||
%files jp3d-devel
|
||||
%{_includedir}/openjpeg-2.0/openjp3d.h
|
||||
%{_libdir}/libopenjp3d.so
|
||||
%{_libdir}/pkgconfig/libopenjp3d.pc
|
||||
|
||||
%files jp3d-tools
|
||||
%{_bindir}/opj2_jp3d*
|
||||
%endif
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Oct 16 2018 Nikola Forró <nforro@redhat.com> - 2.3.0-8
|
||||
- Fix important Covscan defects (#1602643)
|
||||
|
||||
* Mon Oct 15 2018 Nikola Forró <nforro@redhat.com> - 2.3.0-7
|
||||
- Fix CVE-2018-18088 (#1638562)
|
||||
|
||||
* Mon Feb 19 2018 Sandro Mani <manisandro@gmail.com> - 2.3.0-6
|
||||
- Add missing BR: gcc, make
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.3.0-4
|
||||
- Switch to %%ldconfig_scriptlets
|
||||
|
||||
* Mon Dec 25 2017 Sandro Mani <manisandro@gmail.com> - 2.3.0-3
|
||||
- Rename tool names at cmake level to ensure OpenJPEGTargets.cmake refers to the renamed files
|
||||
|
||||
* Mon Dec 25 2017 Sandro Mani <manisandro@gmail.com> - 2.3.0-2
|
||||
- Use BUILD_STATIC_LIBS=OFF instead of deleting the static library after build
|
||||
|
||||
* Thu Oct 05 2017 Sandro Mani <manisandro@gmail.com> - 2.3.0-1
|
||||
- Update to 2.3.0
|
||||
|
||||
* Thu Sep 07 2017 Sandro Mani <manisandro@gmail.com> - 2.2.0-4
|
||||
- Backport fix for CVE-2017-14039
|
||||
|
||||
* Thu Aug 31 2017 Sandro Mani <manisandro@gmail.com> - 2.2.0-3
|
||||
- Backport more security fixes, including for CVE-2017-14041 and CVE-2017-14040
|
||||
|
||||
* Thu Aug 31 2017 Sandro Mani <manisandro@gmail.com> - 2.2.0-2
|
||||
- Backport patch for CVE-2017-12982
|
||||
|
||||
* Thu Aug 10 2017 Sandro Mani <manisandro@gmail.com> - 2.2.0-1
|
||||
- Update to 2.2.0
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.2-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Sat Dec 17 2016 Sandro Mani <manisandro@gmail.com> - 2.1.2-3
|
||||
- Add patch for CVE-2016-9580 (#1405128) and CVE-2016-9581 (#1405135)
|
||||
|
||||
* Thu Dec 08 2016 Sandro Mani <manisandro@gmail.com> - 2.1.2-2
|
||||
- Add patch for CVE-2016-9572 (#1402714) and CVE-2016-9573 (#1402711)
|
||||
|
||||
* Wed Sep 28 2016 Sandro Mani <manisandro@gmail.com> - 2.1.2-1
|
||||
- Update to 2.1.2
|
||||
- Fixes: CVE-2016-7445
|
||||
|
||||
* Fri Sep 09 2016 Sandro Mani <manisandro@gmail.com> - 2.1.1-3
|
||||
- Backport: Add sanity check for tile coordinates (#1374337)
|
||||
|
||||
* Fri Sep 09 2016 Sandro Mani <manisandro@gmail.com> - 2.1.1-2
|
||||
- Backport fixes for CVE-2016-7163
|
||||
|
||||
* Wed Jul 06 2016 Sandro Mani <manisandro@gmail.com> - 2.1.1-1
|
||||
- Update to 2.1.1
|
||||
- Fixes: CVE-2016-3183, CVE-2016-3181, CVE-2016-3182, CVE-2016-4796, CVE-2016-4797, CVE-2015-8871
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Oct 01 2015 Sandro Mani <manisandro@gmail.com> - 2.1.0-7
|
||||
- Backport fix for possible double-free (#1267983)
|
||||
|
||||
* Tue Sep 15 2015 Sandro Mani <manisandro@gmail.com> - 2.1.0-6
|
||||
- Backport fix for use after free vulnerability (#1263359)
|
||||
|
||||
* Thu Jun 25 2015 Sandro Mani <manisandro@gmail.com> - 2.1.0-5
|
||||
- Add openjpeg2_bigendian.patch (#1232739)
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Tue May 27 2014 Sandro Mani <manisandro@gmail.com> - 2.1.0-1
|
||||
- Update to 2.1.0
|
||||
|
||||
* Wed Apr 16 2014 Sandro Mani <manisandro@gmail.com> - 2.0.0-5
|
||||
- Switch to official 2.0 release and backport pkg-config patch
|
||||
|
||||
* Thu Apr 10 2014 Sandro Mani <manisandro@gmail.com> - 2.0.0-4.svn20140403
|
||||
- Replace define with global
|
||||
- Fix #define optional_components 1S typo
|
||||
- Fix %%(pwd) -> $PWD for test data
|
||||
- Added some BR for optional components
|
||||
- Include opj2_jpip_viewer.jar in %%files
|
||||
|
||||
* Wed Apr 09 2014 Sandro Mani <manisandro@gmail.com> - 2.0.0-3.svn20140403
|
||||
- Fix source url
|
||||
- Fix mixed tabs and spaces
|
||||
- Fix description too long
|
||||
|
||||
* Wed Apr 09 2014 Sandro Mani <manisandro@gmail.com> - 2.0.0-2.svn20140403
|
||||
- Remove thirdparty libraries folder in prep
|
||||
- Own %%{_libdir}/openjpeg-2.0/
|
||||
- Fix Requires
|
||||
- Add missing ldconfig
|
||||
- Add possibility to run conformance tests if desired
|
||||
|
||||
* Thu Apr 03 2014 Sandro Mani <manisandro@gmail.com> - 2.0.0-1.svn20140403
|
||||
- Initial package
|
Loading…
Reference in New Issue
Block a user