openjade/openjade-ppc64.patch
cvsdist 39aec48a2b auto-import changelog data from openjade-1.3.2-8.src.rpm
Mon Oct 20 2003 Tim Waugh <twaugh@redhat.com> 1.3.2-8
- Rebuilt.
Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.3.2-7
- do not link against -lnsl
Thu Aug 07 2003 Tim Waugh <twaugh@redhat.com> 1.3.2-6
- Rebootstrap to create a libtool that actually works.
Wed Aug 06 2003 Tim Waugh <twaugh@redhat.com> 1.3.2-5
- Rebuilt.
Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> 1.3.2-4
- rebuilt
Thu May 22 2003 Tim Waugh <twaugh@redhat.com> 1.3.2-3
- Fixes for GCC 3.3.
- Use --parents for %doc.
Tue Mar 18 2003 Tim Waugh <twaugh@redhat.com> 1.3.2-2
- Provide sgml2xml man page (bug #83759).
- Add devel subpackage.
Fri Mar 14 2003 Tim Waugh <twaugh@redhat.com> 1.3.2-1
- OpenSP 1.5, openjade 1.3.2.
- Renumber patches.
Thu Feb 13 2003 Elliot Lee <sopwith@redhat.com> 1.3.1-13
- Add openjade-ppc64.patch
2004-09-09 09:33:46 +00:00

28 lines
909 B
Diff

--- openjade-1.3.1/Makefile.prog.in.sopwith 2002-01-22 06:57:53.000000000 -0500
+++ openjade-1.3.1/Makefile.prog.in 2003-02-11 16:59:44.000000000 -0500
@@ -1,3 +1,4 @@
+
#
# Makefile.prog.in - Makerules for bilding programs
#
@@ -11,15 +12,17 @@
LINKFLAGS = @LINKFLAGS@
ALL_LIBS = $(XLIBS) $(LIBS)
+LT_LIBS = $(shell echo $(XLIBS) | sed 's/\.a/.la/g')
+LT_ALL_LIBS = $(shell echo $(ALL_LIBS) | sed 's/\.a/.la/g')
Makefile.lt:
- echo 'LT_LIBS='`echo $(ALL_LIBS)|sed 's/\.a/.la/g'` >Makefile.lt
+ echo > Makefile.lt
PROG:=$(shell echo "$(PROG)" | sed '@program_transform_name@')
all: $(PROG)
$(PROG): $(OBJS) $(COBJS) $(LT_LIBS)
- $(LIBTOOL) --mode=link $(CXX) $(LINKFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(COBJS) $(LT_LIBS)
+ $(LIBTOOL) --mode=link $(CXX) $(LINKFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(COBJS) $(LT_ALL_LIBS)
install: $(PROG)
-test -d $(DESTDIR)$(bindir) || \