Update to 0.3.5, enabling dynamic CPU detection on aarch64.
This commit is contained in:
parent
5ba251ab16
commit
53f8e436b9
@ -1,12 +0,0 @@
|
|||||||
diff -up OpenBLAS-0.3.3/Makefile.rule.tls OpenBLAS-0.3.3/Makefile.rule
|
|
||||||
--- OpenBLAS-0.3.3/Makefile.rule.tls 2018-08-31 00:07:48.000000000 +0200
|
|
||||||
+++ OpenBLAS-0.3.3/Makefile.rule 2018-09-29 19:00:47.804678736 +0200
|
|
||||||
@@ -113,7 +113,7 @@ USE_SIMPLE_THREADED_LEVEL3 = 1
|
|
||||||
# thread-local storage instead of a central memory buffer in memory.c
|
|
||||||
# Note that if your system uses GLIBC, it needs to have at least glibc 2.21
|
|
||||||
# for this to work.
|
|
||||||
-USE_TLS = 1
|
|
||||||
+#USE_TLS = 1
|
|
||||||
|
|
||||||
# If you want to drive whole 64bit region by BLAS. Not all Fortran
|
|
||||||
# compiler supports this. It's safe to keep comment it out if you
|
|
@ -14,8 +14,8 @@
|
|||||||
# "obsoleted" features are still kept in the spec.
|
# "obsoleted" features are still kept in the spec.
|
||||||
|
|
||||||
Name: openblas
|
Name: openblas
|
||||||
Version: 0.3.3
|
Version: 0.3.5
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: An optimized BLAS library based on GotoBLAS2
|
Summary: An optimized BLAS library based on GotoBLAS2
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -29,8 +29,6 @@ Patch1: openblas-0.2.5-libname.patch
|
|||||||
Patch2: openblas-0.2.15-constructor.patch
|
Patch2: openblas-0.2.15-constructor.patch
|
||||||
# Supply the proper flags to the test makefile
|
# Supply the proper flags to the test makefile
|
||||||
Patch3: openblas-0.3.2-tests.patch
|
Patch3: openblas-0.3.2-tests.patch
|
||||||
# Fix BZ #1634060
|
|
||||||
Patch4: openblas-0.3.3-tls.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-gfortran
|
BuildRequires: gcc-gfortran
|
||||||
@ -253,7 +251,6 @@ cd OpenBLAS-%{version}
|
|||||||
%patch2 -p1 -b .constructor
|
%patch2 -p1 -b .constructor
|
||||||
%endif
|
%endif
|
||||||
%patch3 -p1 -b .tests
|
%patch3 -p1 -b .tests
|
||||||
%patch4 -p1 -b .tls
|
|
||||||
|
|
||||||
# Fix source permissions
|
# Fix source permissions
|
||||||
find -name \*.f -exec chmod 644 {} \;
|
find -name \*.f -exec chmod 644 {} \;
|
||||||
@ -389,7 +386,7 @@ TARGET="TARGET=POWER7 DYNAMIC_ARCH=0"
|
|||||||
TARGET="TARGET=POWER8 DYNAMIC_ARCH=0"
|
TARGET="TARGET=POWER8 DYNAMIC_ARCH=0"
|
||||||
%endif
|
%endif
|
||||||
%ifarch aarch64
|
%ifarch aarch64
|
||||||
TARGET="TARGET=ARMV8 DYNAMIC_ARCH=0"
|
TARGET="TARGET=ARMV8 DYNAMIC_ARCH=1"
|
||||||
%endif
|
%endif
|
||||||
%ifarch s390x
|
%ifarch s390x
|
||||||
TARGET="TARGET=ZARCH_GENERIC DYNAMIC_ARCH=0"
|
TARGET="TARGET=ZARCH_GENERIC DYNAMIC_ARCH=0"
|
||||||
@ -699,6 +696,9 @@ rm -rf %{buildroot}%{_libdir}/pkgconfig
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 07 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.3.5-1
|
||||||
|
- Update to 0.3.5, with dynamic CPU detection on aarch64.
|
||||||
|
|
||||||
* Fri Nov 09 2018 Nikola Forró <nforro@redhat.com> - 0.3.3-3
|
* Fri Nov 09 2018 Nikola Forró <nforro@redhat.com> - 0.3.3-3
|
||||||
- Fix i686-x86_64 multilib difference.
|
- Fix i686-x86_64 multilib difference.
|
||||||
- Get rid of executable stack in libRblas.so.
|
- Get rid of executable stack in libRblas.so.
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (openblas-0.3.3.tar.gz) = 1c72dbe2b85675f564e777a807d0a8f2ab836abee8223b15ac4eb001c6ca06eeb2db7fa83a66d3f9e8420202b5afca6b6b1acb920e52abb3cec27b6f4629e618
|
SHA512 (openblas-0.3.5.tar.gz) = 91b3074eb922453bf843158b4281cde65db9e8bbdd7590e75e9e6cdcb486157f7973f2936f327bb3eb4f1702ce0ba51ae6729d8d4baf2d986c50771e8f696df0
|
||||||
|
Loading…
Reference in New Issue
Block a user