Disable CPU affinity.
This commit is contained in:
parent
37b74659ce
commit
42355d300f
23
1495.patch
Normal file
23
1495.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
From e453555d97732f1691c0f07378486e10ab04cd86 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Martin Kroeker <martin@ruby.chemie.uni-freiburg.de>
|
||||||
|
Date: Mon, 19 Mar 2018 18:02:23 +0100
|
||||||
|
Subject: [PATCH] Disable CPU affinity by default again
|
||||||
|
|
||||||
|
This setting must have been changed unintentionally by my PR #1214 (probably leftover from unrelated tests)
|
||||||
|
---
|
||||||
|
Makefile.rule | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile.rule b/Makefile.rule
|
||||||
|
index 718f04090..62bf63df4 100644
|
||||||
|
--- a/Makefile.rule
|
||||||
|
+++ b/Makefile.rule
|
||||||
|
@@ -100,7 +100,7 @@ BUILD_LAPACK_DEPRECATED = 1
|
||||||
|
NO_WARMUP = 1
|
||||||
|
|
||||||
|
# If you want to disable CPU/Memory affinity on Linux.
|
||||||
|
-#NO_AFFINITY = 1
|
||||||
|
+NO_AFFINITY = 1
|
||||||
|
|
||||||
|
# if you are compiling for Linux and you have more than 16 numa nodes or more than 256 cpus
|
||||||
|
# BIGNUMA = 1
|
@ -15,7 +15,7 @@
|
|||||||
|
|
||||||
Name: openblas
|
Name: openblas
|
||||||
Version: 0.2.20
|
Version: 0.2.20
|
||||||
Release: 9%{?dist}
|
Release: 10%{?dist}
|
||||||
Summary: An optimized BLAS library based on GotoBLAS2
|
Summary: An optimized BLAS library based on GotoBLAS2
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -29,6 +29,8 @@ Patch1: openblas-0.2.5-libname.patch
|
|||||||
Patch2: openblas-0.2.15-constructor.patch
|
Patch2: openblas-0.2.15-constructor.patch
|
||||||
# Supply the proper flags to the test makefile
|
# Supply the proper flags to the test makefile
|
||||||
Patch3: openblas-0.2.19-tests.patch
|
Patch3: openblas-0.2.19-tests.patch
|
||||||
|
# Disable CPU affinity (patch from upstream)
|
||||||
|
Patch4: https://patch-diff.githubusercontent.com/raw/xianyi/OpenBLAS/pull/1495.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-gfortran
|
BuildRequires: gcc-gfortran
|
||||||
@ -228,6 +230,7 @@ cd OpenBLAS-%{version}
|
|||||||
%patch2 -p1 -b .constructor
|
%patch2 -p1 -b .constructor
|
||||||
%endif
|
%endif
|
||||||
%patch3 -p1 -b .tests
|
%patch3 -p1 -b .tests
|
||||||
|
%patch4 -p1 -b .affinity
|
||||||
|
|
||||||
# Fix source permissions
|
# Fix source permissions
|
||||||
find -name \*.f -exec chmod 644 {} \;
|
find -name \*.f -exec chmod 644 {} \;
|
||||||
@ -660,6 +663,9 @@ rm -rf %{buildroot}%{_libdir}/pkgconfig
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 22 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.2.20-10
|
||||||
|
- Disable CPU affinity unintentionally enabled upstream (BZ #1558091).
|
||||||
|
|
||||||
* Wed Mar 04 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.2.20-9
|
* Wed Mar 04 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.2.20-9
|
||||||
- Clean up obsolete conditionals for 64 bit builds in spec file.
|
- Clean up obsolete conditionals for 64 bit builds in spec file.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user