Re-add flags for tests
The patch was removed as part of rebase to 0.3.19 (4720c1464
), but only
half of the patch was included upstream. The flags added to tests seem
to be still valid for the current version.
This commit is contained in:
parent
3967337978
commit
219f52b0f1
@ -1,42 +1,26 @@
|
||||
diff -up OpenBLAS-0.3.11/cpp_thread_test/Makefile.tests OpenBLAS-0.3.11/cpp_thread_test/Makefile
|
||||
--- OpenBLAS-0.3.11/cpp_thread_test/Makefile.tests 2020-10-17 22:14:12.000000000 +0200
|
||||
+++ OpenBLAS-0.3.11/cpp_thread_test/Makefile 2020-10-18 18:18:59.460796184 +0200
|
||||
@@ -1,13 +1,14 @@
|
||||
-include ../Makefile.rule
|
||||
+TOPDIR = ..
|
||||
+include $(TOPDIR)/Makefile.system
|
||||
|
||||
all :: dgemv_tester dgemm_tester
|
||||
|
||||
dgemv_tester :
|
||||
- $(CXX) $(COMMON_OPT) -Wall -Wextra -Wshadow -fopenmp -std=c++11 dgemv_thread_safety.cpp ../libopenblas.a -lpthread -o dgemv_tester
|
||||
+ $(CXX) $(COMMON_OPT) -Wall -Wextra -Wshadow -fopenmp -std=c++11 dgemv_thread_safety.cpp ../$(LIBNAME) -lpthread -o dgemv_tester
|
||||
./dgemv_tester
|
||||
|
||||
dgemm_tester : dgemv_tester
|
||||
- $(CXX) $(COMMON_OPT) -Wall -Wextra -Wshadow -fopenmp -std=c++11 dgemm_thread_safety.cpp ../libopenblas.a -lpthread -o dgemm_tester
|
||||
+ $(CXX) $(COMMON_OPT) -Wall -Wextra -Wshadow -fopenmp -std=c++11 dgemm_thread_safety.cpp ../$(LIBNAME) -lpthread -o dgemm_tester
|
||||
./dgemm_tester
|
||||
|
||||
clean ::
|
||||
diff -up OpenBLAS-0.3.11/Makefile.tests OpenBLAS-0.3.11/Makefile
|
||||
--- OpenBLAS-0.3.11/Makefile.tests 2020-10-17 22:14:12.000000000 +0200
|
||||
+++ OpenBLAS-0.3.11/Makefile 2020-10-18 18:19:54.134437445 +0200
|
||||
@@ -138,13 +138,13 @@ tests :
|
||||
diff -up OpenBLAS-0.3.21/Makefile.fixtests OpenBLAS-0.3.21/Makefile
|
||||
--- OpenBLAS-0.3.21/Makefile.fixtests 2022-08-26 07:37:06.257272957 +0200
|
||||
+++ OpenBLAS-0.3.21/Makefile 2022-08-26 07:37:53.168414307 +0200
|
||||
@@ -147,18 +147,18 @@ tests :
|
||||
ifeq ($(NOFORTRAN), $(filter 0,$(NOFORTRAN)))
|
||||
touch $(LIBNAME)
|
||||
ifndef NO_FBLAS
|
||||
- $(MAKE) -C test all
|
||||
+ $(MAKE) -C test FC="$(FC)" CC="$(CC)" COMMON_OPT="$(COMMON_OPT)" FCOMMON_OPT="$(FCOMMON_OPT)" all
|
||||
endif
|
||||
endif
|
||||
ifneq ($(ONLY_CBLAS), 1)
|
||||
- $(MAKE) -C utest all
|
||||
+ $(MAKE) -C utest FC="$(FC)" CC="$(CC)" COMMON_OPT="$(COMMON_OPT)" FCOMMON_OPT="$(FCOMMON_OPT)" all
|
||||
endif
|
||||
ifneq ($(NO_CBLAS), 1)
|
||||
ifneq ($(ONLY_CBLAS), 1)
|
||||
- $(MAKE) -C ctest all
|
||||
+ $(MAKE) -C ctest FC="$(FC)" CC="$(CC)" COMMON_OPT="$(COMMON_OPT)" FCOMMON_OPT="$(FCOMMON_OPT)" all
|
||||
endif
|
||||
ifeq ($(CPP_THREAD_SAFETY_TEST), 1)
|
||||
- $(MAKE) -C cpp_thread_test all
|
||||
+ $(MAKE) -C cpp_thread_test FC="$(FC)" CC="$(CC)" COMMON_OPT="$(COMMON_OPT)" FCOMMON_OPT="$(FCOMMON_OPT)" all
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
|
||||
|
@ -15,7 +15,7 @@
|
||||
|
||||
Name: openblas
|
||||
Version: 0.3.21
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: An optimized BLAS library based on GotoBLAS2
|
||||
License: BSD
|
||||
URL: https://github.com/xianyi/OpenBLAS/
|
||||
@ -28,6 +28,8 @@ Patch1: openblas-0.2.5-libname.patch
|
||||
Patch2: openblas-0.2.15-constructor.patch
|
||||
# Fix SBGEMM test to work with INTERFACE64
|
||||
Patch3: openblas-0.3.21-sbgemm-test.patch
|
||||
# Supply the proper flags to the test makefile
|
||||
Patch4: openblas-0.3.11-tests.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
@ -241,6 +243,7 @@ cd OpenBLAS-%{version}
|
||||
%patch2 -p1 -b .constructor
|
||||
%endif
|
||||
%patch3 -p1 -b .sbgemm
|
||||
%patch4 -p1 -b .tests
|
||||
|
||||
# Fix source permissions
|
||||
find -name \*.f -exec chmod 644 {} \;
|
||||
@ -646,6 +649,9 @@ rm -rf %{buildroot}%{_libdir}/pkgconfig
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Aug 26 2022 Honza Horak <hhorak@redhat.com> - 0.3.21-3
|
||||
- Re-add flags for tests
|
||||
|
||||
* Wed Aug 24 2022 Honza Horak <hhorak@redhat.com> - 0.3.21-2
|
||||
- Fix SBGEMM test to work with INTERFACE64
|
||||
Resolves: #2120974
|
||||
|
Loading…
Reference in New Issue
Block a user