Check for arm_neon.h only on 32bit ARM
This commit is contained in:
parent
120c009c12
commit
35c3ddabc3
13
openal-soft-arm_neon-only-for-32bit.patch
Normal file
13
openal-soft-arm_neon-only-for-32bit.patch
Normal file
@ -0,0 +1,13 @@
|
||||
Index: openal-soft-1.16.0/CMakeLists.txt
|
||||
===================================================================
|
||||
--- openal-soft-1.16.0.orig/CMakeLists.txt
|
||||
+++ openal-soft-1.16.0/CMakeLists.txt
|
||||
@@ -679,7 +679,7 @@ ENDIF()
|
||||
# Check for ARM Neon support
|
||||
OPTION(ALSOFT_REQUIRE_NEON "Require ARM Neon support" OFF)
|
||||
CHECK_INCLUDE_FILE(arm_neon.h HAVE_ARM_NEON_H)
|
||||
-IF(HAVE_ARM_NEON_H)
|
||||
+IF(HAVE_ARM_NEON_H AND CMAKE_SIZEOF_VOID_P EQUAL 4) # only 32-bit ARM
|
||||
OPTION(ALSOFT_CPUEXT_NEON "Enable ARM Neon support" ON)
|
||||
IF(ALSOFT_CPUEXT_NEON)
|
||||
SET(HAVE_NEON 1)
|
@ -7,6 +7,7 @@ Group: System Environment/Libraries
|
||||
License: LGPLv2+
|
||||
URL: http://kcat.strangesoft.net/openal.html
|
||||
Source0: http://kcat.strangesoft.net/openal-releases/openal-soft-%{version}.tar.bz2
|
||||
Patch0: openal-soft-arm_neon-only-for-32bit.patch
|
||||
|
||||
BuildRequires: alsa-lib-devel
|
||||
BuildRequires: pulseaudio-libs-devel
|
||||
@ -49,6 +50,7 @@ for configuring OpenAL features.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%cmake .
|
||||
|
Loading…
Reference in New Issue
Block a user