Package new upstream version open-vm-tools-10.0.5-3227872.
- Add a patch for fixing GCC 6 build issue (RHBZ#1305108). - Replace kill-werror.patch with no-unused-const.patch.
This commit is contained in:
parent
d065140552
commit
ee4478213d
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
||||
/open-vm-tools-9.10.0-2476743.tar.gz
|
||||
/open-vm-tools-9.10.2-2822639.tar.gz
|
||||
/open-vm-tools-10.0.0-3000743.tar.gz
|
||||
/open-vm-tools-10.0.5-3227872.tar.gz
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- open-vm-tools-10.0.0-3000743/configure.ac.old 2015-09-10 08:31:38.000000000 +0100
|
||||
+++ open-vm-tools-10.0.0-3000743/configure.ac 2016-04-23 07:45:08.405052511 +0100
|
||||
@@ -935,7 +935,6 @@
|
||||
|
||||
### General flags / actions
|
||||
CFLAGS="$CFLAGS -Wall"
|
||||
-CFLAGS="$CFLAGS -Werror"
|
||||
|
||||
# -Wno-unknown-pragmas is due to gcc not understanding '#pragma ident'
|
||||
# in Xlib.h on OpenSolaris.
|
12
no-unused-const.patch
Normal file
12
no-unused-const.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- configure.ac.old 2016-05-24 23:43:41.265711304 -0700
|
||||
+++ configure.ac 2016-05-25 00:03:39.128437427 -0700
|
||||
@@ -942,7 +942,8 @@
|
||||
# Glib2 keep changing mutex APIs so we also need to disable 'deprecated'
|
||||
# warnings for now (-Wno-deprecated-declarations).
|
||||
for TEST_CFLAG in -Wno-pointer-sign -Wno-unused-value -fno-strict-aliasing \
|
||||
- -Wno-unknown-pragmas -Wno-uninitialized -Wno-deprecated-declarations; do
|
||||
+ -Wno-unknown-pragmas -Wno-uninitialized -Wno-deprecated-declarations \
|
||||
+ -Wno-unused-const-variable; do
|
||||
AC_MSG_CHECKING([for GCC flag $TEST_CFLAG])
|
||||
ORIGINAL_CFLAGS="$CFLAGS"
|
||||
CFLAGS="$CFLAGS $TEST_CFLAG"
|
@ -1,5 +1,5 @@
|
||||
################################################################################
|
||||
### Copyright 2013-15 VMware, Inc. All rights reserved.
|
||||
### Copyright 2013-16 VMware, Inc. All rights reserved.
|
||||
###
|
||||
### RPM SPEC file for building open-vm-tools packages.
|
||||
###
|
||||
@ -20,15 +20,15 @@
|
||||
|
||||
%global _hardened_build 1
|
||||
%global majorversion 10.0
|
||||
%global minorversion 0
|
||||
%global toolsbuild 3000743
|
||||
%global minorversion 5
|
||||
%global toolsbuild 3227872
|
||||
%global toolsversion %{majorversion}.%{minorversion}
|
||||
%global toolsdaemon vmtoolsd
|
||||
%global vgauthdaemon vgauthd
|
||||
|
||||
Name: open-vm-tools
|
||||
Version: %{toolsversion}
|
||||
Release: 12%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Open Virtual Machine Tools for virtual machines hosted on VMware
|
||||
Group: Applications/System
|
||||
License: GPLv2
|
||||
@ -42,52 +42,52 @@ ExclusiveArch: x86_64
|
||||
ExclusiveArch: %{ix86} x86_64
|
||||
%endif
|
||||
|
||||
# Kill -Werror. Upstreams: Please do not use -Werror as the default.
|
||||
Patch1: kill-werror.patch
|
||||
Patch1: no-unused-const.patch
|
||||
Patch2: vmw-bitmask-gcc6.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: libtool
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: libtool
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: doxygen
|
||||
# Fuse is optional and enables vmblock-fuse
|
||||
BuildRequires: fuse-devel
|
||||
BuildRequires: glib2-devel >= 2.14.0
|
||||
BuildRequires: gtk2-devel >= 2.4.0
|
||||
BuildRequires: fuse-devel
|
||||
BuildRequires: glib2-devel >= 2.14.0
|
||||
BuildRequires: gtk2-devel >= 2.4.0
|
||||
%if 0%{?fedora} >= 23
|
||||
# F23 split gdk-pixbuf2-devel >= 2.31.3-5 into 3 packages,
|
||||
# gdk-pixbuf2-devel, gdk-pixbuf2-modules-devel, and
|
||||
# gdk-pixbuf2-xlib-devel. gtk2-devel does not depend on
|
||||
# gdk-pixbuf2-xlib-devel. Therefore, we need to pull in
|
||||
# gdk-pixbuf2-xlib-devel dependency ourselves.
|
||||
BuildRequires: gdk-pixbuf2-xlib-devel
|
||||
BuildRequires: gdk-pixbuf2-xlib-devel
|
||||
%endif
|
||||
BuildRequires: gtkmm24-devel
|
||||
BuildRequires: libdnet-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: libmspack-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXi-devel
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libXtst-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: pam-devel
|
||||
BuildRequires: procps-devel
|
||||
BuildRequires: systemd
|
||||
BuildRequires: xerces-c-devel
|
||||
BuildRequires: xml-security-c-devel
|
||||
BuildRequires: gtkmm24-devel
|
||||
BuildRequires: libdnet-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: libmspack-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXi-devel
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libXtst-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: pam-devel
|
||||
BuildRequires: procps-devel
|
||||
BuildRequires: systemd
|
||||
BuildRequires: xerces-c-devel
|
||||
BuildRequires: xml-security-c-devel
|
||||
|
||||
Requires: coreutils
|
||||
Requires: fuse
|
||||
Requires: net-tools
|
||||
Requires: grep
|
||||
Requires: sed
|
||||
Requires: systemd
|
||||
Requires: tar
|
||||
Requires: which
|
||||
Requires: coreutils
|
||||
Requires: fuse
|
||||
Requires: net-tools
|
||||
Requires: grep
|
||||
Requires: sed
|
||||
Requires: systemd
|
||||
Requires: tar
|
||||
Requires: which
|
||||
|
||||
%description
|
||||
The %{name} project is an open source implementation of VMware Tools. It
|
||||
@ -119,7 +119,8 @@ VMware virtual machines.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}-%{toolsbuild}
|
||||
|
||||
%patch1 -p1
|
||||
%patch1 -p0
|
||||
%patch2 -p0
|
||||
|
||||
%build
|
||||
# Fedora 23 uses libsigc++-2.0 version 2.6.1.
|
||||
@ -287,6 +288,11 @@ fi
|
||||
%{_libdir}/libvmtools.so
|
||||
|
||||
%changelog
|
||||
* Wed May 25 2016 Ravindra Kumar <ravindrakumar@vmware.com> - 10.0.5-1
|
||||
- Package new upstream version open-vm-tools-10.0.5-3227872.
|
||||
- Add a patch for fixing GCC 6 build issue (RHBZ#1305108).
|
||||
- Replace kill-werror.patch with no-unused-const.patch.
|
||||
|
||||
* Wed May 25 2016 Richard W.M. Jones <rjones@redhat.com> - 10.0.0-12
|
||||
- Bump and rebuild.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
d83e3b0b94da48ede8cde0ab8ad11151 open-vm-tools-10.0.0-3000743.tar.gz
|
||||
734eccf6e9e007cb37dc4eb3ed6707b5 open-vm-tools-10.0.5-3227872.tar.gz
|
||||
|
16
vmw-bitmask-gcc6.patch
Normal file
16
vmw-bitmask-gcc6.patch
Normal file
@ -0,0 +1,16 @@
|
||||
--- lib/include/x86cpuid.h.old 2016-05-24 23:23:20.747118224 -0700
|
||||
+++ lib/include/x86cpuid.h 2016-05-24 23:28:35.829547406 -0700
|
||||
@@ -905,11 +905,9 @@
|
||||
*
|
||||
* e.g. - CPUID_VIRT_BITS_MASK = 0xff00
|
||||
* - CPUID_VIRT_BITS_SHIFT = 8
|
||||
- *
|
||||
- * Note: The MASK definitions must use some gymnastics to get
|
||||
- * around a warning when shifting left by 32.
|
||||
*/
|
||||
-#define VMW_BIT_MASK(shift) (((1 << (shift - 1)) << 1) - 1)
|
||||
+#define VMW_BIT_MASK(shift) (0xffffffffu >> (32 - shift))
|
||||
+
|
||||
|
||||
#define FIELD(lvl, ecxIn, reg, bitpos, size, name, s, c3) \
|
||||
CPUID_##name##_SHIFT = bitpos, \
|
Loading…
Reference in New Issue
Block a user