Package new upstream version open-vm-tools-10.3.0-8931395.
Updated cloud-init.patch for 10.3.0. Removed use-tirpc.patch which is no longer needed.
This commit is contained in:
parent
f2c8cc77e4
commit
c16e623315
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@
|
||||
/open-vm-tools-10.1.10-6082533.tar.gz
|
||||
/open-vm-tools-10.2.0-7253323.tar.gz
|
||||
/open-vm-tools-10.2.5-8068406.tar.gz
|
||||
/open-vm-tools-10.3.0-8931395.tar.gz
|
||||
|
@ -1,10 +1,10 @@
|
||||
diff --git a/open-vm-tools/libDeployPkg/linuxDeployment.c b/open-vm-tools/libDeployPkg/linuxDeployment.c
|
||||
index 023d41f1..7bcdd0a8 100644
|
||||
index 996f184c..34c8b956 100644
|
||||
--- a/open-vm-tools/libDeployPkg/linuxDeployment.c
|
||||
+++ b/open-vm-tools/libDeployPkg/linuxDeployment.c
|
||||
@@ -143,7 +143,7 @@ static bool CopyFileToDirectory(const char* srcPath, const char* destPath,
|
||||
@@ -139,7 +139,7 @@ static bool CopyFileToDirectory(const char* srcPath, const char* destPath,
|
||||
const char* fileName);
|
||||
static int Deploy(const char* pkgName);
|
||||
static DeployPkgStatus Deploy(const char* pkgName);
|
||||
static char** GetFormattedCommandLine(const char* command);
|
||||
-int ForkExecAndWaitCommand(const char* command);
|
||||
+int ForkExecAndWaitCommand(const char* command, bool ignoreStdErr);
|
||||
@ -83,8 +83,8 @@ index 023d41f1..7bcdd0a8 100644
|
||||
if (forkExecResult != 0) {
|
||||
sLog(log_info, "cloud-init is not installed");
|
||||
free(cfgFullPath);
|
||||
@@ -1191,7 +1191,7 @@ Deploy(const char* packageName)
|
||||
deployStatus = CloudInitSetup(tmpDirPath);
|
||||
@@ -1194,7 +1194,7 @@ Deploy(const char* packageName)
|
||||
deployPkgStatus = CloudInitSetup(tmpDirPath);
|
||||
} else {
|
||||
sLog(log_info, "Executing traditional GOSC workflow");
|
||||
- deploymentResult = ForkExecAndWaitCommand(command);
|
||||
@ -92,7 +92,7 @@ index 023d41f1..7bcdd0a8 100644
|
||||
free(command);
|
||||
|
||||
if (deploymentResult != CUST_SUCCESS) {
|
||||
@@ -1257,7 +1257,7 @@ Deploy(const char* packageName)
|
||||
@@ -1260,7 +1260,7 @@ Deploy(const char* packageName)
|
||||
strcat(cleanupCommand, tmpDirPath);
|
||||
|
||||
sLog(log_info, "Launching cleanup. \n");
|
||||
@ -101,7 +101,7 @@ index 023d41f1..7bcdd0a8 100644
|
||||
sLog(log_warning, "Error while clean up tmp directory %s: (%s)",
|
||||
tmpDirPath, strerror (errno));
|
||||
}
|
||||
@@ -1286,7 +1286,7 @@ Deploy(const char* packageName)
|
||||
@@ -1289,7 +1289,7 @@ Deploy(const char* packageName)
|
||||
int rebootComandResult = 0;
|
||||
do {
|
||||
sLog(log_info, "Rebooting\n");
|
||||
@ -110,12 +110,14 @@ index 023d41f1..7bcdd0a8 100644
|
||||
sleep(1);
|
||||
} while (rebootComandResult == 0);
|
||||
sLog(log_error, "telinit returned error %d\n", rebootComandResult);
|
||||
@@ -1497,11 +1497,12 @@ GetFormattedCommandLine(const char* command)
|
||||
@@ -1499,12 +1499,13 @@ GetFormattedCommandLine(const char* command)
|
||||
* Fork off the command and wait for it to finish. Classical Linux/Unix
|
||||
* fork-and-exec.
|
||||
*
|
||||
* @param [IN] command Command to execute
|
||||
- * @param [IN] command Command to execute
|
||||
+ * @param [IN] command Command to execute
|
||||
+ * @param [IN] ignoreStdErr If we ignore stderr when cmd's return code is 0
|
||||
* @return Return code from the process (or DEPLOY_ERROR)
|
||||
* @return Return code from the process (or -1)
|
||||
*
|
||||
**/
|
||||
int
|
||||
@ -124,7 +126,7 @@ index 023d41f1..7bcdd0a8 100644
|
||||
{
|
||||
ProcessHandle hp;
|
||||
int retval;
|
||||
@@ -1519,14 +1520,30 @@ ForkExecAndWaitCommand(const char* command)
|
||||
@@ -1522,14 +1523,30 @@ ForkExecAndWaitCommand(const char* command)
|
||||
|
||||
Process_RunToComplete(hp, 100);
|
||||
sLog(log_info, "Customization command output: %s\n", Process_GetStdout(hp));
|
||||
|
@ -19,16 +19,16 @@
|
||||
################################################################################
|
||||
|
||||
%global _hardened_build 1
|
||||
%global majorversion 10.2
|
||||
%global minorversion 5
|
||||
%global toolsbuild 8068406
|
||||
%global majorversion 10.3
|
||||
%global minorversion 0
|
||||
%global toolsbuild 8931395
|
||||
%global toolsversion %{majorversion}.%{minorversion}
|
||||
%global toolsdaemon vmtoolsd
|
||||
%global vgauthdaemon vgauthd
|
||||
|
||||
Name: open-vm-tools
|
||||
Version: %{toolsversion}
|
||||
Release: 7%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Open Virtual Machine Tools for virtual machines hosted on VMware
|
||||
Group: Applications/System
|
||||
License: GPLv2
|
||||
@ -42,8 +42,7 @@ ExclusiveArch: x86_64
|
||||
ExclusiveArch: %{ix86} x86_64
|
||||
%endif
|
||||
|
||||
Patch1: use-tirpc.patch
|
||||
Patch2: cloud-init.patch
|
||||
Patch1: cloud-init.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
@ -149,8 +148,7 @@ machines.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}-%{toolsbuild}
|
||||
%patch1 -p1
|
||||
%patch2 -p2
|
||||
%patch1 -p2
|
||||
|
||||
%build
|
||||
# Required for regenerating configure script when
|
||||
@ -328,6 +326,11 @@ fi
|
||||
%{_bindir}/vmware-vgauth-smoketest
|
||||
|
||||
%changelog
|
||||
* Thu Aug 02 2018 Ravindra Kumar <ravindrakumar@vmware.com> - 10.3.0-1
|
||||
- Package new upstream version open-vm-tools-10.3.0-8931395.
|
||||
- Updated cloud-init.patch for 10.3.0.
|
||||
- Removed use-tirpc.patch which is no longer needed.
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 10.2.5-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (open-vm-tools-10.2.5-8068406.tar.gz) = da2f26b4b22e195af111cc16d5819aeb963f0dfa18b5d2677d897549836ec8679808315646f7f86ae36862df9e623bbcb5d553dae97a68b3ef928a5c07ea2e68
|
||||
SHA512 (open-vm-tools-10.3.0-8931395.tar.gz) = 627056db94b79aa7782324ed1a71e7f0c2420f0a0d76d3e65b84035b1350e29757a1412cbf195ef3d79fae37ddd6f17c6892ea2c64dbfa331854ded016965604
|
||||
|
460
use-tirpc.patch
460
use-tirpc.patch
@ -1,460 +0,0 @@
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/configure.ac open-vm-tools-10.2.5-8068406/configure.ac
|
||||
--- open-vm-tools-10.2.5-8068406.orig/configure.ac 2018-03-22 02:05:02.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/configure.ac 2018-05-08 18:10:45.650397285 -0700
|
||||
@@ -586,6 +586,11 @@
|
||||
[enable_vgauth=no],
|
||||
[with_xml2=yes])
|
||||
|
||||
+AC_ARG_WITH([tirpc],
|
||||
+ [AS_HELP_STRING([--without-tirpc],
|
||||
+ [compiles without tirpc support.])],
|
||||
+ [with_tirpc="$withval"],
|
||||
+ [with_tirpc="auto"])
|
||||
|
||||
# Make sure we are building with openssl 1.0.1 and above so that
|
||||
# we use only TLSv1_2.
|
||||
@@ -1066,10 +1071,45 @@
|
||||
|
||||
fi
|
||||
|
||||
+have_tirpc="no"
|
||||
+if test "x$with_tirpc" != "xno"; then
|
||||
+ AC_VMW_CHECK_LIB([libtirpc],
|
||||
+ [TIRPC],
|
||||
+ [libtirpc],
|
||||
+ [],
|
||||
+ [],
|
||||
+ [],
|
||||
+ [],
|
||||
+ [have_tirpc="yes"],
|
||||
+ [have_tirpc="no"])
|
||||
+fi
|
||||
+
|
||||
+if test "$with_tirpc" = "no"; then
|
||||
+ use_tirpc="no"
|
||||
+elif test "$with_tirpc" = "auto"; then
|
||||
+ use_tirpc=$have_tirpc
|
||||
+elif test "$with_tirpc" = "yes"; then
|
||||
+ if test "$have_tirpc" = "no"; then
|
||||
+ AC_MSG_ERROR([libtirpc is required, but not found.])
|
||||
+ else
|
||||
+ use_tirpc="yes"
|
||||
+ fi
|
||||
+fi
|
||||
+
|
||||
+if test "$use_tirpc" = "yes"; then
|
||||
+ AC_MSG_NOTICE([Building with libtirpc])
|
||||
+else
|
||||
+ AC_MSG_NOTICE([Building without libtirpc])
|
||||
+fi
|
||||
+
|
||||
AC_PATH_PROG(
|
||||
[RPCGEN],
|
||||
[rpcgen],
|
||||
- [ AC_MSG_ERROR([rpcgen not found. Please install the libc devel package.]) ])
|
||||
+ [not_found])
|
||||
+
|
||||
+if test "$RPCGEN" = "not_found"; then
|
||||
+ AC_MSG_ERROR([rpcgen not found. Please install libc-devel or libc-rpcgen package.])
|
||||
+fi
|
||||
|
||||
###
|
||||
### Headers
|
||||
@@ -1406,6 +1446,7 @@
|
||||
AM_CONDITIONAL(HAVE_UDEV, test "$have_udev" = "yes")
|
||||
AM_CONDITIONAL(ENABLE_RESOLUTIONKMS, test "x$enable_resolutionkms" = "xyes")
|
||||
AM_CONDITIONAL(VGAUTH_USE_CXX, test "$with_icu" = "yes" -o "$use_xmlsec1" != "yes")
|
||||
+AM_CONDITIONAL(HAVE_TIRPC, test "$use_tirpc" = "yes")
|
||||
|
||||
if test "$have_xsm" != "yes"; then
|
||||
AC_DEFINE([NO_XSM], 1, [])
|
||||
@@ -1454,6 +1495,13 @@
|
||||
XDR_LIBS="-lnsl -lrpcsvc"
|
||||
fi
|
||||
|
||||
+# In newer Linux distros Sun RPC has been removed from libc
|
||||
+XDR_CPPFLAGS=
|
||||
+if test "$os" = "linux" -a "$use_tirpc" = "yes"; then
|
||||
+ XDR_CPPFLAGS="-DUSE_TIRPC $TIRPC_CPPFLAGS"
|
||||
+ XDR_LIBS="$TIRPC_LIBS"
|
||||
+fi
|
||||
+
|
||||
# Installation directories for core services plugins.
|
||||
TEST_PLUGIN_INSTALLDIR=$datadir/open-vm-tools/tests
|
||||
COMMON_PLUGIN_INSTALLDIR=$libdir/open-vm-tools/plugins/common
|
||||
@@ -1492,6 +1540,7 @@
|
||||
AC_SUBST([VMTOOLS_CPPFLAGS])
|
||||
AC_SUBST([VMTOOLS_LIBS])
|
||||
AC_SUBST([RPCGENFLAGS])
|
||||
+AC_SUBST([XDR_CPPFLAGS])
|
||||
AC_SUBST([XDR_LIBS])
|
||||
AC_SUBST([TEST_PLUGIN_INSTALLDIR])
|
||||
AC_SUBST([COMMON_PLUGIN_INSTALLDIR])
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/lib/dynxdr/dynxdr.c open-vm-tools-10.2.5-8068406/lib/dynxdr/dynxdr.c
|
||||
--- open-vm-tools-10.2.5-8068406.orig/lib/dynxdr/dynxdr.c 2018-03-22 02:08:52.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/lib/dynxdr/dynxdr.c 2018-05-09 11:03:11.700032698 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
/*********************************************************
|
||||
- * Copyright (C) 2008-2017 VMware, Inc. All rights reserved.
|
||||
+ * Copyright (C) 2008-2018 VMware, Inc. All rights reserved.
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or modify it
|
||||
* under the terms of the GNU Lesser General Public License as published
|
||||
@@ -55,7 +55,7 @@
|
||||
* Mac OS X, FreeBSD and Solaris don't take a const parameter to the
|
||||
* "x_getpostn" function.
|
||||
*/
|
||||
-#if defined(__APPLE__) || defined(__FreeBSD__) || defined(sun)
|
||||
+#if defined(__APPLE__) || defined(__FreeBSD__) || defined(sun) || defined(USE_TIRPC)
|
||||
# define DYNXDR_GETPOS_CONST
|
||||
#else
|
||||
# define DYNXDR_GETPOS_CONST const
|
||||
@@ -172,7 +172,11 @@
|
||||
}
|
||||
|
||||
|
||||
-#if defined(__GLIBC__) || (defined(sun) && (defined(_LP64) || defined(_KERNEL)))
|
||||
+#if !defined(USE_TIRPC) && \
|
||||
+ defined(__GLIBC__) || \
|
||||
+ (defined(sun) && \
|
||||
+ (defined(_LP64) || \
|
||||
+ defined(_KERNEL)))
|
||||
/*
|
||||
*-----------------------------------------------------------------------------
|
||||
*
|
||||
@@ -322,11 +326,11 @@
|
||||
DynXdrSetPos, /* x_setpostn */
|
||||
DynXdrInline, /* x_inline */
|
||||
NULL, /* x_destroy */
|
||||
-#if defined(__GLIBC__)
|
||||
+#if defined(__APPLE__) || defined (USE_TIRPC)
|
||||
+ NULL, /* x_control */
|
||||
+#elif defined(__GLIBC__)
|
||||
NULL, /* x_getint32 */
|
||||
DynXdrPutInt32, /* x_putint32 */
|
||||
-#elif defined(__APPLE__)
|
||||
- NULL, /* x_control */
|
||||
#elif defined(sun) && (defined(_LP64) || defined(_KERNEL))
|
||||
NULL, /* x_control */
|
||||
NULL, /* x_getint32 */
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/lib/dynxdr/Makefile.am open-vm-tools-10.2.5-8068406/lib/dynxdr/Makefile.am
|
||||
--- open-vm-tools-10.2.5-8068406.orig/lib/dynxdr/Makefile.am 2018-03-22 02:05:02.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/lib/dynxdr/Makefile.am 2018-05-09 11:03:50.510199020 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
################################################################################
|
||||
-### Copyright (C) 2008-2016 VMware, Inc. All rights reserved.
|
||||
+### Copyright (C) 2008-2018 VMware, Inc. All rights reserved.
|
||||
###
|
||||
### This program is free software; you can redistribute it and/or modify
|
||||
### it under the terms of version 2 of the GNU General Public License as
|
||||
@@ -21,3 +21,5 @@
|
||||
libDynxdr_la_SOURCES += dynxdr.c
|
||||
libDynxdr_la_SOURCES += xdrutil.c
|
||||
|
||||
+libDynxdr_la_CPPFLAGS = @XDR_CPPFLAGS@
|
||||
+libDynxdr_la_LIBADD = @XDR_LIBS@
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/lib/guestRpc/Makefile.am open-vm-tools-10.2.5-8068406/lib/guestRpc/Makefile.am
|
||||
--- open-vm-tools-10.2.5-8068406.orig/lib/guestRpc/Makefile.am 2018-03-22 02:05:02.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/lib/guestRpc/Makefile.am 2018-05-09 11:04:33.695343248 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
################################################################################
|
||||
-### Copyright (C) 2008-2016 VMware, Inc. All rights reserved.
|
||||
+### Copyright (C) 2008-2018 VMware, Inc. All rights reserved.
|
||||
###
|
||||
### This program is free software; you can redistribute it and/or modify
|
||||
### it under the terms of version 2 of the GNU General Public License as
|
||||
@@ -20,6 +20,10 @@
|
||||
libGuestRpc_la_SOURCES =
|
||||
libGuestRpc_la_SOURCES += nicinfo_xdr.c
|
||||
|
||||
+libGuestRpc_la_CPPFLAGS = @XDR_CPPFLAGS@
|
||||
+
|
||||
+libGuestRpc_la_LIBADD = @XDR_LIBS@
|
||||
+
|
||||
# XXX: Autoreconf complains about this and recommends using AM_CFLAGS instead.
|
||||
# Problem is, $(CFLAGS) is appended to the compiler command line after AM_CFLAGS
|
||||
# and after libGuestRpc_la_CFLAGS, so "-Wall -Werror" will override this flag.
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/lib/netUtil/Makefile.am open-vm-tools-10.2.5-8068406/lib/netUtil/Makefile.am
|
||||
--- open-vm-tools-10.2.5-8068406.orig/lib/netUtil/Makefile.am 2018-03-22 02:05:02.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/lib/netUtil/Makefile.am 2018-05-09 11:05:22.720325766 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
################################################################################
|
||||
-### Copyright (C) 2007-2016 VMware, Inc. All rights reserved.
|
||||
+### Copyright (C) 2007-2018 VMware, Inc. All rights reserved.
|
||||
###
|
||||
### This program is free software; you can redistribute it and/or modify
|
||||
### it under the terms of version 2 of the GNU General Public License as
|
||||
@@ -20,3 +20,6 @@
|
||||
libNetUtil_la_SOURCES =
|
||||
libNetUtil_la_SOURCES += netUtilLinux.c
|
||||
|
||||
+libNetUtil_la_CPPFLAGS = @XDR_CPPFLAGS@
|
||||
+
|
||||
+libNetUtil_la_LIBADD = @XDR_LIBS@
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/lib/nicInfo/Makefile.am open-vm-tools-10.2.5-8068406/lib/nicInfo/Makefile.am
|
||||
--- open-vm-tools-10.2.5-8068406.orig/lib/nicInfo/Makefile.am 2018-03-22 02:05:02.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/lib/nicInfo/Makefile.am 2018-05-09 11:16:45.873499080 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
################################################################################
|
||||
-### Copyright (C) 2014-2016 VMware, Inc. All rights reserved.
|
||||
+### Copyright (C) 2014-2018 VMware, Inc. All rights reserved.
|
||||
###
|
||||
### This program is free software; you can redistribute it and/or modify
|
||||
### it under the terms of version 2 of the GNU General Public License as
|
||||
@@ -25,6 +25,9 @@
|
||||
|
||||
libNicInfo_la_CPPFLAGS =
|
||||
libNicInfo_la_CPPFLAGS += @GLIB2_CPPFLAGS@
|
||||
+libNicInfo_la_CPPFLAGS += @XDR_CPPFLAGS@
|
||||
+
|
||||
+libNicInfo_la_LIBADD = @XDR_LIBS@
|
||||
|
||||
AM_CFLAGS = $(DNET_CPPFLAGS)
|
||||
if USE_SLASH_PROC
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/lib/rpcChannel/Makefile.am open-vm-tools-10.2.5-8068406/lib/rpcChannel/Makefile.am
|
||||
--- open-vm-tools-10.2.5-8068406.orig/lib/rpcChannel/Makefile.am 2018-03-22 02:05:02.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/lib/rpcChannel/Makefile.am 2018-05-09 11:06:28.808588597 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
################################################################################
|
||||
-### Copyright (C) 2009-2016 VMware, Inc. All rights reserved.
|
||||
+### Copyright (C) 2009-2018 VMware, Inc. All rights reserved.
|
||||
###
|
||||
### This program is free software; you can redistribute it and/or modify
|
||||
### it under the terms of version 2 of the GNU General Public License as
|
||||
@@ -27,3 +27,6 @@
|
||||
|
||||
libRpcChannel_la_CPPFLAGS =
|
||||
libRpcChannel_la_CPPFLAGS += @VMTOOLS_CPPFLAGS@
|
||||
+libRpcChannel_la_CPPFLAGS += @XDR_CPPFLAGS@
|
||||
+
|
||||
+libRpcChannel_la_LIBADD = @XDR_LIBS@
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/lib/slashProc/net.c open-vm-tools-10.2.5-8068406/lib/slashProc/net.c
|
||||
--- open-vm-tools-10.2.5-8068406.orig/lib/slashProc/net.c 2018-03-22 02:05:41.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/lib/slashProc/net.c 2018-05-09 11:06:37.592208338 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
/*********************************************************
|
||||
- * Copyright (C) 2009-2016 VMware, Inc. All rights reserved.
|
||||
+ * Copyright (C) 2009-2018 VMware, Inc. All rights reserved.
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or modify it
|
||||
* under the terms of the GNU Lesser General Public License as published
|
||||
@@ -36,7 +36,6 @@
|
||||
#include "panic.h"
|
||||
#include "slashProc.h"
|
||||
#include "slashProcNetInt.h"
|
||||
-#include "netutil.h"
|
||||
|
||||
|
||||
/*
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/libguestlib/Makefile.am open-vm-tools-10.2.5-8068406/libguestlib/Makefile.am
|
||||
--- open-vm-tools-10.2.5-8068406.orig/libguestlib/Makefile.am 2018-03-22 02:05:02.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/libguestlib/Makefile.am 2018-05-09 11:07:16.200301424 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
################################################################################
|
||||
-### Copyright (C) 2007-2016 VMware, Inc. All rights reserved.
|
||||
+### Copyright (C) 2007-2018 VMware, Inc. All rights reserved.
|
||||
###
|
||||
### This program is free software; you can redistribute it and/or modify
|
||||
### it under the terms of version 2 of the GNU General Public License as
|
||||
@@ -22,6 +22,7 @@
|
||||
|
||||
libguestlib_la_LIBADD =
|
||||
libguestlib_la_LIBADD += @VMTOOLS_LIBS@
|
||||
+libguestlib_la_LIBADD += @XDR_LIBS@
|
||||
|
||||
libguestlib_la_SOURCES =
|
||||
libguestlib_la_SOURCES += guestlibV3_xdr.c
|
||||
@@ -56,6 +57,7 @@
|
||||
libguestlib_la_CPPFLAGS =
|
||||
libguestlib_la_CPPFLAGS += -DVMTOOLS_USE_GLIB
|
||||
libguestlib_la_CPPFLAGS += @GLIB2_CPPFLAGS@
|
||||
+libguestlib_la_CPPFLAGS += @XDR_CPPFLAGS@
|
||||
|
||||
EXTRA_DIST = vmguestlib.pc.in
|
||||
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/services/plugins/dndcp/Makefile.am open-vm-tools-10.2.5-8068406/services/plugins/dndcp/Makefile.am
|
||||
--- open-vm-tools-10.2.5-8068406.orig/services/plugins/dndcp/Makefile.am 2018-03-22 02:05:02.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/services/plugins/dndcp/Makefile.am 2018-05-09 11:08:54.693686707 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
################################################################################
|
||||
-### Copyright (C) 2009-2016 VMware, Inc. All rights reserved.
|
||||
+### Copyright (C) 2009-2018 VMware, Inc. All rights reserved.
|
||||
###
|
||||
### This program is free software; you can redistribute it and/or modify
|
||||
### it under the terms of version 2 of the GNU General Public License as
|
||||
@@ -28,6 +28,7 @@
|
||||
libdndcp_la_CPPFLAGS += -I$(top_srcdir)/services/plugins/dndcp/stringxx
|
||||
libdndcp_la_CPPFLAGS += -I$(top_srcdir)/services/plugins/dndcp/xutils
|
||||
libdndcp_la_CPPFLAGS += -I$(top_srcdir)/include
|
||||
+libdndcp_la_CPPFLAGS += @XDR_CPPFLAGS@
|
||||
|
||||
# Passing C++ related flags to CPPFLAGS generates error.
|
||||
# So, we need to pass these to C++ compilation only.
|
||||
@@ -45,6 +46,7 @@
|
||||
libdndcp_la_LIBADD += @VMTOOLS_LIBS@
|
||||
libdndcp_la_LIBADD += @HGFS_LIBS@
|
||||
libdndcp_la_LIBADD += $(top_builddir)/lib/hgfsUri/hgfsUriPosix.lo
|
||||
+libdndcp_la_LIBADD += @XDR_LIBS@
|
||||
|
||||
libdndcp_la_SOURCES =
|
||||
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/services/plugins/guestInfo/Makefile.am open-vm-tools-10.2.5-8068406/services/plugins/guestInfo/Makefile.am
|
||||
--- open-vm-tools-10.2.5-8068406.orig/services/plugins/guestInfo/Makefile.am 2018-03-22 02:05:02.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/services/plugins/guestInfo/Makefile.am 2018-05-09 11:09:40.650361114 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
################################################################################
|
||||
-### Copyright (C) 2009-2017 VMware, Inc. All rights reserved.
|
||||
+### Copyright (C) 2009-2018 VMware, Inc. All rights reserved.
|
||||
###
|
||||
### This program is free software; you can redistribute it and/or modify
|
||||
### it under the terms of version 2 of the GNU General Public License as
|
||||
@@ -22,6 +22,7 @@
|
||||
|
||||
libguestInfo_la_CPPFLAGS =
|
||||
libguestInfo_la_CPPFLAGS += @PLUGIN_CPPFLAGS@
|
||||
+libguestInfo_la_CPPFLAGS += @XDR_CPPFLAGS@
|
||||
|
||||
libguestInfo_la_LDFLAGS =
|
||||
libguestInfo_la_LDFLAGS += @PLUGIN_LDFLAGS@
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/services/plugins/resolutionKMS/resolutionKMS.c open-vm-tools-10.2.5-8068406/services/plugins/resolutionKMS/resolutionKMS.c
|
||||
--- open-vm-tools-10.2.5-8068406.orig/services/plugins/resolutionKMS/resolutionKMS.c 2018-03-22 02:05:41.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/services/plugins/resolutionKMS/resolutionKMS.c 2018-05-09 11:09:53.202894953 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
/*********************************************************
|
||||
- * Copyright (C) 2008-2017 VMware, Inc. All rights reserved.
|
||||
+ * Copyright (C) 2008-2018 VMware, Inc. All rights reserved.
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or modify it
|
||||
* under the terms of the GNU Lesser General Public License as published
|
||||
@@ -29,16 +29,13 @@
|
||||
#include <sys/stat.h>
|
||||
#include <fcntl.h>
|
||||
|
||||
+#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
|
||||
#include "vmware.h"
|
||||
-#include "debug.h"
|
||||
-#include "rpcout.h"
|
||||
-#include "str.h"
|
||||
#include "strutil.h"
|
||||
|
||||
-#include "xdrutil.h"
|
||||
#include "vmware/guestrpc/tclodefs.h"
|
||||
#include "vmware/tools/plugin.h"
|
||||
#include "vmware/tools/utils.h"
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/services/plugins/resolutionSet/resolutionSet.c open-vm-tools-10.2.5-8068406/services/plugins/resolutionSet/resolutionSet.c
|
||||
--- open-vm-tools-10.2.5-8068406.orig/services/plugins/resolutionSet/resolutionSet.c 2018-03-22 02:05:41.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/services/plugins/resolutionSet/resolutionSet.c 2018-05-09 11:09:59.737718774 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
/*********************************************************
|
||||
- * Copyright (C) 2008-2017 VMware, Inc. All rights reserved.
|
||||
+ * Copyright (C) 2008-2018 VMware, Inc. All rights reserved.
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or modify it
|
||||
* under the terms of the GNU Lesser General Public License as published
|
||||
@@ -34,7 +34,6 @@
|
||||
|
||||
#include "resolutionInt.h"
|
||||
|
||||
-#include "xdrutil.h"
|
||||
#include "vmware/guestrpc/tclodefs.h"
|
||||
#include "vmware/tools/plugin.h"
|
||||
#include "vmware/tools/utils.h"
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/services/plugins/vix/Makefile.am open-vm-tools-10.2.5-8068406/services/plugins/vix/Makefile.am
|
||||
--- open-vm-tools-10.2.5-8068406.orig/services/plugins/vix/Makefile.am 2018-03-22 02:05:02.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/services/plugins/vix/Makefile.am 2018-05-09 11:10:15.184453099 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
################################################################################
|
||||
-### Copyright (C) 2009-2016 VMware, Inc. All rights reserved.
|
||||
+### Copyright (C) 2009-2018 VMware, Inc. All rights reserved.
|
||||
###
|
||||
### This program is free software; you can redistribute it and/or modify
|
||||
### it under the terms of version 2 of the GNU General Public License as
|
||||
@@ -20,6 +20,7 @@
|
||||
|
||||
libvix_la_CPPFLAGS =
|
||||
libvix_la_CPPFLAGS += @PLUGIN_CPPFLAGS@
|
||||
+libvix_la_CPPFLAGS += @XDR_CPPFLAGS@
|
||||
libvix_la_CPPFLAGS += -I$(top_srcdir)/vgauth/public
|
||||
|
||||
libvix_la_LDFLAGS =
|
||||
@@ -32,6 +33,7 @@
|
||||
libvix_la_LIBADD += $(top_builddir)/lib/auth/libAuth.la
|
||||
libvix_la_LIBADD += $(top_builddir)/lib/foundryMsg/libFoundryMsg.la
|
||||
libvix_la_LIBADD += $(top_builddir)/lib/impersonate/libImpersonate.la
|
||||
+libvix_la_LIBADD += @XDR_LIBS@
|
||||
if ENABLE_VGAUTH
|
||||
libvix_la_LIBADD += $(top_builddir)/vgauth/lib/libvgauth.la
|
||||
endif
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/services/plugins/vix/vixTools.c open-vm-tools-10.2.5-8068406/services/plugins/vix/vixTools.c
|
||||
--- open-vm-tools-10.2.5-8068406.orig/services/plugins/vix/vixTools.c 2018-03-22 02:05:41.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/services/plugins/vix/vixTools.c 2018-05-09 00:12:44.258433002 -0700
|
||||
@@ -91,7 +91,6 @@
|
||||
#include "str.h"
|
||||
#include "file.h"
|
||||
#include "err.h"
|
||||
-#include "guestInfo.h" // MAX_VALUE_LEN
|
||||
#include "hostinfo.h"
|
||||
#include "guest_os.h"
|
||||
#include "guest_msg_def.h"
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/services/plugins/vmbackup/Makefile.am open-vm-tools-10.2.5-8068406/services/plugins/vmbackup/Makefile.am
|
||||
--- open-vm-tools-10.2.5-8068406.orig/services/plugins/vmbackup/Makefile.am 2018-03-22 02:05:02.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/services/plugins/vmbackup/Makefile.am 2018-05-09 11:10:27.959367162 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
################################################################################
|
||||
-### Copyright (C) 2009-2017 VMware, Inc. All rights reserved.
|
||||
+### Copyright (C) 2009-2018 VMware, Inc. All rights reserved.
|
||||
###
|
||||
### This program is free software; you can redistribute it and/or modify
|
||||
### it under the terms of version 2 of the GNU General Public License as
|
||||
@@ -20,6 +20,7 @@
|
||||
|
||||
libvmbackup_la_CPPFLAGS =
|
||||
libvmbackup_la_CPPFLAGS += @PLUGIN_CPPFLAGS@
|
||||
+libvmbackup_la_CPPFLAGS += @XDR_CPPFLAGS@
|
||||
|
||||
libvmbackup_la_LDFLAGS =
|
||||
libvmbackup_la_LDFLAGS += @PLUGIN_LDFLAGS@
|
||||
@@ -27,6 +28,7 @@
|
||||
libvmbackup_la_LIBADD =
|
||||
libvmbackup_la_LIBADD += @GOBJECT_LIBS@
|
||||
libvmbackup_la_LIBADD += @VMTOOLS_LIBS@
|
||||
+libvmbackup_la_LIBADD += @XDR_LIBS@
|
||||
|
||||
libvmbackup_la_SOURCES =
|
||||
libvmbackup_la_SOURCES += nullProvider.c
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/services/plugins/vmbackup/stateMachine.c open-vm-tools-10.2.5-8068406/services/plugins/vmbackup/stateMachine.c
|
||||
--- open-vm-tools-10.2.5-8068406.orig/services/plugins/vmbackup/stateMachine.c 2018-03-22 02:05:41.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/services/plugins/vmbackup/stateMachine.c 2018-05-09 10:14:03.721823229 -0700
|
||||
@@ -35,7 +35,6 @@
|
||||
|
||||
#include "vmBackupInt.h"
|
||||
|
||||
-#include "dynxdr.h"
|
||||
#include <glib-object.h>
|
||||
#include <gmodule.h>
|
||||
#include "guestApp.h"
|
||||
diff -ru open-vm-tools-10.2.5-8068406.orig/toolbox/Makefile.am open-vm-tools-10.2.5-8068406/toolbox/Makefile.am
|
||||
--- open-vm-tools-10.2.5-8068406.orig/toolbox/Makefile.am 2018-03-22 02:05:02.000000000 -0700
|
||||
+++ open-vm-tools-10.2.5-8068406/toolbox/Makefile.am 2018-05-09 11:11:30.514058368 -0700
|
||||
@@ -1,5 +1,5 @@
|
||||
################################################################################
|
||||
-### Copyright (C) 2007-2016 VMware, Inc. All rights reserved.
|
||||
+### Copyright (C) 2007-2018 VMware, Inc. All rights reserved.
|
||||
###
|
||||
### This program is free software; you can redistribute it and/or modify
|
||||
### it under the terms of version 2 of the GNU General Public License as
|
||||
@@ -20,9 +20,11 @@
|
||||
vmware_toolbox_cmd_LDADD =
|
||||
vmware_toolbox_cmd_LDADD += ../libguestlib/libguestlib.la
|
||||
vmware_toolbox_cmd_LDADD += @VMTOOLS_LIBS@
|
||||
+vmware_toolbox_cmd_LDADD += @XDR_LIBS@
|
||||
|
||||
vmware_toolbox_cmd_CPPFLAGS =
|
||||
vmware_toolbox_cmd_CPPFLAGS += @VMTOOLS_CPPFLAGS@
|
||||
+vmware_toolbox_cmd_CPPFLAGS += @XDR_CPPFLAGS@
|
||||
|
||||
vmware_toolbox_cmd_SOURCES =
|
||||
vmware_toolbox_cmd_SOURCES += toolbox-cmd.c
|
Loading…
Reference in New Issue
Block a user