import open-vm-tools-11.3.5-1.el8
This commit is contained in:
parent
d5aafbd39f
commit
8a4609a402
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/open-vm-tools-11.2.5-17337674.tar.gz
|
SOURCES/open-vm-tools-11.3.5-18557794.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
bf29ee42227601fe0c0380822fa4cd2cc0f46c55 SOURCES/open-vm-tools-11.2.5-17337674.tar.gz
|
f6990193579d96a04bfec6f09e93e0164deef71e SOURCES/open-vm-tools-11.3.5-18557794.tar.gz
|
||||||
|
@ -1,72 +0,0 @@
|
|||||||
From 46b67e93a5458ef50eebfeb6a16e1df417274003 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Cathy Avery <cavery@redhat.com>
|
|
||||||
Date: Sun, 25 Apr 2021 14:54:39 -0400
|
|
||||||
Subject: [PATCH] Fix a memory leak reported by a partner from their Coverity
|
|
||||||
scans.
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
RH-Author: Cathy Avery (cavery)
|
|
||||||
RH-MergeRequest: 3: Fix a memory leak reported by a partner from their Coverity scans.
|
|
||||||
RH-Commit: [1/1] 31c94232c885c6d902cae33720a063ab0de401ce
|
|
||||||
RH-Bugzilla: 1935807
|
|
||||||
RH-Acked-by: Mohammed Gamal <mgamal@redhat.com>
|
|
||||||
RH-Acked-by: Philippe Mathieu-Daudé <philmd@redhat.com>
|
|
||||||
|
|
||||||
commit 4f7441d8cd20923e509ff819084693bbd8c928df
|
|
||||||
Author: John Wolfe <jwolfe@vmware.com>
|
|
||||||
Date: Thu Mar 25 20:21:17 2021 -0700
|
|
||||||
|
|
||||||
Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1935807
|
|
||||||
Brew: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=36406926
|
|
||||||
Tested: Tested by QE
|
|
||||||
Upstream Status: origin/devel
|
|
||||||
Conflicts: None
|
|
||||||
|
|
||||||
Fix a memory leak reported by a partner from their Coverity scans.
|
|
||||||
|
|
||||||
Signed-off-by: Cathy Avery <cavery@redhat.com>
|
|
||||||
---
|
|
||||||
open-vm-tools/vgauth/serviceImpl/saml-xmlsec1.c | 8 +++-----
|
|
||||||
1 file changed, 3 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/open-vm-tools/vgauth/serviceImpl/saml-xmlsec1.c b/open-vm-tools/vgauth/serviceImpl/saml-xmlsec1.c
|
|
||||||
index fbadee2c..aaa5082a 100644
|
|
||||||
--- a/open-vm-tools/vgauth/serviceImpl/saml-xmlsec1.c
|
|
||||||
+++ b/open-vm-tools/vgauth/serviceImpl/saml-xmlsec1.c
|
|
||||||
@@ -1,5 +1,5 @@
|
|
||||||
/*********************************************************
|
|
||||||
- * Copyright (C) 2016-2020 VMware, Inc. All rights reserved.
|
|
||||||
+ * Copyright (C) 2016-2021 VMware, Inc. All rights reserved.
|
|
||||||
*
|
|
||||||
* This program is free software; you can redistribute it and/or modify it
|
|
||||||
* under the terms of the GNU Lesser General Public License as published
|
|
||||||
@@ -872,7 +872,6 @@ VerifySubject(xmlDocPtr doc,
|
|
||||||
xmlNodePtr nameIDNode;
|
|
||||||
xmlNodePtr child;
|
|
||||||
gchar *subjectVal = NULL;
|
|
||||||
- gboolean retCode = FALSE;
|
|
||||||
gboolean validSubjectFound = FALSE;
|
|
||||||
xmlChar *tmp;
|
|
||||||
|
|
||||||
@@ -956,14 +955,13 @@ VerifySubject(xmlDocPtr doc,
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
+done:
|
|
||||||
if (validSubjectFound && (NULL != subjectRet)) {
|
|
||||||
*subjectRet = subjectVal;
|
|
||||||
} else {
|
|
||||||
g_free(subjectVal);
|
|
||||||
}
|
|
||||||
- retCode = validSubjectFound;
|
|
||||||
-done:
|
|
||||||
- return retCode;
|
|
||||||
+ return validSubjectFound;
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
||||||
--
|
|
||||||
2.27.0
|
|
||||||
|
|
@ -19,21 +19,24 @@
|
|||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
%global _hardened_build 1
|
%global _hardened_build 1
|
||||||
%global majorversion 11.2
|
%global majorversion 11.3
|
||||||
%global minorversion 5
|
%global minorversion 5
|
||||||
%global toolsbuild 17337674
|
%global toolsbuild 18557794
|
||||||
|
|
||||||
%global toolsversion %{majorversion}.%{minorversion}
|
%global toolsversion %{majorversion}.%{minorversion}
|
||||||
%global toolsdaemon vmtoolsd
|
%global toolsdaemon vmtoolsd
|
||||||
%global vgauthdaemon vgauthd
|
%global vgauthdaemon vgauthd
|
||||||
|
|
||||||
|
%if 0%{?rhel} == 7
|
||||||
|
%global _modulesloaddir %{_prefix}/lib/modules-load.d
|
||||||
|
%endif
|
||||||
|
|
||||||
Name: open-vm-tools
|
Name: open-vm-tools
|
||||||
Version: %{toolsversion}
|
Version: %{toolsversion}
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Open Virtual Machine Tools for virtual machines hosted on VMware
|
Summary: Open Virtual Machine Tools for virtual machines hosted on VMware
|
||||||
Group: Applications/System
|
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: https://github.com/vmware/%{name}
|
URL: https://github.com/vmware/%{name}
|
||||||
|
|
||||||
Source0: https://github.com/vmware/%{name}/releases/download/stable-%{version}/%{name}-%{version}-%{toolsbuild}.tar.gz
|
Source0: https://github.com/vmware/%{name}/releases/download/stable-%{version}/%{name}-%{version}-%{toolsbuild}.tar.gz
|
||||||
Source1: %{toolsdaemon}.service
|
Source1: %{toolsdaemon}.service
|
||||||
Source2: %{vgauthdaemon}.service
|
Source2: %{vgauthdaemon}.service
|
||||||
@ -41,28 +44,27 @@ Source3: run-vmblock\x2dfuse.mount
|
|||||||
Source4: open-vm-tools.conf
|
Source4: open-vm-tools.conf
|
||||||
Source5: vmtoolsd.pam
|
Source5: vmtoolsd.pam
|
||||||
|
|
||||||
# For bz#1935807 - [ESXi][RHEL-8.5][open-vm-tools] Coverity detected an important defect in open-vm-tools-11.2.5 rebase
|
|
||||||
Patch1: ovt-Fix-a-memory-leak-reported-by-a-partner-from-their-C.patch
|
|
||||||
|
|
||||||
|
%if 0%{?rhel} >= 7
|
||||||
ExclusiveArch: x86_64
|
ExclusiveArch: x86_64
|
||||||
|
%else
|
||||||
|
ExclusiveArch: %{ix86} x86_64 aarch64
|
||||||
|
%endif
|
||||||
|
|
||||||
|
|
||||||
BuildRequires: make
|
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
|
BuildRequires: make
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: doxygen
|
BuildRequires: doxygen
|
||||||
# Fuse is optional and enables vmblock-fuse
|
# Fuse is optional and enables vmblock-fuse
|
||||||
BuildRequires: fuse-devel
|
BuildRequires: fuse-devel
|
||||||
BuildRequires: glib2-devel >= 2.14.0
|
BuildRequires: glib2-devel >= 2.14.0
|
||||||
BuildRequires: gdk-pixbuf2-xlib-devel
|
|
||||||
BuildRequires: gtk3-devel >= 3.10.0
|
|
||||||
BuildRequires: gtkmm30-devel >= 3.10.0
|
|
||||||
BuildRequires: libicu-devel
|
BuildRequires: libicu-devel
|
||||||
BuildRequires: libmspack-devel
|
BuildRequires: libmspack-devel
|
||||||
# Unfortunately, xmlsec1-openssl does not add libtool-ltdl
|
# Unfortunately, xmlsec1-openssl does not add libtool-ltdl dependency, so we
|
||||||
# dependency, so we need to add it ourselves.
|
# need to add it ourselves.
|
||||||
BuildRequires: libtool-ltdl-devel
|
BuildRequires: libtool-ltdl-devel
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
BuildRequires: libXext-devel
|
BuildRequires: libXext-devel
|
||||||
@ -73,30 +75,40 @@ BuildRequires: libXrender-devel
|
|||||||
BuildRequires: libXtst-devel
|
BuildRequires: libXtst-devel
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
BuildRequires: pam-devel
|
BuildRequires: pam-devel
|
||||||
|
BuildRequires: pkgconfig(libdrm)
|
||||||
|
BuildRequires: pkgconfig(libudev)
|
||||||
BuildRequires: procps-devel
|
BuildRequires: procps-devel
|
||||||
BuildRequires: rpcgen
|
|
||||||
BuildRequires: systemd
|
|
||||||
BuildRequires: libtirpc-devel
|
|
||||||
BuildRequires: xmlsec1-openssl-devel
|
BuildRequires: xmlsec1-openssl-devel
|
||||||
|
|
||||||
|
%if 0%{?fedora} || 0%{?rhel} >= 8
|
||||||
|
BuildRequires: gdk-pixbuf2-xlib-devel
|
||||||
|
BuildRequires: gtk3-devel >= 3.10.0
|
||||||
|
BuildRequires: gtkmm30-devel >= 3.10.0
|
||||||
|
BuildRequires: libtirpc-devel
|
||||||
|
BuildRequires: rpcgen
|
||||||
|
BuildRequires: systemd-rpm-macros
|
||||||
|
%else
|
||||||
|
BuildRequires: gtk2-devel >= 2.4.0
|
||||||
|
BuildRequires: gtkmm24-devel
|
||||||
|
BuildRequires: systemd
|
||||||
|
%endif
|
||||||
|
|
||||||
Requires: coreutils
|
Requires: coreutils
|
||||||
Requires: fuse
|
Requires: fuse
|
||||||
Requires: libdrm
|
|
||||||
Requires: iproute
|
Requires: iproute
|
||||||
Requires: grep
|
Requires: grep
|
||||||
Requires: pciutils
|
Requires: pciutils
|
||||||
Requires: sed
|
Requires: sed
|
||||||
Requires: systemd
|
Requires: systemd
|
||||||
Requires: systemd-libs
|
|
||||||
Requires: tar
|
Requires: tar
|
||||||
Requires: util-linux
|
Requires: util-linux
|
||||||
Requires: which
|
Requires: which
|
||||||
# xmlsec1-openssl needs to be added explicitly
|
# xmlsec1-openssl needs to be added explicitly
|
||||||
Requires: xmlsec1-openssl
|
Requires: xmlsec1-openssl
|
||||||
|
|
||||||
# open-vm-tools >= 10.0.0 do not require open-vm-tools-deploypkg
|
# open-vm-tools >= 10.0.0 do not require open-vm-tools-deploypkg provided by
|
||||||
# provided by VMware. That functionality is now available as part
|
# VMware. That functionality is now available as part of open-vm-tools package
|
||||||
# of open-vm-tools package itself.
|
# itself.
|
||||||
Obsoletes: open-vm-tools-deploypkg <= 10.0.5
|
Obsoletes: open-vm-tools-deploypkg <= 10.0.5
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -108,7 +120,6 @@ This package contains only the core user-space programs and libraries of
|
|||||||
|
|
||||||
%package desktop
|
%package desktop
|
||||||
Summary: User experience components for Open Virtual Machine Tools
|
Summary: User experience components for Open Virtual Machine Tools
|
||||||
Group: System Environment/Libraries
|
|
||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
%description desktop
|
%description desktop
|
||||||
@ -118,7 +129,6 @@ machines.
|
|||||||
|
|
||||||
%package sdmp
|
%package sdmp
|
||||||
Summary: Service Discovery components for Open Virtual Machine Tools
|
Summary: Service Discovery components for Open Virtual Machine Tools
|
||||||
Group: Development/Libraries
|
|
||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
Requires: coreutils
|
Requires: coreutils
|
||||||
Requires: gawk
|
Requires: gawk
|
||||||
@ -129,12 +139,11 @@ Requires: procps
|
|||||||
|
|
||||||
%description sdmp
|
%description sdmp
|
||||||
This package contains only the user-space programs and utility scripts of
|
This package contains only the user-space programs and utility scripts of
|
||||||
%{name} that are essential for performing service discovery in VMware virtual
|
%{name} that are essential for performing service discovery in VMware
|
||||||
machines by vRealize Operations Service Discovery Management Pack.
|
virtual machines by vRealize Operations Service Discovery Management Pack.
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Development libraries for Open Virtual Machine Tools
|
Summary: Development libraries for Open Virtual Machine Tools
|
||||||
Group: Development/Libraries
|
|
||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
@ -144,7 +153,6 @@ VMware virtual machines.
|
|||||||
|
|
||||||
%package test
|
%package test
|
||||||
Summary: Test utilities for Open Virtual Machine Tools
|
Summary: Test utilities for Open Virtual Machine Tools
|
||||||
Group: Development/Libraries
|
|
||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
%description test
|
%description test
|
||||||
@ -156,18 +164,22 @@ machines.
|
|||||||
%autosetup -p2 -n %{name}-%{version}-%{toolsbuild}
|
%autosetup -p2 -n %{name}-%{version}-%{toolsbuild}
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Required for regenerating configure script when
|
|
||||||
# configure.ac get modified
|
|
||||||
autoreconf -vif
|
autoreconf -vif
|
||||||
|
|
||||||
%global usetirpc with-tirpc
|
|
||||||
|
|
||||||
%configure \
|
%configure \
|
||||||
--without-kernel-modules \
|
--without-kernel-modules \
|
||||||
--enable-xmlsec1 \
|
--enable-xmlsec1 \
|
||||||
--enable-resolutionkms \
|
--enable-resolutionkms \
|
||||||
--enable-servicediscovery \
|
--enable-servicediscovery \
|
||||||
--%{usetirpc} \
|
%if 0%{?fedora} || 0%{?rhel} >= 8
|
||||||
|
--with-tirpc \
|
||||||
|
--without-gtk2 \
|
||||||
|
--without-gtkmm \
|
||||||
|
%else
|
||||||
|
--without-tirpc \
|
||||||
|
--without-gtk3 \
|
||||||
|
--without-gtkmm3 \
|
||||||
|
%endif
|
||||||
--disable-static
|
--disable-static
|
||||||
|
|
||||||
sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool
|
sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool
|
||||||
@ -206,12 +218,11 @@ install -p -m 644 -D '%{SOURCE3}' %{buildroot}%{_unitdir}/run-vmblock\\x2dfuse.m
|
|||||||
install -p -m 644 -D %{SOURCE4} %{buildroot}%{_modulesloaddir}/open-vm-tools.conf
|
install -p -m 644 -D %{SOURCE4} %{buildroot}%{_modulesloaddir}/open-vm-tools.conf
|
||||||
install -p -m 644 -D %{SOURCE5} %{buildroot}%{_sysconfdir}/pam.d/vmtoolsd
|
install -p -m 644 -D %{SOURCE5} %{buildroot}%{_sysconfdir}/pam.d/vmtoolsd
|
||||||
|
|
||||||
# 'make check' in open-vm-tools rebuilds docs and ends up regenerating
|
# 'make check' in open-vm-tools rebuilds docs and ends up regenerating the font
|
||||||
# the font file. We can add %%check secion once 'make check' is fixed
|
# file. We can add %%check secion once 'make check' is fixed upstream.
|
||||||
# upstream
|
|
||||||
|
|
||||||
%post
|
%post
|
||||||
%{?ldconfig}
|
%?ldconfig
|
||||||
# Setup mount point for Shared Folders
|
# Setup mount point for Shared Folders
|
||||||
# NOTE: Use systemd-detect-virt to detect VMware platform because
|
# NOTE: Use systemd-detect-virt to detect VMware platform because
|
||||||
# vmware-checkvm might misbehave on non-VMware platforms.
|
# vmware-checkvm might misbehave on non-VMware platforms.
|
||||||
@ -236,11 +247,19 @@ if [ "$1" = "2" ]; then
|
|||||||
# Cleanup vmtoolsd-init.service in case of upgrades
|
# Cleanup vmtoolsd-init.service in case of upgrades
|
||||||
%{_bindir}/systemctl disable %{toolsdaemon}-init.service &> /dev/null || /bin/true
|
%{_bindir}/systemctl disable %{toolsdaemon}-init.service &> /dev/null || /bin/true
|
||||||
fi
|
fi
|
||||||
%systemd_post %{vgauthdaemon}.service
|
%systemd_post %{vgauthdaemon}.service %{toolsdaemon}.service
|
||||||
%systemd_post %{toolsdaemon}.service
|
|
||||||
|
|
||||||
%post desktop
|
%post desktop
|
||||||
%systemd_post run-vmblock\x2dfuse.mount
|
%systemd_post run-vmblock\\x2dfuse.mount
|
||||||
|
# Need to enable the service as it is not enabled by default.
|
||||||
|
# Enabling an already-enabled service is not an error. So, we can perform this
|
||||||
|
# step everytime during the post-install.
|
||||||
|
if [ -f %{_bindir}/vmware-checkvm ] && \
|
||||||
|
%{_bindir}/systemd-detect-virt | grep -iq VMware && \
|
||||||
|
%{_bindir}/vmware-checkvm &> /dev/null && \
|
||||||
|
%{_bindir}/vmware-checkvm -p | grep -q Workstation; then
|
||||||
|
%{_bindir}/systemctl enable run-vmblock\\x2dfuse.mount &> /dev/null || /bin/true
|
||||||
|
fi
|
||||||
|
|
||||||
%post sdmp
|
%post sdmp
|
||||||
# Load the newly installed or upgraded SDMP plugin
|
# Load the newly installed or upgraded SDMP plugin
|
||||||
@ -249,8 +268,8 @@ if %{_bindir}/systemctl is-active %{toolsdaemon}.service &> /dev/null; then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%preun
|
%preun
|
||||||
%systemd_preun %{toolsdaemon}.service
|
%?ldconfig
|
||||||
%systemd_preun %{vgauthdaemon}.service
|
%systemd_preun %{toolsdaemon}.service %{vgauthdaemon}.service
|
||||||
|
|
||||||
if [ "$1" = "0" -a \
|
if [ "$1" = "0" -a \
|
||||||
-f %{_bindir}/vmware-checkvm ] && \
|
-f %{_bindir}/vmware-checkvm ] && \
|
||||||
@ -271,15 +290,14 @@ if [ "$1" = "0" -a \
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%preun desktop
|
%preun desktop
|
||||||
%systemd_preun run-vmblock\x2dfuse.mount
|
%systemd_preun run-vmblock\\x2dfuse.mount
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
%{?ldconfig}
|
%?ldconfig
|
||||||
%systemd_postun_with_restart %{toolsdaemon}.service
|
%systemd_postun_with_restart %{toolsdaemon}.service %{vgauthdaemon}.service
|
||||||
%systemd_postun_with_restart %{vgauthdaemon}.service
|
|
||||||
|
|
||||||
%postun desktop
|
%postun desktop
|
||||||
%systemd_postun run-vmblock\x2dfuse.mount
|
%systemd_postun run-vmblock\\x2dfuse.mount
|
||||||
|
|
||||||
%postun sdmp
|
%postun sdmp
|
||||||
# In case of uninstall, unload the uninstalled SDMP plugin
|
# In case of uninstall, unload the uninstalled SDMP plugin
|
||||||
@ -307,6 +325,7 @@ fi
|
|||||||
%{_bindir}/vm-support
|
%{_bindir}/vm-support
|
||||||
%{_bindir}/vmhgfs-fuse
|
%{_bindir}/vmhgfs-fuse
|
||||||
%{_bindir}/vmtoolsd
|
%{_bindir}/vmtoolsd
|
||||||
|
%{_bindir}/vmware-alias-import
|
||||||
%{_bindir}/vmware-checkvm
|
%{_bindir}/vmware-checkvm
|
||||||
%{_bindir}/vmware-hgfsclient
|
%{_bindir}/vmware-hgfsclient
|
||||||
%{_bindir}/vmware-namespace-cmd
|
%{_bindir}/vmware-namespace-cmd
|
||||||
@ -316,6 +335,7 @@ fi
|
|||||||
%{_bindir}/vmware-xferlogs
|
%{_bindir}/vmware-xferlogs
|
||||||
%{_libdir}/libDeployPkg.so.*
|
%{_libdir}/libDeployPkg.so.*
|
||||||
%{_libdir}/libguestlib.so.*
|
%{_libdir}/libguestlib.so.*
|
||||||
|
%{_libdir}/libguestStoreClient.so.*
|
||||||
%{_libdir}/libhgfs.so.*
|
%{_libdir}/libhgfs.so.*
|
||||||
%{_libdir}/libvgauth.so.*
|
%{_libdir}/libvgauth.so.*
|
||||||
%{_libdir}/libvmtools.so.*
|
%{_libdir}/libvmtools.so.*
|
||||||
@ -326,7 +346,9 @@ fi
|
|||||||
%dir %{_libdir}/%{name}/plugins/vmsvc
|
%dir %{_libdir}/%{name}/plugins/vmsvc
|
||||||
%{_libdir}/%{name}/plugins/vmsvc/libappInfo.so
|
%{_libdir}/%{name}/plugins/vmsvc/libappInfo.so
|
||||||
%{_libdir}/%{name}/plugins/vmsvc/libdeployPkgPlugin.so
|
%{_libdir}/%{name}/plugins/vmsvc/libdeployPkgPlugin.so
|
||||||
|
%{_libdir}/%{name}/plugins/vmsvc/libgdp.so
|
||||||
%{_libdir}/%{name}/plugins/vmsvc/libguestInfo.so
|
%{_libdir}/%{name}/plugins/vmsvc/libguestInfo.so
|
||||||
|
%{_libdir}/%{name}/plugins/vmsvc/libguestStore.so
|
||||||
%{_libdir}/%{name}/plugins/vmsvc/libpowerOps.so
|
%{_libdir}/%{name}/plugins/vmsvc/libpowerOps.so
|
||||||
%{_libdir}/%{name}/plugins/vmsvc/libresolutionKMS.so
|
%{_libdir}/%{name}/plugins/vmsvc/libresolutionKMS.so
|
||||||
%{_libdir}/%{name}/plugins/vmsvc/libtimeSync.so
|
%{_libdir}/%{name}/plugins/vmsvc/libtimeSync.so
|
||||||
@ -336,16 +358,16 @@ fi
|
|||||||
%{_udevrulesdir}/99-vmware-scsi-udev.rules
|
%{_udevrulesdir}/99-vmware-scsi-udev.rules
|
||||||
%{_unitdir}/%{toolsdaemon}.service
|
%{_unitdir}/%{toolsdaemon}.service
|
||||||
%{_unitdir}/%{vgauthdaemon}.service
|
%{_unitdir}/%{vgauthdaemon}.service
|
||||||
%{_unitdir}/run-vmblock\x2dfuse.mount
|
|
||||||
%{_modulesloaddir}/open-vm-tools.conf
|
%{_modulesloaddir}/open-vm-tools.conf
|
||||||
|
|
||||||
|
|
||||||
%files desktop
|
%files desktop
|
||||||
%{_sysconfdir}/xdg/autostart/*.desktop
|
%{_sysconfdir}/xdg/autostart/*.desktop
|
||||||
%{_bindir}/vmware-user
|
%{_bindir}/vmware-user
|
||||||
|
%{_bindir}/vmwgfxctrl
|
||||||
%attr(4755,-,-) %{_bindir}/vmware-user-suid-wrapper
|
%attr(4755,-,-) %{_bindir}/vmware-user-suid-wrapper
|
||||||
%{_bindir}/vmware-vmblock-fuse
|
%{_bindir}/vmware-vmblock-fuse
|
||||||
%{_libdir}/%{name}/plugins/vmusr/
|
%{_libdir}/%{name}/plugins/vmusr/
|
||||||
|
%{_unitdir}/run-vmblock\x2dfuse.mount
|
||||||
|
|
||||||
%files sdmp
|
%files sdmp
|
||||||
%{_libdir}/%{name}/plugins/vmsvc/libserviceDiscovery.so
|
%{_libdir}/%{name}/plugins/vmsvc/libserviceDiscovery.so
|
||||||
@ -358,6 +380,7 @@ fi
|
|||||||
%{_libdir}/pkgconfig/*.pc
|
%{_libdir}/pkgconfig/*.pc
|
||||||
%{_libdir}/libDeployPkg.so
|
%{_libdir}/libDeployPkg.so
|
||||||
%{_libdir}/libguestlib.so
|
%{_libdir}/libguestlib.so
|
||||||
|
%{_libdir}/libguestStoreClient.so
|
||||||
%{_libdir}/libhgfs.so
|
%{_libdir}/libhgfs.so
|
||||||
%{_libdir}/libvgauth.so
|
%{_libdir}/libvgauth.so
|
||||||
%{_libdir}/libvmtools.so
|
%{_libdir}/libvmtools.so
|
||||||
@ -366,6 +389,16 @@ fi
|
|||||||
%{_bindir}/vmware-vgauth-smoketest
|
%{_bindir}/vmware-vgauth-smoketest
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 18 2021 Miroslav Rezanian <mrezanin@redhat.com> - 11.3.5-1.el9
|
||||||
|
- Rebase to open-vm-tools 11.3.5 [bz#2008244]
|
||||||
|
- Resolves: bz#2008244
|
||||||
|
([ESXi][RHEL8]Open-vm-tools release 11.3.5 has been released - please rebase)
|
||||||
|
|
||||||
|
* Thu Sep 23 2021 Miroslav Rezanina <mrezanin@redhat.com> - 11.3.0-1.el8
|
||||||
|
- Rebase to open-vm-tools 11.3.0 [bz#1974468]
|
||||||
|
- Resolves: bz#1974468
|
||||||
|
([ESXi][RHEL8]Open-vm-tools release 11.3.0 has been released - please rebase)
|
||||||
|
|
||||||
* Thu Apr 29 2021 Miroslav Rezanina <mrezanin@redhat.com> - 11.2.5-2.el8
|
* Thu Apr 29 2021 Miroslav Rezanina <mrezanin@redhat.com> - 11.2.5-2.el8
|
||||||
- ovt-Fix-a-memory-leak-reported-by-a-partner-from-their-C.patch [bz#1935807]
|
- ovt-Fix-a-memory-leak-reported-by-a-partner-from-their-C.patch [bz#1935807]
|
||||||
- Resolves: bz#1935807
|
- Resolves: bz#1935807
|
||||||
@ -373,7 +406,6 @@ fi
|
|||||||
|
|
||||||
* Tue Mar 02 2021 Miroslav Rezanina <mrezanin@redhat.com> - 11.2.5-1.el8
|
* Tue Mar 02 2021 Miroslav Rezanina <mrezanin@redhat.com> - 11.2.5-1.el8
|
||||||
- Rebase to 11.2.5 [bz#1916561]
|
- Rebase to 11.2.5 [bz#1916561]
|
||||||
- Resolves: bz#1916561
|
|
||||||
([ESXi][RHEL8.5]Open-vm-tools update release 11.2.5 has been released)
|
([ESXi][RHEL8.5]Open-vm-tools update release 11.2.5 has been released)
|
||||||
|
|
||||||
* Tue Dec 01 2020 Miroslav Rezanina <mrezanin@redhat.com> - 11.2.0-2.el8
|
* Tue Dec 01 2020 Miroslav Rezanina <mrezanin@redhat.com> - 11.2.0-2.el8
|
||||||
|
Loading…
Reference in New Issue
Block a user