Update SPEC file

This commit is contained in:
Simone Caronni 2018-10-01 13:22:52 +02:00
parent 6296e846e8
commit 4f1758de53
2 changed files with 20 additions and 19 deletions

View File

@ -1,7 +1,7 @@
diff --git a/open-vm-tools/libDeployPkg/linuxDeployment.c b/open-vm-tools/libDeployPkg/linuxDeployment.c
diff --git a/libDeployPkg/linuxDeployment.c b/libDeployPkg/linuxDeployment.c
index 996f184c..34c8b956 100644
--- a/open-vm-tools/libDeployPkg/linuxDeployment.c
+++ b/open-vm-tools/libDeployPkg/linuxDeployment.c
--- a/libDeployPkg/linuxDeployment.c
+++ b/libDeployPkg/linuxDeployment.c
@@ -139,7 +139,7 @@ static bool CopyFileToDirectory(const char* srcPath, const char* destPath,
const char* fileName);
static DeployPkgStatus Deploy(const char* pkgName);
@ -163,10 +163,10 @@ index 996f184c..34c8b956 100644
Process_Destroy(hp);
return retval;
}
diff --git a/open-vm-tools/libDeployPkg/linuxDeploymentUtilities.c b/open-vm-tools/libDeployPkg/linuxDeploymentUtilities.c
diff --git a/libDeployPkg/linuxDeploymentUtilities.c b/libDeployPkg/linuxDeploymentUtilities.c
index 83f942da..93e1b0aa 100644
--- a/open-vm-tools/libDeployPkg/linuxDeploymentUtilities.c
+++ b/open-vm-tools/libDeployPkg/linuxDeploymentUtilities.c
--- a/libDeployPkg/linuxDeploymentUtilities.c
+++ b/libDeployPkg/linuxDeploymentUtilities.c
@@ -1,5 +1,5 @@
/*********************************************************
- * Copyright (C) 2016-2017 VMware, Inc. All rights reserved.

View File

@ -28,15 +28,16 @@
Name: open-vm-tools
Version: %{toolsversion}
Release: 4%{?dist}
Release: 5%{?dist}
Summary: Open Virtual Machine Tools for virtual machines hosted on VMware
Group: Applications/System
License: GPLv2
URL: https://github.com/vmware/%{name}
Source0: https://github.com/vmware/%{name}/releases/download/stable-%{version}/%{name}-%{version}-%{toolsbuild}.tar.gz
Source1: %{toolsdaemon}-init.service
Source2: %{toolsdaemon}.service
Source3: %{vgauthdaemon}.service
%if 0%{?rhel} >= 7
ExclusiveArch: x86_64
%else
@ -120,7 +121,6 @@ This package contains only the core user-space programs and libraries of
%package desktop
Summary: User experience components for Open Virtual Machine Tools
Group: System Environment/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
%description desktop
@ -130,7 +130,6 @@ machines.
%package devel
Summary: Development libraries for Open Virtual Machine Tools
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
@ -140,7 +139,6 @@ VMware virtual machines.
%package test
Summary: Test utilities for Open Virtual Machine Tools
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
%description test
@ -149,15 +147,12 @@ useful for verifying the functioning of %{name} in VMware virtual
machines.
%prep
%setup -q -n %{name}-%{version}-%{toolsbuild}
%patch1 -p2
%patch2 -p1
%autosetup -p1 -n %{name}-%{version}-%{toolsbuild}
%build
# Required for regenerating configure script when
# configure.ac get modified
autoreconf -i
autoconf
autoreconf -vif
%if 0%{?fedora} >= 28
%global usetirpc with-tirpc
@ -173,11 +168,11 @@ autoconf
--disable-static
sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool
make %{?_smp_mflags}
%make_build
%install
export DONT_STRIP=1
make install DESTDIR=%{buildroot}
%make_install
# Remove exec bit from config files
chmod a-x %{buildroot}%{_sysconfdir}/pam.d/*
@ -214,6 +209,7 @@ install -p -m 644 -D %{SOURCE3} %{buildroot}%{_unitdir}/%{vgauthdaemon}.service
# upstream
%post
%{?ldconfig}
# Setup mount point for Shared Folders
# NOTE: Use systemd-detect-virt to detect VMware platform because
# vmware-checkvm might misbehave on non-VMware platforms.
@ -257,12 +253,12 @@ if [ "$1" = "0" -a \
fi
%postun
%{?ldconfig}
%systemd_postun_with_restart %{toolsdaemon}-init.service
%systemd_postun_with_restart %{toolsdaemon}.service
%systemd_postun_with_restart %{vgauthdaemon}.service
%files
%{!?_licensedir:%global license %%doc}
%license COPYING
%doc AUTHORS ChangeLog NEWS README
%config(noreplace) %{_sysconfdir}/pam.d/*
@ -326,6 +322,11 @@ fi
%{_bindir}/vmware-vgauth-smoketest
%changelog
* Mon Oct 01 2018 Simone Caronni <negativo17@gmail.com> - 10.3.0-5
- Update SPEC file to match packaging guidelines.
- Re-add ldconfig scriptlets. They expand to nothing in Fedora 28+, but they
are still required for Fedora 27. These can be removed when Fedora 27 is EOL.
* Fri Aug 10 2018 Ravindra Kumar <ravindrakumar@vmware.com> - 10.3.0-4
- Fixed few bugs related to vmtoolsd-init.service.