73 lines
2.5 KiB
RPMSpec
73 lines
2.5 KiB
RPMSpec
%global fontname open-sans
|
|
%global fontconf 60-%{fontname}.conf
|
|
|
|
Name: %{fontname}-fonts
|
|
Version: 1.10
|
|
Release: 6%{?dist}
|
|
Summary: Open Sans is a humanist sans-serif typeface designed by Steve Matteson
|
|
|
|
License: ASL 2.0
|
|
URL: http://www.google.com/fonts/specimen/Open+Sans
|
|
|
|
# Since the font doesn't have clear upstream, the source zip package is
|
|
# downloaded from Google Fonts. It is then converted to tar.gz. All by
|
|
# getopensans.sh.
|
|
Source0: %{name}-%{version}.tar.xz
|
|
Source1: %{name}-fontconfig.conf
|
|
Source2: getopensans.sh
|
|
|
|
BuildArch: noarch
|
|
BuildRequires: fontpackages-devel
|
|
BuildRequires: ttembed
|
|
Requires: fontpackages-filesystem
|
|
|
|
%description
|
|
Open Sans is a humanist sans serif typeface designed by Steve Matteson, Type
|
|
Director of Ascender Corp. This version contains the complete 897 character
|
|
set, which includes the standard ISO Latin 1, Latin CE, Greek and Cyrillic
|
|
character sets. Open Sans was designed with an upright stress, open forms and
|
|
a neutral, yet friendly appearance. It was optimized for print, web, and mobile
|
|
interfaces, and has excellent legibility characteristics in its letter forms.
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
# set Embedding permission to 'Installable'
|
|
ls *.ttf | xargs ttembed
|
|
|
|
%install
|
|
install -m 0755 -d %{buildroot}%{_fontdir}
|
|
install -m 0644 -p *.ttf %{buildroot}%{_fontdir}
|
|
|
|
install -m 0755 -d %{buildroot}%{_fontconfig_templatedir} \
|
|
%{buildroot}%{_fontconfig_confdir}
|
|
|
|
install -m 0644 -p %{SOURCE1} \
|
|
%{buildroot}%{_fontconfig_templatedir}/%{fontconf}
|
|
|
|
ln -s %{_fontconfig_templatedir}/%{fontconf} \
|
|
%{buildroot}%{_fontconfig_confdir}/%{fontconf}
|
|
|
|
%_font_pkg -f %{fontconf} *.ttf
|
|
%doc LICENSE.txt
|
|
|
|
%changelog
|
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.10-6
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
|
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.10-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
|
|
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.10-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
|
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
|
|
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
|
|
|
* Tue Nov 26 2013 Petr Vobornik <pvoborni@redhat.com> - 1.10-1
|
|
- initial package
|