diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..a561756
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/open-sans-fonts-1.10.tar.xz
diff --git a/EMPTY b/EMPTY
deleted file mode 100644
index 0519ecb..0000000
--- a/EMPTY
+++ /dev/null
@@ -1 +0,0 @@
-
\ No newline at end of file
diff --git a/getopensans.sh b/getopensans.sh
new file mode 100755
index 0000000..3bf1a69
--- /dev/null
+++ b/getopensans.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+# Get upstream zip and make source tar.gz
+
+ARCHIVE="open-sans-fonts-1.10"
+TMPDIR=$(mktemp -d --tmpdir=/var/tmp getopensans-XXXXXXXXXX)
+[ $? != 0 ] && exit 1
+umask 022
+pushd "$TMPDIR"
+
+wget -N -O $ARCHIVE.zip http://www.google.com/fonts/download?kit=3hvsV99qyKCBS55e5pvb3ltkqrIMaAZWyLYEoB48lSQ
+unzip $ARCHIVE.zip -d $ARCHIVE
+tar -cvJf "$ARCHIVE.tar.xz" $ARCHIVE
+
+popd
+mv "$TMPDIR/$ARCHIVE.tar.xz" .
+rm -fr "$TMPDIR"
\ No newline at end of file
diff --git a/open-sans-fonts-fontconfig.conf b/open-sans-fonts-fontconfig.conf
new file mode 100644
index 0000000..048b45e
--- /dev/null
+++ b/open-sans-fonts-fontconfig.conf
@@ -0,0 +1,16 @@
+
+
+
+
+ Open Sans
+
+ sans-serif
+
+
+
+ sans-serif
+
+ Open Sans
+
+
+
diff --git a/open-sans-fonts.spec b/open-sans-fonts.spec
new file mode 100644
index 0000000..96f2b90
--- /dev/null
+++ b/open-sans-fonts.spec
@@ -0,0 +1,72 @@
+%global fontname open-sans
+%global fontconf 60-%{fontname}.conf
+
+Name: %{fontname}-fonts
+Version: 1.10
+Release: 6%{?dist}
+Summary: Open Sans is a humanist sans-serif typeface designed by Steve Matteson
+
+License: ASL 2.0
+URL: http://www.google.com/fonts/specimen/Open+Sans
+
+# Since the font doesn't have clear upstream, the source zip package is
+# downloaded from Google Fonts. It is then converted to tar.gz. All by
+# getopensans.sh.
+Source0: %{name}-%{version}.tar.xz
+Source1: %{name}-fontconfig.conf
+Source2: getopensans.sh
+
+BuildArch: noarch
+BuildRequires: fontpackages-devel
+BuildRequires: ttembed
+Requires: fontpackages-filesystem
+
+%description
+Open Sans is a humanist sans serif typeface designed by Steve Matteson, Type
+Director of Ascender Corp. This version contains the complete 897 character
+set, which includes the standard ISO Latin 1, Latin CE, Greek and Cyrillic
+character sets. Open Sans was designed with an upright stress, open forms and
+a neutral, yet friendly appearance. It was optimized for print, web, and mobile
+interfaces, and has excellent legibility characteristics in its letter forms.
+
+%prep
+%setup -q
+
+%build
+# set Embedding permission to 'Installable'
+ls *.ttf | xargs ttembed
+
+%install
+install -m 0755 -d %{buildroot}%{_fontdir}
+install -m 0644 -p *.ttf %{buildroot}%{_fontdir}
+
+install -m 0755 -d %{buildroot}%{_fontconfig_templatedir} \
+ %{buildroot}%{_fontconfig_confdir}
+
+install -m 0644 -p %{SOURCE1} \
+ %{buildroot}%{_fontconfig_templatedir}/%{fontconf}
+
+ln -s %{_fontconfig_templatedir}/%{fontconf} \
+ %{buildroot}%{_fontconfig_confdir}/%{fontconf}
+
+%_font_pkg -f %{fontconf} *.ttf
+%doc LICENSE.txt
+
+%changelog
+* Thu Jul 27 2017 Fedora Release Engineering - 1.10-6
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
+
+* Sat Feb 11 2017 Fedora Release Engineering - 1.10-5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
+
+* Thu Feb 04 2016 Fedora Release Engineering - 1.10-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
+
+* Wed Jun 17 2015 Fedora Release Engineering - 1.10-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
+
+* Sat Jun 07 2014 Fedora Release Engineering - 1.10-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
+
+* Tue Nov 26 2013 Petr Vobornik - 1.10-1
+- initial package
diff --git a/sources b/sources
new file mode 100644
index 0000000..bf26da7
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+SHA512 (open-sans-fonts-1.10.tar.xz) = 7e49f5ec6eeb6f7c95ca28ec9ebf170b126e1d1e07bc42a15029374ecb594756a7cf130d1da435f28df37e1385e183ccc07f08dd0f0dd468b830cdccd33c0b71