26 lines
772 B
Diff
26 lines
772 B
Diff
commit 6278c6df4ff2123725efc10e5e6ea48d02fda55a
|
|
Author: Dan Horák <dan@danny.cz>
|
|
Date: Mon Aug 10 12:59:04 2020 +0200
|
|
|
|
external/ffspart: define $(sbindir) for Makefile
|
|
|
|
Right now the $(sbindir) variable isn't defined, so the binary gets installed
|
|
directly into $(DESTDIR).
|
|
|
|
Signed-off-by: Dan Horák <dan@danny.cz>
|
|
|
|
diff --git a/external/ffspart/rules.mk b/external/ffspart/rules.mk
|
|
index 40972c688..e006dc5b7 100644
|
|
--- a/external/ffspart/rules.mk
|
|
+++ b/external/ffspart/rules.mk
|
|
@@ -10,6 +10,9 @@ LIBFLASH_SRC := $(addprefix libflash/,$(LIBFLASH_FILES))
|
|
OBJS += $(LIBFLASH_OBJS)
|
|
OBJS += common-arch_flash.o
|
|
|
|
+prefix = /usr/local/
|
|
+sbindir = $(prefix)/sbin
|
|
+
|
|
CC = $(CROSS_COMPILE)gcc
|
|
|
|
FFSPART_VERSION ?= $(shell ./make_version.sh $(EXE))
|