4f4f4996df
Package review completed and Dan has approved the package (#1284527). Lets import package to fedora repo. Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
33 lines
1.0 KiB
Diff
33 lines
1.0 KiB
Diff
From e290a55cb40d2f53a9cfcc445d0b98a487a3f4a0 Mon Sep 17 00:00:00 2001
|
|
From: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
|
Date: Tue, 23 Feb 2016 20:01:41 +0530
|
|
Subject: [PATCH] external/opal-prd: Make compilation prerequisites as
|
|
order-only prerequisites
|
|
|
|
Makefile creates symbolic link to libflash, ccan, etc. Presently we added them
|
|
as normal prerequisites. In some cases (like we compile skiboot after compiling
|
|
opal-prd) it will result in recompiling source again during make install. Hence
|
|
make it as order-only prerequisites.
|
|
|
|
Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
|
---
|
|
external/opal-prd/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/external/opal-prd/Makefile b/external/opal-prd/Makefile
|
|
index 98c7b48..3f34371 100644
|
|
--- a/external/opal-prd/Makefile
|
|
+++ b/external/opal-prd/Makefile
|
|
@@ -52,7 +52,7 @@ asm/opal-prd.h:
|
|
$(Q_LN)ln -sfr $(KERNEL_DIR)/arch/powerpc/include/uapi/asm/opal-prd.h \
|
|
asm/opal-prd.h
|
|
|
|
-$(OBJS): $(LINKS)
|
|
+$(OBJS): | $(LINKS)
|
|
|
|
%.o: %.c
|
|
$(Q_CC)$(COMPILE.c) $< -o $@
|
|
--
|
|
2.5.0
|
|
|