- Fixed opal-prd crash
- Fixed annocheck distro flag failures
This commit is contained in:
parent
8358aa16bb
commit
f3308871f7
@ -2,7 +2,7 @@
|
||||
|
||||
Name: opal-prd
|
||||
Version: 6.1
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: OPAL Processor Recovery Diagnostics Daemon
|
||||
|
||||
Group: System Environment/Daemons
|
||||
@ -24,6 +24,8 @@ Requires(preun): systemd
|
||||
Requires(postun): systemd
|
||||
|
||||
Source0: https://github.com/open-power/%{project}/archive/v%{version}/%{project}-%{version}.tar.gz
|
||||
Patch0: skiboot-6.0.4-crash.patch
|
||||
Patch1: skiboot-6.1-annocheck.patch
|
||||
|
||||
%description
|
||||
This package provides a daemon to load and run the OpenPower firmware's
|
||||
@ -55,9 +57,11 @@ services to the OS (Linux) on IBM Power and OpenPower systems.
|
||||
%prep
|
||||
|
||||
%setup -q -n %{project}-%{version}
|
||||
%patch0 -p1 -b .crash
|
||||
%patch1 -p1 -b .annocheck
|
||||
|
||||
%build
|
||||
OPAL_PRD_VERSION=%{version} make V=1 CC="gcc" CFLAGS="%{build_cflags}" LDFLAGS="%{build_ldflags}" -C external/opal-prd
|
||||
OPAL_PRD_VERSION=%{version} make V=1 CC="gcc" CFLAGS="%{build_cflags}" LDFLAGS="%{build_ldflags}" ASFLAGS="-m64 -Wa,--generate-missing-build-notes=yes" -C external/opal-prd
|
||||
GARD_VERSION=%{version} make V=1 CC="gcc" CFLAGS="%{build_cflags}" LDFLAGS="%{build_ldflags}" -C external/gard
|
||||
PFLASH_VERSION=%{version} make V=1 CC="gcc" CFLAGS="%{build_cflags}" LDFLAGS="%{build_ldflags}" -C external/pflash
|
||||
XSCOM_VERSION=%{version} make V=1 CC="gcc" CFLAGS="%{build_cflags}" LDFLAGS="%{build_ldflags}" -C external/xscom-utils
|
||||
@ -114,6 +118,10 @@ install -m 644 -p skiboot.lid.xz %{buildroot}%{_datadir}/qemu/skiboot.lid.xz
|
||||
%{_datadir}/qemu/
|
||||
|
||||
%changelog
|
||||
* Fri Sep 21 2018 Than Ngo <than@redhat.com> - 6.1-3
|
||||
- Fixed opal-prd crash
|
||||
- Fixed annocheck distro flag failures
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
|
30
skiboot-6.0.4-crash.patch
Normal file
30
skiboot-6.0.4-crash.patch
Normal file
@ -0,0 +1,30 @@
|
||||
diff -up skiboot-6.0.4/external/opal-prd/thunk.S.me skiboot-6.0.4/external/opal-prd/thunk.S
|
||||
--- skiboot-6.0.4/external/opal-prd/thunk.S.me 2018-07-30 15:44:08.319427493 +0200
|
||||
+++ skiboot-6.0.4/external/opal-prd/thunk.S 2018-07-30 15:44:54.541609924 +0200
|
||||
@@ -118,7 +118,7 @@ call_le:
|
||||
std %r0,(32+16)(%r1)
|
||||
|
||||
/* Branch to original function */
|
||||
- mtlr %r11
|
||||
+ mtlr %r12
|
||||
blrl
|
||||
|
||||
/* Restore stack and LR */
|
||||
@@ -136,7 +136,7 @@ call_le:
|
||||
/* Callback from HBRT. There is one entry point per function.
|
||||
*
|
||||
* We assume the proper r2 is already set via the OPD, so we grab our
|
||||
- * target function pointer in r11 and jump to call_le
|
||||
+ * target function pointer in r12 and jump to call_le
|
||||
*/
|
||||
#define CALLBACK_THUNK(name) \
|
||||
.pushsection ".text","ax" ;\
|
||||
@@ -145,7 +145,7 @@ name##_thunk: ;\
|
||||
.long 0x00000038 | le_si16(__NR_switch_endian) ;\
|
||||
/* byteswapped li %r0,__NR_switch_endian */ ;\
|
||||
.long 0x02000044 /* byteswapped sc */ ;\
|
||||
- ld %r11,name@got(%r2) ;\
|
||||
+ ld %r12,name@got(%r2) ;\
|
||||
b call_le ;\
|
||||
.popsection ;\
|
||||
.pushsection ".data.thunk_opd","aw" ;\
|
12
skiboot-6.1-annocheck.patch
Normal file
12
skiboot-6.1-annocheck.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up skiboot-6.1/external/xscom-utils/Makefile.me skiboot-6.1/external/xscom-utils/Makefile
|
||||
--- skiboot-6.1/external/xscom-utils/Makefile.me 2018-09-21 14:08:33.410739418 +0100
|
||||
+++ skiboot-6.1/external/xscom-utils/Makefile 2018-09-21 14:09:19.791593164 +0100
|
||||
@@ -21,7 +21,7 @@ endif
|
||||
|
||||
all: getscom putscom getsram
|
||||
|
||||
-getscom: getscom.c xscom.o version.o
|
||||
+getscom: getscom.o xscom.o version.o
|
||||
$(Q_LINK)$(LINK.o) -o $@ $^
|
||||
|
||||
getsram: getsram.o xscom.o sram.o version.o
|
Loading…
Reference in New Issue
Block a user