Update to latest upstream 5.7.0
Contains P9 support. Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
This commit is contained in:
parent
165e969804
commit
40777bdea8
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
/skiboot-5.1.13.tar.gz
|
||||
/skiboot-5.2.0.tar.gz
|
||||
/skiboot-5.5.0.tar.gz
|
||||
/v5.7.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: opal-prd
|
||||
Version: 5.5.0
|
||||
Release: 4%{?dist}
|
||||
Version: 5.7.0
|
||||
Release: 1%{?dist}
|
||||
Summary: OPAL Processor Recovery Diagnostics Daemon
|
||||
|
||||
Group: System Environment/Daemons
|
||||
@ -18,8 +18,7 @@ Requires(post): systemd
|
||||
Requires(preun): systemd
|
||||
Requires(postun): systemd
|
||||
|
||||
Source0: https://github.com/open-power/skiboot/archive/skiboot-%{version}.tar.gz
|
||||
Patch0: skiboot-5.5.0-Fix-build-warnings.patch
|
||||
Source0: https://github.com/open-power/skiboot/archive/v5.7.tar.gz
|
||||
|
||||
%description
|
||||
This package provides a daemon to load and run the OpenPower firmware's
|
||||
@ -50,8 +49,7 @@ services to the OS (Linux) on IBM Power and OpenPower systems.
|
||||
|
||||
%prep
|
||||
|
||||
%setup -q -n skiboot-skiboot-%{version}
|
||||
%patch0 -p1 -b .Fix-build-warnings
|
||||
%setup -q -n skiboot-5.7
|
||||
|
||||
%build
|
||||
OPAL_PRD_VERSION=%{version} make V=1 CFLAGS="%{optflags}" -C external/opal-prd
|
||||
@ -104,17 +102,20 @@ install -m 644 -p skiboot.lid.xz %{buildroot}%{_datadir}/qemu/skiboot.lid.xz
|
||||
%{_datadir}/qemu/
|
||||
|
||||
%changelog
|
||||
* Fri Aug 4 2017 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 5.7.0-1
|
||||
- Update to latest upstream 5.7.0
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Tue Apr 19 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.0-2
|
||||
* Wed Apr 19 2017 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 5.5.0-2
|
||||
- Fix build warning
|
||||
- Include skiboot.lid.xz file
|
||||
|
||||
* Tue Apr 18 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.0-1
|
||||
* Tue Apr 18 2017 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 5.5.0-1
|
||||
- Update to latest upstream 5.5.0
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-2
|
||||
|
@ -1,57 +0,0 @@
|
||||
From 5ba562436eceb8ebf90032f595d963e869472ddd Mon Sep 17 00:00:00 2001
|
||||
From: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
||||
Date: Wed, 19 Apr 2017 11:36:08 +0530
|
||||
Subject: [PATCH] Fix build warnings
|
||||
|
||||
Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
||||
---
|
||||
Makefile.main | 3 +--
|
||||
core/pcie-slot.c | 4 +++-
|
||||
2 files changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/Makefile.main b/Makefile.main
|
||||
index 5494131..5a66324 100644
|
||||
--- a/Makefile.main
|
||||
+++ b/Makefile.main
|
||||
@@ -190,7 +190,6 @@ pflash-coverity:
|
||||
(cd external/pflash; ./build-all-arch.sh)
|
||||
|
||||
all: $(SUBDIRS) $(TARGET).lid $(TARGET).lid.xz $(TARGET).map extract-gcov
|
||||
-all: $(TARGET).lid.stb $(TARGET).lid.xz.stb
|
||||
|
||||
OBJS := $(ASM) $(CORE) $(HW) $(PLATFORMS) $(LIBFDT) $(LIBFLASH) $(LIBSTB)
|
||||
ifeq ($(PORE),1)
|
||||
@@ -278,7 +277,7 @@ clean:
|
||||
$(RM) *.[odsa] $(SUBDIRS:%=%/*.[odsa])
|
||||
$(RM) *.elf $(TARGET).lid *.map $(TARGET).lds $(TARGET).lid.xz
|
||||
$(RM) include/asm-offsets.h version.c .version
|
||||
- $(RM) extract-gcov $(TARGET).lid.stb $(TARGET).lid.xz.stb
|
||||
+ $(RM) extract-gcov
|
||||
|
||||
distclean: clean
|
||||
$(RM) *~ $(SUBDIRS:%=%/*~) include/*~
|
||||
diff --git a/core/pcie-slot.c b/core/pcie-slot.c
|
||||
index 022668a..e649fd0 100644
|
||||
--- a/core/pcie-slot.c
|
||||
+++ b/core/pcie-slot.c
|
||||
@@ -404,7 +404,7 @@ static int64_t pcie_slot_sm_hreset(struct pci_slot *slot)
|
||||
*/
|
||||
static int64_t pcie_slot_sm_freset(struct pci_slot *slot)
|
||||
{
|
||||
- uint8_t power_state = PCI_SLOT_POWER_ON;
|
||||
+ uint8_t power_state;
|
||||
|
||||
switch (slot->state) {
|
||||
case PCI_SLOT_STATE_NORMAL:
|
||||
@@ -416,6 +416,8 @@ static int64_t pcie_slot_sm_freset(struct pci_slot *slot)
|
||||
if (slot->ops.get_power_state) {
|
||||
PCIE_SLOT_DBG(slot, "FRESET: Retrieve power state\n");
|
||||
slot->ops.get_power_state(slot, &power_state);
|
||||
+ } else {
|
||||
+ power_state = PCI_SLOT_POWER_ON;
|
||||
}
|
||||
|
||||
/* In power on state, power it off */
|
||||
--
|
||||
2.9.3
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (skiboot-5.5.0.tar.gz) = 7fc00168b45e49ba9c3aba29bae81d1f3e387bd8ae023297eb9e52b0ac165fedf06e651e824b02a4b198eff7f33dc1c036f64a1fd14ad93fb542224bd8db34e9
|
||||
SHA512 (v5.7.tar.gz) = aa061ab61d5fe9792d8ddccad4e581ff94f552e423136c7c304070917fbc9e91dfd8035305fadc5b6a8100e84f06cfb10bd15f0654117beae18b09358aad92f5
|
||||
|
Loading…
Reference in New Issue
Block a user