Update to latest upstream 5.2.0
Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
This commit is contained in:
parent
00f8c4d83a
commit
1f59b0ff59
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/skiboot-5.1.13.tar.gz
|
/skiboot-5.1.13.tar.gz
|
||||||
|
/skiboot-5.2.0.tar.gz
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
Name: opal-prd
|
Name: opal-prd
|
||||||
Version: 5.1.13
|
Version: 5.2.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: OPAL Processor Recovery Diagnostics Daemon
|
Summary: OPAL Processor Recovery Diagnostics Daemon
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -19,8 +19,7 @@ Requires(postun): systemd
|
|||||||
Source0: https://github.com/open-power/skiboot/archive/skiboot-%{version}.tar.gz
|
Source0: https://github.com/open-power/skiboot/archive/skiboot-%{version}.tar.gz
|
||||||
Source1: opal-prd.socket
|
Source1: opal-prd.socket
|
||||||
Source2: opal-prd.service
|
Source2: opal-prd.service
|
||||||
Patch0: skiboot-1.1.13-opal-prd-makefile-fix.patch
|
Patch0: skiboot-1.1.13-gcc6-builtin-frame-addr-fix.patch
|
||||||
Patch1: skiboot-1.1.13-gcc6-builtin-frame-addr-fix.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
This package provides a daemon to load and run the OpenPower firmware's
|
This package provides a daemon to load and run the OpenPower firmware's
|
||||||
@ -52,8 +51,7 @@ services to the OS (Linux) on IBM Power and OpenPower systems.
|
|||||||
%prep
|
%prep
|
||||||
|
|
||||||
%setup -q -n skiboot-skiboot-%{version}
|
%setup -q -n skiboot-skiboot-%{version}
|
||||||
%patch0 -p1 -b .opal-prd-makefile-fix
|
%patch0 -p1 -b .gcc6-builtin-frame-addr-fix
|
||||||
%patch1 -p1 -b .gcc6-builtin-frame-addr-fix
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
OPAL_PRD_VERSION=%{version} make V=1 CFLAGS="%{optflags}" -C external/opal-prd
|
OPAL_PRD_VERSION=%{version} make V=1 CFLAGS="%{optflags}" -C external/opal-prd
|
||||||
@ -107,6 +105,9 @@ install -m 644 -p skiboot.lid %{buildroot}%{_datadir}/qemu/skiboot.lid
|
|||||||
%{_datadir}/qemu/
|
%{_datadir}/qemu/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 21 2016 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 5.2.0
|
||||||
|
- Update to latest upstream 5.2.0
|
||||||
|
|
||||||
* Fri Feb 26 2016 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 5.1.13-4
|
* Fri Feb 26 2016 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 5.1.13-4
|
||||||
- Fix stack frame compilation issue on gcc6
|
- Fix stack frame compilation issue on gcc6
|
||||||
- Remove ppc64 from ExclusiveArch list
|
- Remove ppc64 from ExclusiveArch list
|
||||||
|
@ -1,13 +1,14 @@
|
|||||||
From d46ef7856c5b8f6f883350fc9523ca6c3399a1a5 Mon Sep 17 00:00:00 2001
|
From a6e7d1171f47d58a3e9cef5e517c70abbefc141c Mon Sep 17 00:00:00 2001
|
||||||
From: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
From: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
||||||
Date: Fri, 26 Feb 2016 11:26:54 +0530
|
Date: Mon, 21 Mar 2016 19:30:39 +0530
|
||||||
Subject: [PATCH] core/stack: Fix __builtin_frame_address issue
|
Subject: [PATCH] core/stack: Fix __builtin_frame_address issue
|
||||||
|
|
||||||
GCC 6 warns if we pass nonzero values to __builtin_frame_address(). Hence
|
GCC 6 warns if we pass nonzero values to __builtin_frame_address().
|
||||||
reorganize the code and pass zero to __builtin_frame_address().
|
Hence reorganize the code and pass zero to __builtin_frame_address().
|
||||||
|
|
||||||
core/stack.c: In function '__backtrace':
|
core/stack.c: In function '__backtrace':
|
||||||
core/stack.c:34:17: error: calling '__builtin_frame_address' with a nonzero argument is unsafe [-Werror=frame-address]
|
core/stack.c:34:17: error: calling '__builtin_frame_address' with a
|
||||||
|
nonzero argument is unsafe [-Werror=frame-address]
|
||||||
unsigned long *fp = __builtin_frame_address(1);
|
unsigned long *fp = __builtin_frame_address(1);
|
||||||
|
|
||||||
Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
||||||
@ -16,26 +17,31 @@ Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
|||||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/core/stack.c b/core/stack.c
|
diff --git a/core/stack.c b/core/stack.c
|
||||||
index 17f89d4..ead2b6d 100644
|
index 5fba6c7..5024135 100644
|
||||||
--- a/core/stack.c
|
--- a/core/stack.c
|
||||||
+++ b/core/stack.c
|
+++ b/core/stack.c
|
||||||
@@ -31,10 +31,14 @@ extern uint32_t _stext, _etext;
|
@@ -31,15 +31,19 @@ extern uint32_t _stext, _etext;
|
||||||
void __nomcount __backtrace(struct bt_entry *entries, unsigned int *count)
|
void __nomcount __backtrace(struct bt_entry *entries, unsigned int *count)
|
||||||
{
|
{
|
||||||
unsigned int room = *count;
|
unsigned int room = *count;
|
||||||
- unsigned long *fp = __builtin_frame_address(1);
|
- unsigned long *fp = __builtin_frame_address(1);
|
||||||
+ unsigned long *fp = __builtin_frame_address(0);
|
+ unsigned long *fp = __builtin_frame_address(0);
|
||||||
+
|
unsigned long top_adj = top_of_ram;
|
||||||
+ if (!fp || (unsigned long)fp > top_of_ram)
|
|
||||||
+ return;
|
|
||||||
|
|
||||||
|
/* Assume one stack for early backtraces */
|
||||||
|
if (top_of_ram == SKIBOOT_BASE + SKIBOOT_SIZE)
|
||||||
|
top_adj = top_of_ram + STACK_SIZE;
|
||||||
|
|
||||||
|
+ if (!fp || (unsigned long)fp > top_adj)
|
||||||
|
+ return;
|
||||||
|
+
|
||||||
*count = 0;
|
*count = 0;
|
||||||
while(room) {
|
while(room) {
|
||||||
+ fp = (unsigned long *)fp[0];
|
+ fp = (unsigned long *)fp[0];
|
||||||
if (!fp || (unsigned long)fp > top_of_ram)
|
if (!fp || (unsigned long)fp > top_adj)
|
||||||
break;
|
break;
|
||||||
entries->sp = (unsigned long)fp;
|
entries->sp = (unsigned long)fp;
|
||||||
@@ -42,7 +46,6 @@ void __nomcount __backtrace(struct bt_entry *entries, unsigned int *count)
|
@@ -47,7 +51,6 @@ void __nomcount __backtrace(struct bt_entry *entries, unsigned int *count)
|
||||||
entries++;
|
entries++;
|
||||||
*count = (*count) + 1;
|
*count = (*count) + 1;
|
||||||
room--;
|
room--;
|
||||||
|
@ -1,32 +0,0 @@
|
|||||||
From e290a55cb40d2f53a9cfcc445d0b98a487a3f4a0 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
|
||||||
Date: Tue, 23 Feb 2016 20:01:41 +0530
|
|
||||||
Subject: [PATCH] external/opal-prd: Make compilation prerequisites as
|
|
||||||
order-only prerequisites
|
|
||||||
|
|
||||||
Makefile creates symbolic link to libflash, ccan, etc. Presently we added them
|
|
||||||
as normal prerequisites. In some cases (like we compile skiboot after compiling
|
|
||||||
opal-prd) it will result in recompiling source again during make install. Hence
|
|
||||||
make it as order-only prerequisites.
|
|
||||||
|
|
||||||
Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
|
|
||||||
---
|
|
||||||
external/opal-prd/Makefile | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/external/opal-prd/Makefile b/external/opal-prd/Makefile
|
|
||||||
index 98c7b48..3f34371 100644
|
|
||||||
--- a/external/opal-prd/Makefile
|
|
||||||
+++ b/external/opal-prd/Makefile
|
|
||||||
@@ -52,7 +52,7 @@ asm/opal-prd.h:
|
|
||||||
$(Q_LN)ln -sfr $(KERNEL_DIR)/arch/powerpc/include/uapi/asm/opal-prd.h \
|
|
||||||
asm/opal-prd.h
|
|
||||||
|
|
||||||
-$(OBJS): $(LINKS)
|
|
||||||
+$(OBJS): | $(LINKS)
|
|
||||||
|
|
||||||
%.o: %.c
|
|
||||||
$(Q_CC)$(COMPILE.c) $< -o $@
|
|
||||||
--
|
|
||||||
2.5.0
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user