import opa-fm-10.9.2.2.1-1.el8
This commit is contained in:
parent
48e017869d
commit
5cc3485fab
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/opa-fm-10.7.0.0.145.tar.xz
|
SOURCES/opa-fm-10.9.2.2.1.tar.xz
|
||||||
|
@ -1 +1 @@
|
|||||||
b93202b2cc3f2631dc9e88a08ddef36772502a46 SOURCES/opa-fm-10.7.0.0.145.tar.xz
|
60fd1b4b0887ddedd8294027fa6909d6138502e8 SOURCES/opa-fm-10.9.2.2.1.tar.xz
|
||||||
|
15
SOURCES/add-fPIC-flag.patch
Normal file
15
SOURCES/add-fPIC-flag.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff --git a/Makerules/Target.LINUX.GNU.X86_64 b/Makerules/Target.LINUX.GNU.X86_64
|
||||||
|
index 5a852b3..194a8b2 100755
|
||||||
|
--- a/Makerules/Target.LINUX.GNU.X86_64
|
||||||
|
+++ b/Makerules/Target.LINUX.GNU.X86_64
|
||||||
|
@@ -77,8 +77,8 @@ SHLIB_SONAME=$(notdir $(CMD_TARGETS_SHLIB))
|
||||||
|
# ----------------------------
|
||||||
|
# -fcheck-new does the opposite of what the manual implies.
|
||||||
|
# -fcheck-new DISABLES the run-time test of return value from new
|
||||||
|
-CMACH = -pipe -DTARGET_CPU_FAMILY_X86 -Wall -Werror=format-security -D__X86_64__ -DCPU_LE -m64 -fno-strict-aliasing -fstack-protector
|
||||||
|
-CCMACH = -pipe -DTARGET_CPU_FAMILY_X86 -Wall -Werror=format-security -D__X86_64__ -DCPU_LE -m64 -fno-strict-aliasing -fstack-protector -fcheck-new -Wno-ctor-dtor-privacy
|
||||||
|
+CMACH = -fPIC -pipe -DTARGET_CPU_FAMILY_X86 -Wall -Werror=format-security -D__X86_64__ -DCPU_LE -m64 -fno-strict-aliasing -fstack-protector
|
||||||
|
+CCMACH = -fPIC -pipe -DTARGET_CPU_FAMILY_X86 -Wall -Werror=format-security -D__X86_64__ -DCPU_LE -m64 -fno-strict-aliasing -fstack-protector -fcheck-new -Wno-ctor-dtor-privacy
|
||||||
|
ifeq ($(shell expr $(GCC_MAJOR_VERSION) \>= 7), 1)
|
||||||
|
ifeq ($(shell expr $(GCC_MINOR_VERSION) \>= 0), 1)
|
||||||
|
CMACH+= -std=gnu90 -Wno-misleading-indentation -Wno-format-truncation
|
@ -1,8 +1,8 @@
|
|||||||
diff --git a/Esm/ib/src/linux/startup/Makefile b/Esm/ib/src/linux/startup/Makefile
|
diff --git a/Esm/ib/src/linux/startup/Makefile b/Esm/ib/src/linux/startup/Makefile
|
||||||
index 86bf29b..4001ac8 100644
|
index ad23e67..00c7f2c 100644
|
||||||
--- a/Esm/ib/src/linux/startup/Makefile
|
--- a/Esm/ib/src/linux/startup/Makefile
|
||||||
+++ b/Esm/ib/src/linux/startup/Makefile
|
+++ b/Esm/ib/src/linux/startup/Makefile
|
||||||
@@ -143,7 +143,7 @@ include $(TL_DIR)/Makerules/Maketargets.build
|
@@ -145,7 +145,7 @@ include $(TL_DIR)/Makerules/Maketargets.build
|
||||||
include $(TL_DIR)/Makerules/Maketargets.install
|
include $(TL_DIR)/Makerules/Maketargets.install
|
||||||
|
|
||||||
$(BUILDDIR)/opafmd: $(BUILDDIR)/opafmd.o
|
$(BUILDDIR)/opafmd: $(BUILDDIR)/opafmd.o
|
||||||
@ -12,7 +12,7 @@ index 86bf29b..4001ac8 100644
|
|||||||
$(BUILDDIR)/opaxmlextract: $(PROJ_BIN_DIR)/opaxmlextract
|
$(BUILDDIR)/opaxmlextract: $(PROJ_BIN_DIR)/opaxmlextract
|
||||||
cp $(PROJ_BIN_DIR)/opaxmlextract $(BUILDDIR)
|
cp $(PROJ_BIN_DIR)/opaxmlextract $(BUILDDIR)
|
||||||
diff --git a/Esm/ib/src/linux/startup/fm_config/Makefile b/Esm/ib/src/linux/startup/fm_config/Makefile
|
diff --git a/Esm/ib/src/linux/startup/fm_config/Makefile b/Esm/ib/src/linux/startup/fm_config/Makefile
|
||||||
index cbf277f..99b3635 100644
|
index c4108fa..cd3f301 100644
|
||||||
--- a/Esm/ib/src/linux/startup/fm_config/Makefile
|
--- a/Esm/ib/src/linux/startup/fm_config/Makefile
|
||||||
+++ b/Esm/ib/src/linux/startup/fm_config/Makefile
|
+++ b/Esm/ib/src/linux/startup/fm_config/Makefile
|
||||||
@@ -150,10 +150,10 @@ include $(TL_DIR)/Makerules/Maketargets.build
|
@@ -150,10 +150,10 @@ include $(TL_DIR)/Makerules/Maketargets.build
|
||||||
|
@ -1,26 +1,30 @@
|
|||||||
Name: opa-fm
|
Name: opa-fm
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 10.7.0.0.145
|
Version: 10.9.2.2.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Intel Omni-Path Fabric Management Software
|
Summary: Intel Omni-Path Fabric Management Software
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
License: GPLv2 or BSD
|
License: GPLv2 or BSD
|
||||||
Url: https://github.com/01org/opa-fm
|
Url: https://github.com/intel/opa-fm
|
||||||
# tarball created by:
|
# tarball created by:
|
||||||
# git clone https://github.com/01org/opa-fm.git
|
# git clone https://github.com/intel/opa-fm.git
|
||||||
# cd opa-fm
|
# cd opa-fm
|
||||||
# git archive --format=tar --prefix=opa-fm-%{version}/ \
|
# git archive --format=tar --prefix=opa-fm-%{version}/ \
|
||||||
# d435129bef2eb1d9aaec0b68c7c36032d746dfef | xz > opa-fm-%{version}.tar.xz
|
# 18110638b7a54e66b1b5ad702db6aad1f536fa55 | xz > opa-fm-%{version}.tar.xz
|
||||||
Source0: %{name}-%{version}.tar.xz
|
Source0: %{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# bz1262327 needs Patch0002
|
# bz1262327 needs Patch0002
|
||||||
Patch0002: 0001-Fix-well-known-tempfile-issue-in-script.patch
|
Patch0002: 0001-Fix-well-known-tempfile-issue-in-script.patch
|
||||||
Patch0003: opafm-link-all-executables-with-pie.patch
|
Patch0003: opafm-link-all-executables-with-pie.patch
|
||||||
|
Patch0004: add-fPIC-flag.patch
|
||||||
|
|
||||||
BuildRequires: openssl-devel, expat-devel
|
BuildRequires: openssl-devel, expat-devel
|
||||||
BuildRequires: libibverbs-devel >= 1.2.0
|
BuildRequires: libibverbs-devel >= 1.2.0
|
||||||
BuildRequires: libibumad-devel
|
BuildRequires: libibumad-devel
|
||||||
|
BuildRequires: zlib-devel
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: gcc-c++
|
||||||
Requires(post): systemd
|
Requires(post): systemd
|
||||||
Requires(preun): systemd
|
Requires(preun): systemd
|
||||||
Requires(postun): systemd
|
Requires(postun): systemd
|
||||||
@ -36,6 +40,7 @@ Fabric Executive, and some fabric management tools.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0002 -p1
|
%patch0002 -p1
|
||||||
%patch0003 -p1
|
%patch0003 -p1
|
||||||
|
%patch0004 -p1
|
||||||
|
|
||||||
# Make it possible to override hardcoded compiler flags
|
# Make it possible to override hardcoded compiler flags
|
||||||
sed -i -r -e 's/(release_C(C)?OPT_Flags\s*)=/\1?=/' Makerules/Target.LINUX.GNU.*
|
sed -i -r -e 's/(release_C(C)?OPT_Flags\s*)=/\1?=/' Makerules/Target.LINUX.GNU.*
|
||||||
@ -46,7 +51,7 @@ export CXXFLAGS='%{optflags}'
|
|||||||
export release_COPT_Flags='%{optflags}'
|
export release_COPT_Flags='%{optflags}'
|
||||||
export release_CCOPT_Flags='%{optflags}'
|
export release_CCOPT_Flags='%{optflags}'
|
||||||
cd Esm
|
cd Esm
|
||||||
./fmbuild
|
OPA_FEATURE_SET= ./fmbuild $BUILD_ARGS
|
||||||
|
|
||||||
%install
|
%install
|
||||||
BUILDDIR=%{_builddir} DESTDIR=%{buildroot} LIBDIR=%{_libdir} RPM_INS=n ./Esm/fm_install.sh
|
BUILDDIR=%{_builddir} DESTDIR=%{buildroot} LIBDIR=%{_libdir} RPM_INS=n ./Esm/fm_install.sh
|
||||||
@ -67,15 +72,22 @@ chmod a-x %{buildroot}/%{_prefix}/share/opa-fm/opafm_src.xml
|
|||||||
%doc Esm/README
|
%doc Esm/README
|
||||||
%{_unitdir}/opafm.service
|
%{_unitdir}/opafm.service
|
||||||
%config(noreplace) %{_sysconfdir}/opa-fm/opafm.xml
|
%config(noreplace) %{_sysconfdir}/opa-fm/opafm.xml
|
||||||
|
%config(noreplace) %{_sysconfdir}/opa-fm/opafm_pp.xml
|
||||||
|
%{_sysconfdir}/opa-fm
|
||||||
%{_prefix}/lib/opa-fm/bin/*
|
%{_prefix}/lib/opa-fm/bin/*
|
||||||
%{_prefix}/lib/opa-fm/runtime/*
|
%{_prefix}/lib/opa-fm/runtime/*
|
||||||
%{_prefix}/share/opa-fm/*
|
%{_prefix}/share/opa-fm/*
|
||||||
%{_sbindir}/opafmcmd
|
%{_sbindir}/opafmcmd
|
||||||
%{_sbindir}/opafmcmdall
|
%{_sbindir}/opafmcmdall
|
||||||
|
%{_sbindir}/opafmconfigpp
|
||||||
|
%{_sbindir}/opafmvf
|
||||||
%{_mandir}/man8/*
|
%{_mandir}/man8/*
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 11 2019 Honggang Li <honli@redhat.com> - 10.9.2.2.1-1
|
||||||
|
- Rebase to upstream release 10.9.2.2.1
|
||||||
|
- Resolves: bz1660617
|
||||||
|
|
||||||
* Wed Sep 26 2018 Honggang Li <honli@redhat.com> - 10.7.0.0.145-2
|
* Wed Sep 26 2018 Honggang Li <honli@redhat.com> - 10.7.0.0.145-2
|
||||||
- Link all executables with '-pie'
|
- Link all executables with '-pie'
|
||||||
- Resovles: bz1624155
|
- Resovles: bz1624155
|
||||||
|
Loading…
Reference in New Issue
Block a user