opa-ff/SOURCES/0002-Lets-build-config-deci...

141 lines
6.3 KiB
Diff

From d8aa76c06080e3a627e0d2872ad0a60b034b764b Mon Sep 17 00:00:00 2001
From: Honggang Li <honli@redhat.com>
Date: Tue, 11 Jun 2019 09:31:24 -0400
Subject: [PATCH 2/3] Lets build config decide C optimization flags
Signed-off-by: Honggang Li <honli@redhat.com>
---
Dsap/Makefile | 4 ++--
IbaTools/stream/Makefile | 2 +-
opasadb/path_tools/cache/Makefile | 2 +-
opasadb/path_tools/dump/Makefile | 2 +-
opasadb/path_tools/exercise/Makefile | 2 +-
opasadb/path_tools/load/Makefile | 2 +-
opasadb/path_tools/perf/Makefile | 2 +-
opasadb/path_tools/query/Makefile | 2 +-
opasadb/path_tools/query_many/Makefile | 2 +-
9 files changed, 10 insertions(+), 10 deletions(-)
diff --git a/Dsap/Makefile b/Dsap/Makefile
index 64aeb2d..e66d0aa 100644
--- a/Dsap/Makefile
+++ b/Dsap/Makefile
@@ -133,8 +133,8 @@ include $(TL_DIR)/$(PROJ_FILE_DIR)/Makerules.project
# (Windows Only)
#USEMFC = How Windows MFC should be used (none, static, shared, no_mfc) [none]
# (Windows Only)
-COPT = # set by CKERNEL for drivers
-CCOPT = # set by CKERNEL for drivers
+COPT ?= # set by CKERNEL for drivers
+CCOPT ?= # set by CKERNEL for drivers
#=============================================================================#
#=============================================================================#
diff --git a/IbaTools/stream/Makefile b/IbaTools/stream/Makefile
index 7ed670d..9284a91 100644
--- a/IbaTools/stream/Makefile
+++ b/IbaTools/stream/Makefile
@@ -125,7 +125,7 @@ include $(TL_DIR)/IbaTools/Makerules.module
# (Windows Only)
#USEMFC = How Windows MFC should be used (none, static, shared, no_mfc) [none]
# (Windows Only)
-COPT = -O3
+COPT ?= -O3
#=============================================================================#
#=============================================================================#
diff --git a/opasadb/path_tools/cache/Makefile b/opasadb/path_tools/cache/Makefile
index 769bad7..61b9ec9 100644
--- a/opasadb/path_tools/cache/Makefile
+++ b/opasadb/path_tools/cache/Makefile
@@ -129,7 +129,7 @@ include $(TL_DIR)/IbaTools/Makerules.module
# C++ optimization flags, default lets build config decide
#CCOPT =
# C optimization flags, default lets build config decide
-COPT = -g -D_GNU_SOURCE -Wall -fPIE
+COPT ?= -g -D_GNU_SOURCE -Wall -fPIE
#SUBSYSTEM = Subsystem to build for (none, console or windows) [none]
# (Windows Only)
#USEMFC = How Windows MFC should be used (none, static, shared, no_mfc) [none]
diff --git a/opasadb/path_tools/dump/Makefile b/opasadb/path_tools/dump/Makefile
index 4562df3..ecc91d7 100644
--- a/opasadb/path_tools/dump/Makefile
+++ b/opasadb/path_tools/dump/Makefile
@@ -129,7 +129,7 @@ include $(TL_DIR)/IbaTools/Makerules.module
# C++ optimization flags, default lets build config decide
#CCOPT =
# C optimization flags, default lets build config decide
-COPT = -g -D_GNU_SOURCE -Wall -fPIE
+COPT ?= -g -D_GNU_SOURCE -Wall -fPIE
#SUBSYSTEM = Subsystem to build for (none, console or windows) [none]
# (Windows Only)
#USEMFC = How Windows MFC should be used (none, static, shared, no_mfc) [none]
diff --git a/opasadb/path_tools/exercise/Makefile b/opasadb/path_tools/exercise/Makefile
index ebed0f5..2f164ee 100644
--- a/opasadb/path_tools/exercise/Makefile
+++ b/opasadb/path_tools/exercise/Makefile
@@ -129,7 +129,7 @@ include $(TL_DIR)/IbaTools/Makerules.module
# C++ optimization flags, default lets build config decide
#CCOPT =
# C optimization flags, default lets build config decide
-COPT = -g -D_GNU_SOURCE -Wall -fPIE
+COPT ?= -g -D_GNU_SOURCE -Wall -fPIE
#SUBSYSTEM = Subsystem to build for (none, console or windows) [none]
# (Windows Only)
#USEMFC = How Windows MFC should be used (none, static, shared, no_mfc) [none]
diff --git a/opasadb/path_tools/load/Makefile b/opasadb/path_tools/load/Makefile
index 4e9d10b..640d284 100644
--- a/opasadb/path_tools/load/Makefile
+++ b/opasadb/path_tools/load/Makefile
@@ -128,7 +128,7 @@ include $(TL_DIR)/IbaTools/Makerules.module
# C++ optimization flags, default lets build config decide
#CCOPT =
# C optimization flags, default lets build config decide
-COPT = -g -D_GNU_SOURCE -Wall -fPIE
+COPT ?= -g -D_GNU_SOURCE -Wall -fPIE
#SUBSYSTEM = Subsystem to build for (none, console or windows) [none]
# (Windows Only)
#USEMFC = How Windows MFC should be used (none, static, shared, no_mfc) [none]
diff --git a/opasadb/path_tools/perf/Makefile b/opasadb/path_tools/perf/Makefile
index 5029c4a..b3e448c 100644
--- a/opasadb/path_tools/perf/Makefile
+++ b/opasadb/path_tools/perf/Makefile
@@ -128,7 +128,7 @@ include $(TL_DIR)/IbaTools/Makerules.module
# C++ optimization flags, default lets build config decide
#CCOPT =
# C optimization flags, default lets build config decide
-COPT = -g -D_GNU_SOURCE -Wall -fPIE
+COPT ?= -g -D_GNU_SOURCE -Wall -fPIE
#SUBSYSTEM = Subsystem to build for (none, console or windows) [none]
# (Windows Only)
#USEMFC = How Windows MFC should be used (none, static, shared, no_mfc) [none]
diff --git a/opasadb/path_tools/query/Makefile b/opasadb/path_tools/query/Makefile
index 0b6e480..75fe5c4 100644
--- a/opasadb/path_tools/query/Makefile
+++ b/opasadb/path_tools/query/Makefile
@@ -128,7 +128,7 @@ include $(TL_DIR)/IbaTools/Makerules.module
# C++ optimization flags, default lets build config decide
#CCOPT =
# C optimization flags, default lets build config decide
-COPT = -g -D_GNU_SOURCE -Wall -fPIE
+COPT ?= -g -D_GNU_SOURCE -Wall -fPIE
#SUBSYSTEM = Subsystem to build for (none, console or windows) [none]
# (Windows Only)
#USEMFC = How Windows MFC should be used (none, static, shared, no_mfc) [none]
diff --git a/opasadb/path_tools/query_many/Makefile b/opasadb/path_tools/query_many/Makefile
index b7ff7d4..295fe8f 100644
--- a/opasadb/path_tools/query_many/Makefile
+++ b/opasadb/path_tools/query_many/Makefile
@@ -128,7 +128,7 @@ include $(TL_DIR)/IbaTools/Makerules.module
# C++ optimization flags, default lets build config decide
#CCOPT =
# C optimization flags, default lets build config decide
-COPT = -g -D_GNU_SOURCE -Wall -fPIE
+COPT ?= -g -D_GNU_SOURCE -Wall -fPIE
#SUBSYSTEM = Subsystem to build for (none, console or windows) [none]
# (Windows Only)
#USEMFC = How Windows MFC should be used (none, static, shared, no_mfc) [none]
--
2.20.1