44 lines
1.2 KiB
Diff
44 lines
1.2 KiB
Diff
From b32e6fc3318a2d25d7ae233a8999beb752d6131d Mon Sep 17 00:00:00 2001
|
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
Date: Fri, 26 Apr 2019 16:16:29 +0100
|
|
Subject: [PATCH 3/8] configure: Remove incorrect assumption about
|
|
cross-compiling.
|
|
|
|
See https://github.com/ocaml/ocaml/issues/8647#issuecomment-487094390
|
|
---
|
|
configure.ac | 11 ++++++-----
|
|
1 file changed, 6 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 0648f0553..ad07516e7 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -505,10 +505,11 @@ AS_IF(
|
|
|
|
# Are we building a cross-compiler
|
|
|
|
-AS_IF(
|
|
- [test x"$host" = x"$target"],
|
|
- [cross_compiler=false],
|
|
- [cross_compiler=true])
|
|
+#AS_IF(
|
|
+# [test x"$host" = x"$target"],
|
|
+# [cross_compiler=false],
|
|
+# [cross_compiler=true])
|
|
+cross_compiler=false
|
|
|
|
# Checks for programs
|
|
|
|
@@ -970,7 +971,7 @@ AS_IF([test $arch != "none" && $arch64 ],
|
|
|
|
# Assembler
|
|
|
|
-AS_IF([test -n "$host_alias"], [toolpref="${host_alias}-"], [toolpref=""])
|
|
+#AS_IF([test -n "$host_alias"], [toolpref="${host_alias}-"], [toolpref=""])
|
|
|
|
# We first compute default values for as and aspp
|
|
# If values have been given by the user then they take precedence over
|
|
--
|
|
2.24.1
|
|
|