41 lines
1.3 KiB
Diff
41 lines
1.3 KiB
Diff
From 1c908c961738067dd52a5ba4515cc35abd35b96b Mon Sep 17 00:00:00 2001
|
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
Date: Wed, 26 Jan 2022 15:47:02 +0000
|
|
Subject: [PATCH 17/18] configure: Only use OC_* for building executables
|
|
|
|
Fedora >= 36 fills LD_FLAGS with lots of cruft, particularly stuff for
|
|
"package notes" which contains build paths.
|
|
|
|
In any case it seems pointless having both the OC_* variables and also
|
|
including the regular CFLAGS/LDFLAGS. Give me full control over what
|
|
ocamlopt uses.
|
|
---
|
|
configure.ac | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 8068de3cfc..19b23f9400 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -36,7 +36,7 @@ CONFIGURE_ARGS="$*"
|
|
# rely on $CFLAGS because these cannot be processed by flexlink (and are not
|
|
# passed)
|
|
mkexe_cmd='$(CC)'
|
|
-mkexe_cflags='$(OC_CFLAGS) $(CFLAGS)'
|
|
+mkexe_cflags='$(OC_CFLAGS)'
|
|
mkexe_extra_flags=''
|
|
mkexe_via_cc_extra_cmd=''
|
|
mkexe_ldflags_prefix=''
|
|
@@ -2208,7 +2208,7 @@ ${mkdll_ldflags}"
|
|
],[
|
|
mkdll_ldflags='$(OC_DLL_LDFLAGS) $(LDFLAGS)'
|
|
mkdll_ldflags_exp="${oc_dll_ldflags} ${LDFLAGS}"
|
|
- mkexe="${mkexe} \$(OC_LDFLAGS) \$(LDFLAGS)"
|
|
+ mkexe="${mkexe} \$(OC_LDFLAGS)"
|
|
mkexe_exp="${mkexe_exp} ${oc_ldflags} ${LDFLAGS}"
|
|
])
|
|
mkdll="$mkdll $mkdll_ldflags"
|
|
--
|
|
2.41.0
|
|
|